Programm-Information

Ashampoo UnInstaller Suite
Für Windows® 95, 98, Me, NT4, 2000 und XP

Copyright © 1999-2003, ashampoo GmbH & Co. KG
Felix-Wankel-Str. 16, 26125 Oldenburg, Germany

Chef-Programmierer: Bernd Klaiber
Hilfe und Dokumentation: Tim Green & Johann Lüppen

Wichtig:
Dieses Programm unterliegt den Bestimmungen der
Lizenzvereinbarung, denen Sie bei der Installation zugestimmt haben.


Einführung
Sie wollen gleich starten?

Wenn Sie gleich mit dem Programm arbeiten möchten, lesen Sie die Hinweis im Kapitel Wie die UnInstaller Suite arbeitet und wechseln dann zum Kapitel Das Programm im Easy-Modus benutzen.

Wichtiger Hinweis für Benutzer von Ashampoo UnInstaller 2000

Die Art und Weise, wie die Auswahl gespeichert, geladen und benutzt wird, hat sich in der Ashampoo UnInstaller Suite ein wenig geändert, um das Programm einfacher und intuitiver in der Handhabung gestalten zu können. Sollten Sie bereits mit Ashampoo UnInstaller 2000 gearbeitet haben, lesen Sie bitte die Kapitel Auswahl und Auswahl speichern im Abschnitt Referenzen sorgfältig, bevor Sie das Programm im Experten-Modus benutzen wollen.

Hilfe anfordern

Die Ashampoo UnInstaller Suite verfügt über ein vollständiges kontextsensitives Hilfesystem. Drücken Sie einfach, egal wo Sie sich im Programm befinden, die Taste F1, um das entsprechende Kapitel oder den entsprechende Abschnitt in der Online-Hilfe zu sehen. Wenn Sie wirklich nicht mehr weiter wissen, kontaktieren Sie bitte den Ashampoo Support. Lesen Sie aber bitte zunächst diese Online-Hilfe sorgfältig durch. Sie werden sicherlich für die meisten Fragen die Antworten bereits in dieser Dokumentation finden.

Über die Ashampoo UnInstaller Suite

Windows-Anwendungen sind grundsätzlich schwer von einem Rechner zu entfernen. Sie installieren eigene Bestandteile überall auf Ihrem System und erschweren ein effektives und vollständiges Entfernen. Die Ashampoo UnInstaller Suite ändert das!

Anstelle ein neues Programm direkt zu installieren, starten Sie das Installationsprogramm mit der Ashampoo UnInstaller Suite, die ein Installationsprotokoll mit allen Änderungen, die während der Installation vorgenommen wurden, erzeugt.

Wenn Sie sich dafür entscheiden, das Programm zu entfernen, laden Sie einfach das Protokoll mit der Ashampoo UnInstaller Suite, welches dann alle protokollierten Änderungen rückgängig macht. Hinzugefügte Dateien und Registry-Einträge werden gelöscht und veränderte Einstellungen in den ursprünglichen Zustand zurückgesetzt. Siehe das Kapitel Wie der UnInstaller arbeitet für weitere Einzelheiten.

Easy-Modus und Experten-Modus

Ashampoo UnInstaller Suite ist der richtige UnInstaller sowohl für unerfahrene Benutzer von Windows als auch für Experten. Im erstaunlich einfachen neuen Easy-Modus werden alle schwierigen und kritischen Entscheidungen vom Programm getroffen. Das Überwachen von Programminstallationen und das anschließende Entfernen könnte nicht einfacher sein.

Im Experten-Modus verfügen Sie über alle Features, die bereits den Vorgänger Ashampoo UnInstaller 2000 zu einem der beliebtesten Anwendungen für Experten werden ließ. In diesem Modus können Sie mit dem Programm alle Veränderungen an Ihrem System zwischen zwei Zeitpunkten überwachen und rückgängig machen - das gilt nicht nur für Programminstallationen.


Wie die UnInstaller Suite arbeitet
Wozu braucht man eigentlich einen UnInstaller?

Wie der Name bereits suggeriert, besteht die primäre Funktion der Ashampoo UnInstaller Suite im Entfernen oder der Deinstallation von Anwendungen aus dem Windows-Betriebssystem. Die Frage ist, ob das unbedingt nötig ist. Warum braucht man dazu ein spezielles Programm? Warum kann man nicht eine Anwendungen genauso wie eine Datei einfach mit Löschen entfernen?

Die vollständige Antwort auf diese Fragen würde ein Buch füllen. In wenigen Worten formuliert: Moderne Windows-Anwendungen sind komplizierte "Biester". Sie beinhalten eine große Anzahl von Dateien, die sehr oft an den unterschiedlichsten Orten im System abgespeichert sind - nicht nur im Programmverzeichnis der Anwendungen selbst. Zusätzlich besitzen viele Anwendungen eine ebenso große Anzahl von Einstellungen, die in die zentrale Datenbank von Windows, der Windows Registry geschrieben werden.

Es ist schlimm:
Viele der Programmdateien, die von Anwendungen benutzt werden, werden mit anderen Anwendungen "geteilt". Diese Dateien beinhalten sehr oft universelle Funktionen, die von vielen Windows-Programmen für allgemeine Aufgaben benutzt werden. Obwohl diese Dateien als zu einer Anwendung gehörig gelistet werden, kann das Löschen einer solchen Datei beim Entfernen einer Anwendung das Funktionieren einer anderen Anwendung beeinträchtigen.

Die Einträge in der Windows Registry sind ähnlich problematisch. Neben anderen Dingen, verändern sich die Einträge sehr häufig, weil Programme Werte und Einstellungen während des Arbeitens schreiben und löschen. Und die Einstellungen werden an alle möglichen Orte geschrieben, nicht nur im programmeigenen Abschnitt der Registry.

Man könnte fast schon sagen, dass eine Windows-Anwendung nach der Installation ein Bestandteil von Windows wird. Stellen Sie sich vor, Sie kippen ein halbes Glas Coca Cola in ein halbes Glas mit Orangensaft und versuchen anschließend beide Getränke wieder voneinander zu trennen. Es ist vielleicht nicht ganz so schlimm, aber als Vergleich sehr hilfreich.

Warum die mitgelieferten programmeigenen UnInstaller in der Regel nicht so gut sind

Heutzutage verfügen fast alle Programme über die Möglichkeit, sich selbst zu deinstallieren - zu guter Letzt im Abschnitt Programme hinzufügen / entfernen in der Windows-Systemsteuerung. Das Problem besteht in der minimalen Funktionalität dieser "UnInstaller". Viele von ihnen hinterlassen eine beträchtliche Anzahl von "verwaisten" Registry-Einträgen, Einstellungen und im System verstreuten Dateien zurück - quasi wie Touristen ihren Müll nach einem Picknick im Grünen hinterlassen. (Wenn es Sie interessiert, testen Sie doch die Leistungsfähigkeit anderer UnInstaller mit der Ashampoo UnInstaller Suite im Experten-Modus.)

Warum ist das so? Im Grunde möchte doch kein Programmierer, dass Sie sein Programm entfernen. Das Schreiben eines guten UnInstallers bedeutet viel Arbeit, ohne jedoch die Funktionalität eines Programmes zu erweitern. Viele Programmierer scheuen diese lästige Mehrarbeit. Sie wählen den sicheren Weg und hinterlassen scheinbar alles intakt.
Für weitere Informationen siehe den Abschnitt Was ist mit programmeigenen UnInstallern?

Wie erledigt die Ashampoo UnInstaller Suite ihre Aufgabe?

Die Ashampoo UnInstaller Suite arbeitet quasi mit zwei "Schnappschüssen" von Ihrem System - der erste Schnappschuss entsteht bevor Sie ein Programm installieren, der zweite direkt im Anschluss. Diese beiden Schnappschüsse beschreiben den gegenwärtigen Status ihres Systems, einschließlich aller Registry-Einträge, den Orten, Daten, Größen und Versionen aller Dateien und den Inhalt der Konfigurationsdateien. Die korrekte Erfassung dieser Daten ist sehr komplex, diese Aufgabe wird aber von der Ashampoo UnInstaller Suite mit Bravour erledigt.

Nach dem Erzeugen des zweiten Schnappschusses vergleicht das Programm dieses Abbild mit dem ersten Schnappschuss und schreibt alle Unterschiede in eine besondere Datei, das "Installationsprotokoll".

Wenn Sie über die Ashampoo UnInstaller Suite eine Anwendung entfernen, wird diese Protokolldatei geladen und anhand der darin gespeicherten Information der Zustand Ihres System vor der Programminstallation wiederhergestellt. Neue Dateien, Verzeichnisse und Registry-Einträge sind gelöscht. Veränderte Registry-Einträge werden ebenfalls wieder auf die Werte zurückgesetzt, die sie vor der Installation des Programmes hatten. Wenn Sie das Feature Backup erstellen benutzen (Nur im Experten-Modus verfügbar!), können Sie sogar Originaldateien wiederherstellen, die bei der Installation der Anwendung überschrieben wurden.


Was können Sie noch mit diesem Programm machen?
Windows-Anwendungen einfach und vollständig zu deinstallieren ist nicht das Einzige, was Sie mit der Ashampoo UnInstaller Suite machen können. Dieses mächtige Programm enthält eine ganze Reihe starker integrierter Module mit vielen Funktionen, die es zu einem unverzichtbaren Werkzeug für jeden Windows-Benutzer machen:

· Kreative Anwendungen zur Überwachung und zum Vergleich:

Da die Ashampoo UnInstaller Suite alle Veränderungen in ihrem System zwischen zwei definierten Zeitpunkten vergleichen und wieder zurücksetzen kann, können Sie weitaus aus mehr mit diesen Überwachungs- und Vergleichsfunktionen anfangen, als nur Anwendungen deinstallieren! Zum Beispiel können Sie mit den Funktionen herausfinden, wo Programme ihre Einstellungen speichern - Sie brauchen dazu nur die Änderungen der Dateien und in der Registry vor und nach dem Ablauf des Programmes vergleichen. Oder Sie benutzen die Ashampoo UnInstaller Suite als ein Sicherheitssystem, wenn Sie mit Konfigurations- und Registry-Einstellungen experimentieren. Sie speichern einfach Ihre Konfiguration bevor Sie Änderungen vornehmen, erzeugen eine Protokolldatei nach den vorgenommenen Änderungen und können alle Veränderungen wieder zurücksetzen, falls die neuen Einstellungen nicht funktionieren sollten. Die Möglichkeiten sind endlos! (Diese Funktionalität ist nur im Experten-Modus verfügbar!)

Doppelte Dateien suchen und löschen:

Mit diesem Modul können Sie doppelte Dateien, die wertvollen Speicherplatz vergeuden, identifizieren, finden und löschen. Sie werden erstaunt sein, wie viele Kopien von identischen Dateien sich im Laufe der Zeit in Ihrem System angesammelt haben!

Temporäre Dateien suchen und löschen:

Das Gleiche gilt für temporäre Dateien. Viele Programme erzeugen temporäre Dateien während der Arbeitssitzung, "vergessen" aber, diese anschließend zu löschen. Installationsprogramme erzeugen sehr oft ein ganzes Paket temporärer Dateien während der Installationsroutine und sehr oft bleiben auch diese Dateien einfach übrig und werden nicht wieder entfernt. Im Laufe der Zeit füllt sich Ihre Festplatte mit immer mehr Datenmüll.

Leere Ordner suchen und löschen:

Sehr oft werden Ordner angelegt und nie wieder benutzt - manchmal werden sie von Programmen angelegt, manchmal auch vom Benutzer selbst. Warum auch immer es sie gibt, es gibt keinen Grund, diese Ordner beizubehalten. Mit diesem Modul finden Sie ganz schnell leere Ordner und befreien sich von ihnen.

· Schriften verwalten und löschen:

Wie viele Schriften (Schriftarten) brauchen Sie wirklich? Alle auf ihrem System installierten Schriften werden bei jedem Start von Windows geladen. Sie verbrauchen nicht nur Speicherplatz, sondern auch wertvolle Systemressourcen. Dieses nützliche Modul listet alle Schriftarten in einem integrierten Betrachter auf und Sie können so ganz einfach die Schriften löschen, welche Sie nicht mehr benutzen wollen.

· Internetbereich säubern:

Wissen Sie, dass Jedermann mit Zugriff auf Ihren Rechner ganz einfach Ihren Spuren der letzten Internet-Sesssions folgen kann? Selbst noch nach mehr als drei Wochen, je nach dem, wie Ihr Rechner konfiguriert ist! Unbefugte sehen alle Seiten, die Sie betrachtet haben und die Namen und Adressen der von Ihnen besuchten Webseiten. Wenn Sie Ihre Privatsphäre schützen wollen, benutzen Sie bitte dieses Modul regelmäßig. Sie können sich alle Cookies, die von besuchten Seiten auf Ihrem Rechner hinterlegt werden, anschauen und löschen.


Das Programm UIWatcher
Das UIWatcher Icon | Ashampoo UnInstaller Watcher ist ein kleines Programm, welches in die Taskbar integriert ist. Es aktiviert sich automatisch, wenn ein Installationsprogramm startet. Mit einem Rechtsklick auf das UIWatcher Icon öffnet sich ein PopUp-Menü mit direkten Zugriff auf häufig benutzte Funktionen der UnInstaller Suite. Sie können z.B. Programme direkt installieren und deinstallieren, ohne den UnInstaller zu starten.
 | Mit einem Rechtsklick auf das UIWatcher Icon öffnet sich das PopUp Menü. Die Abbildung zeigt die Version, die im Easy-Modus zur Verfügung steht. Im Experten-Modus enthält das Menü noch die Optionen Speichere aktuelle Konfiguration und Vergleiche (Protokoll erstellen). Sie können damit die wichtigsten Funktionen durchführen, ohne das Hauptprogramm gestartet zu haben. Die meisten Menüs sind selbst erklärend. In den Einstellungen zur Installationsüberwachung bestimmen Sie, ob der UIWatcher aktiv sein soll und ob Sie ein Installationsprotokoll nach der Installation von Anwendungen automatisch speichern lassen wollen. Wenn Sie nicht sicher sind, lassen Sie bitte beide Optionen aktiv geschaltet. Sie sind für eine saubere Programmdurchführung notwendig. Die Option Installationsüberwachung aktiv erlaubt Ihnen das zwischenzeitliche Abschalten der Installationsüberwachung, ohne das Programm zu verlassen.
 | Wenn der UIWatcher den Start einer Installation bemerkt, öffnet sich automatisch ein Bildschirm mit der Abfrage, ob Sie die Installation einer neuen Anwendungen überwachen wollen. Sie können eine Protokolldatei erzeugen, mit der Sie die Anwendung mit der Ashampoo UnInstaller Suite später wieder deinstallieren können. UIWatcher führt Sie automatisch durch den Vorgang einer Programminstallation. Nach der Installation wird der UIWatcher wieder aktiv und fordert Sie, dass neue Programm einmal zu starten und anschließend das Installationsprotokoll zu speichern. Sie können Ihr Windows neu starten und selbst ihren Rechner während der Installation ein- oder ausschalten - das wird den UIWatcher nicht davon abhalten, sich wieder einzuschalten, wenn die Installation beendet ist.

Einschränkung:

UIWatcher wird nur dann automatisch aktiv, wenn die standardmäßigen Namen INSTALL.EXE oder SETUP.EXE der Installationsdateien vorhanden sind. Sollte das Installationsprogramm über einen anderen Namen verfügen, sollten Sie die Installation von Hand starten. Klicken Sie bitte mit Rechts auf das UIWatcher Icon in der Taskbar und wählen dann die Option Anwendung installieren.

Wie auch immer, viele Installationsprogramme mit anderem Namen erzeugen und starten ein Programm mit dem Namen INSTALL.EXE oder SETUP.EXE, die dann den UIWatcher auslösen. Wenn Sie sich entscheiden, eine Installation manuell mit der Option Neue Anwendung installieren zu überwachen, sollten Sie zunächst den UIWatcher zwischenzeitlich deaktivieren. Klicken Sie dazu mit der rechten Maustaste auf das UIWatcher Icon in der Taskbar und deaktivieren die Option Installationsüberwachung aktiv.


Konfiguration und Setup
Bevor Sie das Programm zu ersten Mal benutzen, wählen Sie bitte Einstellungen im Menü Datei oder in der Werkzeugleiste und prüfen, ob alle Einstellungen wie von Ihnen benötigt gesetzt sind. Die Einstellungen kontrollieren die Arbeitsweise der Ashampoo UnInstaller Suite und ermöglichen Ihnen, das Programm nach Ihren persönlichen Erfordernissen und Wünschen zu konfigurieren. Die Optionen werden unterschiedlich angezeigt, abhängig davon ob Sie das Programm im Easy-Modus oder Experten-Modus benutzen.

Der Easy-Modus für unerfahrene Benutzer von Windows:

Wenn Sie über wenig Erfahrung mit Windows verfügen, prüfen Sie, ob der Easy-Modus aktiviert ist. (Wählen Sie Wechsle Modus und anschließend Wechsle zum Easy-Modus im Menü Datei). Folgen Sie bitte den Anweisungen im Abschnitt Die Konfiguration im Easy-Modus.

Der Experten-Modus für erfahrene Benutzer von Windows:

Sollten Sie bereits ein erfahrener Benutzer von Windows sein und den Einsatz der Ashampoo UnInstaller Suite im Experten-Modus planen, wechseln Sie bitte in den Experten-Modus mit der entsprechenden Option im Menü Datei. Lesen Sie bitte den Abschnitt Die Konfiguration im Easy-Modus für die wesentlichen Einstellungen des Programms und den Abschnitt Die Konfiguration im Experten-Modus für zusätzliche Optionen und Einstellungen, die im Easy-Modus nicht zur Verfügung stehen.


Die Konfiguration im Easy-Modus

Easy-Modus Konfiguration
Bitte prüfen Sie zunächst, ob der Easy-Modus aktiv ist. (Wählen Sie Wechsle Modus und anschließend Wechsle zum Easy-Modus im Menü Datei).

Wählen Sie dann Einstellungen im Menü Datei oder das Icon Einstellungen in der Werkzeugleiste. Die Einstellungen im Easy-Modus sind in vier Registern organisiert:

Das Register Allgemein

· Pfad zur Autoexec.bat und Config.sys:

Diese sind die Adressen der zwei wesentlichen Startdateien, die überwiegend von Windows 95, 98 und Me Systemen verwendet werden. Bitte tragen Sie hier nichts ein, solange Sie ihr System nicht anders konfiguriert haben und andere, vom Standard abweichende (normalerweise C:\ ) Speicheradressen, angegeben haben. Wenn Sie unsicher sind, tragen Sie bitte nichts ein oder befragen Sie die Person, die auch den Rechner eingerichtet hat.

· Vorgabe für Standard-Registry-Einträge:

Dies ist der Text, der bei der Anzeige von Standardschlüsseln in der Windows Registry verwendet wird. Der Standardwert ist (Standard). Bitte ändern Sie nichts daran, wenn kein Grund dafür vorliegt - es ist auch nur für den Experten-Modus von Bedeutung.

· leerer Registry-Eintrag:

Dies ist der Text, der bei noch leeren Registry-Einträgen angezeigt wird. Bitte ändern Sie nichts daran, wenn kein Grund dafür vorliegt - es ist auch nur für den Experten-Modus von Bedeutung.

· Zeige Registry-Fehlermeldungen:

Manchmal ist es nicht möglich, Teile der Registry korrekt zu lesen, vor allem auf Systemen mit Windows 2000 oder XP. Die Abwahl dieser Option unterdrückt diese Fehlermeldungen. Wenn Sie generell im Easy-Modus arbeiten, sollten Sie diese Optionen abgewählt lassen.

· Aktiviere Installationsüberwachung in der Taskbar:

Wenn ausgewählt, startet der UIWatcher jedes mal automatisch, wenn Windows gestartet wird. Sie sollten die Einstellung so belassen. Der UIWatcher wird dann automatisch aktiv, wenn Sie ein neues Programm installieren und Sie daran erinnern, die Installation zu überwachen und zu protokollieren. Sie können die Anwendungen später restlos und sauber entfernen. Der UIWatcher verbraucht kaum Speicherplatz und beeinflusst auch keine anderen Programme auf Ihrem System.

Hinweis: UIWatcher wird nur dann aktiviert bei Installationsprogrammen mit den Namen setup.exe oder install.exe. Wie auch immer, Sie können Programme von Hand aus dem UIWatcher installieren. Klicken Sie dazu mit Rechts auf das Icon des UIWatcher in der Taskbar und wählen dann Neue Anwendung installieren.

· Modus:

Bestimmt, ob die Ashampoo UnInstaller Suite im Easy-Modus oder Experten-Modus starten soll. Sie können zwischen beiden Modi auch mit dem Icon Wechsle Modus und der Option Wechsle Modus im Menü Datei wechseln.

Das Register Ansicht

· Anzeigen der Hilfe-Hinweise:

Aktiviert oder deaktiviert die Hilfe-Hinweise, die automatisch angezeigt werden, wenn Sie die Maus über Bedienungselemente in den Programmfenstern positionieren.

· Menüs im XP-Style:

Aktiviert oder deaktiviert Menüs im Windows® XP-Style. Bitte deaktivieren Sie diese Option unter Windows® Me, wenn Sie Probleme mit der grafischen Anzeige von Icons und Menü-Elementen feststellen sollten.

Das Register Löschen

Mit diesen Optionen bestimmen Sie, wie die Ashampoo UnInstaller Suite gelöschte Dateien behandeln soll, wenn Sie eine Anwendungen deinstallieren.

· Optionen beim Löschen:

Sie können auswählen, ob die gelöschten Dateien in den Papierkorb verschoben werden (Standard) oder in einem speziellen Verzeichnis gespeichert werden sollen. Wenn Sie die Option Dateien sichern im nachfolgenden Verzeichnis: wählen, werden die gelöschten Dateien automatisch von der Ashampoo UnInstaller Suite an die gewählte Adresse verschoben. Wenn Sie grundsätzlich im Easy-Modus arbeiten, wählen Sie bitte die Option verschieben der Dateien in Papierkorb beim Löschen aus. Siehe den Abschnitt Die Konfiguration im Experten-Modus für Details zur Verwendung der Backup-Funktion.

Warnung:
Wenn Sie beide Optionen verschieben der Dateien in Papierkorb beim Löschen und Dateien sichern im nachfolgenden Verzeichnis: abwählen wird die Ashampoo UnInstaller Suite die Dateien einfach löschen - ohne ein Backup im Papierkorb oder einem Backup-Verzeichnis zu erstellen!

· gemeinsam benutzte Dateien:

Dieser Abschnitt ist im Easy-Modus abgeschaltet. Siehe Die Konfiguration im Experten-Modus für weitere Hinweise.

Das Register Sprache

Bestimmt die Sprache der Programmoberfläche. Wenn Sie Systemvorgabe wählen, versucht die Ashampoo UnInstaller Suite in die Sprache zu wechseln, in der das Windows-System konfiguriert ist. Das kann misslingen, wenn die Einstellungen Ihres Keyboards (Tastatur) und andere sogenannte lokale Einstellungen nicht mit denen Ihrer Windows-Version übereinstimmen. Sie müssen das Programm mit einer ausgewählten Sprache neu starten, damit die Änderungen wirksam werden.

Hinweis:
Die Fenstergrößen, die Position der Werkzeugleiste etc. werden automatisch beim Verlassen der Ashampoo UnInstaller Suite gespeichert und erneut geladen, wenn Sie das Programm wieder starten.


Die Konfiguration im Experten-Modus
Dieser Abschnitt deckt die Einstellungen ab, die im Easy-Modus entweder nicht verfügbar oder nicht relevant sind. Bitte lesen Sie die Informationen sorgfältig, wenn Sie beabsichtigen, im Experten-Modus zu arbeiten!

Das Register Allgemein:

· Pfad zur Autoexec.bat und Config.sys:

Ashampoo UnInstaller Suite benötigt die gültigen Pfade zu den Versionen dieser Dateien, die beim Starten Ihrer Windows-Konfiguration verwendet werden. Wenn Sie Ihr System so eingestellt haben, dass andere Versionen der autoexec.bat und config.sys an anderen Speicheradressen verwendet werden, tragen Sie bitte den entsprechenden Pfad ein. Sonst kann Ashampoo UnInstaller Suite die Änderungen an diesen Dateien nicht korrekt überwachen.

Hinweis: Wenn Sie ein Dual-Boot-System mit einer Windows 9x Version auf ihrer sichtbaren primären Partition (z.B. C:\ ) benutzen und ein NT-basiertes System wie NT4, 2000 oder XP auf einer anderen Partition (z.B. D:\ oder höher), wird das NT-basierte Betriebssystem die Dateien Autoexec.bat und Config.sys auf C:\ beim Starten abarbeiten!

· Texte für "Default-Registry-Einträge" und "Leerer Registry-Eintrag":
Diese Texte werden automatisch für Standardschlüssel und leere Werte in der Windows Registry angezeigt. Die Standardwerte sind (Standard) und (leer).

Das Register Löschen:

· Lösch-Einstellungen:

Wenn Sie die Option Dateien sichern im nachfolgenden Verzeichnis: auswählen, erzeugt Ashampoo UnInstaller Suite Kopien aller gelöschten Dateien mit ihrem Quellverzeichnis in dem angegebenen Ordner. Dadurch können Sie die Dateien schnell wieder finden und wiederherstellen, wenn sie versehentlich gelöscht wurden. Diese Einstellung ist unbedingt notwendig zur Deinstallation von Anwendungen mit Installationsprotokollen, die von der Ashampoo UnInstaller Suite erzeugt wurden. Darüber hinaus ist diese Einstellung für alle Vergleichs- und Wiederherstellungsfunktionen, die von Hand im Experten-Modus durchgeführt werden, unbedingt erforderlich.

Zum Beispiel können Sie um 9 Uhr 30 im Experten-Modus die Option Speichere aktuelle Konfiguration durchführen, anschließend eine Vielzahl von Aktionen tätigen und um 10 Uhr 30 die Option Vergleiche (Protokoll erstellen) nutzen. Dieses Protokoll enthält alles, was Sie während der 1 1/2 Stunden an Ihrem Rechner zwischen Speichern und Vergleichen getan haben - einschließlich neuer, von Ihnen erzeugter Dokumente etc. Wenn Sie dann das Protokoll von 10 Uhr 30 laden und die Option Alles Wiederherstellen wählen, können Sie leicht Einträge löschen, die Sie behalten möchten. In einem solchen Fall ist es hilfreich, über ein Backup zu verfügen.

Warnung:
Wenn Sie beide Optionen Verschieben der Dateien in Papierkorb beim Löschen und Dateien sichern im nachfolgenden Verzeichnis: abwählen wird die Ashampoo UnInstaller Suite die Dateien einfach löschen - ohne ein Backup im Papierkorb oder einem Backup-Verzeichnis zu erstellen!

· Gemeinsam benutzte Dateien:

Diese Option bestimmt die Arbeitsweise des Programms bei gemeinsam genutzten Dateien. Im Easy-Modus ist aus Sicherheitsgründen diese Option deaktiviert. Im Experten-Modus verfügen Sie über drei Optionen:

Jeweils nachfragen: Wenn Sie diese Option auswählen, werden Sie vom Programm immer gefragt, bevor Sie eine gemeinsam genutzte Datei löschen, selbst wenn der Zähler Null ist. (Siehe gemeinsam benutzte Dateien für weitere Erläuterungen).

Automatisch löschen wenn Zähler Null wird: In diesem Modus wird das Programm automatisch gemeinsam benutzte Dateien ohne Abfrage löschen, wenn der "Zähler" Null erreicht hat. Bitte nur auswählen, wenn Sie dem Zähler von Windows völlig vertrauen oder gelöschte Dateien wenn nötig mit Backups wieder herstellen wollen.

Alle Dateien beibehalten: Diese Option belässt gemeinsam benutzte Dateien immer auf Ihrer Festplatte, selbst wenn der Zähler auf Null gesetzt wurde. Das ist die sicherste Option. Da Speicherplatz kein Kostenfaktor mehr darstellt ist es die wahrscheinlich beste Möglichkeit. Gemeinsam benutzte Dateien verbrauchen relativ gesehen nicht all zu viel Festplattenplatz. Es ist daher einfacher, sie an ihrem Platz zu belassen, als sie zu löschen.

Das Register Backup

Dieses Register wird nur im Experten-Modus angezeigt. Es ermöglicht die Konfiguration für die Funktion Backup erstellen, die ebenfalls nur im Experten-Modus verfügbar ist.

· Verzeichnisse autom. sichern im nachfolgenden Verzeichnis:

Ist diese Option ausgewählt, werden die in Backup erstellen ausgewählten Dateien jedes mal automatisch gesichert, wenn Sie Speichere aktuelle Konfiguration oder Speichere Konfiguration unter wählen. Sie können einen Ordner angeben, der für diese Backups verwendet werden soll. Wenn Sie Windows® NT, 2000 oder XP verwenden, ist es ratsam, einen komprimierten Order dafür zu verwenden.

· Gesicherte Dateien beim Wiederherstellen verwenden:

Ist diese Option ausgewählt, versucht die Ashampoo UnInstaller Suite eine Wiederherstellung mit diesen Dateien, wenn Sie eine Anwendung deinstallieren oder andere Veränderungen an ihrem System mit einem Protokoll wiederherstellen wollen. (Siehe Backup erstellen und die entsprechenden Abschnitte im Kapitel Das Programm im Experten-Modus benutzen für weitere Hinweise zu diesem Thema.)

Das Register Versionsinformation

Dieses Register wird nur im Experten-Modus angezeigt. Sie können mit dieser Option bestimmen, ob Versionsinformationen für Dateien auf ihrem System mit der Funktion Speichere Konfiguration gespeichert werden sollen. Sie können auch die Dateitypen bestimmen, für die Sie die Funktion nutzen wollen.

Im Allgemeinen macht es nur Sinn, Versionsinformationen für wichtige Systemdateien zu speichern, die von anderen Programmen überschrieben werden könnten.

Besonderer Tipp:
Aktivieren Sie die Option Speichere Versionsinformation und prüfen die Register Installationsprotokolle nach dem Installieren einer Anwendung. Sie können dann sofort sehen, ob wichtige Dateien mit älteren Versionen überschrieben wurden. Wenn Sie diese Funktion in Verbindung mit dem Feature Backup erstellen nutzen, können Sie umgehend Ihre Originaldateien wiederherstellen.


Systemvoraussetzungen

Betriebssysteme:

Windows® 95, 98, Me, NT4, 2000 oder XP.

Wichtiger Hinweis für Benutzer von Windows® NT4, 2000 & XP:

Ashampoo UnInstaller Suite unterstützt Windows® NT4 (ServicePack 3 oder höher erforderlich), 2000 und XP. Sie können das Programm zur Überwachung von Installationen sowohl als Administrator aber auch als normaler Benutzer ohne Administratorrechte benutzen. In der Regel sind jedoch Administratorrechte zur Programminstallation und für Änderungen am Betriebssystem erforderlich. Das Entfernen von Anwendungen und die Wiederherstellung berührt das Löschen oder die Veränderungen von Registry- und Dateieinträgen, die vom Betriebssystem geschützt sind.

Hardware:

Jeder Computer, der das verwendete Betriebssystem unterstützt. Eine Grafikkarte mit einer Auflösung von 800 x 600 Pixeln und mindestens 256 Farben (Das Programm wird bei weniger Farben nicht so schön aussehen.) sowie ausreichend Speicherplatz für das von Ihnen benutzte Betriebssystem.

Speicherplatz:

Ca. 10MB für die Programmdateien. Zusätzlicher Speicherplatz für die Backups Ihres Betriebssystems, wenn Sie die Funktion Backup erstellen benutzen (Wie viel Platz Sie benötigen hängt von den von Ihnen ausgewählten Ordnern und Dateien ab).


Sicherheit
Ashampoo UnInstaller Suite ist ein mächtiges Werkzeug und wie alle Werkzeuge kann es bei unkorrekter Anwendung zu Problemen führen. Bitte lesen Sie die Dokumentation sorgfältig und beachten Sie alle Warnungen und Hinweise.

Experten-Modus

Bitte seien Sie besonders sorgfältig, wenn Sie das Programm im Experten-Modus benutzen. Dieses Modul wurde für erfahrene Benutzer mit guten Kenntnissen über die Windows-Konfiguration und der Windows Registry entwickelt.
Bevor Sie irgendwelche Operationen im Experten-Modus durchführen, lesen Sie bitte den Abschnitt Das Programm im Experten-Modus benutzen sorgfältig durch.

Autostart-Programme

Sehr oft wird durch Installationsprogramme Windows automatisch heruntergefahren und neu gestartet, um die Installation einer Anwendung abzuschließen. Die manuellen und automatischen Optionen der Ashampoo UnInstaller Suite zur Installationsüberwachung können damit ohne Probleme umgehen - ein Neustart von Windows beeinträchtigt nicht die Überwachung der Installation. Weil das Programm alle Änderungen an Ihrem System, die während der Installation einer Anwendungen stattfinden, überwacht, sollten Sie sich einige Gedanken zu den Programmen machen, die Sie automatisch zusammen mit Windows starten.

Wenn eine Anwendung neue Daten erzeugt, wenn es mit Windows gestartet wird, besteht die Möglichkeit, dass die Ashampoo UnInstaller Suite diese Daten als Teil der Installation aufzeichnet. Diese Daten würden dann beim Entfernen der Anwendung gelöscht werden. Angenommen Sie hätten ein Programm, dass Ihre E-Mails sammelt oder Wetterberichte oder Börsendaten herunter lädt - es ist offensichtlich, dass Sie solche Daten nicht als Teil einer Anwendung protokollieren möchten, welches Sie später vielleicht einmal entfernen möchten.

Die meisten Autostart-Programme verursachen keine Probleme. Um aber auf der sicheren Seite zu sein, sollten Sie Anwendungen, die automatisch E-Mails anfordern oder automatische neue Daten erzeugen, abschalten, während Sie neue Anwendungen installieren.

Wann Sie das Feature der automatischen Erkennung des UIWatcher nicht nutzen sollten

Die Fähigkeit des UIWatcher, automatisch Installationsprogramme zu erkennen wird für die meisten Installationen sehr gut arbeiten. Das Programm kann aber "verwirrt" sein, wenn Sie ein Installationsprogramm für ein Paket an Anwendungen starten. Das Problem besteht darin, dass ein solcher Installer zwei, drei oder mehr Installationsprogramme starten. Darüber hinaus starten einige dieser Pakete dann Installationsprogramme mit einer ganzen Serie von unterschiedlichen Namen. Einige davon werden vom UIWatcher erkannt, andere wiederum nicht. Wenn Sie Pech haben, wird das erste Installationsprogramm vom UIWatcher nicht erkannt. Das Installationsprotokoll wird dann nicht die gesamte Anwendung enthalten, weil einige Einträge bereits installiert sind, bevor der UIWatcher aktiviert ist.

Um auf der sicheren Seite zu sein, benutzen Sie die im Abschnitt Installieren mit dem UIWatcher beschrieben Arbeitsweise für:

· Anwendungen, die mehr als ein Software-Modul enthalten.

· Installationsprogramme, die weder INSTALL.EXE oder SETUP.EXE heißen.

Multi-Boot-Systeme

Wenn Sie ein System mit verschiedenen Instanzen von Windows auf sichtbaren Partitionen benutzen, lesen und beachten Sie bitte die folgenden Sicherheitshinweise. (Diese Hinweise gelten nicht, wenn ein Boot Manager verwendet wird, der aktuell nicht benutzte Systempartitionen physikalisch verbirgt.)

· Benutzen Sie den Easy-Modus nie auf Multi-Boot-Systemen mit mehr als einem installierten Windows-System auf der gleichen Partition. Ashampoo UnInstaller Suite wurde dafür nicht entwickelt und Sie können Ihr System schwer beeinträchtigen. (Die Installation von mehr als einem Windows-System auf einer Partition führt von sich aus schon zu vielen Problemen ...). Bei solchen Konfigurationen müssen Sie den Experten-Modus benutzen und alles abwählen, was in Verbindung mit den Windows-Instanzen steht und in den Auswahl-Registern aktuell nicht aufgeführt sind.

· Egal ob Sie den Easy-Modus oder Experten-Modus benutzen, bitte wählen Sie alle Laufwerke der Windows-Betriebssysteme ab, die gegenwärtig nicht arbeiten.

· Wir empfehlen Ihnen dringend, mehrere Installationen der Ashampoo UnInstaller Suite in unterschiedlichen Ordner für jede Windows-Instanz durchzuführen. Der Inhalt der Konfigurations- und Installationsprotokolldateien, die unter einem System erstellt wurden, müssen ja nicht mit der aktuellen Struktur der Registry eines anderen Windows-Systems übereinstimmen. Wenn Sie die Ashampoo UnInstaller Suite aus dem gleichen Ordner heraus für mehr als ein System starten und benutzen, erhalten Sie völlig bedeutungslose und (möglicherweise gefährliche) Resultate, wenn Sie die Konfigurationen von zwei verschiedenen Systemen vergleichen wollen.


Hilfe-Tipps
Der Zugriff auf das Hilfe-System:

Die Ashampoo UnInstaller Suite verfügt über ein komplett kontextsensitives Hilfe-System. Um sich die Online-Hilfe anzeigen zu lassen, klicken Sie einfach in jedem Bildschirm auf die Schaltfläche Hilfe oder Sie wählen Hilfe im Menü Hilfe, um jederzeit den Zugriff auf die entsprechenden Hinweise und Erläuterungen zur gerade geplanten Aktion zu haben. Sollten Ihnen die Hinweise nicht weiterhelfen, kontaktieren Sie bitte den Ashampoo Support. Lesen Sie aber bitte zunächst diese Hilfe - es wurden viele Anstrengungen unternommen, diese so umfassend wie möglich zu gestalten. Wir sind sicher, Sie werden auf die Mehrzahl Ihrer Fragen die Antworten bereits in dieser Online-Dokumentation finden!

Links in diesem Hilfe-System:

In dieser Online-Hilfe werden drei verschiedene Arten von Links benutzt, die durch unterschiedliche Farben gekennzeichnet sind:

(Sprung-) Jump-Links | Grün: Durch Klicken auf einen dieser Links werden Sie zu einem anderen Abschnitt oder einer anderen Stelle im aktuellen Abschnitt geleitet. Um zum ursprünglichen Abschnitt nach dem "Sprung" zurückzukehren, klicken Sie einfach auf die Schaltfläche Zurück in der Werkzeugleiste der Hilfe. Durch Klicken auf das Beispiel links gelangen Sie zum Abschnitt Sicherheit in der Einführung.
PopUp-Links | Rot: Durch Klicken auf einen dieser Links erhalten Sie zusätzliche Informationen in einem PopUp-Fenster.
Internet-Links | Blau mit einem Internet-Icon: Wenn Sie über eine Internet-Verbindung verfügen, öffnet sich durch einen Klick auf einen dieser Links Ihr Internet-Browser und führt Sie zu der voreingestellten Internet-Seite. Das Beispiel links führt Sie zu der deutschen Homepage von Ashampoo.

So finden Sie die benötigten Informationen:

So fangen Sie an:

Dieses Hilfe-System wurde entwickelt, um Ihnen schnell und einfach die benötigten Informationen zu liefern. Wenn Sie das Programm zum ersten Mal benutzen, sollten Sie die Abschnitte im Kapitel Einführung studieren; sie vermitteln Ihnen das Basiswissen zur Arbeitsweise dieses Programms.

Der Inhalt:

Wenn Sie beim Aufruf der Online-Hilfe nicht automatisch das benötigte Kapitel oder den benötigten Abschnitt angezeigt bekommen, müssen Sie zunächst in den Inhalt schauen. Sollte der Inhalt noch nicht angezeigt werden, klicken Sie bitte auf das Register Inhalt im linken Fenster des Hilfe-Fensters. (Klicken Sie auf das Icon Einblenden in der Werkzeugleiste, falls die Register nicht sichtbar sein sollten.)

Das Hilfe-System verfolgt den Ansatz des "Learning by doing". Sie werden zu allen Aktionen, die Sie mit dem Programm durchführen können, die entsprechenden Abschnitte mit den Erläuterungen finden. Zusätzliche Informationen stehen Ihnen in den Abschnitten Referenzen sowie Menüs und Werkzeuge zur Verfügung.

Der Index:

Um sich den Index der Hilfe anzeigen zu lassen, klicken Sie einfach auf das Register Index (Klicken Sie auf das Icon Einblenden in der Werkzeugleiste, falls das Register nicht sichtbar sein sollte.). Sie können dann durch die Liste aller Einträge "scrollen" oder einen Suchbegriff im Feld oben eingeben. Wenn Sie ein passendes Stichwort gefunden haben, klicken Sie bitte doppelt auf den Eintrag, um sich den Abschnitt anzeigen zulassen, auf den das Stichwort verweist.

Suchen:

Falls Sie keinen passenden Begriff oder ein passendes Stichwort gefunden haben, können Sie selbstverständlich eine Volltextsuche durchführen. Klicken Sie einfach auf das Register Suchen im Hilfe-Fenster. (Klicken Sie auf das Icon Einblenden in der Werkzeugleiste, falls das Register nicht sichtbar sein sollte.) Bitte geben Sie dann Ihren Suchbegriff ein, nach dem gesucht werden soll. Anschließend klicken Sie auf die Schaltfläche Themen auflisten, um die Suche zu starten.

Tipp:

Sie können auch komplexe Suchvorgänge mit mehreren Suchbegriffen durchführen, indem Sie die Operatoren AND, OR, NEAR und NOT verwenden. Zum Beispiel: Bei Eingabe von "Installieren AND UIWatcher NOT XP" werden alle Abschnitte aufgelistet, welche die Begriffe "Installieren" und "UIWatcher" beinhalten; aber nicht den Begriff "XP". ("Installieren AND UIWATCHER AND XP" wird ein anderes Ergebnis liefern.)
Bei der Eingabe von "Installieren NEAR UIWatcher" finden Sie die Abschnitte, in denen der Begriff "Installieren" nahe beim Begriff "UIWatcher" auftaucht. Durch Klicken auf das Pfeil-Symbol direkt rechts neben dem Eingabefeld öffnet sich eine Popup-Auswahlliste, mit der Sie die Operatoren direkt eingeben können.


Hinweise für Benutzer von Windows® NT
Bei bestimmten Konstellationen von Windows®NT, dem Microsoft Internet Explorer und ActiveX-Controls kann es vereinzelt zu Problemen beim Benutzen dieser Online-Hilfe kommen.
Sollten Sie Fehlermeldungen erhalten, wenn Sie einige Seiten öffnen oder auf einige Links dieser Hilfe klicken, lesen Sie bitte den Artikel der Microsoft Knowledge Base zur Problemlösung.

MS Knowledge Base Q235653


Das Programm im Easy-Modus benutzen
Der Easy-Modus ist der Standardmodus der Ashampoo UnInstaller Suite. Alle weiterführenden Funktionen des Programms, die tiefer gehende Kenntnisse erfordern, sind verborgen. Das bedeutet keinesfalls, dass der Easy-Modus nicht leistungsfähig ist. Im Gegenteil: Auch als erfahrener Windows-Benutzer werden Sie feststellen, dass der Easy-Modus der einfachste Weg zur Überwachung von Anwendungen und zur späteren Deinstallation ist. Sie werden nur dann in Experten-Modus wechseln, um die weiteren tollen Features des Programms (wie im Abschnitt Das Programm im Experten-Modus benutzen) beschrieben, zu nutzen.

Erkennen und Wechsel des Modus:

Der aktuelle Modus wird in der Titelzeile des Hauptfensters des Programms und durch das erste Icon links in der Werkzeugleiste Werkzeugleiste angezeigt.

Ein Küken symbolisiert den Easy-Modus, der Adler den Experten-Modus. Um in den Easy-Modus zu wechseln, klicken Sie auf den Adler und wählen dann Wechsle zum Easy-Modus.

Der Easy-Modus schützt Sie

Wenn Sie zum Easy-Modus wechseln, werden alle Einstellungen der Ashampoo UnInstaller Suite auf die sicheren Standardeinstellungen zurückgesetzt. Es ist damit unmöglich, mit den im Experten-Modus gemachten Einstellungen Daten zu verlieren oder irgendeinen Schaden anzurichten, falls Sie vergessen haben sollten, diese Einstellungen vor dem Wechsel in den Easy-Modus zurückzusetzen.

Ebenso schützt Sie die Ashampoo UnInstaller Suite vor dem Verlust von Einstellungen im Experten-Modus. Wenn Sie in den Easy-Modus wechseln, werden Ihre Einstellungen automatisch in eine Sicherungsdatei gespeichert. Beim nächsten Wechsel zurück in den Experten-Modus erfolgt die automatische Abfrage, ob Sie Ihre Einstellungen wieder laden möchten, die Sie vor dem Wechsel in den Easy-Modus benutzt hatten.


Anwendungen installieren
Dieser Abschnitt enthält Anweisungen zur Installation von Anwendungen im Easy-Modus.

Warum benötigen Sie den UnInstaller oder UIWatcher bei der Programminstallation?

Ashampoo UnInstaller Suite kann nur dann alle Spuren einer Anwendung von Ihrem System entfernen, wenn ein Installationsprotokoll mit allen Veränderungen, die durch die Installation eines Programms vorgenommen wurden, erstellt wurde. Dazu ist es erforderlich, den Status Ihrer Systemkonfiguration vor der Installation eines Programmes und direkt nach der Installation in einer Protokolldatei zu speichern. Aus dem Vergleich der beiden Berichte wird das Installationsprotokoll erzeugt.

Im Easy-Modus ist der gesamte Prozess automatisiert

Ist der Easy-Modus aktiviert, ist der gesamte Prozess der Installation und Deinstallation eines Programmes automatisiert, unabhängig davon, ob der Vorgang aus dem UIWatcher in der Taskbar oder aus dem Hauptprogramm-Bildschirm heraus gestartet wird.

Die Auswahlregister - was das Programm überwacht

Bevor Sie beginnen, starten Sie bitte die Ashampoo UnInstaller Suite und prüfen, ob sich das Programm im Easy-Modus befindet. Klicken Sie dann auf Auswahl: Registry & Laufwerke. Sie sehen dann eine Liste aller Laufwerke auf Ihrem Computer. Anhand dieser Liste wird bestimmt, an welchen Stellen das Programm nach Dateien und Einträgen, die während der Installation einer neuen Anwendung hinzugefügt werden, schauen soll.

· Im Easy-Modus wählt das Programm alle Festplatten auf Ihrem Rechner aus (1), aber ohne die Einträge, die nicht eingeschlossen werden sollten. Wenn es Sie interessiert, können Sie sich die Einträge durch Klicken auf die + Symbole links neben den Laufwerken anzeigen lassen. (2) Sie können aber keine Änderungen vornehmen.

· Die einzige Änderung, die Sie vornehmen können ist die Aus- oder Abwahl von Laufwerken. Sie können z.B. das Laufwerk, auf dem Sie ihre persönlichen Daten speichern, abwählen. Es ist sehr unwahrscheinlich, dass ein Programm irgendwelche Dateien dahin installiert. Dort wird die Geschwindigkeit der Ashampoo UnInstaller Suite erhöht, da ein Scannen dieses Laufwerks entfällt.

· Um ein Laufwerk aus- oder abzuwählen, klicken Sie bitte in das Kästchen neben dem Namen des Laufwerks (2) . Einträge, die nicht überwacht werden sollten, sind automatisch ausgeschlossen. Sie können das Laufwerk, auf welchem Windows installiert, im Easy-Modus nicht abwählen.

· CD-ROM Laufwerke und Netzlaufwerke (3) sind zur Überwachung nicht auswählbar, da Programme keine Einträge auf diesen Laufwerken vornehmen können. Bitte wählen Sie solche Laufwerke nur dann aus, wenn Sie gute Gründe für Ihre Entscheidung haben.


Installieren mit dem UIWatcher
Sobald Sie ein Installationsprogramm mit den Namen INSTALL.EXE oder SETUP.EXE starten, schaltet sich der Ashampoo UnInstaller Watcher automatisch ein und fragt ab, ob Sie die Installation mit der Ashampoo UnInstaller Suite überwachen möchten. Bitte folgen Sie einfach den Hinweisen auf den Bildschirmen. (Das funktioniert natürlich nur, wenn Sie den UIWatcher in der Taskbar nicht deaktiviert haben!)

Die Vorgehensweise ist nahezu identisch wie beim weiter unten beschriebenen Ablauf bei der manuellen Installation von Anwendungen mit dem UIWatcher - der einzige Unterschied liegt in der automatischen Erkennung des Installationsprogramms und dem automatischen Start des UIWatcher.

Wann Sie das Feature der automatischen Erkennung des UIWatcher nicht nutzen sollten

Die Fähigkeit des UIWatcher, automatisch Installationsprogramme zu erkennen wird für die meisten Installationen sehr gut arbeiten. Das Programm kann aber "verwirrt" sein, wenn Sie ein Installationsprogramm für ein Paket an Anwendungen starten. Das Problem besteht darin, dass ein solcher Installer zwei, drei oder mehr Installationsprogramme starten. Darüber hinaus starten einige dieser Pakete dann Installationsprogramme mit einer ganzen Serie von unterschiedlichen Namen. Einige davon werden vom UIWatcher erkannt, andere wiederum nicht. Wenn Sie Pech haben, wird das erste Installationsprogramm vom UIWatcher nicht erkannt. Das Installationsprotokoll wird dann nicht die gesamte Anwendung enthalten, weil einige Einträge bereits installiert sind, bevor der UIWatcher aktiviert ist.

Um auf der sicheren Seite zu sein, benutzen Sie die beschriebenen Arbeitsweise für:

· Anwendungen, die mehr als ein Software-Modul enthalten.

· Installationsprogramme, die weder INSTALL.EXE noch SETUP.EXE heißen.

Programme manuell mit dem UIWatcher installieren

Das Programm UIWatcher schaltet sich nur automatisch ein, wenn ein Installationsprogramm mit den Namen INSTALL.EXE oder SETUP.EXE gestartet wird. Das gilt in der Regel für die meisten Installationsprogramme. Selbst Instaallationsprogramme mit anderen Namen generieren gewöhnlich Dateien, die INSTALL.EXE oder SETUP.EXE heißen und die dann gestartet werden.

Wenn der UIWatcher nicht aktiviert wird, wenn Sie ein Installationsprogramm mit einem anderen Namen starten, klicken Sie bitte im Installationsprogramm auf Abbrechen und starten dann den Vorgang manuell.

Sie sollten den UIWatcher in der Taskbar deaktivieren, bevor Sie eine manuelle Installation durchführen. Sie verhindern damit, dass der UIWatcher automatisch aktiviert wird, wenn Sie ein Installationsprogramm starten, das Sie bereits manuell überwachen. Klicken Sie einfach mit der rechten Maustaste auf das Icon des UIWatcher und wählen die Option Installationsüberwachung aktivieren ab.

Vorgehensweise:

1. Klicken Sie mit der rechten Maustaste auf das Icon des UIWatcher in der Taskbar.

2. Wählen Sie Neue Anwendung installieren im geöffneten PopUp-Menü.

3. Lokalisieren und wählen Sie das Installationsprogramm im folgenden Dialog aus. Klicken Sie dann auf Öffnen und folgen den Anweisungen des UIWatcher und des Installationsprogrammes.

Sie können Ihr Windows neu starten oder gar den Rechner während des Installationsvorgangs aus- und wieder einschalten - die Überwachung des Installationsprozesses durch die Ashampoo UnInstaller Suite wird dadurch nicht beeinträchtigt.

Hinweis: Wenn Sie Ihr Windows während des Installationsvorgangs neu starten müssen, werden Sie festellen, dass das Fenster von UIWatcher kurz vor dem Neustart von Windows auftaucht. Sie werden keine Zeit zum Betrachten des Fensters oder zur Eingabe des Namens für das Installationsprotokolls haben -- machen Sie sich aber keine Sorgen. Dieser Vorgang ist völlig normal und hat keinerlei Einfluss auf den Überwachungsvorgang.

4. Wenn die Installation abgeschlossen ist, wird der UIWatcher wieder automatisch aktiviert. Sie werden aufgefordert, das Programm einmal zu starten und dann wieder zu verlassen (Das ist sehr wichtig zum Beenden der Installation).

Sie sollten dann das Installationsprotokoll speichern. Geben Sie bitte einen Namen in das entsprechende Feld im UIWatcher ein (1) und klicken dann auf Installationsprotokoll speichern.

Das in Schritt 4 erzeugte Protokoll enthält alle Änderungen, die bei der Installation der neuen Anwendung an Ihrem System vorgenommen wurden. Diese Informationen ermöglichen der Ashampoo UnInstaller Suite das Programm komplett von Ihrem Rechner zu entfernen, wenn Sie sich zum Deinstallieren entscheiden. Siehe Programme deinstallieren für weitere Hinweise.

Wichtiger Hinweis:

Bitte schließen Sie den Installationsvorgang so schnell wie möglich ab und führen auch keine Arbeiten an Ihrem Computer durch, bis Sie Installationsprotokoll gespeichert haben. Das Programm erlaubt Ihnen nur die Durchführung des automatischen Deinstallationsvorgangs mit Installationsprotokollen, die unmittelbar nach der Installation erzeugt wurden. Dieser Schutzmechanismus wurde entwickelt, damit sichergestellt wird, dass Sie keine wichtigen Daten in Ihr Installationsprotokoll einschließen, die nicht mit der neuen Anwendung in Beziehung stehen (Zum Beispiel Text- und andere Dateien, die Sie vor dem Generieren der Installationsprotokolle erzeugt haben).


Installieren mit dem UnInstaller
Im Easy-Modus ist das Installieren von Anwendungen mit dem Hauptprogramm UnInstaller ebenso einfach wie mit der automatischen Funktion des UIWatcher.

Es ist sinnvoll, den UIWatcher in der Taskbar zu deaktivieren, bevor Sie eine manuelle Installation vornehmen. Dadurch wird verhindert, dass der UIWatcher automatisch aktiviert wird, wenn Sie ein Installationsprogramm starten, das Sie schon manuell überwachen. Klicken Sie einfach mit der rechten Maustaste auf das UIWatcher Icon in der Taskbar und wählen die Option Installationsüberwachung aktiv ab.

Vorgehensweise:

1. Starten Sie die Ashampoo UnInstaller Suite und prüfen, ob der Easy-Modus aktiv ist. (Wählen Sie Wechsle zum Easy-Modus im Menü Datei, wenn es nicht der Fall sein sollte.)

2. Wählen Sie das Register Suite und klicken dann doppelt auf das Icon Neue Anwendung installieren.

Sie können ebenso Neue Anwendung installieren im Menü UnInstaller wählen.

3. Folgen Sie den Anweisungen auf dem Bildschirm.

Sie können Ihr Windows neu starten oder gar den Rechner während des Installationsvorgangs aus- und wieder einschalten - die Überwachung des Installationsprozesses durch die Ashampoo UnInstaller Suite wird nicht beeinträchtigt.

4. Wenn die Installation abgeschlossen ist, wird der UIWatcher wieder automatisch aktiviert. Sie werden aufgefordert, das Programm einmal zu starten und dann wieder zu verlassen (Das ist sehr wichtig zum Beenden der Installation).

Sie sollten dann das Installationsprotokoll speichern. Geben Sie bitte einen Namen in das entsprechende Feld im UIWatcher ein (1) und klicken dann auf Installationsprotokoll speichern.

Das in Schritt 4 erzeugte Protokoll enthält alle Änderungen, die bei der Installation der neuen Anwendung an Ihrem System vorgenommen wurden. Diese Informationen ermöglichen der Ashampoo UnInstaller Suite das Programm komplett von Ihrem Rechner zu entfernen, wenn Sie sich zum Deinstallieren entscheiden. Siehe Programme deinstallieren für weitere Hinweise.

Wichtiger Hinweis:

Bitte schließen Sie den Installationsvorgang so schnell wie möglich ab und führen auch keine Arbeiten an Ihrem Computer durch, bis Sie Installationsprotokoll gespeichert haben. Das Programm erlaubt Ihnen nur die Durchführung des automatischen Deinstallationsvorgangs mit Installationsprotokollen, die unmittelbar nach der Installation erzeugt wurden. Dieser Schutzmechanismus wurde entwickelt, damit sichergestellt wird, dass Sie keine wichtigen Daten in Ihr Installationsprotokoll einschließen, die nicht mit der neuen Anwendung in Beziehung stehen (Zum Beispiel Text- und andere Dateien, die Sie vor dem Generieren der Installationsprotokolle erzeugt haben).


Anwendungen deinstallieren
Vorhandene Anwendungen zu deinstallieren ist im Easy-Modus sogar einfacher als die Installation. Sie wählen einfach das Protokoll aus, welches während der Installation der Anwendung mit der Ashampoo UnInstaller Suite erzeugt wurde - alles andere wird vom Programm geregelt. Sie können den Deinstallationsvorgang aus dem Menü des UIWatcher in der Taskbar oder aus dem Hauptprogramm-Bildschirm starten - der Vorgang ist absolut identisch.

Programme deinstallieren ohne Protokolldatei

Wenn Sie über kein Protokoll verfügen (z.B. wenn Sie das Programme ohne die Ashampoo UnInstaller Suite installiert haben), können Sie die automatische Deinstallationsroutine des Programmes nicht nutzen. Wenn Sie ein Programm dennoch entfernen müssen, wählen Sie bitte die Funktion Anwendung ohne Protokoll deinstallieren im Bildschirm der Suite oder im Menü UnInstaller und folgen dann den angezeigten Erläuterungen.


Deinstallieren mit dem UIWatcher
Zum Verständnis:

Der automatische Deinstallationsprozess wird nur dann aktiviert, wenn Sie ein Protokoll direkt nach der Installation einer Anwendung erzeugt haben. Wenn Sie das Protokoll später erzeugen, werden die Auswahlbildschirme des Experten-Modus angezeigt und Sie werden gefragt, welche Einträge Sie per Hand wiederherstellen möchten. Das ist eine Sicherheitsfunktion - es wird angenommen, dass Sie bereits andere Aktivitäten auf Ihrem Rechner vorgenommen haben, bevor Sie das Protokoll geschrieben haben.

Vorgehensweise:

1. Klicken Sie rechts auf das Icon des UIWatcher in der Taskbar.

2. Wählen Sie Anwendung deinstallieren im PopUp-Menü.

3. Wählen Sie die Protokolldatei im Dialog Lade eine Protokolldatei.

Installationsdateien verfügen immer über die Endung .ECL. Im Beispiel links heißt das Installationsprotokoll Ashampoo WinOptimizer Suite.ECL (Das hängt natürlich davon ab, welchen Namen Sie während der Überwachung der Installation eingetragen haben).

Klicken Sie bitte zum Markieren auf die Datei und anschließend auf Öffnen. Folgen Sie dann den Anweisungen auf dem Bildschirm.

4. Wenn die Deinstallation abgeschlossen wurde, erfolgt eine Abfrage, ob auch das Installationsprotokoll gelöscht werden soll. Da auf Ihrem Rechner alle relevanten Daten gelöscht wurden, macht es Sinn, das Protokoll zu löschen.

Wenn Sie diesen Dialog sehen:

Wenn Sie diesen Dialog sehen, haben Sie zu lange mit dem Speichern des Installationsprotokolls nach der Installation der Anwendung gewartet.

Der voll-automatische Deinstallationsvorgang wird nur dann aktiviert, wenn Sie das Installationsprotokoll umgehend nach der Installation einer Anwendung erzeugen. Wenn das Protokoll später erzeugt wurde, zeigt Ihnen die Ashampoo UnInstaller Suite alle Einträge an, die wiederhergestellt werden und erwartet Ihre Bestätigung.

Das ist ein Schutzmechanismus für Ihre Daten. Das Programm geht davon aus, dass Sie bereits andere Aktionen auf dem Rechner vor dem Schreiben des Protokolls durchgeführt haben könnten.

Wenn Sie nicht über ein Protokoll verfügen:
Wenn Sie über kein Protokoll verfügen (z.B. wenn Sie das Programm ohne die Ashampoo UnInstaller Suite installiert haben), folgen Sie bitte den Anweisungen, wie im Abschnitt Anwendungen ohne Protokoll deinstallieren beschrieben


Deinstallieren mit dem UnInstaller
Folgen Sie bitte Schritt für Schritt den Anweisungen, um eine Anwendung mit der Ashampoo UnInstaller Suite von Ihrem Rechner zu entfernen.

Hinweise:

· Dieser Vorgang gilt nur für Programme, die Sie mit der Hilfe der Ashampoo UnInstaller Suite installiert haben. Siehe den Abschnitt Anwendungen ohne Protokoll deinstallieren zur Vorgehensweise zum Entfernen von Anwendungen, die Sie vor dem Benutzen dieses Programmes installiert haben.

· Der automatische Deinstallationsprozess wird nur dann aktiviert, wenn Sie ein Protokoll direkt nach der Installation einer Anwendung erzeugt haben. Wenn Sie das Protokoll später erzeugen, werden die Auswahlbildschirme des Experten-Modus angezeigt und Sie werden gefragt, welche Einträge Sie per Hand wiederherstellen möchten. Das ist eine Sicherheitsfunktion - es wird angenommen, dass Sie bereits andere Aktivitäten auf Ihrem Rechner vorgenommen haben, bevor Sie das Protokoll geschrieben haben.

Vorgehensweise:

1. Starten Sie die Ashampoo UnInstaller Suite und prüfen, ob der Easy-Modus aktiv ist. (Wählen Sie Wechsle zum Easy-Modus im Menü Datei, wenn es nicht der Fall sein sollte.)

2. Wählen Sie das Register Suite und klicken dann doppelt auf das Icon Anwendung ohne Protokoll deinstallieren.

Sie können ebenso Anwendung ohne Protokoll deinstallieren im Menü UnInstaller wählen.

3. Lesen Sie bitte die Hinweise auf dem Bildschirm und klicken dann auf OK.

4. Wählen Sie die Protokolldatei der Anwendung, die Sie entfernen möchten im Dialog Lade ein Protokolldatei.

6. Klicken Sie auf OK im Bestätigungsdialog, um die Anwendung vollständig von Ihrem Rechner zu entfernen.

Wenn die Deinstallation abgeschlossen wurde, erfolgt eine Abfrage, ob auch das Installationsprotokoll gelöscht werden soll. Da auf Ihrem Rechner alle relevanten Daten gelöscht wurden, macht es Sinn, das Protokoll zu löschen.

Alternative Methode:

1. Wählen Sie das Register Installationsprotokolle im Hauptbildschirm des Programmes.

2. Klicken Sie auf das Installationsprotokoll der Anwendung, die Sie entfernen möchten.

3. Klicken Sie auf den Schalter Anwendung deinstallieren und folgen dann den angezeigten Hinweisen.

Wenn Sie nicht über ein Protokoll verfügen:
Wenn Sie über kein Protokoll verfügen (z.B. wenn Sie das Programm ohne die Ashampoo UnInstaller Suite installiert haben), folgen Sie bitte den Anweisungen, wie im Abschnitt Anwendungen ohne Protokoll deinstallieren beschrieben.


Anwendungen ohne Protokoll deinstallieren
Wenn Sie über kein Protokoll verfügen (z.B. wenn Sie das Programm ohne die Ashampoo UnInstaller Suite installiert haben), müssen Sie entweder den programmeigenen Uninstaller benutzen oder in den Experten-Modus wechseln und die Komponenten der Anwendung manuell entfernen. Die Benutzung des programmeigenen Uninstaller ist immer sicherer als die manuelle Vorgehensweise, besonders wenn noch keine Erfahrungen vorhanden sind.

Vorgehensweise:

1. Starten Sie die Ashampoo UnInstaller Suite im Easy-Modus, klicken auf das Register Protokolldateien und anschließend auf das Unterregister Protokolldatei laden. Wenn Sie ein Protokoll für die zu entfernende Anwendung sehen (1), klicken Sie auf den Schalter Anwendung deinstallieren (2) und folgen dann Anweisungen, wie unter Deinstallieren mit dem UnInstaller beschrieben.

2. Wenn Sie kein Installationsprotokoll finden können, klicken Sie bitte auf das Register Suite und klicken dann doppelt auf das Icon Anwendung deinstallieren.

Sie können aber auch Anwendung ohne Protokoll deinstallieren im Menü UnInstaller wählen.

3. Es wird eine Liste mit allen Programmen, die ihr eigenes Deinstallationsprogramm auf dem Rechner geschrieben haben, angezeigt. Wenn das Programm aufgeführt ist, klicken Sie bitte auf den Namen, um den Eintrag zu markieren (1). Klicken Sie dann bitte auf den Schalter Ausgewählte Anwendung deinstallieren (2) und folgen den angezeigten Erläuterungen.

Wenn das Programm nicht im Bildschirm aufgeführt ist:

1. Es gibt öfters Anwendungen mit der Option der eigenen Deinstallation in der Programmgruppe im Windows-Startmenü. Bitte prüfen Sie diese Option. Sollten Sie eine Option finden, wie Programm XXX entfernen oder Programm löschen treffen Sie bitte die entsprechende Auswahl und folgen den Hinweisen.

2. Sollte das Programm nicht über einen Uninstaller verfügen, müssen Sie in den Experten-Modus wechseln und den manuellen Deinstallationsvorgang benutzen. Wenn Ihnen die Optionen zu komplex erscheinen, versuchen Sie bitte nichts auf eigene Faust. Holen Sie sich Rat von einem erfahrenen Windows-Benutzer. Lassen Sie im Zweifelsfall eine Anwendung mehr auf Ihrem System als eine unnötige Zerstörung Ihres Setup oder Ihrer Konfiguration zu riskieren!


Das Programm im Experten-Modus benutzen
Wie der Name bereits verdeutlicht, ist der Experten-Modus für erfahrene Windows-Benutzer entwickelt worden. Bevor Sie ausgiebigen Gebrauch von der Funktionalität in diesem Modus machen, sollten Sie sich mit den wesentlichen Prinzipien der Windows-Konfiguration und der Windows Registry vertraut machen.

Die im Experten-Modus verfügbaren Funktionen sind sehr mächtig und falls Sie nicht sorgfältig arbeiten, können Registry-Einträge sowie weitere Dateien, die Sie besser behalten sollten, ganz leicht gelöscht werden.

Wie man im Experten-Modus erfolgreich arbeitet

Der sicherste Weg um die Möglichkeiten im Experten-Modus verstehen zu lernen ist den Erläuterungen zu den von Ihnen geplanten Aufgaben zu folgen. Jeder Abschnitt verfügt über Links zu den benötigten weiteren Informationen. "Learning by doing" ist in der Regel der einfachste Weg ein neues Progamm komplett zu begreifen.

Was passiert beim Wechsel in den Experten-Modus?

Wenn sich die Ashampoo UnInstaller Suite im Experten-Modus befindet, verfügen Sie über die volle Kontrolle über alle Ihre Arbeitsschritte. Alle vollautomatischen Mechanismen im Easy-Modus sind deaktiviert und bis dato verborgene Features stehen jetzt zur Verfügung. Sie können die Vorgänge mit Hilfe interaktiven Assistenten oder aber völlig für sich alleine erledigen.

Was passiert beim Wechsel zurück in den Easy-Modus?

Wenn Sie zum Easy-Modus wechseln, werden alle Einstellungen durch die Ashampoo UnInstaller Suite automatisch auf die sicheren Standardwerte zurückgesetzt. Dadurch ist gewährleistet, dass Sie weder Daten verlieren noch irgendwelche Schäden durch Einstellungen im Experten-Modus verursachen können, wenn Sie ohne deren Zurücksetzen in den Easy-Modus wechseln.

Gleichzeitig werden alle Einstellungen im Experten-Modus automatisch in einem Backup gesichert. Sie werden beim erneuten Wechsel in den Experten-Modus gefragt, ob Sie die letzten benutzten Einstellungen wieder laden möchten, bevor Sie in den Easy-Modus wechseln.

Interaktive Assistenten

Im Experten-Modus starten die folgenden Optionen jeweils mit einem interaktiven Assistenten, der Sie durch die weiteren Schritte führt. Diese Assistenten unterscheiden sich von denen, die im Easy-Modus aktiv sind. Neben der aktuellen Benutzerführung erfahren Sie mehr darüber, wie Sie die mächtigen Programmfunktionen für sich selbst nutzen können.

Neue Anwendung installieren (Suite Bildschirm, Menü UnInstaller, Werkzeugleiste)
Führt Sie durch die Installation einer neuen Anwendung und der Überwachung der Installation, um ein Installationsprotokoll zu erzeugen.

Anwendung deinstallieren (Suite Bildschirm, Menü UnInstaller, Werkzeugleiste)
Führt Sie durch den Vorgang, eine Anwendung zu deinstallieren, welche mit der Ashampoo UnInstaller Suite installiert und protokolliert wurde.

Anwendung ohne Protokoll deinstallieren (Suite Bildschirm, Menü UnInstaller)
Führt Sie durch den Vorgang, eine Anwendung zu deinstallieren, für die kein von der Ashampoo UnInstaller Suite erzeugtes Installationsprotokoll zur Verfügung steht.

Schritt-für-Schritt Assistent (Menü UnInstaller, Werkzeugleiste)
Spezieller Assistent, der Sie durch die wesentlichen Vorgänge beim Benutzen der Ashampoo UnInstaller Suite führt.

Vorgehensweise:

Die Kapitel in diesem Abschnitt der Hilfe enthalten Hinweise zu den wesentlichen Aufgaben, die Sie mit der Ashampoo UnInstaller Suite bewältigen wollen. Sie sind an erfahrene Benutzer gerichtet und setzen voraus, dass Sie mit den grundlegenden Funktionen von Windows vertraut sind. Sie sollten ebenfalls über Grundkenntnisse in Bezug auf die Windows-Registry verfügen, bevor Sie die weiterreichenden Funktionen nutzen.


Anwendungen installieren
Methode 1: Interaktiver Assistent

Es ist sinnvoll, diese Methode zunächst öfters zu benutzen, bevor Sie alles per Hand erledigen wollen. Sie verstehen die Arbeitsweise des Programmes so viel besser.

Es ist sinnvoll, den UIWatcher in der Taskbar zu deaktivieren, bevor Sie eine manuelle Installation vornehmen. Dadurch wird verhindert, dass der UIWatcher automatisch aktiviert wird, wenn Sie ein Installationsprogramm starten, das Sie schon manuell überwachen. Klicken Sie einfach mit der rechten Maustaste auf das UIWatcher Icon in der Taskbar und wählen die Option Installationsüberwachung aktiv ab.

1. Stellen Sie sicher, dass das Programm im Experten-Modus ist. Klicken Sie dann doppelt auf Neue Anwendung installieren im Register Suite oder wählen Neue Anwendung installieren im Menü UnInstaller oder der Werkzeugleiste.

2. Arbeiten Sie sich durch die Register des Assistenten von links nach rechts und folgen den Anweisungen. An einigen Punkten werden Sie aufgefordert, zur Ashampoo UnInstaller Suite zu wechseln. Nach den geforderten Aktionen im Hauptprogramm können Sie zum Assistenten zurückkehren und Ihren Kurs fortsetzen.

Der Schritt-für-Schritt Assistent

Um einen anderen Zugriff auf das Programm zu erleben, versuchen Sie doch den Schritt-für-Schritt Assistenten, den Sie durch Klicken auf das Hasen-Symbol in der Werkzeugleiste oder durch Auswahl vom Schritt-für Schritt Assistenten Menü Uninstaller starten können.

Methode 2: Benutzen der Werkzeuge

Sie sollten diese Methode erst dann benutzen, wenn Sie mit dem Programm vertraut sind. Sie haben die volle Kontrolle und können alle verfügbaren Optionen nutzen.

1. Stellen Sie sicher, dass das Programm im Experten-Modus ist. Klicken Sie dann auf das Register Auswahl: Registry & Laufwerke im Hauptbildschirm. Sie sehen anschließend weitere Unterregister, in denen Sie alle Einträge sehen und verändern können, die von der Ashampoo UnInstaller Suite überwacht werden, wenn Sie ein Programm installieren oder sonstige Änderungen an Ihrem System vornehmen.

Sie können jederzeit mit der Option Zurücksetzen der Auswahl im Menü Datei den ursprünglichen Zustand wiederherstellen.

2. Gehen Sie durch alle Einträge in den Unterregistern und wählen die Einträge aus, die überwacht werden sollen bzw. wählen die Einträge ab, die von der Überwachung ausgeschlossen werden sollen. Sie können spezielle Dateien auch unter dem Register Ausgeschlossene Dateien ausschließend. Bitte keine Einträge auswählen oder abwählen, wenn Sie nicht wirklich sicher sind, was Sie tun! Wählen Sie insbesondere keine Einträge aus, die in den Vorgaben des Programms abgewählt sind. Bitte benutzen Sie bitte die sichere Standardauswahl.

3. Wählen Sie Speichere aktuelle Konfiguration im Menü UnInstaller oder in der Werkzeugleiste.

Wenn Sie die Auswahl verändern, bevor Sie die aktuelle Konfiguration speichern, stellen Sie beim Verlassen des Programms sicher, dass Ihre neue Einstellungen als Standard gespeichert werden (Sie werden dazu aufgefordert!). Geschieht das nicht, werden unterschiedliche Auswahl-Einstellungen für den Vergleich benutzt und die daraus resultierende Protokolldatei wird nicht korrekt sein. Als Alternative können Sie Ihre Auswahl in eine Datei speichern (Speichere eine Auswahl-Datei im Menü Datei) und laden diese Auswahl wieder (Lade eine Auswahl-Datei im Menü Datei), bevor Sie den Vergleich durchführen.

4. Installieren Sie die neue Anwendung. Es besteht keine Notwendigkeit, die Ashampoo UnInstaller Suite während dessen gestartet zu haben. Sie können das Programm beenden und sogar den Rechner neu starten, wenn Sie es möchten.

5. Nach der Installation starten Sie das Programm bitte einmal und beenden es dann. Das ist wichtig, weil viele Anwendungen die Installation erst dann abschließen, wenn sie einmal gestartet wurden. Sie können die Anwendung jetzt konfigurieren, aber das ist nicht so wichtig. Sie brauchen letztendlich das Programm nur einmal starten und wieder beenden.

6. Starten Sie die Ashampoo UnInstaller Suite wenn das Programm nicht bereits gestartet sein sollte. Wählen Sie Vergleiche/Protokoll erstellen im Menü UnInstaller oder benutzen Sie einen einfachen Dateinamen für Ihr Protokoll, damit Sie das Protokoll schnell und einfach identifizieren können. Es ist sinnvoll, den Namen der gerade installierten Anwendung zu benutzen.

Das ist alles. Sie können jetzt das soeben erzeugte Protokoll zum Entfernen der Anwendung benutzen. Wann immer Sie es möchten. Wenn Sie interessiert sind, können Sie einen Blick in das Register Installationsprotokolle werfen. Hier sind alle Komponenten aufgeführt, die von der Anwendung dem System hinzugefügt wurden. (Die Protokolldatei wird automatisch nach dem Erzeugen geladen).

Methode 3: Benutzen der UIWatcher Menü-Optionen

Die wesentlichen Funktionen, die für die Methode 1 und 2 benutzt werden, können auch aus dem PopUp-Menü des UIWatcher heraus gewählt werden. Sie können die meisten dieser Operationen durchführen, ohne das Hauptprogramm zu starten. (Diese Optionen werden im Menü des UIWatcher nur dann angezeigt, wenn sich die Ashampoo UnInstaller Suite im Experten-Modus befindet.)

Besonderer Tipp:

Nutzen Sie für zusätzliche Sicherheit und Informationen die Funktion Backup erstellen in Verbindung mit dem Feature Speichere Versionsinformationen. Wenn Sie nach der Installation einer Anwendung die Register Installationsprotokolle überprüfen, können Sie sofort sehen, ob wichtige Dateien mit älteren Versionen überschrieben wurden. Sie können sie dann mit den Originaldateien aus Ihrem Backup wiederherstellen. Vergessen Sie nicht die Option Gesicherte Dateien beim Wiederherstellen verwenden in den Einstellungen zu aktivieren!


Abgebrochene Installationen
Es kommt ja vor: Sie sind mitten bei der Installation einer Anwendung und entweder haben Sie gerade Ihre Meinung geändert oder es passiert etwas, was die Fortführung der Installation unmöglich macht. Das Passwort oder der Code für die Installation wird nicht akzeptiert. Es "friert" etwas auf Ihrem Bildschirm ein, das Programm stürzt ab, das Installationsprogramm "hängt sich auf" oder Windows ist der Meinung, dass es an der Zeit ist, Sie mit dem berühmten "blauen Bildschirm" unterhalten zu müssen. Was auch immer - Sie können oder wollen nicht mehr fortfahren.

Installationsprogramme sind nicht zum Verlassen entwickelt worden

Installationsprogramme wollen nur eines: Sie möchten das Programm des Herstellers auf Ihre Festplatte bringen. Die Programme sind wahrlich nicht an einem Stopp interessiert. Sie wollen fortfahren, bis das Programm installiert ist. Bis auf wenige Ausnahmen brechen Installationsprogramm nicht "in Schönheit" ab. Die meisten Installationsprogramme werden zwar abbrechen, sind aber "beleidigt" und verabschieden ohne sich selbst wegzuräumen. Es gibt nur wenige Installationsprogramme mit einer Abbrechfunktion, die auch wirklich alle temporären Dateien oder Einträge in der Registry löscht, die vor dem Befehl zum Abbruch geschrieben wurden. Das Ergebnis ist eine weitere Ladung von Müll, der Ihre Festplatten und Windows Registry verstopft.

Jetzt können Sie den Rest abgebrochener Installationen "entsorgen"

Für die Ashampoo UnInstaller Suite besteht kein Unterschied zwischen einer abgebrochenen und kompletten Installation. Beide Formen führen zu Veränderungen auf Ihrer Festplatte und der Registry. Es spielt keine Rolle, ob Sie den blauen Bildschirm erhalten - der vorherige Status wurde bereits in einer Konfigurationsdatei aufgezeichnet, so dass Sie nach dem erfolgreichen Neustart von Windows mit den Kommandos Vergleiche (Protokoll erstellen) und Alles wiederherstellen den ganzen hinterlassenen "Müll" der abgebrochenen Installation entfernen können. Und zwar wie folgt:

Vorgehensweise:

Wir gehen davon, dass Sie ihre aktuelle System-Konfiguration gespeichert haben (siehe Anwendungen installieren) und dass Sie das Installationsprogramm für eine Anwendung, welches Sie auf Ihrem Rechner installieren möchten, gestartet haben. Jetzt beenden Sie das Installationsprogramm oder das Programm oder Windows stürzen ab oder "hängen sich auf". Jetzt unternehmen Sie folgende Schritte:

1. Sollte etwas abgestürzt sein, starten Sie zunächst Windows wieder. Verlassen Sie die Ashampoo UnInstaller Suite wenn möglich vor dem Neustart. Sollte das nicht gelingen, ist es nicht weiter tragisch. Die aktuelle Konfiguration wurde ja bereits protokolliert, Sie verlieren also keine Daten.

2. Wenn der UIWatcher "anspringt" und Ihnen mitteilt, dass die Installation abgeschlossen ist (was sehr unwahrscheinlich ist, aber passieren kann), geben Sie bitte einen Namen für das Installationsprotokoll in das Feld ein und klicken auf Installationsprotokoll speichern.

3. Wenn nichts passiert, starten Sie einfach die Ashampoo UnInstaller Suite und wählen Vergleiche (Protokoll erstellen) im Menü UnInstaller oder der Werkzeugleiste. Alternativ können Sie mit einem Rechtsklick auf das Icon in der Taskbar das Menü des UIWatcher öffnen und wählen dort Vergleiche (Protokoll erstellen) - dann brauchen Sie die Ashampoo UnInstaller Suite nicht starten.

4. Geben Sie einen Namen für die Protokolldatei ein und klicken Sie auf Speichern. Wenn das Protokoll erzeugt wurde, werden alle registrierten Änderungen automatisch in den Registern Installationsprotokolle der Ashampoo UnInstaller Suite angezeigt. (Wenn Sie aus dem Menü des UIWatcher heraus arbeiten, müssen Sie das Hauptprogramm starten und das Protokoll manuell laden, um die Änderungen zu sehen.)

5. Um alle Änderungen rückgängig zu machen wählen Sie einfach Alles wiederherstellen im Menü UnInstaller oder der Werkzeugleiste. Um einzelne Änderungen wiederherzustellen folgen Sie bitte den Anweisungen wie im Abschnitt Manuelle Wiederherstellung von Änderungen beschrieben. Wenn Sie aus dem Menü des UIWatcher heraus arbeiten, wählen Sie bitte Anwendung deinstallieren und wählen die Protokolldatei aus, die Sie in Schritt 2 oder 3 erzeugt haben.

Das ist alles. Ihr System wurde auf den Status wiederhergestellt, den es hatte, bevor Sie das abgebrochene Installationsprogramm gestartet hatten. Sie können die Protokolldatei jetzt löschen. Es besteht keine Veranlassung diese Datei zu behalten.


Anwendungen deinstallieren
Methode 1: Interaktiver Assistent

Es ist sinnvoll, diese Methode zunächst öfters zu benutzen, bevor Sie alles von Hand erledigen wollen. Sie verstehen die Arbeitsweise des Programmes so viel besser.

1. Stellen Sie sicher, dass das Programm im Experten-Modus ist. Klicken Sie dann doppelt auf Anwendung deinstallieren im Register Suite oder wählen Anwendung ohne Protokoll deinstallieren im Menü UnInstaller oder der Werkzeugleiste.

2. Arbeiten Sie sich durch die Register des Assistenten von links nach rechts und folgen den Anweisungen. An einigen Punkten werden Sie aufgefordert, zur Ashampoo UnInstaller Suite zu wechseln. Nach den geforderten Aktionen im Hauptprogramm können Sie zum Assistenten zurückkehren und Ihren Kurs fortsetzen.

Diese Methode steht Ihnen auch im PopUp-Menü des UIWatcher in der Taskbar zur Verfügung.

Der Schritt-für-Schritt

Um einen anderen Zugriff auf das Programm zu erleben, versuchen Sie doch den Schritt-für-Schritt Assistenten, den Sie durch Klicken auf das Hasen-Symbol in der Werkzeugleiste oder durch Auswahl von Anwendung deinstallieren im Menü Uninstaller starten können.

Methode 2: Schnelles Deinstallieren aus dem Register Installationsprotokolle

1. Stellen Sie sicher, dass das Programm im Experten-Modus ist. Wählen Sie dann das Register Installationsprotokolle und das Unterregister Protokolldateien aus. Alle verfügbaren Protokolle werden im Hauptfenster dieses Register aufgelistet.

2. Klicken Sie auf das Protokoll der Anwendungen, die Sie entfernen möchten, um es zu markieren. Klicken Sie dann auf den Schalter Anwendung deinstallieren.

3. Im angezeigten Dialog wählen Sie alle Einträge ab, die Sie nicht entfernen möchten (Registry, Dateien, Systemdateien).

4. Klicken Sie auf OK. Das Programm zeigt Ihnen jede Liste mit Einträgen zum Löschen oder Wiederherstellen. Sie können die Aktion bestätigen oder abbrechen. Sie können keine einzelnen Einträge mit dieser Methode bearbeiten. Sie können den Vorgang abbrechen, wenn Sie Ihre Meinung über das Entfernen der Anwendung geändert haben sollten.

Methode 3: Verwenden der Werkzeuge im Experten-Modus

Sie sollten diese Methode erst dann benutzen, wenn Sie mit dem Programm vertraut sind. Sie haben die volle Kontrolle und können alle verfügbaren Optionen nutzen.

1. Stellen Sie sicher, dass das Programm im Experten-Modus ist. Wählen Sie dann Lade Protokolldatei (Installationsprotokoll) im Menü Datei oder der Werkzeugleiste und wählen das Protokoll des Programmes, welches Sie entfernen möchten.

2. Um alle im Protokoll gelisteten Einträge automatisch zu entfernen, wählen Sie einfach Alles wiederherstellen im Menü UnInstaller oder der Werkzeugleiste. Bestätigungsfenster öffnen sich, damit Sie die Einträge betrachten können und wenn nötig den Vorgang auch abbrechen können.

3. Zum Betrachten und Wiederherstellen der einzelnen Einträge, müssen Sie sich durch die Anzeige in den Registern der Protokolldatei (Änderungen in Registry, Veränderte Dateistruktur und Veränderte Systemdateien) durcharbeiten. Klicken Sie Rechts auf einen Eintrag, den Sie wiederherstellen möchten, um sich ein Menü mit Optionen zur Wiederherstellung anzeigen zu lassen.

Klicken Sie auf das [image] Zeichen im Baum, um die Zweige darunter zu öffnen. Durch Drücken der Taste STRG und Klicken auf das [image] Zeichen werden alle Verästelungen des aktuellen Zweiges geöffnet.

4. Wählen Sie Änderungen wiederherstellen im PopUp-Menü, um den aktuellen Eintrag wiederherzustellen. Es öffnet sich ein Dialog, der Ihnen alle durchzuführenden Operationen zur Wiederherstellung anzeigt. Zusätzliche Optionen ermöglichen Ihnen die Feinabstimmung des Vorgangs.

WICHTIG:

Wenn Sie einen Zweig in einem Baum auswählen, werden sowohl der aktuelle Eintrag als auch die Sub-Einträge zusammen wiederhergestellt. Zum Beispiel werden durch die Auswahl des Icons [image] Arbeitsplatz im Register Änderungen in Registry alle Änderungen in der Registry wiederhergestellt. Die Auswahl des Icons [image] im Register Veränderte Dateistruktur wird alle Änderungen an Dateien zusammen zurücksetzen.

Siehe das Unterregister Ausgeschlossene Dateien im Register Auswahl: Registry & Laufwerke für weitere Hinweise zur Benutzung von Icons im Register Installationsprotokolle.

Weitere Optionen im Popup Menü:

· Daten exportieren
Exportiert die gemeldeten Änderungen in eine kommentierte Textdatei. Wie bei der Option Änderungen wiederherstellen werden durch diese Funktion nur der ausgewählte Ast und dessen Verästelungen eingeschlossen. Im Beispiel oben würden die Änderungen im Schlüssel HKEY_LOCAL_MACHINE eingeschlossen sein, aber nicht die Änderungen in HKEY_USERS.

· Das nächste Mal nicht überwachen
Durch Klicken auf diese Option werden der aktuelle Eintrag und die darunter liegenden Einträge aus den Auswahl-Registern abgewählt, so dass das Programm sie nicht mehr überwacht, wenn Sie beim nächsten Mal eine Konfiguration speichern oder einen Vergleich durchführen. Wenn Sie dann das Programm verlassen erfolgt eine Abfrage, ob die neuen veränderten Einstellungen als neue Standardeinstellungen gespeichert werden sollen. Als Alternative können Sie auch die Funktion Speichere Auswahl in Datei im Menü Datei nutzen, um Ihre neuen Einstellungen in eine Datei zu speichern, die Sie wenn nötig laden können.

· Installationsdateien erzeugen
Exportiert den aktuellen Eintrag und die darunter liegenden Einträge in .REG und .INF Dateien, die Sie für automatische Installationsvorgänge benutzen können. Siehe Installationsdateien erzeugen für weitere Details.

Besonderer Tipp:

Nutzen Sie für zusätzliche Sicherheit und Informationen die Funktion Backup erstellen in Verbindung mit dem Feature Speichere Versionsinformationen. Wenn Sie nach der Installation einer Anwendung die Register Installationsprotokolle überprüfen, können Sie sofort sehen, ob wichtige Dateien mit älteren Versionen überschrieben wurden. Sie können sie dann mit den Originaldateien aus Ihrem Backup wiederherstellen. Vergessen Sie nicht die Option Gesicherte Dateien beim Wiederherstellung verwenden in den Einstellungen zu aktivieren!


Anwendungen ohne Protokoll deinstallieren

Es gibt zwei wesentliche Optionen um Anwendungen zu entfernen, für die kein mit der Ashampoo UnInstaller Suite erzeugtes Installationsprotokoll vorhanden ist:

Sie können den programmeigenen UnInstaller benutzen (Empfohlene Methode) oder Sie benutzen den interaktiven Assistenten der Ashampoo UnInstaller Suite (Nur im Experten-Modus verfügbar!), der Sie durch den Vorgang der manuellen Installation führt.

Alternativ dazu können Sie aber auch beide Methoden verwenden: Zunächst arbeiten Sie mit dem programmeigenen UnInstaller und anschließend mit dem interaktiven Assistenten, um ggf. übrig gebliebene Einträge zu finden und zu löschen.

Den programmeigenen UnInstaller benutzen

1. Klicken Sie auf Anwendung ohne Protokoll deinstallieren im Programm-Bildschirm (oder wählen Sie Anwendung ohne Protokoll deinstallieren im Menü UnInstaller).

2. Wenn die Anwendung im Fenster gelistet ist, klicken Sie bitte zur Auswahl auf den Namen in der Liste. Klicken Sie dann auf den Schalter Ausgewählte Anwendung deinstallieren und folgen den angezeigten Hinweisen.

Den interaktiven Assistenten benutzen:

1. Klicken Sie doppelt auf das Icon Anwendung ohne Protokoll deinstallieren im Programm-Bildschirm (oder wählen Sie Anwendung ohne Protokoll deinstallieren im Menü UnInstaller).

2. Wählen Sie das Register Manuell und arbeiten sich anschließend von rechts nach links durch alle Register des Assistenten. In jedem Bildschirm erhalten Sie die entsprechenden Hinweise und Erläuterungen zur Vorgehensweise.


Manuelle Wiederherstellung von Änderungen
Einführung und Warnung

Die Funktionen zum Entfernen von Anwendungen sind ausgezeichnet, wenn Sie einfach mit der Ashampoo UnInstaller Suite protokollierte Anwendungen entfernen. Wenn Sie das Programm aber zu anderen Zwecken benutzen, möchten Sie verständlicherweise auch die Änderungen im Register Installationsprotokolle sehen und einzelne Änderungen wiederherstellen.

Schwierig daran ist die Entscheidung, welche Änderungen wiederhergestellt werden sollen und welche man besser belässt. Das gilt im Besonderen für Änderungen in der Windows Registry. Bitte denken Sie daran, dass die Wiederherstellungsfunktionen der Ashampoo UnInstaller Suite direkt auf die Registry zugreifen und diese verändern. Seien Sie also bitte vorsichtig, wenn Sie Änderungen in der Registry wiederherstellen möchten.

Sie sind mit den Installationsprotokollen, die direkt nach der Installation von Anwendungen generiert wurden, auf der sicheren Seite. Diese Protokolle enthalten nur die Änderungen, die durch die Installation der Anwendung bewirkt wurden. Für alle anderen Aktionen gilt: Lassen Sie diese Funktion auf sich beruhen, wenn Sie keine Ahnung von den Einträgen haben, die Sie wiederherstellen.

Sie sollten über wirklich gute Kenntnisse der Windows-Konfiguration und der Windows Registry verfügen, bevor Sie ernsthaften Gebrauch dieser Möglichkeiten der Ashampoo UnInstaller Suite machen.

Vorgehensweise:

Wenn Sie einen Vergleich durchführen oder eine Protokolldatei laden (Lade Auswahl aus Datei im Menü Datei oder der Werkzeugleiste) werden die Änderungen immer in den Registern unterhalb von Installationsprotokolle angezeigt. Sollten Sie noch keine Protokolldatei geladen haben, tun Sie es jetzt. Dann können Sie auf eines der Register mit den Veränderungen im Register Installationsprotokolle klicken, um sich die in der Protokolldateien dokumentierten Änderungen anzeigen zu lassen.

Fenster:

Alle drei Register zeigen die dokumentierten Änderungen in zwei Fenstern an. Das Fenster links zeigt die gesamte Liste von Änderungen in einem Verzeichnisbaum, der die Struktur Ihres Rechnersystems reflektiert. Im rechten Fenster werden alle einzelnen Einträge jedes Astes des Verzeichnisbaums in einer Liste dargestellt.

Icons:

Jeder Eintrag, der eine protokollierte Änderung repräsentiert, ist durch ein Icon gekennzeichnet. Die kurze Erläuterung der Icons (siehe die Grafik links) können Sie sich jederzeit durch die Auswahl des Unterregisters Ausgeschlossene Dateien im Register Auswahl: Registry & Laufwerke anzeigen lassen.

Tipp:
Halten Sie die Taste Ctrl gedrückt, wenn Sie auf das [image] Symbol klicken. Es öffnet sich der gesamte Verzeichnisbaum ab dieser Stelle, einschließlich aller weiteren Zweige.

Es werden nur die Verzweigungen, für die Änderungen dokumentiert sind, in der Baumansicht angezeigt. Zum Beispiel sehen Sie im Register Änderungen in der Registry nur die Abschnitte der Registry, die in der Auswahl, mit denen die Protokolldatei gespeichert wurde, eingeschlossen waren. Sie können also nur die Abschnitte und Verzweigungen aufklappen, die auch wirklich Änderungen enthalten. Im Register Veränderte Dateistruktur werden alle Laufwerke angezeigt, die bei Auswahl mit einbezogen waren, aber Sie können nur die Zweige für die Laufwerke aufklappen, für die Änderungen dokumentiert sind. Ähnliches gilt für das Register Änderungen an den Systemdateien. Sie können nur die Baumansicht für Systemdateien öffnen, die verändert wurden.

Änderungen wiederherstellen:

Um Änderungen wiederherzustellen, klicken Sie bitte mit der rechten Maustaste auf einen Eintrag und wählen Änderungen wiederherstellen aus dem PopUp Menü. Es öffnet sich ein Dialog, der Ihnen alle Operationen die bei der Wiederherstellung durchgeführt werden, anzeigt. Mit Hilfe zusätzlicher Optionen können Sie den Vorgang genauer abstimmen.

Klicken Sie bitte auf die [image] Symbole in der Ansicht, um die einzelnen Zweige zu öffnen. Halten Sie die Taste Ctrl gedrückt und drücken auf [image] Symbol, um alle weiteren Verzweigungen des aktuell ausgewählten Astes zu öffnen.

WICHTIG:

Wenn Sie einen Zweig in einem Baum auswählen, werden sowohl der aktuelle Eintrag als auch die Sub-Einträge zusammen wiederhergestellt. Zum Beispiel werden durch die Auswahl des Icons Arbeitsplatz im Register Änderungen in der Registry alle Änderungen in der Registry wiederhergestellt. Die Auswahl des Icons Laufwerke im Register Veränderungen an der Dateistruktur wird alle Änderungen an Dateien zusammen zurücksetzen.

Weitere Optionen im Popup Menü:

· Daten exportieren
Exportiert die gemeldeten Änderungen in eine kommentierte Textdatei. Wie bei der Option Änderungen wiederherstellen werden durch diese Funktion nur der ausgewählte Ast und dessen Verästelungen eingeschlossen. Im Beispiel oben würden die Änderungen im Schlüssel HKEY_LOCAL_MACHINE eingeschlossen sein, aber nicht die Änderungen in HKEY_USERS.

· Das nächste Mal nicht überwachen
Durch Klicken auf diese Option werden der aktuelle Eintrag und die darunter liegenden Einträge aus den Auswahl-Registern abgewählt, so dass das Programm sie nicht mehr überwacht, wenn Sie beim nächsten Mal eine Konfiguration speichern oder einen Vergleich durchführen. Wenn Sie dann das Programm verlassen erfolgt eine Abfrage, ob die neuen veränderten Einstellungen als neue Standardeinstellungen gespeichert werden sollen. Als Alternative können Sie auch die Funktion Speichere Auswahl in Datei im Menü Datei nutzen, um Ihre neuen Einstellungen in eine Datei zu speichern, die Sie wenn nötig laden können.

· Installationsdateien erzeugen
Exportiert den aktuellen Eintrag und die darunter liegenden Einträge in .REGT und .IN Dateien, die Sie für automatische Installationsvorgänge benutzen können. Siehe Installationsdateien erzeugen für weitere Details.

Besonderer Tipp:

Nutzen Sie für zusätzliche Sicherheit und Informationen die Funktion Backup erstellen in Verbindung mit dem Feature Speichere Versionsinformationen. Wenn Sie nach der Installation einer Anwendung die Register Installationsprotokolle überprüfen, können Sie sofort sehen, ob wichtige Dateien mit älteren Versionen überschrieben wurden. Sie können sie dann mit den Originaldateien aus Ihrem Backup wiederherstellen. Vergessen Sie nicht die Option Gesicherte Dateien beim Wiederherstellen verwenden in den Einstellungen zu aktivieren!

Einträge, die nicht wiederhergestellt werden können:

Einige Einträge können nicht wiederhergestellt werden, es sei denn, Sie haben zuvor Backups von ihnen erstellt. Nachfolgend ein Beispiel:

In diesem Fall hat ein Programm eine neue von MSINFO32.HLP mit einer veralteten Version überschrieben. Da die neue Version überschrieben wurde ist sie nicht mehr verfügbar.

Es besteht keine Möglichkeit schon im voraus zu erkennen, ob sich ein Programm so verhalten wird. Der einzige Schutz liegt in der Verwendung des Features Backup erstellen, um alle wichtigen Dateien in Ihren System-und Windows-Verzeichnissen zu schützen. Aber manchmal wird ein "schelmisches" Programm einen anderen Ort finden, um Dateien zu überschreiben, die besser in Ruhe gelassen werden sollten. Sie können das Feature Benutzerdefinierte Systemdateien benutzen, um Ihre .INI Dateien gegen Änderungen zu schützen. Ashampoo UnInstaller Suite wird dann in der Lage sein, Änderungen an Ihren .INI Dateien genauso wiederherzustellen wie die Änderungen in der Registry.

Programme, die neue Dateien mit alten Versionen überschreiben:

Eine erstaunliche Anzahl von Windows-Installationsprogrammen scheren sich wenig darum, ob durch die Installation schon vorhandene Dateien durch ältere Versionen überschrieben werden. Kann zu unerklärlichen Problemen führen, die nur schwer zu lokalisieren sind. Sie können solche Probleme verhindern, in dem Sie die Option Speichere Versionsinformation nutzen und direkt nach der Installation einer Anwendung prüfen, ob Dateien überschrieben wurden.

Die Einträge zum Anschauen sind die Paare der "überschriebenen Dateien" in den Registern Änderungen, besonders alle Dateien in den Windows - und Systemverzeichnissen.

Im Beispiel oben hat das Programm eine Version der Datei MSVBVM50.DLL aus dem Jahr 1998 mit einer kleineren Version aus dem Jahr 1997 überschrieben. Auch in diesem Fall besteht der einzige Schutz in der Verwendung der Backup-Funktion, um alle wichtigen Systemdateien in Kombination mit der Funktion Speichere Versionsinformation zu schützen. Bei einigen neuen Windows-Versionen können Sie das system-eigene Feature zum Schutz von Systemdateien benutzen. Nähere Hinweise entnehmen Sie bitte der Online-Hilfe Ihres Windows-Systems.


Inkrementelles Installieren & Vergleichen
Die Funktion Inkrementelles Vergleichen (Menü UnInstaller und Werkzeugleiste) ermöglicht Ihnen die Installation einer ganzen Reihe von Anwendungen und das Erzeugen einzelner Protokolle, ohne jedes mal die Konfiguration speichern zu müssen. Diese Option ist bei der Installation von Programmpaketen oder Suiten, die aus separaten Programmmodulen mit eigenen Installationsprogrammen bestehen, von Vorteil.

Diese Funktion steht nur im Experten-Modus zur Verfügung.

Alle Operationen zum inkrementellen Vergleichen, die Sie durchführen, müssen direkt nacheinander in einer Sitzung durchgeführt werden. Bitte versuchen Sie nicht, einen inkrementellen Vergleich durchzuführen, nach dem Sie an Ihrem Computer gearbeitet haben oder neue Dateien erzeugt haben - alle Arbeiten und Dateien werden mit in das Installationsprotokoll aufgenommen!

Wenn Sie verschiedene Teile einer Programmgruppe zu unterschiedlichen Zeiten installieren, müssen Sie die Funktionen Speichere aktuelle Konfiguration und Vergleiche (Protokoll erstellen) für jede einzelne Anwendung benutzen.

Es ist sinnvoll, den UIWatcher in der Taskbar zu deaktivieren, bevor Sie eine manuelle Installation vornehmen. Dadurch wird verhindert, dass der UIWatcher automatisch aktiviert wird, wenn Sie ein Installationsprogramm starten, das Sie schon manuell überwachen. Klicken Sie einfach mit der rechten Maustaste auf das UIWatcher Icon in der Taskbar und wählen die Option Installationsüberwachung aktiv ab.

Vorgehensweise:

1. Prüfen Sie Ihre Einstellungen im Register Auswahl ( Klicken Sie hier für weitere Informationen), als wenn Sie eine normale Anwendung installieren würden.

2. Wählen Sie Speichere aktuelle Konfiguration, um die aktuelle Konfiguration Ihres Rechners zu speichern (Siehe die Kapitel zum Installieren von Anwendungen für weitere Hinweise).

3. Installieren Sie die erste Anwendung. Bitte vergessen Sie nicht, die Anwendung nach der Installation einmal zu starten und wieder zu beenden.

4. Falls die Ashampoo UnInstaller Suite nicht gestartet sein sollte, starten Sie das Programm bitte. Stellen Sie sicher, dass Sie die gleichen Einstellungen in den Auswahl-Registern wie unter Schritt 2 benutzt eingestellt haben.

5. Wählen Sie Inkrementelles Vergleichen. Dadurch wird die neue Systemkonfiguration mit der in Schritt 2 erzeugten Version verglichen. Es wird ein Protokoll gespeichert (Sie müssen wie gewohnt einen Namen angeben). Anschließend wird die neue Konfiguration als aktuelle Konfiguration definiert. Sie können dadurch zum nächsten Arbeitsschritt weitergehen, ohne die aktuelle Konfiguration speichern zu müssen.

6. Wiederholen Sie bitte die Schritte 3 - 5, bis Sie alle Anwendungen des Paketes oder der Gruppe installiert haben.

Wie funktioniert das?

Inkrementelles Vergleichen ist relativ einfach. Die aktuelle Konfigurationsdatei, die in Schritt 2 erzeugt wurde, heißt OldCfg.ECD. Wenn Sie einen inkrementellen Vergleich nach der Installation einer Anwendung durchführen, wird eine neue Konfigurationsdatei mit dem Namen NewCfg.ECD geschrieben. Es wird ein Vergleich zwischen der zweiten Datei und der ersten Datei durchgeführt und die Unterschiede zwischen beiden Dateien werden protokolliert. Anschließend wird die Datei OldCfg.ECD gelöscht und NewCfg.ECD in OldCfg.ECD umbenannt.

Besonderer Tipp:

Nutzen Sie für zusätzliche Sicherheit und Informationen die Funktion Backup erstellen in Verbindung mit dem Feature Speichere Versionsinformationen. Wenn Sie nach der Installation einer Anwendung die Register Installationsprotokolle überprüfen, können Sie sofort sehen, ob wichtige Dateien mit älteren Versionen überschrieben wurden. Sie können sie dann mit den Originaldateien aus Ihrem Backup wiederherstellen. Vergessen Sie nicht die Option Gesicherte Dateien beim Wiederherstellen verwenden in den Einstellungen zu aktivieren!


Arbeiten mit Konfigurationsdateien
Konfigurationsdateien sind die Dateien, in denen die Ashampoo UnInstaller Suite die Schnappschüsse Ihrer gesamten Systemkonfiguration speichern - einschließlich der Kopien aller Einträge und Werte in der Windows Registry und Berichte über alle Dateien auf Ihrem System.

Normalerweise werden Konfigurationsdateien automatisch erzeugt. Wenn Sie Speichere aktuelle Konfiguration wählen, speichert die Ashampoo UnInstaller Suite einen Schnappschuss ihres aktuellen Systems in einer Konfigurationsdatei mit dem Namen OldCFG.ECD. Wenn Sie Vergleiche (Protokoll erstellen) auswählen, wird vom Programm ein weiterer Schnappschuss Ihres Systems als Konfigurationsdatei mit dem Namen NewCFG.ECD erzeugt und gespeichert. Anschließend werden beide Dateien verglichen und die Unterschiede in einem Installationsprotokoll gespeichert.

Manuelles Erzeugen und Vergleichen von Konfigurationen

Wenn Sie es möchten können Sie Konfigurationsdateien manuell erzeugen und vergleichen. Sie können Namen Ihrer Wahl vergeben. Diese Option richtet sich an erfahrene Benutzer. Sie haben die volle Kontrolle über den gesamten Vergleichsvorgang.

Vorgehensweise:

1. Bitte prüfen Sie Ihre Einstellungen in den Auswahl-Registern und wählen dann Speichere Konfiguration unter ... im Menü UnInstaller. Sie werden zur Eingabe eines Namens aufgefordert und das Programm wird Ihr System absuchen und einen Schnappschuss der Konfiguration in einer Datei speichern.

2. Installieren Sie eine Anwendung oder führen Sie irgendwelche Änderungen an Ihrem System durch.

3. Wählen Sie erneut Speichere Konfiguration unter ..., um den Schnappschuss des neuen Systemstatus zu speichern.

4. Bitte prüfen Sie Ihre Einstellungen in den Auswahl-Registern und wählen dann Vergleiche zwei Konfigurationen im Menü UnInstaller. Es öffnet sich ein Dialog, in dem Sie die beiden Konfigurationsdateien auswählen und den Namen für die Protokolldatei eingeben können, in der Sie die gefundenen Unterschiede zwischen beiden Konfigurationen speichern können.

5. Wenn Sie dann auf OK klicken, werden beide Konfigurationen verglichen und die Unterschiede in das Protokoll geschrieben und in die Register unter Installationsprotokolle geladen. Sie können die einzelnen Register auswählen, um sich die gefundenen Unterschiede anzuschauen und wenn gewünscht wieder herstellen.

Hinweis:
Wie immer wird die Ashampoo UnInstaller Suite nur die in den Auswahl-Registern ausgewählten Einträge speichern und vergleichen. Im Allgemeinen sollten Sie in den Schritten 1 und 4 immer die gleichen Einstellungen getroffen haben. Es sei denn, dass gute Gründe dafür sprechen. Sie erhalten sonst bedeutungslose Resultate.


Arbeiten mit Auswahldateien
Auswahldateien speichern alle in den Auswahl-Registern benutzten Einstellungen. Sie geben der Ashampoo UnInstaller Suite vor, nach welchen Einträgen das System abgesucht werden soll, was in den Konfigurationsdateien gespeichert und verglichen werden soll. Klicken Sie hier für weitere Informationen.

Die standardmäßige Auswahldatei

Wenn Sie irgendwelche Änderungen an Ihren Auswahl-Einstellungen vorgenommen haben, erscheint beim Verlassen ein Dialog mit der Abfrage, ob Sie die Änderungen als neuen Standard speichern wollen. Wenn Sie Ja wählen, wird Ihre aktuelle Auswahl in einer Datei mit dem Namen Last.ECS gespeichert, die automatisch beim Starten der Ashampoo UnInstaller Suite geladen wird. Dies gilt auch, wenn Sie Zurücksetzen der Auswahl im Menü Datei wählen. Dadurch wird die Auswahl verändert. Wenn Sie das Programm verlassen und die Änderungen als neuen Standard speichern, wird die Datei Last.ECS diese als neue Standardeinstellungen enthalten. (Sie können die Standardeinstellungen auch durch das Löschen der Datei Last.ECS zurücksetzen, aber dadurch werden enthaltenen Einstellungen gelöscht.)

Wann sollten Sie Ihre eigenen Auswahldateien erzeugen?

Das Speichern Ihrer Auswahl als Standard ist sinnvoll, wenn Sie diese Einstellungen beibehalten wollen. Wenn Sie zum Beispiel Ihr Laufwerk D:\ nur zur Datensicherung benutzen und keine Anwendungen installieren, können Sie das Laufwerk im Unterregister Laufwerk der Auswahl-Register abwählen. Dadurch werden die Funktionen Speichere aktuelle Konfiguration und Vergleiche (Protokoll erstellen) beschleunigt, da die Ashampoo UnInstaller Suite ein Laufwerk weniger absuchen muss.

Die Situation ist bei speziellen Einstellung natürlich anders. Zum Beispiel wenn Sie alle Laufwerke Ihres Systems abwählen, weil Sie nur die Veränderungen in der Windows Registry, wie im Abschnitt Die Registry ausspionieren beschrieben überwachen wollen. Wenn Sie diese Einstellung nun als Standard speichern (Was sehr leicht geschehen kann), wird die Ashampoo UnInstaller Suite viele wichtige Komponenten der Anwendungen "vermissen".
Wenn alle Laufwerke abgewählt werden, erscheint ein Warnhinweis, bevor Sie die aktuelle Konfiguration speichern. Andere subtile Änderungen an der Auswahl, die zu Problemen führen können, verursachen jedoch keine Warnmeldungen. Aus diesem Grund ist es ratsam, spezielle Einstellungen gesondert zu speichern und bei Bedarf zu laden, statt sie als Standardeinstellung zu sichern.

Wie werden Auswahldateien gespeichert und geladen?

Speichern:
Nehmen Sie alle gewünschten Änderungen in den Auswahl-Registern vor und wählen dann Speichere Auswahl in Datei im Menü Datei. Die Dateierweiterung .ECS wird automatisch von Ashampoo UnInstaller Suite angefügt.

Laden:
Wählen Sie einfach die Funktion Lade Auswahl aus Datei im Menü Datei und suchen anschließend die Datei mit Ihren Einstellungen aus dem geöffneten Dialog aus. Alle Auswahleinstellungen werden automatisch in die Auswahl-Register geladen, wenn Sie auf Öffnen klicken. Alle aktuellen Einstellungen werden überschrieben.

Siehe auch:

Die gute Auswahl von Einstellungen sind der Schlüsseln, um die besten Ergebnisse mit der Ashampoo UnInstaller Suite im Experten-Modus zu erzielen. Für weitere Informationen lesen Sie bitte die Kapitel Auswahl, Eine Auswahl speichern, Eine Auswahl als Standard speichern, Was Sie nicht auswählen sollten und Dateitypen.


Das Backup-Feature benutzen

Das Feature Backup benutzen
Ashampoo UnInstaller Suite überwacht und speichert normalerweise die Veränderungen bei Dateien zwischen zwei Zeitstempeln - gewöhnlich vor und nach der Installation einer Anwendung. Dateien, die gelöscht oder überschrieben wurden, werden in die Protokolldatei aufgenommen. Sie können aber normalerweise nicht wiederhergestellt werden, da die Originaldaten zerstört wurden.

Eine vollautomatische Wiederherstellungsfunktion für gelöschte oder überschriebene Dateien ist unmöglich, da vorher nicht bekannt ist, welche Dateien von einer Anwendung gelöscht oder überschrieben werden. Die einzige Chance bestünde in einem kompletten Backup Ihrer Festplatte nach jeder Installation einer Anwendung. Aber das ist wirklich keine praktikable Option.

Ganz so schlimm wie es klingt ist es aber nicht. Die große Mehrheit an Anwendungen speichert Dateien nur im eigenen Programmverzeichnis und den Windows- und Systemverzeichnissen. An dieser Stelle müssen Sie ansetzen: Der Inhalt der Windows- und Systemverzeichnisse ist so wichtig für Ihr System, dass eine Sicherung mehr als sinnvoll ist. Falls eine Anwendung Dateien in diesen Verzeichnissen überschreibt, können Sie die Daten mit Hilfe des Backups wiederherstellen.

Es gibt aber einige wichtige Dateien in Ihrem System, die auf jeden Fall standardmäßig durch ein Backup gesichert werden sollten. Als Schutzmaßnahme für den Fall, dass eine Anwendung diese Dateien löscht oder überschreibt. Zum Beispiel alle wichtigen Dateien in den Verzeichnissen ..\Windows\System32 und ..\Windows\System.

Über das Backup erstellen

Die Funktion Backup erstellen ist nur im Experten-Modus verfügbar. Sie können die Funktion in der Werkzeugleiste oder im Menü Werkzeuge aufrufen. Sie können eine Reihe von Ordnern und Filterkriterien bestimmen, um spezifische Dateien für das Backup aus zu wählen. Die Dateien können entweder manuell oder automatisch wiederhergestellt werden, wann immer Sie die aktuelle Konfiguration speichern. Sie können das Programm auch so einstellen, dass gelöschte oder überschriebene Dateien durch das Backup wiederhergestellt werden, wenn Sie die Wiederherstellungsfunktion benutzen.

Die Einstellungen für das Backup befinden sich in der Gruppe der Programm-Einstellungen. Sie können diese Einstellungen direkt aus dem Dialog Backup durch Klicken auf den Schalter Optionen erreichen. Bitte lesen Sie den Abschnitt Konfiguration und Setup für nähere Erläuterungen, bevor Sie das Feature Backup erstellen benutzen.

Warnung:
Die intensive Durchführung von automatischen Backups von großen Systemordnern verlangsamt das Speichern Ihrer aktuellen Konfiguration erheblich.

Besonderer Tipp:

Nutzen Sie für zusätzliche Sicherheit und Informationen die Funktion Backup erstellen in Verbindung mit dem Feature Speichere Versionsinformationen. Wenn Sie nach der Installation einer Anwendung die Register Installationsprotokolle überprüfen, können Sie sofort sehen, ob wichtige Dateien mit älteren Versionen überschrieben wurden. Sie können sie dann mit den Originaldateien aus Ihrem Backup wiederherstellen. Vergessen Sie nicht die Option Gesicherte Dateien beim Wiederherstellen verwenden in den Einstellungen zu aktivieren!

Vorgehensweise:
Wählen Sie Backup erstellen im Menü Werkzeuge oder klicken Sie auf das Icon Backup erstellen in der Werkzeugleiste. Es öffnet sich folgender Dialog:

Klicken Sie bitte auf den Schalter Optionen und prüfen Ihre Einstellungen für das Backup.

Die Verzeichnisse für das Backup sind im Hauptfensters aufgelistet. Um einen neuen Eintrag zu erstellen, klicken Sie bitte auf Neuer Eintrag, geben Sie dann im folgenden Dialog die Suchkriterien an. Zusätzlich zur Bestimmung der Verzeichnisse können auch Filter mit einer Suchmaske angelegt werden. Sie können zum Beispiel *.dll für DLL-Dateien angeben. Dadurch werden nur die Dateien aus den ausgewählten Verzeichnissen, die Ihrem Suchtext entsprechen, eingeschlossen.

Wählen Sie dann Dateien sichern, um das Backup zu starten. Alle Dateien, die Ihren Kriterien entsprechen, werden in das angegebene Backup-Verzeichnis kopiert. Sollten Dateien durch eine Installation gelöscht oder überschrieben worden sein, sind Sie in der Lage, sie mittels der Kopien aus dem Backup-Verzeichnis wieder herzustellen. Sie können das Programm dahin gehend konfigurieren, dass gelöschte oder überschriebene Dateien automatisch mit diesen Backups wieder hergestellt werden. Siehe Konfiguration und Setup für weitere Hinweise.

Dateien, die aktuell von Windows benutzt werden, werden nicht gesichert. Wenn Sie solche Dateien einschließen erhalten Sie eine Fehlermeldung des Betriebssystem. Klicken Sie auf OK und das Backup wird normal fortfahren. Es besteht keine Möglichkeit, dieses Problem zu umgehen und Sie brauchen auch keine Lösung dafür finden. Installationsprogramme können diese Dateien nicht überschreiben.

Welche Dateien gesichert werden sollten:

Es ist nicht notwendig und sinnvoll, alle Dateien auf Ihrem System-Laufwerk zu sichern. Sie möchten ja Ihre wichtigen Systemdateien vor dem Überschreiben durch Installationsprogramme schützen. Diese Dateien sind immer im Windows-Verzeichnis und den System-Verzeichnissen gespeichert. Da die Ashampoo UnInstaller Suite automatisch Registry-Einträge überspringt (siehe unten) können Sie Ihr gesamtes Windows-Verzeichnis ohne Risiken sichern - vorausgesetzt Sie verfügen über genügend Speicherplatz.
Ihr System-Verzeichnis ist immer ein Unterverzeichnis Ihres Windows-Verzeichnis, somit decken Sie mit einem Backup des Windows-Verzeichnis alle Anforderungen ab.

Die Vorschläge im folgenden betreffen die Installation und Deinstallation von Anwendungen. Wenn Sie Ashampoo UnInstaller Suite zur Überwachung anderer Veränderungen an Ihrem System benutzen, sind die Anforderungen an das Backup natürlich komplett anders. Was Sie auch vorhaben: Es ist Ihnen überlassen!

Klicken Sie hier für weitere Informationen über eine effektive Backup-Strategie.

Windows 95, 98 und Me

C:\Windows und das Systemverzeichnis ist C:\Windows\System. Sie werden öfters auch ein Verzeichnis C:\Windows\System32 Verzeichnis auf Windows 9x Versionen finden, das offizielle Systemverzeichnis wird aber ..\System genannt. Wenn Sie alle wichtigen Systemdateien schützen wollen, erstellen Sie einfach einen Eintrag für das Backup (Sie müssen etwas anderes als C:\WINDOWS eintragen, wenn Sie Ihr Windows in ein anderes Verzeichnis installiert haben):

Ordner | Unterverzeichnis einbeziehen? | Suchmaske
C:\WINDOWS | Ja | *.*

Sie können als Alternative mit den drei folgenden Einträgen Platz sparen:

Ordner | Unterverzeichnis einbeziehen? | Suchmaske
C:\WINDOWS | Nein | *.*
C:\WINDOWS\SYSTEM | Nein | *.*
C:\WINDOWS\SYSTEM32 | Nein | *.*

Dadurch wird das meiste abgedeckt. Wenn Sie absolut sicher gehen wollen, können Sie Unterverzeichnisse einbeziehen? auf Ja setzen. Da die meisten Unterverzeichnisse von Programmen von anderen Herstellern erzeugt werden, besteht im Grunde keine Gefahr, dass hier Dateien überschrieben werden.

Windows NT4, 2000 und XP

Bei diesen Windows-Versionen ist das Windows-Verzeichnis in der Regel C:\WINNT und das Systemverzeichnis ist C:\WINNT\SYSTEM32. Sie werden öfters auch ein Verzeichnis C:\WINNT\SYSTEM finden, das offizielle Systemverzeichnis ist ..\SYSTEM32. Der umfassende Backup-Eintrag für diese Systeme lautet:

Ordner | Unterverzeichnis einbeziehen? | Suchmaske
C:\WINDOWS | Ja | *.*

Sie können als Alternative mit den drei folgenden Einträgen Platz sparen:

Ordner | Unterverzeichnis einbeziehen? | Suchmaske
C:\WINNT | Nein | *.*
C:\WINNT\SYSTEM | Nein | *.*
C:\WINNT\SYSTEM32 | Nein | *.*

Auch hier gilt: Sie decken damit wird das meiste ab. Wenn Sie absolut sicher gehen wollen, können Sie Unterverzeichnisse einbeziehen? auf Ja setzen. Da die meisten Unterverzeichnisse von Programmen von anderen Herstellern erzeugt werden, besteht im Grunde keine Gefahr, dass hier Dateien überschrieben werden.

Registry-Dateien werden nicht durch das Backup wiederhergestellt:

Wenn Sie versuchen, Dateien der Windows Registry oder Verzeichnisse, die Registry-Dateien enthalten, in die Liste der Backups aufzunehmen, werden Sie von der Ashampoo UnInstaller Suite benachrichtigt, dass diese Dateien nicht in das Backup aufgenommen werden. Es handelt sich um eine Schutzmaßnahme, um die mögliche Zerstörung ihrer Systemkonfiguration zu verhindern.

Auf den ersten Blick erscheint es sinnvoll, die gesamte Registry in das Backup zu integrieren und wiederherzustellen. In Wirklichkeit handelt es sich aber um ein denkbar schlechte Idee.

Zunächst einmal müssen Sie die Registry-Dateien nicht durch Backups wiederherstellen. Die Ashampoo UnInstaller Suite überwacht und stellt alle individuellen Veränderungen der Registry durch Programm-Installationen oder sonstigen System-Modifikationen wieder her. Außerdem würden Sie beim Wiederherstellen der Registry mittels Backups automatisch alle anderen Veränderungen der Registry überschreiben.

· Ein Beispiel, warum Sie die gesamte Registry nicht wiederherstellen sollten:

Stellen Sie sich folgenden Vorgang vor: Sie erstellen ein Backup der Registry-Dateien und installieren die Anwendung A, überwachen die Installation und erstellen mit der Ashampoo UnInstaller Suite ein Installationsprotokoll. Etwas später installieren Sie eine Anwendung B. Nach der Installation der Anwendung B entschließen Sie sich, die Anwendung A zu entfernen. Sie laden das entsprechende Installationsprotokoll und schreiben alle Veränderungen, die mit der Installation von Anwendung A verbunden sind, zurück.

Wenn Sie ein Backup der Registry-Dateien erstellt haben, stellen Sie die Dateien aus dem Backup wieder her, bevor Sie die Anwendung A installiert haben. Das Problem besteht darin, dass alle Einträge der Registry für die Anwendung B nach der Installation der Anwendung A geschrieben wurden. Durch das Backup werden alle Einträge der Anwendung B überschrieben - einschließlich aller anderen in der Zwischenzeit veränderten Registry-Einträge. Im schlimmsten Fall werden Sie die Anwendung B nicht mehr benutzen können. Sie werden darüber hinaus feststellen müssen, dass viele wichtige Informationen zur Konfiguration und Systemdaten fehlen.

· Welche Dateien sind denn nun Registry-Dateien?

In Windows® 95, 98 und Me ist die Registry in zwei verborgenen Dateien in Ihrem Windows-Verzeichnis gespeichert. Es sind die Dateien USER.DAT und SYSTEM.DAT. In Windows® NT4, 2000 und XP ist die Registry an verschiedenen Orten in den Verzeichnissen \winnt\system32\config und \Dokumente und Einstellungen\{Benutzername} gespeichert.

Unter Windows® 95, 98 und Me können Sie Ihr ...\Windows Verzeichnis in Ihr Backup aufnehmen, wenn Sie darin enthaltene andere Dateien sichern wollen, da die Ashampoo UnInstaller Suite automatisch die Registry-Dateien ausschließt. Bei den Betriebssystemen Windows® NT4, 2000 und XP sollten Sie das Verzeichnis ...\winnt\system32\config nicht aufnehmen, da es nur Registry-Dateien enthält (Es wird keine Zerstörung nach sich ziehen, es macht nur absolut keinen Sinn!). Sie können die Verzeichnisse \Dokumente und Einstellungen\{Benutzername} aufnehmen, wenn Sie andere Dateien in diesen Verzeichnissen wiederherstellen möchten. Registry-Dateien werden automatisch übersprungen.


Die Registry ausspionieren
Da die Ashampoo UnInstaller Suite in der Lage ist, alle Veränderungen an Ihrem System zwischen zwei Zeitpunkten zu überwachen und anzuzeigen, können Sie das Programm als ein wirklich mächtiges und flexibles Werkzeug zur Systemüberwachung und zur Fehlersuche (Debugging) benutzen. Erfahrene Benutzer werden feststellen, dass es sich um eines der nützlichsten Features der Ashampoo UnInstaller Suite handelt. Viele Benutzer verwenden das Programm mehr zum Ausspionieren der Registry und des Restes Ihres System denn als Programm zur Deinstallation von Programmen!

Finden Sie heraus, wo Einstellungen gespeichert werden

Angenommen Sie möchten herausfinden, wo und wie Windows selbst oder eine Anwendung die Einstellungen zur Aktivierung oder Deaktivierung von speziellen Features speichert. Alles was Sie tun müssen, ist Ihre aktuelle Konfiguration mit der Ashampoo UnInstaller Suite abzuspeichern, die Einstellungen zu ändern und dann Vergleiche (Protokoll erstellen) durchführen. Wenn Sie dann einen Blick in die Register unter Installationsprotokolle werfen, sehen Sie auf Anhieb alles, was mit den Einträgen verbunden ist, einschließlich Registry-Schlüssel, Registry-Werte, Dateien und Einträgen zu Systemdateien.

Erstellen Sie Ihre eigenen Windows Tuning-Funktionen mit Ashampoo PowerUp XP

Wir benutzten den gleichen Denkansatz beim Ausspionieren der Registry für viele Funktionen, die in unserem Windows-Konfigurations- und Tuning-Programm Ashampoo PowerUp XP integriert sind. Und da Ashampoo PowerUp XP über einen Funktions-Editor verfügt, können Sie das Programm mit der Ashampoo UnInstaller Suite zusammen einsetzen, um Ihre eigenen Windows-Funktionen zu erstellen, die Sie mit nur wenigen Klicks aktivieren oder deaktivieren können.

Besuchen Sie die [image] Ashampoo PowerUp XP Produktseite im Internet!

Benutzen Sie die Ashampoo UnInstaller Suite als mächtiges Werkzeug zur Fehlersuche

Stellen Sie sich vor, Sie möchten ein Programm "debuggen" (kontrollieren), dass nicht einwandfrei läuft. Mit der gleichen Prozedur wie oben bereits beschrieben können Sie prüfen, ob das Programm auch die richtigen Registry-Schlüssel in die Registry schreibt. Das Protokoll wird alle zusätzlichen Schlüssel offenbaren, bei denen Sie keine Änderungen wahrgenommen haben.

Weitere Einsatzmöglichkeiten

Die Möglichkeiten sind nahezu unbegrenzt - Sie können mit der Ashampoo UnInstaller Suite alle Änderungen an Ihrem System überwachen! Sie können das Programm vor und nach dem Surfen im Internet benutzen, um festzustellen, was Ihr Internet Browser und die Webseiten auf Ihrem Rechner abspeichern. Sie können das Programm vor und nach dem Benutzen von Programm verwenden, um zu sehen, wo und wie Konfigurationseinstellungen gespeichert werden. Sie werden sicherlich noch eigene Ideen entwickeln.

Vorgehensweise

Der erste Schritt liegt in der Entscheidung was Sie überwachen möchten - nur die Registry oder die Registry und die Systemdateien. Wenn Sie herausfinden möchten, wo Programmeinstellungen gespeichert werden, sollten Sie alles überwachen. Sie wissen nie, ob die Programme einen Registry-Eintrag oder eine Datei benutzen. Sie könnten auch die Überwachung aller Laufwerke ins Auge fassen, da versteckte Einstellungen oft an "unmöglichen" Stellen gespeichert werden. Wenn Sie die Windows Registry ausspionieren, ist es sicher, nur die Registry zu überwachen, da fast alle Aktivitäten von Windows selbst hier gespeichert sind.

Erstellen Sie Auswahldateien für besondere Zwecke
Wenn Sie nur die Registry überwachen wollen oder andere spezielle Auswahl-Einstellungen benutzen wollen, die nicht zur Überwachung von Installationen passen, sollten Sie spezielle Auswahldateien erzeugen, die Sie nur zu diesem Zweck nutzen. Wenn Sie spezielle Auswahl-Einstellungen als neuen Standard gespeichert haben, kann das leicht in Vergessenheit geraten und Sie würden diese Einstellung bei der Installation einer Anwendung benutzen.

1. Starten Sie die Ashampoo UnInstaller Suite. Prüfen Sie Ihre Auswahl in den Auswahl-Registern und ändern Sie notfalls die Einstellungen. Wenn Sie spezielle Auswahldateien für die besondere Aufgabe erzeugt haben, laden Sie diese mit der Option Lade Auswahl aus Datei im Menü Datei.

2. Wenn Sie versuchen, eine bestimmte Einstellung zu lokalisieren, sollten Sie alles so einstellen, um die Einstellung an diesem Punkt zu ändern. Starten Sie zum Beispiel die Systemsteuerung, um Windows-Einstellungen zu ändern oder führen alle notwendigen Vorbereitungen mit einem anderen Programm (welches Sie überwachen wollen) durch. Die nächste Operation sollte dann die sein, die Sie ausspionieren wollen. Sie verhindern dadurch, dass das Protokoll zu viele überflüssige Einträge enthält.

3. Wählen Sie Speichere aktuelle Konfiguration im Menü UnInstaller oder der Werkzeugleiste.

Sie können auch die Option Speichere Konfiguration unter ... benutzen. Sie können selbst den Namen für Ihre Konfigurationsdatei vergeben. Wenn Sie diese Option nutzen, müssen Sie diese Datei wieder in Schritt 5 anstelle der Funktion Vergleiche (Protokoll erstellen) benutzen.

4. Nehmen Sie die Änderungen vor, die Sie überwachen möchten. Um das Erzeugen von "überflüssigen Änderungen" zu vermeiden, sollten Sie während dessen die Ashampoo UnInstaller Suite laufen lassen. Bitte vermeiden Sie sonstige Aktivitäten an Ihrem Computer.

5. Wählen Sie Vergleiche (Protokoll erstellen) im Menü UnInstaller oder in der Werkzeugleiste.

Wenn Sie die Option Speichere Konfiguration unter ... wie in Schritt 3 verwendet haben, benutzen Sie bitte Vergleiche (Protokoll erstellen) hier nicht! Statt dessen benutzen Sie zunächst wieder Speichere Konfiguration unter ..., anschließend Vergleiche zwei Konfigurationen (Beide Optionen sind im Menü UnInstaller verfügbar).

6. Zusätzlich zur Aufzeichnung in den Protokollen werden die gefundenen Änderungen automatisch in die Unterregister Änderungen des Registers Installationsprotokolle geladen. Sie können damit die Änderungen direkt sehen.

Export der gefundenen Änderungen in eine Textdatei

Nach dem Sie die Änderungen entdeckt haben, möchten Sie diese Änderungen in eine Textdateien als Referenz speichern. Klicken Sie einfach mit der rechten Maustaste in das Register Installationsprotokolle und wählen Daten exportieren aus dem PopUp Menü. Dadurch erzeugen Sie eine kommentierte ASCII-Datei mit allen Informationen, die Sie zum Identifizieren der gefundenen Einstellungen benötigen.

Die Export-Funktion exportiert immer den aktuellen Eintrag und dessen Untereinträge. Wenn Sie zum Beispiel das Icon Arbeitsplatz im Unterregister Änderungen in der Registry auswählen, werden alle in der gesamten Registry gefundenen Änderungen in eine Textdatei exportiert. Das gilt auch für die Unterregister.

Benutzen Sie den inkrementellen Vergleich für "Spionage-Sequenzen"

Wenn Sie eine Reihenfolge von Änderungen herausfinden möchten, benutzen Sie bitte Inkrementelles Vergleichen in Schritt 5 statt Vergleichen. Sie können dann die nächste Änderung direkt anschließend durchführen, ohne die Funktion Speichere aktuelle Konfiguration wieder ausführen zu müssen. Siehe Inkrementelles Installieren & Vergleichen für weitere Hinweise.

Wenn Sie die Änderungen in Textdateien exportieren möchten, vergessen Sie bitte nicht, die Export-Funktion nach jedem inkrementellen Vergleich aufzurufen.


Programme ohne UnInstaller installieren
Wenn Sie Windows intensiv nutzen, können Sie auf Shareware-Programme treffen, die über keinen UnInstaller verfügen. Die Anweisungen zur Installation sind in der Regel wie folgt: "Bitte legen Sie ein Verzeichnis an, kopieren Sie alle Dateien in diesem Ordner und klicken anschließend doppelt auf die Datei program.exe, um das Programm zu starten."

Sie mögen nun denken, dass die Überwachung einer solchen Installation eines solchen Programms unnötig ist. Ebenso könnte man meinen, man braucht nur den Ordner und dessen Inhalt zu löschen, um das Programm vollständig vom System zu entfernen. Es ist eine verständliche Annahme, aber leider falsch.

Es gibt zwei wesentliche Probleme mit solchen Programmen:

1. Selbst wenn das Programm nicht über einen Installer verfügt, "installiert" es sich selbst beim ersten Programmstart gewöhnlich durch das Schreiben einer Vielzahl von Einträgen in die Windows Registry. Wenn Sie später das Programmverzeichnis und dessen Inhalt löschen, bleiben die Einträge in der Registry "verwaist" zurück. Das ist zwar kein großes Problem, Sie sollten diese verwaisten Einträgen jedoch entfernen. Sie halten Ihr System schlank und vermeiden das "Aufblasen" Ihrer Registry.

2. Sehr oft verwenden diese Programm gemeinsam benutzte Dateien, die auf Ihrem System installiert sind. Das ist das eigentliche Problem. Wenn ein solches Programm zum ersten Mal läuft, sucht es die benötigte DLL und registriert sich selbst als Benutzer, was Zugriffszähler erhöht (Siehe Gemeinsam benutzte Dateien für weitere Hinweise zu diesem Thema). Wenn Sie einfach das Programmverzeichnis und die darin enthalten Dateien löschen, bleibt der Zähler auf einem falschen Wert stehen. Diesen Umstand möchten Sie ja vermeiden. Das Problem ist nicht unbedingt gravierend. Der Zählerstand wird immer eher zu hoch als zu niedrig sein. Im schlimmsten Fall wird die fragliche DLL nie von Ihrem System entfernt, weil der Zählerstand nie auf Null sinken wird.

Wenn Sie solche Probleme vermeiden möchten, benutzen Sie die Ashampoo UnInstaller Suite um die "Installation" von Programmen ohne Installer zu überwachen.

Vorgehensweise:

1. Starten Sie die Ashampoo UnInstaller Suite und prüfen die Einstellungen in den Auswahl-Registern. Wählen Sie Zurücksetzen der Auswahl im Menü Datei, wenn Sie die Standardauswahl für die Installation von Anwendungen nutzen möchten.

2. Wählen Sie Speichere aktuelle Konfiguration im Menü UnInstaller oder in der Werkzeugleiste.

Wenn Sie möchten, können Sie die Ashampoo UnInstaller Suite jetzt verlassen.

3. Erstellen Sie jetzt ein neues Programmverzeichnis für die Anwendung und kopieren alle Dateien des Programms in dieses Verzeichnis. Starten Sie dann das neue Programm mindestens einmal, führen alle notwendigen Einstellungen in dem Programm durch und verlassen es wieder.

Sie Windows erneut starten oder sogar Ihren Rechner aus- und wieder einschalten. Das wird den Vorgang nicht beeinträchtigen. Sie sollten aber nichts anderes machen. Bitte starten Sie keine anderen Programme oder erstellen irgendwelche Dateien. Sie würden sonst in das Installationsprotokoll aufgenommen werden!

4. Sollte die Ashampoo UnInstaller Suite nicht laufen, starten Sie das Programm wieder. Vergewissern Sie sich, dass Sie die gleichen Einstellungen in den Auswahl-Registern verwenden, die Sie auch zum Speichern der aktuellen Konfiguration wie in Schritt 2 benutzt haben.

Wählen Sie anschließend Vergleiche (Protokoll erstellen) im Menü UnInstaller oder der Werkzeugleiste und geben den Namen für das Installationsprotokoll ein. Sobald der Vergleich abgeschlossen ist, können Sie die neuen Inhalte in den Registern Installationsprotokolle untersuchen, um alle durch das Programm erzeugten Änderungen zu betrachten. Es ist manchmal erstaunlich, wie viele Einträge von einem Programm erzeugt werden, was "nur in ein Verzeichnis kopiert und gestartet" wurde!

Hinweis:
Wenn Sie das Programmverzeichnis und die Dateien nicht in das Installationsprotokoll aufnehmen möchten, müssen Sie lediglich Schritt 2 nach dem Erstellen des Verzeichnisses und dem Kopieren der Dateien in das Verzeichnis durchführen. Alternativ können Sie auch alle Festplatten im Unterregister Laufwerke im Auswahl-Register abwählen. Dann werden die Verzeichnisse und Dateien ignoriert.


Andere Uninstaller testen
Mit Hilfe dieser Anweisungen können Sie unseren eigenen Anspruch an die Ashampoo UnInstaller Suite, eine weitaus bessere Leistung bei der Deinstallation von Anwendungen als die mitgelieferten UnInstaller zu erzielen, testen.

Bevor Sie beginnen:

· Die Ashampoo UnInstaller Suite muss sich im Experten-Modus befinden, um diesen Test durchzuführen.

· Diese Anweisungen setzen voraus, dass Sie bereits über einige Erfahrungen mit der Ashampoo UnInstaller Suite verfügen. Sollten Ihnen die folgenden Hinweise zu schwierig erscheinen, lesen Sie bitte zunächst die Erläuterungen in den Abschnitten Anwendungen installieren und Anwendungen deinstallieren.

Es ist sinnvoll, den UIWatcher in der Taskbar zu deaktivieren, bevor Sie eine manuelle Installation vornehmen. Dadurch wird verhindert, dass der UIWatcher automatisch aktiviert wird, wenn Sie ein Installationsprogramm starten, das Sie schon manuell überwachen. Klicken Sie einfach mit der rechten Maustaste auf das UIWatcher Icon in der Taskbar und wählen die Option Installationsüberwachung aktiv ab.

Vorgehensweise:

1. Starten Sie die Ashampoo UnInstaller Suite und wählen die zu überwachenden Einträge in den Auswahl-Registern. Wenn Sie wollen können Sie die Option Zurücksetzen der Auswahl im Menü Datei wählen, um die Auswahl auf den Standard zurückzusetzen. Bitte vergessen Sie nicht, das Register Laufwerke zu prüfen. Alle lokalen Laufwerke sind standardmäßig ausgewählt. Sie können diese Einstellung ändern. Wenn es das erste Mal ist, dass Sie die Ashampoo UnInstaller Suite benutzen, ist es ratsam, die standardmäßige Auswahl für die Registry nicht zu ändern. Siehe den Abschnitt Eine Auswahl speichern für weitere Hinweise.

2. Wählen Sie anschließend Speichere aktuelle Konfiguration (Menü UnInstaller oder Werkzeugleiste). Es wird dadurch ein Schnappschuss Ihres gesamten Systems erzeugt, einschließlich aller Dateien, Verzeichnisstrukturen, der Registry und der Systemdateien.

3. Beenden Sie die Ashampoo UnInstaller Suite und installieren eine große Anwendung auf Ihrem Rechner (Im Idealfall ein umfangreiches Office-Paket oder eine Bildbearbeitungs-Software). Die Ashampoo UnInstaller Suite muss dazu nicht gestartet sein, um den Vorgang der Installation zu überwachen; es werden keine Veränderungen geprüft bis die Installation vollständig abgeschlossen ist.

Wichtig: Es muss sich um die erste Installation der ausgewählten Anwendung auf Ihrem Rechner handeln! Bitte versuchen Sie nicht, die Anwendung über eine bestehende Installation zu installieren. Sollten Sie es dennoch vornehmen, wird das Programm nicht in der Lage sein, viele Einträge zu "sehen", da sie ja bereits auf Ihrem Rechner vorhanden sind. Im Endeffekt würde nichts Neues hinzugefügt sein!

4. Starten und beenden Sie die Anwendung bitte mindestens einmal (Alle Anwendungen, wenn es sich um eine Suite handelt). Siehe den Abschnitt Warum Anwendungen vor dem Protokollieren starten? zu den notwendigen Gründen.

5. Starten Sie die Ashampoo UnInstaller Suite bitte wieder und führen die Funktion Vergleiche (Protokoll erstellen) (Werkzeugleiste oder Menü UnInstaller), um die neue Systemkonfiguration mit der in Schritt 2 gespeicherten Version zu vergleichen und das Installationsprotokoll zu speichern. Bitte benutzen Sie den Namen der Anwendung für das Protokoll. Sie können es dann später leichter identifizieren.

Der Inhalt des Protokolls wird automatisch in den Registern Installationsprotokolle angezeigt. Sie können sich alle Veränderungen an Ihrem System, die durch die Installation der Anwendung vorgenommen wurden, anschauen. Klicken Sie einfach auf die Einträge in den Registern.

6. Jetzt kommt der lustige Teil der Arbeit: Entfernen Sie die gerade installierte Anwendung mit Hilfe der mitgelieferten Deinstallations-Routine (In der Systemsteuerung im Abschnitt Programme hinzufügen/entfernen oder in der Programmgruppe der Anwendung im Windows-Startmenü) oder anderer Windows-Deinstaller.

7. Starten Sie die Ashampoo UnInstaller Suite und wählen erneut Vergleiche (Protokoll erstellen) - ohne jedoch die Funktion Speichere aktuelle Konfiguration auszuführen, um ein anderes Protokoll mit einem anderen Namen zu erzeugen. Es werden alle durch die Anwendung installierten Komponenten angezeigt, die vom eigenen UnInstaller nicht entfernt wurden. Bleiben nur wenige Komponenten zurück, handelt es sich um eine gute Routine. In der Regel finden Sie jedoch eine erstaunliche Anzahl an Dateien und Registry-Einträgen. Sie können die Ashampoo UnInstaller Suite jetzt dazu benutzen, um diese Komponenten ebenfalls zu entfernen (Siehe die Erläuterungen im Abschnitt Anwendungen deinstallieren).


Das Konfigurationssicherheitsnetz
Die Ashampoo UnInstaller Suite ist in der Lage, jegliche Änderungen an der System-Konfiguration zu protokollieren und wieder zurückzusetzen. Dabei spielt es keine Rolle, ob die Änderungen automatisch durch ein Installationsprogramm oder von Ihnen von Hand durchgeführt wurden. Sie können das Programm dazu benutzen, sich selbst vor den negativen Konsequenzen beim Experimentieren mit der System-Konfiguration zu schützen. Sie speichern einfach Ihre aktuelle Konfiguration, nehmen Änderungen, führen einen Vergleich durch und zeichnen die Änderungen in einem Protokoll mit. Wenn Ihnen die eigenen Änderungen nicht gefallen, können Sie das Protokoll laden und die Änderungen zurücksetzen. Ihr System wird auf den Status zurückgesetzt, den es beim Speichern der Konfiguration im ersten Schritt hatte.

Arbeiten Sie bitte sorgfältig!

Obwohl in die Ashampoo UnInstaller Suite einige Sicherheitsfunktionen eingebaut sind, bestehen doch einige Einschränkungen hinsichtlich seiner Fähigkeiten. Das Programm kann Sie zum Beispiel nicht davor schützen, dass durch die Bearbeitung der Registry ein Neustart von Windows unmöglich geworden ist. Sie können dann das Programm nicht mehr starten, um die Änderungen rückgängig zu machen!

Selbst wenn Sie durch die Ashampoo UnInstaller Suite geschützt sind, sollten Sie die notwendigen Schritte unternehmen, um sich selbst vor einer solchen Katastrophe zu schützen. Bitte erstellen Sie Sicherungen Ihrer Registrydateien und halten Sie Ihre Notfall- und Reparaturdisketten auf den aktuellen Stand. Für weitere Hinweise suchen Sie in Ihrer Windows-Hilfe nach Begriffen wie: Notfalldiskette, Reparaturdiskette, Backup, Dateisicherung etc.

Der beste Schutz ist immer ein komplettes Image-Backup Ihres gesamten Systems. Sie können dazu professionelle Backup-Software wie DriveImage von PowerQuest oder Norton Ghost von Symantec benutzen. Diese Programme sind in der Lage, ein komplettes, funktionierendes Backup Ihres Standardsystems zu erstellen, was Sie in wenigen Minuten wiederherstellen können. Der einzige Nachteil besteht darin, dass Sie Ihr gesamtes System-Laufwerk überschreiben.

Vorgehensweise:

Der erste Schritt liegt in der Entscheidung darin, was Sie überwachen möchten - nur die Registry oder die Registry, Dateien und Systemdateien. Ihre Auswahl hier hängt von Ihren geplanten Aktionen ab.

Wenn Sie planen, Änderungen vorzunehmen, die Dateien löschen oder überschreiben, sollten Sie die Verwendung des Features Backup erstellen in Erwägung ziehen, damit Sie wichtige gelöschte oder überschriebene Dateien wiederherstellen können.

Erstellen Sie Auswahldateien für besondere Zwecke
Wenn Sie nur die Registry überwachen wollen oder andere spezielle Auswahl-Einstellungen benutzen wollen, die nicht zur Überwachung von Installationen passen, sollten Sie spezielle Auswahldateien erzeugen, die Sie nur zu diesem Zweck nutzen. Wenn Sie spezielle Auswahl-Einstellungen als neuen Standard gespeichert haben, kann das leicht in Vergessenheit geraten und Sie würden diese Einstellung versehentlich bei der Installation einer Anwendung benutzen.

1. Starten Sie die Ashampoo UnInstaller Suite. Prüfen Sie Ihre Auswahl in den Auswahl-Registern und ändern Sie notfalls die Einstellungen. Wenn Sie spezielle Auswahldateien für die besondere Aufgabe erzeugt haben, laden Sie diese mit der Option Lade Auswahl aus Datei im Menü Datei.

2. Wählen Sie Speichere aktuelle Konfiguration im Menü UnInstaller oder der Werkzeugleiste.

Sie können auch die Option Speichere Konfiguration unter ... benutzen. Sie können selbst den Namen für Ihre Konfigurationsdatei vergeben. Wenn Sie diese Option nutzen, müssen Sie diese Datei wieder in Schritt 5 anstelle der Funktion Vergleiche (Protokoll erstellen) benutzen.

3. Nehmen Sie die Änderungen vor, die Sie überwachen wollen. Sie können die Ashampoo UnInstaller Suite während dessen verlassen. Es besteht keine Notwendigkeit darin, dass das Programm läuft.

4. Wählen Sie Vergleiche (Protokoll erstellen) im Menü UnInstaller oder in der Werkzeugleiste.

Wenn Sie die Option Speichere Konfiguration unter ... wie in Schritt 2 verwendet haben, benutzen Sie bitte Vergleiche (Protokoll erstellen) hier nicht! Statt dessen benutzen Sie zunächst wieder Speichere Konfiguration unter ..., anschließend Vergleiche zwei Konfigurationen (Beide Optionen sind im Menü UnInstaller verfügbar).

5. Zusätzlich zur Aufzeichnung in den Protokollen werden die gefundenen Änderungen automatisch in die Unterregister Änderungen des Registers Installationsprotokolle geladen. Sie können damit sehen, wie Ihre Aktionen an der Konfiguration implementiert wurden.

Sie können Ihr Windows neu starten und Ihre neue Konfiguration testen. Wenn alles in Ordnung ist, belassen Sie es dabei. Wenn Sie nicht zufrieden mit dem Ergebnis sind, wählen Sie die Option Lade Auswahl aus Datei im Menü Datei oder in der Werkzeugleiste und machen alle oder einige Änderungen wieder rückgängig.

Export der Ergebnisse in eine Textdatei

Sie können die Aufzeichnungen Ihrer Änderungen an der Konfiguration in eine Textdateien als Referenz speichern. Klicken Sie einfach mit der rechten Maustaste in das Register Installationsprotokolle und wählen Daten exportieren aus dem PopUp Menü. Dadurch erzeugen Sie eine kommentierte ASCII-Datei mit allen Informationen, die Sie zum Identifizieren der gefundenen Einstellungen benötigen.

Die Export-Funktion exportiert immer den aktuellen Eintrag und dessen Untereinträge. Wenn Sie zum Beispiel das Icon Arbeitsplatz im Unterregister Änderungen in der Registry auswählen, werden alle in der gesamten Registry gefundenen Änderungen in eine Textdatei exportiert. Das gilt auch für die Unterregister.

Benutzen Sie den inkrementellen Vergleich für "Spionage-Sequenzen"

Wenn Sie eine Reihenfolge von Änderungen herausfinden möchten, benutzen Sie bitte Inkrementelles Vergleichen in Schritt 4 statt Vergleichen. Sie können dann die nächste Änderung direkt anschließend durchführen, ohne die Funktion Speichere aktuelle Konfiguration wieder ausführen zu müssen. Siehe Inkrementelles Installieren & Vergleichen für weitere Hinweise.

Wenn Sie die Änderungen in Textdateien exportieren möchten, vergessen Sie bitte nicht, die Export-Funktion nach jedem inkrementellen Vergleich aufzurufen.


Installationsdateien erzeugen
Die Funktion Installationsdateien erzeugen im Menü Werkzeuge ist tolles Feature, mit dem Sie Installation von Anwendungen auf mehreren Rechnern oder Festplatten "klonen" können, ohne sich jedes mal durch die gesamte Setup-Routine der Anwendung durcharbeiten zu müssen. Das Programm benutzt das Installationsprotokoll der Anwendung, die mit der Funktionen Vergleichen erzeugt wurde, um ein Set von .REG, .INF und .VBS Dateien zu generieren, die Sie als Basis zur "geklonte" Installationen benutzen können.

Nur für erfahrene Benutzer!

Diese Funktion richtet sich an erfahrene Benutzer und Systemadministrator mit fundierten Kenntnissen über das Format, die Syntax und den Gebrauch von .REG, .INF und .VBS Dateien. Sie sollten nicht versuchen, diese Dateien direkt zum Klonen von Installationen zu verwenden. Obwohl die Ashampoo UnInstaller Suite das meiste der Arbeit erledigt, sollten die erzeugten Dateien als Rohmaterial angesehen werden, das Sie entsprechend bearbeiten müssen, um die "Klon"-Dateien zu erstellen.

Es ist eigentlich überflüssig zu erwähnen, aber Sie können diese Methode nur zum Klonen von Installationen auf Rechnern mit identischen Verzeichnis- und Registry-Strukturen, einschließlich aller betroffenen Abschnitte, verwenden!

Vorgehensweise:

1. Installieren Sie die Anwendung, die Sie klonen möchten, auf Ihren Hauptrechner und protokollieren Sie die Installation mit der Ashampoo UnInstaller Suite.

2. Stellen Sie sicher, dass das in Schritt 1 erzeugte Installationsprotokoll geladen ist (Laden Sie es wenn nötig mit der Option Lade Auswahl aus Datei im Menü Datei).

3. Wählen Sie Installationsdateien erzeugen im Menü Werkzeuge.

4. Wählen Sie die Einträge zum Export in der Dialogbox und geben den Pfad und den Dateinamen im darauf folgenden Dialog ein.

Bitte geben Sie keine Dateierweiterung ein! Der gleiche Dateiname wird für alle drei erzeugten Dateitypen benutzt.


Die Registry bearbeiten
Das Unterregister Registry im Register Auswahl: Registry & Laufwerke enthält einen Funktions-Editor, mit dem Sie bestehende Registry-Einträge und neue Werte und Schlüssel hinzufügen können. Sie haben über das Fenster Werte in den Registern Installationsprotokolle auch Zugriff auf den Registry-Editor.

Um den Editor aufzurufen, klicken Sie einfach mit Rechts auf einen Wert oder Schlüssel in eines der Fenster im Register Registry unter Auswahl: Registry & Laufwerke:

Das Bearbeiten der Registry sollten nur erfahrene Benutzer durchführen!

Bitte seien Sie extrem vorsichtig, wenn Sie die Windows Registry bearbeiten. Führen Sie Änderungen nur durch, wenn Sie sich absolut sicher über Ihre Aktionen sind. Bitte sichern Sie Ihre Registry mit Hilfe eines Backups, bevor Sie Änderungen vornehmen. Unbedachte Änderungen der Registry können Fehlfunktionen von Windows provozieren und in seltenen Fällen das ganze System gefährden!

Bitte führen Sie immer ein Backup Ihrer Systemdateien durch und halten Sie Ihre Notfall- und Reparaturdisketten auf dem aktuellsten Stand. Für detaillierte Anweisungen suchen Sie bitte Ihre Windows-Hilfe nach folgenden Begriffen ab: Notfalldisketten, Registrierung, Backup (-Programm) etc.

Werte editieren:

Werte werden im rechten Feld des Registers Registry angezeigt.

Klicken Sie bitte mit Rechts auf einen Eintrag und wählen Sie Wert editieren im PopUp-Menü. Sie können die einzelnen Registry-Einträge nach einem Doppelklick bearbeiten (Das funktioniert aber nicht im Verzeichnisfeld auf der linken Seite).

Der Editor erlaubt Ihnen das Bearbeiten des Namens, des Datentyps und des Inhalts. Alle Datentypen von Windows, einschließlich der weniger bekannten Typen, werden unterstützt.

Das Fenster beim Editieren ändert sich automatisch entsprechend des ausgewählten Datentyps. Die meisten Felder sind selbst erklärend (Wenn Sie die Felder nicht verstehen, sollten Sie die Registry vielleicht noch bearbeiten).

Wenn Sie binäre Werte auswählen (wie im linken Bild) können Sie die einzelnen hexadezimalen Werte bearbeiten, in dem Sie auf die Werte klicken (1). Sie können die Größe des binären Datenblocks mit der Option Datengröße verändern (2). Bitte mit Vorsicht benutzen!

Werte hinzufügen:

Wählen Sie den Schlüssel aus, für den Sie einen Wert eingeben wollen, im linken Feld des Registers Registry aus und klicken dann mit der rechten Maustaste in das Feld rechts (wo die Werte angezeigt sind). Dann wählen Sie Neuer Wert aus dem PopUp Menü.

Im Registry Editor wählen Sie den Datentyp, den Sie eingeben wollen, im Feld Datentyp: aus. Das Fenster passt sich dem ausgewählten Typ an.

Füllen Sie dann die verschiedenen Felder aus und klicken auf OK, um den Wert in die Registry zu schreiben.

Hinweis:
Wenn Sie binäre Werte eingeben, müssen Sie den Parameter für die Datengröße einstellen, bevor Sie die aktuellen Daten eingeben.

Hinzufügen und Löschen von Schlüsseln:

Schlüssel hinzufügen:

Klicken Sie mit der rechten Maustaste auf den Schlüssel im linken Fenster (Verzeichnis), für den Sie einen Unterschlüssel hinzufügen wollen und wählen die Option Neuer Schlüssel aus dem PopUp-Menü.

Geben Sie dann den Namen für den Schlüssel in die Dialogbox wie links angezeigt ein.

Löschen von Schlüsseln:

Klicken Sie mit der rechten Maustaste auf den Schlüssel, den Sie löschen möchten, im linken Fenster (Verzeichnis) des Registers Registry und wählen Schlüssel löschen aus dem PopUp Menü.

Bitte seien Sie vorsichtig! Der Schlüssel wird für immer aus der Registry gelöscht!


Benutzerdefinierte Systemdateien
Die Ashampoo UnInstaller Suite erlaubt Ihnen das Hinzufügen von benutzerdefinierten Dateien zur Standardliste im Register Systemdateien, die normalerweise folgende Dateien enthält: WIN.INI, SYSTEM.INI, CONFIG.SYS und AUTOEXEC.BAT. Sie können dadurch Änderungen an diesen Dateien überwachen und sie mit der Wiederherstellungsfunktion des Programmes wieder rückgängig machen.

Hinweis:
Die Einträge für diese Dateien sind im Register Systemdateien für alle Windows-Systeme einbezogen, obwohl einige oder keine von ihnen noch wirklich von neueren Windows-Versionen gebraucht werden. Der Grund liegt darin, dass sie immer noch manchmal von Anwendungen benutzt werden und einige Kommandos und Einstellungen, die von Anwendungen dort eingetragen werden, von Windows abgearbeitet werden. Obwohl beispielsweise Windows® NT4, 2000 und XP nicht mehr länger auf DOS basieren, werden die DOS-Konfigurationsdateien CONFIG.SYS und AUTOEXEC.BAT weiterhin von diesen Betriebssystemen abgearbeitet, wenn sie vorhanden sind und relevante Einstellungen enthalten.

Unterstützte Typen benutzerdefinierter Systemdateien

Sie können zwei verschiedene Typen von benutzerdefinierten Systemdateien hinzufügen: Gewöhnliche Textdateien wie AUTOEXEC.BAT und INI-Dateien, die dem standardmäßigen INI-Format entsprechen. Die Ashampoo UnInstaller Suite wird die Änderungen in beiden Dateitypen überwachen, kann aber nur die Änderungen in den INI-Dateien umkehren. Wenn Sie Änderungen an Textdateien umkehren möchten, sollten Sie die Funktion Backup erstellen benutzen und die Option Gesicherte Dateien beim Wiederherstellen werden in den Einstellungen verwenden.

Dieses Feature ermöglicht Ihnen die Überwachung und Wiederherstellung von vielen INI-Dateien anderer Anwendungen, die normalerweise im Windows- und Systemverzeichnis oder den programmeigenen Verzeichnissen gespeichert werden.

Wie Sie benutzerdefinierte Systemdateien hinzufügen können:

Um eine Datei hinzuzufügen, klicken Sie einfach mit der rechten Maustaste in das Register Systemdateien und wählen Benutzerdefinierte Datei hinzufügen im PopUp Menü aus.

Es öffnet sich ein Dialog, mit dem Sie die Datei hinzufügen und den Typ (Text oder INI) bestimmen können.

Die Ashampoo UnInstaller Suite wird nur Änderungen in INI-Dateien, die der standardmäßigen Syntax (siehe unten) entsprechen, überwachen und wiederherstellen. Die Kopfzeilen der Abschnitte müssen in eckige Klammern eingefasst sein und die Angaben zu den Einträgen müssen exakt eingegeben werden. Zur Erläuterung schauen Sie sich bitte die auf Ihrem Computer gespeicherten INI-Dateien an.

[Abschnitt 1]
Eintrag1=Wert1
Eintrag2=Wert2
...
[Abschnitt 2]
Eintrag2=Wert2
Eintrag2=Wert22
...

Die Ashampoo UnInstaller Suite wird Dateien, die diesem Format entsprechen, in der gleichen Weise behandeln wie WIN.INI und SYSTEM.INI und erlaubt es Ihnen, einzelne Einträge zur Überwachung aus- oder abzuwählen. Sie können geänderte oder gelöschte Einträge aus Protokollen wiederherstellen, genauso wie Sie Einträge in der Registry wiederherstellen können.


Mit dem Programm im Batchmodus arbeiten
Sie können die Ashampoo UnInstaller Suite im Batchmodus über die Kommandozeile oder durch Batchdateien ausführen:

Kommandozeilen-Parameter für den Batchmodus:

· UNINSTALLER.EXE /STORECONFIG [Dateiname]

Speichert die aktuelle Konfiguration des Rechners in die angegebene Datei [Dateiname] -- bitte die eckigen Klammern nicht einfügen! Dieser Aufruf entspricht den folgenden manuellen Schritten:

1. Starten der Ashampoo UnInstaller Suite.

2. Durchführung von Speichere aktuelle Konfiguration

3. Beenden der Ashampoo UnInstaller Suite.

Der Parameter [Dateinamen] ist optional. Wenn Sie keinen Namen eingeben, wird der standardmäßige "Bevor"-Schnappschuss OldCfg.ECD (durch Speichere aktuelle Konfiguration erstellt) per Voreinstellung verwendet.

· UNINSTALLER.EXE /COMPARE [Name der Protokolldatei] [Alte ECD Datei] [Neue ECD Datei]

Generiert ein Installationsprotokoll mit dem angegebenen Namen [Name der Protokolldatei]. Dieser Aufruf entspricht den folgenden manuellen Schritten:

1. Starten der Ashampoo UnInstaller Suite.

2. Durchführung von Vergleiche (Protokoll erstellen)

3. Beenden der Ashampoo UnInstaller Suite.

Der Parameter [Name der Protokolldatei] ist notwendig. Es ist der Name für das zu erstellende Installationsprotokoll.

Die Parameter [Alte ECD Datei] und [Neue ECD Datei] sind optional. Wenn Sie diese Dateien angeben, müssen die Konfigurationsdateien, auf die sie sich beziehen, vorhanden sein. Das Programm nimmt an, dass die aktuelle Konfiguration für die Vergleichsoperation bereits gespeichert wurde und vergleicht einfach die beiden angegebenen Dateien. Das entspricht der Durchführung von Vergleiche zwei Konfigurationen im Menü UnInstaller.

Wenn Sie keine Dateinamen angeben, wechselt die Ashampoo UnInstaller Suite in den Modus Vergleiche (Protokoll erstellen) und benutzt automatisch die standardmäßigen Dateivorgaben (OldCfg.ecd und NewCfg.ecd). Das Programm speichert die aktuelle Konfiguration in die Datei NewCfg.ecd und vergleicht sie mit der Datei OldCfg.ecd. Das Ergebnis wird in die Datei mit dem Namen [Dateiname]geschrieben. Das entspricht der Durchführung von Vergleiche (Protokoll erstellen) im Menü UnInstaller.

· UNINSTALLER.EXE /UNINSTALL [Dateiname]

Stellt alle Änderungen, die in die Protokolldatei mit dem Namen [Dateiname]geschrieben wurden ohne Warnung oder Abfrage wieder her bzw. entfernt die Anwendung, deren Installation in [Dateiname] protokolliert wurde. Der Parameter [Dateiname] ist erforderlich.
Mit Vorsicht benutzen! Diese Funktion entspricht der Auswahl von Alles wiederherstellen.

· UNINSTALLER.EXE /CREATEINSTALL [Dateiname]

Erzeugt Installationsdateien für die Protokolldatei wie in [Dateiname] angegeben. Die erzeugten Dateien werden automatisch entsprechend der Syntax Dateiname+_xxx.xx benannt und in das Standardverzeichnis gespeichert, welches von der Funktion Installationsdateien erzeugen benutzt wird.

· UNINSTALLER.EXE /EXPORTTEXT [Dateiname]

Exportiert die in die Protokolldatei [Dateiname]geschriebenen protokollierten Änderungen in Textdateien. Diese erzeugten Textdateien werden automatisch entsprechend der Syntax Dateiname+_xxx.TXT benannt. Siehe Daten der Installationsprotokolle exportieren für weitere Erläuterungen zu dieser Funktion.


Daten der Installationsprotokolle exportieren
Sie können alle in den Installationsprotokollen gespeicherten Überwachungsdaten in Textdateien zum Nachschlagen, Archivieren und Drucken exportieren. Klicken Sie einfach auf einen Eintrag in einem der Register unter Installationsprotokolle und wählen Daten exportieren aus dem PopUp Menü, um die Daten dieses Eintrags in eine kommentierte Textdatei zu schreiben. Sie können diese Textdatei mit Notepad oder einem anderen Text-Editor bearbeiten und ausdrucken.

Hinweise:

· Die Funktion exportiert immer die Daten des ausgewählten Eintrags und alle darunter liegenden Einträge (wenn vorhanden) - zum Beispiel der aktuelle Ast der Registry und alle weiteren Verzweigungen.
· Das Auswählen der Icons [image], [image] und [image] wählt alle Daten in den entsprechenden Abschnitten.

· Sie können bestimmte Sets sichern, in dem Sie einzelne Zweige des Baumes auswählen.

· Eine kurze Erläuterung zu den Einträgen mit Legende wird als Kopfzeile an den Anfang jeder Exportdatei eingefügt.


Die Funktionen der Suite
Dieser Abschnitt beschreibt die Funktionen der fünf zusätzlichen Module, die in die Ashampoo UnInstaller Suite integriert worden sind:

· Doppelte Dateien suchen und löschen

Mit diesem Modul können Sie doppelte Dateien, die wertvollen Speicherplatz vergeuden, identifizieren, finden und löschen.

· Temporäre Dateien suchen und löschen

Ermöglicht Ihnen das Aufspüren und Löschen temporärer und anderer unnötiger Dateien, um Ihr System schlank zu halten und Speicherplatz zurück zu gewinnen.

· Leere Ordner suchen und löschen

Ermöglicht Ihnen, leere Ordner aufzuspüren und zu löschen, die nur Speicherplatz auf Ihrem System verschwenden.

· Schriften verwalten und löschen

Anzeige aller auf Ihrem System installierten Schriften mit der Möglichkeit, nicht mehr benötigte Schriften zu löschen.

· Internetbereich säubern

Ermöglicht Ihnen den Schutz Ihrer Privatsphäre und das Wiedergewinnen von Speicherplatz durch das Löschen von temporären Dateien und anderen Objekte, die während Ihrer Internet-Sessions erzeugt wurden.


Doppelte Dateien suchen und löschen
Die Ashampoo UnInstaller Suite ist auch in der Lage, doppelte Dateien auf Ihrem System zu entdecken und zu löschen. Der eingesetzte Suchalgorythmus ist sehr schnell. Ashampoo UnInstaller Suite kann in wenigen Sekunden bis zu 50.000 Dateien in 3.000 Ordnern auf 5 Laufwerken abarbeiten.

Vorgehensweise:

1. Wählen Sie Doppelte Dateien suchen und löschen im Hauptbildschirm, im Menü Werkzeuge oder in der Werkzeugleiste.

2. Wählen Sie die Laufwerke oder Ordner, wo nach doppelten Dateien gesucht werden soll aus, in dem Sie im linken Fenster ein entsprechendes Häkchen (1) setzen.

3. Wählen Sie bitte die Suchkriterien (2) aus:

a) Name, Größe, Inhalt (Extrem genau, aber etwas langsamer) oder
b) Name, Größe, Datum (Weniger genau, aber sehr schnell)

Methode a) identifiziert Dateien, die nach Namen, Größe und Inhalt identisch sind. Diese Methode ist extrem genau, dauert aber etwas länger, da das Programm alle Dateien von Anfang bis Ende absuchen und deren Inhalt vergleichen muss.

Methode b) identifiziert Dateien, die nach Namen, Größe und Datum identisch sind. Diese Methode ist sehr schnell und in den meisten Fällen völlig ausreichend.

4. Wählen Sie Suche beginnen. Die Ashampoo UnInstaller Suite sucht und sortiert zunächst alle Dateinamen an den ausgewählten Orten. Anschließend werden Dateien mit gleichem Namen gesucht und dann die einzelnen Dateien verglichen.

5. Die Resultate werden in den beiden rechten Fenstern aufgelistet. Durch Klicken auf einen Dateinamen im oberen Fenster erhalten Sie die Pfade zu den Dubletten mit den Namen im unteren rechten Fenster angezeigt.

6. Mit einem Rechtsklick auf die Datei öffnet sich ein kleines Menü zum Löschen. Sie können mehrere Dateien auswählen und löschen.

Tipps:

· Sie können die Liste sortieren, in dem auf die Spaltenköpfe im oberen rechten Fenster doppelklicken (Gleiche Funktionalität wie im Windows Explorer). Sie können damit schneller erkennen, wo der meiste Platz verschwendet wird.

· Sie können mit einem Doppelklick auf die Einträge im unteren Ergebnisfenster die Dateien, um deren Inhalte zu prüfen.

· Sie können auch die normalen Tastenkombinationen von Windows im unteren Fenster benutzen: Alt+A (Alles auswählen), Ctrl + Klicken (Auswahl mehrerer ungeordneter Dateien), Shift + Klicken (Auswahl eines Blocks von Dateien) und Del (Löschen).


Temporäre Dateien suchen und löschen
Diese Funktion ermöglicht Ihnen das Auffinden und Löschen temporärer Dateien, die Speicherplatz auf Ihrem System verschwenden.

Die Suchleistung ist sehr genau, da Sie selbst Ihre eigenen Suchkriterien festlegen können, mit denen Sie der Ashampoo UnInstaller Suite vorgeben, wonach und was gesucht werden soll. Diese Kriterien werden als Vorgabe gespeichert und jedes mal automatisch angezeigt, wenn Sie diese Funktion aufrufen.

Vorgehensweise:

Beim ersten Aufruf dieser Funktion gibt es nur einen vorgegebenen Eintrag: Der standardmäßige Windows TEMP Ordner. Um weitere Einträge hinzuzufügen klicken Sie bitte auf Neuer Eintrag: (1).

Sie können bereits existierende Einträge bearbeiten, in dem Sie den Eintrag auswählen und dann auf Eintrag bearbeiten klicken.

Das Beispiel links zeigt eine Definition an, die alle Sicherungsdokumente mit der Dateierweiterung *.bak im Order D:\Eigene Dateien und dessen Unterordner findet.

Beschreibung: Der Name für das Suchkriterium. Wird in der Spalte Beschreibung angezeigt.

Suchpfad: Wo gesucht werden soll. Sie können einen Namen eingeben oder auf den Browse-Schalter rechts neben dem Eingabefeld klicken, um einen Ordner auszusuchen.

Suchmaske: Was soll gefunden werden. Sie können die Standard-Platzhalter ? (Irgendein Zeichen) und * (Ein oder mehrere Zeichen) benutzen, um Ihre Suche zu verfeinern.

Klicken Sie auf Suche beginnen (2), um die Suche durchzuführen. Wenn die Suche abgeschlossen ist, zeigt Ihnen das Modul alle Dateien, die den Suchkriterien entsprechen, im unteren Teil (3) an. Ein Rechtsklick auf die einzelnen Einträge im unteren Fenster öffnet ein kleines Menü zu Löschen.

Tipps:

· Sie können die Liste sortieren, in dem auf die Spaltenköpfe im oberen rechten Fenster doppelklicken (Gleiche Funktionalität wie im Windows Explorer). Sie können damit schneller erkennen, wo der meiste Platz verschwendet wird.

· Sie können mit einem Doppelklick auf die Einträge im unteren Ergebnisfenster die Dateien, um deren Inhalte zu prüfen.

· Sie können auch die normalen Tastenkombinationen von Windows im unteren Fenster benutzen: Alt+A (Alles auswählen), Ctrl + Klicken (Auswahl mehrerer ungeordneter Dateien), Shift + Klicken (Auswahl eines Blocks von Dateien) und Del (Löschen).


Leere Ordner suchen und löschen
Mit Hilfe dieser Funktion können Sie leere Ordner, die keine Daten enthalten, aufspüren und löschen. Es ist in der Regel sicher, leere Ordner zu löschen. Sie sollten aber dennoch vorsichtig mit Odnern, die zu noch installierten Anwendungen gehören, umgehen. Es gibt Programme, die Ordner für eine spätere Verwendung erzeugen. Sie können Fehlermeldungen erhalten, wenn Sie solche Ordner löschen sollten. Aber selbst in solchen Fällen, sind ernsthafte Probleme nicht zu erwarten. Sie werden in der Regel eine Meldung wie die folgende erhalten: "Verzeichnis C:\Programme\Anwendung\Backup" nicht gefunden!" Sie müssen dann nur den Ordner von Hand anlegen.

Wählen Sie bitte Leere Ordner suchen und löschen im Bildschirm der Suite, der Werkzeugleiste oder im Menü Werkzeuge.

Vorgehensweise:

1. Wählen Sie die Laufwerke und/oder Ordner für die Suche aus (1). Sie können die Ansicht weiter aufklappen, wenn Sie auf das + Symbol klicken und einzelne Zweige auswählen .

2. Klicken Sie dann auf Suche beginnen (2) und nach wenigen Sekunden wird das Ergebnis im rechten Feld des Dialoges eingeblendet (3).

Leere Dateien ignorieren (4):
Wenn Sie diese Option aktivieren, wird die Suchroutine Dateien mit einer Länge von Null Bytes ignorieren und Ordner, die Null Bytes-Dateien enthalten, als leer anzeigen. Das ist besonders nützlich für die Ordner, welche die Datei MSCREATE.DIR mit Null Bytes-Länge enthalten.

Auswählen:

Sie können die Einträge, die Sie löschen möchten, mit den standardmäßigen Windows-Tastenkombinationen auswählen: Linksklick, Hochstelltaste (Shift) + Linksklick, Hochstelltaste (Shift) + Linksklick und Ziehen (Beginnen Sie das Ziehen rechts in der ersten Spalte).

Löschen:
Um einzelne Ordner zu löschen, klicken Sie einfach mit rechts auf den Eintrag und wählen dann Löschen aus dem PopUp-Menü. Sie können alle aufgelisteten Ordner mit der Funktion Alle markieren auswählen. Um mehrere Ordner zu löschen, treffen Sie bitte Ihre Auswahl in der Liste, klicken Sie mit der rechten Maustaste auf einen der Einträge und wählen dann Löschen.


Schriften verwalten und löschen
Mit dieser Funktion können Sie sich alle auf Ihrem System installierten Schriften anzeigen lassen. Sie können die Schriften, die Sie nicht benötigen, löschen.

Sie können diese Funktion aufrufen, in dem Sie Schriften verwalten und löschen im Bildschirm der Suite, der Werkzeugleiste oder dem Menü Werkzeuge auswählen.

Vorgehensweise:

· Die installierten Schriften werden in alphabetischer Reihenfolge im linken Fenster gelistet. Das obere rechte Fenster zeigt das Erscheinungsbild an. Sie können die Größe der Anzeige manuell verändern (1).

· Zusätzliche Informationen über die ausgewählte Schrift (Nur True Type) können Sie dem unteren Fenster entnehmen (2).Wenn es sich um eine andere Schrift handelt (z.B. eine Schrift für VGA-Auflösung) bleibt das Informationsfenster leer.

· Der Text im Beispielfenster kann bearbeitet werden. Sie können also einen Text Ihrer Wahl in das Fenster eingeben. Der Text wird automatisch als neuer Standardtext für diese Schrift gespeichert, wenn Sie die Funktion schließen.

· Das Löschen der Schriften ist einfach: Wählen Sie eine oder mehrere Schriften aus und klicken Sie dann auf den Schalter Schrift löschen.


Internetbereich säubern
Diese mächtige Funktion ermöglicht Ihnen das Entfernen aller Dateien und Einträge, die von Ihrem Browser erzeugt wurden, als Sie online waren. Wenn Sie diese Funktion regelmäßig benutzen, werden Sie überrascht sein, wie viel Müll sich ablagert.

Klicken Sie bitte doppelt auf das Icon Internetbereich säubern im Bildschirm der Suite (Ebenso erreichbar über die Werkzeugleiste und das Menü Werkzeuge):

Generelle Vorgehensweise in allen Registern:

1. Wählen Sie das Register für Ihren Browser (1). Die Optionen für Netscape sind etwas begrenzter als die für den Internet Explorer, aber es gelten die gleichen Regeln. (Wenn Sie Netscape benutzen, müssen Sie den Netscape Benutzer wählen, dessen Einträge gelöscht werden sollen.

2. Wählen Sie die Einträge, die Sie löschen möchten. Siehe unten für weitere Hinweise.

3. Klicken Sie auf den Schalter Markierte Elemente löschen (5).

Einträge zum Löschen auswählen:

Es gibt ein separates Register (2) für jede der vier Kategorien von temporären Internet-Einträgen: Temporäre Dateien, Cookies, Besuchte Seiten, URLs.

Auswählen:

Sie können die Dateien, die Sie löschen möchten, mit den standardmäßigen Windows-Tastenkombinationen auswählen: Linksklick, Hochstelltaste (Shift) + Linksklick, Hochstelltaste (Shift) + Linksklick und Ziehen (Beginnen Sie das Ziehen rechts in der ersten Spalte). Im Register Temporäre Dateien können Sie die drei praktischen Auswahlschalter über der Listenbox (siehe unten) benutzen. Klicken Sie auf den Schalter Alle markieren (5), um alle Einträge in der Liste auszuwählen.

Abwählen:
Um alle ausgewählten Einträge wieder abzuwählen, klicken Sie einfach irgendwo in das weiße Feld rechts neben der Liste (6).

Sortieren:

Klicken Sie bitte doppelt auf den Kopf der Spalte, um die Einträge in den Spalten numerisch oder alphabetisch zu sortieren. Durch ein erneutes Klicken auf den Kopf der Spalte ändern Sie die Sortierreihenfolge von absteigend auf aufsteigend und umgekehrt.

Das Register Temporäre Dateien

Wann immer Sie eine Webseite besuchen, speichert Ihr Browser alle besuchten Seiten in einem temporären Speicherbereich mit dem Namen Cache. (Sie können die Einstellungen für diesen Cache in Ihrem Browser vornehmen). Das kann den Zugriff beim erneuten Besuch der Seite enorm beschleunigen, wenn Sie die Seite besuchen, bevor die Dateien im Cache gelöscht wurden. Es werden dann die Daten von Ihrer Festplatte statt aus dem Internet geladen. Auf der anderen Seite nehmen diese Dateien sehr viel Speicherplatz in Ihrem System in Anspruch.
Die Liste im Hauptteil der Dialogbox zeigen Ihnen alle Dateien, die im Browser-Cache gespeichert wurden.

Spezielle Auswahlschalter:

Im Register Temporäre Dateien befinden sich drei besondere Schalter, mit denen Sie Ihre Auswahl in den Listen "tunen" können. Sie tragen dazu entweder den Kontrollwert rechts neben den Schalter ein oder benutzen die Hoch/Runter-Pfeile. Alternativ klicken Sie doppelt in das Zahlenfeld und geben einen neuen Wert ein.

Wählt alle Dateien aus, auf die weniger als n mal zugegriffen wurde. Sie können damit Dateien auswählen, auf die selten oder nie zugegriffen wurde.

Wählt alle Dateien aus, auf die vor n Tagen zugegriffen wurde. Damit wählen Sie Dateien aus, die seit längerer Zeit nicht benutzt wurden.

Wählt alle Dateien, die ein bestimmte Größe überschreiten. Sie können damit große Dateien auswählen, die viel Platz in Anspruch nehmen.

Mit diesem Schalter wählen Sie alle Dateien aus der Liste aus. Sie können damit den gesamten Internet Cache löschen. Zum Beispiel um zu verhindern, dass niemand die von Ihnen besuchten Seiten sehen kann.

Unterschiede bei Netscape:

Temporäre Internetdateien: Aufgrund der Art und Weise, wie die temporären Dateien bei Netscape organisiert sind, können alle temporären Dateien nur zusammen gelöscht werden.

History löschen: Der zweite Schalter im Register Temporäre Dateien unter Netscape löscht die History. Das ist die Liste aller Adressen von allen Dateien, die Sie kürzlich besucht haben.

Das Register Cookies

Viele Webseiten speichern Informationen auf Ihrem Rechner in kleinen Dateien, den sogenannten "Cookies" ab und laden diese Daten wieder, wenn Sie die Seiten erneut besuchen. Vorausgesetzt Sie haben das Setzen von Cookies in den Sicherheitseinstellungen Ihres Webbrowsers nicht unterbunden. Es ist kaum noch möglich, bestimmte Webseiten zu laden, wenn Sie das Setzen von Cookies abgestellt haben. Das gilt insbesondere für kommerzielle Seiten und Online-Shops.

Cookies werden sehr oft benutzt, um das Erscheinungsbild und Verhalten der Internetseiten den Vorlieben und Profilen der Benutzer anzupassen. Die Cookies selbst beinhalten nur wenige Daten, es ist ein spezieller Code, der den Benutzer beim erneuten Besuch der Internetseite identifiziert. Die aktuellen Daten sind auf dem Server des Anbieters gespeichert. Das Cookie auf Ihrem Rechner wird quasi als Zugangscode benutzt, um Ihren Rechner mit den Daten zu verbinden. Das ist die unangenehme Seite an den Cookies - Sie haben keine Chance heraus zu finden, welche Daten gespeichert worden sind.

Viele Benutzer sind von der Vorstellung verschreckt, dass Sie keinen Zugriff auf solche Daten haben, die irgendwo auf einem Server gespeichert und mit einem Cookie auf dem eigenen Rechner verbunden sind. Darüber hinaus können Cookies dazu benutzt werden, Ihren "Internetspuren" zu folgen und ein Benutzerprofil zu erzeugen.
Aus diesen Gründen ist es sinnvoll, Cookies zu löschen. Ein wenig Sorgfalt sollte man dennoch walten lassen. Einige Internetseiten können unerwartet reagieren oder erfordern eine erneute Indifikation, wenn das Cookie gelöscht wurde. Sie sollten die Cookies, von den Internetseiten, denen Sie vertrauen, daher nicht löschen.

Das Register Besuchte Seiten

Ihr Internetbrowser speichert automatisch die Adressen der von Ihnen besuchten Internetseiten. Wenn Sie möchten, dass diese Informationen nicht auf Ihrem System gespeichert werden, können Sie die Einträge hier löschen. Diese Option ist nur für den Internet Explorer von Microsoft verfügbar.

Der Schalter Besuchte Seiten:
Microsoft Internet Explorer speichert Ihre Seitenzugriffe an verschiedenen Orten. Die Liste Besuchte Seiten ist eine verborgene Liste, die im Hintergrund verwaltet wird. Die Liste xxx entspricht der Liste, die Sie sehen können, wenn Sie auf das Icon Verlauf in der Werkzeugleiste des Internet Explorers klicken. Der Inhalt der Liste Verlauf kann nur zusammen gelöscht werden. Klicken Sie einfach auf den Schalter Verlauf löschen.

Unterschiede bei Netscape:

Bei Netscape werden die besuchten Seiten und die History zusammen gelöscht, wenn Sie auf den Schalter History löschen klicken.

Das Register Eingegebene URLs

Alle Adressen von Webseiten (URLs), die Sie manuell in das Adressfeld eingeben, werden von Ihrem Browser in einer Liste gespeichert. Diese Liste kann von jedermann mit Zugriff auf Ihren Computer eingesehen werden. Wenn Sie das verhindern möchten, löschen Sie die Einträge in diesem Register.

Unterschiede bei Netscape:

Bei Netscape werden die manuell eigegebenen Adressen von Webseiten (URLs) ebenfalls gelöscht, wenn Sie auf den Schalter History löschen klicken.


Referenzen
Dieser Abschnitt enthält weitere Informationen zur Funktionsweise der Ashampoo UnInstaller Suite und zur besseren Handhabung des Programmes. Bitte lesen Sie diese Kapitel sorgfältig durch, wenn Sie das Programm ernsthaft im Experten-Modus benutzen wollen.


Dateitypen
Wenn Sie mit der Ashampoo UnInstaller Suite im Experten-Modus arbeiten ist es sehr hilfreich zu verstehen, welche Dateien vom Programm erzeugt werden und welchem Zweck diese Dateien dienen. Das Programm generiert und benutzt die drei folgenden Typen von Dateien im eigenen Programmverzeichnis:

Auswahldateien (.ECS)

Diese Dateien speichern die Einstellungen in den Auswahl-Registern. Es gibt zu mindestens eine .ECS Datei mit dem Namen Last.ECS, in der die Auswahl gespeichert ist, die automatisch bei jedem Start der Ashampoo UnInstaller Suite geladen wird. Wenn Sie das Programm verlassen, werden Sie aufgefordert, irgendwelche in den Auswahl-Registern vorgenommenen Änderungen als neue Vorgabe zu speichern, die beim nächsten Start des Programms benutzt werden. Wenn Sie auf Ja bei der Abfrage klicken, speichert das Programm die aktuelle Auswahl in die Datei Last.ECS und überschreibt die bestehende Version.

Sie können Auswahl-Konfigurationen auch in Ihre eigenen .ECS Dateien speichern. Benutzen Sie dazu das Kommando Speichere Auswahl in Datei im Menü Datei. Das empfiehlt sich besonders für Einstellungen, die Sie nur zu bestimmten Zwecken nutzen wollen - wie zum Beispiel dem Ausspionieren der Registry. Die Standardvorgaben bei den Auswahl-Einstellungen, die Sie zu jeder Zeit mit dem Kommando Zurücksetzen des Auswahl im Menü Datei zurücksetzen können, sind sicherlich die beste Wahl für die Installation und Deinstallation von Anwendungen. Alle anderen Einstellungen sollten in separate .ECS Dateien gespeichert werden und nur wenn benötigt auch geladen werden. Dazu benutzen Sie das Kommando Lade Auswahl aus Datei im Menü Datei.

Backups:
Wenn Sie eine von der Vorgabe abweichende Auswahl benutzen, empfiehlt sich das Erstellen von Backups Ihrer .ECS Dateien.

Konfigurationsdateien (.ECD)

Das sind die Dateien, die zum Speichern der "Schnappschüsse" Ihres gesamten Systems benutzt werden. Aus diesem Grund sind diese Dateien auch verhältnismäßig groß. Sie enthalten Kopien von allen Einträgen in der Windows Registry und Listen aller auf Ihren Festplatten gespeicherten Dateien und deren Daten wie z.B. Datum, Versionsnummer etc.

Wenn Sie Speichere aktuelle Konfiguration auswählen, untersucht die Ashampoo UnInstaller Suite Ihr gesamtes System und speichert alle gefundenen Informationen in eine Konfigurationsdatei mit dem Namen OldCFG.ECD. Wenn diese Datei bereits existiert, wird sie zunächst in OldCFG.BAK umbenannt, damit Sie mit dem Kommando Wiederherstellen der gespeicherten Konfiguration im Menü Datei wiederhergestellt werden kann.

Wenn Sie Vergleiche (Protokoll erstellen) auswählen, untersucht die Ashampoo UnInstaller Suite Ihr System erneut und schreibt eine zweite Konfigurationsdatei mit dem Namen NewCFG.ECD, vergleicht diese Datei mit der Datei OldCFG.ECD und zeichnet die Unterschiede in ein Installationsprotokoll (siehe unten).
Sie können Ihre aktuelle Konfiguration auch in eine Datei mit einem Namen Ihrer Wahl speichern. Wählen Sie dazu Speichere Konfiguration unter ... im Menü UnInstaller. Siehe Arbeiten mit Konfigurationsdateien für weitere Hinweise.

Installationsprotokolle - (Dateierweiterung .ECL)

Diese Dateien werden zur Aufzeichnung der gefundenen Unterschiede beim Vergleich zweier Konfigurationen benutzt. Sie haben in der Regel die Namen, die der Benutzer (also Sie selbst ) eingegeben haben oder den protokollierten Namen der Anwendung, der bei der Installation mit dem UIWatcher vorgeschlagen wurde.

Backups:
Es ist sinnvoll, ein Backup aller .ECL Installationsprotokolle an einem sicheren Ort zu hinterlegen. Sie können die Ashampoo UnInstaller Suite immer wieder installieren, aber wenn Sie Ihre Protokolldateien verlieren, werden Sie nicht mehr in der Lage sein, protokollierte Anwendungen zu deinstallieren.


Auswahl
Im Experten-Modus der Ashampoo UnInstaller Suite können Sie exklusiv alle Teile Ihrer System-Konfiguration bestimmen, die Sie auf Veränderungen hin überwachen wollen. Diese Möglichkeiten machen das Programm sehr mächtig. Es bedeutet aber auch, dass Sie wissen müssen, was Sie tun! Wenn Sie zum Beispiel keine Einträge in den Registern unter Auswahl: Registry & Laufwerke auswählen, wird die Ashampoo UnInstaller Suite keine Änderungen aufzeichnen, wenn Sie eine Protokolldatei erstellen.

Auf der anderen Seite werden Sie durch die Auswahl aller Einträge in den Auswahl-Registern Konflikte und unerwartete Probleme herauf beschwören können. Sie sollten daher zu Beginn mit der Standard-Auswahl des Programms arbeiten. Sie können diese Standardeinstellungen mit der Option Zurücksetzen der Auswahl im Menü Datei zurücksetzen.

Sie sollten die Standardeinstellungen erst dann verändern, wenn Sie einige Erfahrungen mit dem Programm und dem Entfernen von Anwendungen gewonnen haben. Am Ende ist es immer besser, einige überflüssige Daten auf dem Rechner zu haben, als ein komplett "sauberes" System, dass nicht einwandfrei funktioniert oder gar nicht mehr startet.

Wenn Sie die Ashampoo UnInstaller Suite ernsthaft im Experten-Modus benutzen wollen, empfehlen wir Ihnen die Anschaffung und das Studium eines guten Nachschlagewerkes über die Windows-Systemkonfiguration und die Windows Registry.

Tipp für die Registry-Auswahl

Versuchen Sie die Taste Ctrl zu drücken, wenn Sie den Baum "aufklappen" oder "schließen". Dadurch wird der gesamte Verzeichnisbaum unterhalb des aktuellen Auswahlpunkts aufgeklappt oder geschlossen. Durch Klicken auf das Verzeichnis des Eintrags öffnet sich das nächste Unterverzeichnis usw. Das ist hilfreich bei den Registern unter Installationsprotokolle, es kann aber sehr viel Zeit bei den Auswahl-Registern in Anspruch nehmen, insbesondere wenn Sie die ganze Registry "aufklappen".

Standard-Auswahl

Beim ersten Start der Ashampoo UnInstaller Suite zeigt das Programm ein Set an Standardeinstellung mit den Ein- und Ausschlüssen an, die für die meisten Zwecke am effektivsten sind. Wenn Sie andere Registry-Einträge oder andere Einträge überwachen oder ausschließen möchten, müssen Sie diese Einträge in den Auswahl-Registern von Hand aus- oder abwählen.

Sie können die Auswahl immer auf die Standardwerte mit dem Kommando Zurücksetzen der Auswahl im Menü Datei zurücksetzen. Wenn Sie unterschiedliche Auswahl-Konfigurationen für unterschiedliche Aufgaben erstellen wollen, benutzen Sie bitte die Kommandos Speichere Auswahl in Datei und Lade Auswahl aus Datei im Menü Datei.


Eine Auswahl speichern
Wenn Sie mit der Ashampoo UnInstaller Suite im Experten-Modus arbeiten, ist sehr wichtig, die Art und Weise wie das Programm die von Ihnen in den Auswahl-Registern vorgenommenen Änderungen verarbeitet und speichert, zu kennen. Die Auswahl ist kritisch, da sie folgende wichtigen Aspekte beim Programmablauf bestimmen: Was ist eingeschlossen, wenn die aktuelle Konfiguration gespeichert wird? Was wird verglichen, wenn Sie Protokolldateien erstellen? Was wird gelöscht oder wiederhergestellt, wenn Sie Installationsprotokolle zur Deinstallation von Anwendungen und Wiederherstellung Ihres Systems benutzen?

Wichtiger Hinweis für Benutzer von Ashampoo UnInstaller 2000

Wenn Sie mit dem Programm Ashampoo UnInstaller 2000 vertraut sind, lesen Sie bitte diesen Abschnitt sorgfältig durch. Die Art, wie die Auswahl beim Laden von Installationsprotokollen behandelt wird (siehe letzten Punkt am Ende dieses Abschnitts) hat sich bei der Ashampoo UnInstaller Suite geändert, um das Programm intuitiver in der Bedienung zu machen.

Standardauswahl

Die Standardauswahl des Programms beinhalten alle sicheren Einträge in der Windows Registry und auf allen lokalen Festplatten auf Ihrem System sowie eine Reihe von Ausschlüssen im Register Ausgeschlossene Dateien. Sie können diese Auswahl mit der Option Zurücksetzen der Auswahl im Menü Datei zu jeder Zeit zurücksetzen. Bitte ändern Sie diese Auswahl nur dann, wenn Sie genau wissen, was und weshalb Sie es tun. Klicken Sie bitte hier für einige weitere Hintergrundinformationen zur Auswahl und Verwendung von Einstellungen in den Auswahl-Registern.

Eine Auswahl als Standard speichern

Wann immer Sie Änderungen an den Einstellungen in den Auswahl-Registern vornehmen, einschließlich der Einstellungen zu den ausgeschlossenen Dateien im Register Ausgeschlossene Dateien, erfolgt die Abfrage beim Verlassen des Programms, ob die neuen Einstellungen als neuer Standard gespeichert werden sollen. Die Vorgaben werden in der Datei Last.ECS gespeichert. Es ist wichtig, diese Abfrage zu bestätigen, wenn Sie gerade das Kommando Speichere aktuelle Konfiguration durchgeführt haben. Sie müssen die gleichen Auswahleinstellungen benutzen, wenn Sie das Kommando Vergleiche (Protokoll erstellen) durchführen - der Vergleich wäre sonst nicht korrekt.

Wenn Sie Ihre Standardauswahl nicht überschreiben möchten, wählen Sie bitte Speichere Auswahl in Datei im Menü Datei (siehe folgenden Hinweis unten) und laden dann die Auswahl mit dem Kommando Lade Auswahl aus Datei im Menü Datei, bevor Sie den Vergleich ausführen.

Wie man eine Auswahl in eine Datei für eine spätere Wiederverwendung speichert

Sie möchten vielleicht unterschiedliche Sets an Auswahleinstellungen für verschiedene Aufgaben benutzen, zum Beispiel um die die Registry mit besonderen Ansätzen auszuspionieren. Wenn Sie diese besonderen Auswahleinstellungen nicht als Vorgabe speichern möchten, können Sie diese Einstellungen in separate Dateien abspeichern. Benutzen Sie dazu das Kommando Speichere Auswahl in Datei im Menü Datei oder der Werkzeugleiste.

Was passiert beim Ändern der Auswahl

Wenn Sie manuell Änderungen der Einstellungen in den Auswahl-Registern vornehmen, werden diese neuen Einstellungen sofort benutzt, wenn Sie Speichere aktuelle Konfiguration auswählen. Beim Verlassen der Ashampoo UnInstaller Suite erfolgt die Aufforderung zum Speichern der neuen Einstellungen aus neue Standardauswahl. Sollten Sie die Abfrage bestätigen, werden die neuen Einstellungen automatisch beim nächsten Programmstart geladen. Es ist wichtig, diese Abfrage zu bestätigen, wenn Sie gerade das Kommando Speichere aktuelle Konfiguration durchgeführt haben. Sie müssen die gleiche Auswahleinstellungen benutzen, wenn Sie das Kommando Vergleiche (Protokoll erstellen) durchführen - der Vergleich wäre sonst nicht korrekt.

Was passiert wenn Sie das Installationsprotokoll vergleichen / speichern wollen?

Wenn Sie ein Installationsprotokoll mit der Funktion Vergleiche (Protokoll erstellen) oder Inkrementelles Vergleichen oder einer anderen Funktion, die automatisch ein Protokoll nach der Installation einer Anwendung generiert, erzeugen, werden die Auswahleinstellungen automatisch mit dem Protokoll gespeichert und geladen, wenn Sie das Protokoll laden. Sie können dadurch prüfen, welche Einträge zum Erzeugen des Protokolls abgesucht wurden und welche nicht.

Neu: Was passiert beim Laden eines Installationsprotokolls

Wenn Sie das Protokoll erneut laden, werden die Einstellungen in den Auswahl-Registern automatisch geändert, um die Einstellungen des Protokolls widerzuspiegeln. Dieser Vorgang entspricht der Arbeitsweise von Ashampoo UnInstaller 2000. Wie aber die durch das Protokoll geladenen Einstellungen behandelt werden, hat sich in zwei wichtigen Bereichen geändert:

1) Das Laden des Protokolls ändert die Einstellungen in den Auswahl-Registern nur temporär. Wenn Sie das Protokoll laden, dass die Einstellungen in den Auswahl-Registern ändert, erfolgt keine Abfrage zum Speichern dieser Einstellungen als neue Vorgabe, wenn Sie das Programm verlassen. Das Programm nimmt an, dass die Auswahleinstellungen des Protokolls nur zu diesem Protokoll gehören und das Sie Ihre Einstellungen behalten möchten, die Sie vor dem Laden des Protokolls hatten. Diese Einstellungen werden automatisch aus der Datei LAST.ECS geladen. Diese Datei enthält die Standardeinstellungen, die bei jedem Programmstart geladen werden.

Sollten Sie die Einstellungen des Protokolls als neue Vorgabe benutzen, müssen Sie die Funktion Speichere Auswahl in Datei im Menü Datei auswählen und die Datei LAST.ECS überschreiben. Diese Datei enthält die Standardeinstellungen, die bei jedem Start der Ashampoo UnInstaller Suite automatischen geladen werden.

2) Wenn Sie Speichere aktuelle Konfiguration nach dem Laden eines Protokolls auswählen, wird das Programm die Auswahleinstellungen des Protokolls nicht zum Speichern der aktuellen Konfiguration verwenden. Auch hier gilt: Das Programm nimmt jetzt an, dass die Auswahleinstellungen des Protokolls nur zu diesem Protokoll gehören und wird automatisch die Standardauswahl benutzen, die vor dem Laden des Protokolls aktiv waren.


Eine Auswahl als Standard speichern

Wenn Sie Änderungen in den Auswahl-Registern vorgenommen haben, erfolgt beim Verlassen des Programms die Abfrage, ob Sie Ihre neuen Einstellungen als Vorgabe speichern wollen. Eine ähnliche Abfrage erscheint, wenn Sie eine Protokolldatei nach Änderungen in den Auswahl-Registern laden, da Ihre aktuellen Auswahl-Einstellungen mit denen der Protokolldatei überschrieben werden.

Sie sollten die Abfrage nur dann bestätigen, wenn Sie diese Einstellungen jedes mal verwenden wollen, wenn Sie mit dem Programm arbeiten. Wenn Sie spezielle Einstellungen vorgenommen haben, die Sie nur gelegentlich nutzen wollen, sollten Sie in der Abfrage auf Abbrechen klicken und die Option Speichere Auswahl in Datei im Menü Datei nutzen. Sie können damit Ihre Einstellungen in eine separate Datei speichern, die Sie bei Bedarf laden können.

Wenn Sie gerade Speichere aktuelle Konfiguration ausgeführt haben

Wenn Sie diese Abfrage gerade nach dem Speichern Ihrer aktuellen Konfiguration erhalten, bedeutet es, dass die gerade von Ihnen erzeugte Konfigurationsdatei mit veränderten Auswahl-Einstellungen generiert wurde, die noch nicht gespeichert sind. Sie müssen diese Einstellungen vor dem Verlassen des Programms speichern, damit Sie die gleichen Einstellungen benutzen können, wenn Sie Vergleiche (Protokoll erstellen) ausführen. Sie erhalten sonst bedeutungslose Ergebnisse. Klicken Sie hier für weitere Hinweise.

· Option 1: Speichern der neuen Auswahl als Vorgabe
Wenn Sie die neue Auswahl immer vom aktuellen Zeitpunkt an benutzen wollen, klicken Sie in der Abfrage einfach auf Ja. Dadurch wird Ihre geänderte Auswahl als neue Vorgabe gespeichert, die dann bei jedem Start der Ashampoo UnInstaller Suite geladen wird.

· Option 2: Speichern der neuen Auswahl in eine Datei
Wenn Sie spezielle Einstellungen vorgenommen haben, die Sie nur gelegentlich nutzen wollen, sollten Sie bei der Abfrage auf Abbrechen klicken. Wählen Sie dann Speichere Auswahl in Datei im Menü Datei und speichern Ihre Einstellungen in eine separate Datei. Wenn Sie dann die Ashampoo UnInstaller Suite nach der Durchführung von Speichere aktuelle Konfiguration verlassen, vergessen Sie bitte nicht, diese Datei mit Lade Auswahl aus Datei erneut zu laden, bevor Sie Vergleiche (Protokoll erstellen) ausführen. Sie werden ansonsten nicht die gleiche Auswahl für die Vergleichsoperation benutzen! Klicken Sie hier für weitere Hinweise.

Für weitere Informationen lesen Sie bitte auch die Hinweise in folgenden Abschnitten: Auswahl, Eine Auswahl speichern, Was Sie nicht auswählen sollten, Arbeiten mit Auswahldateien und Dateitypen.


Was Sie nicht auswählen sollten
Registry-Schlüssel, die vermieden werden sollten:

HKEY_CURRENT_USER

Es ist keine besonders gute Idee, HKEY_CURRENT_USER zur gleichen Zeit wie HKEY_USERS zu überwachen. Es sei denn, Sie haben einen besonderen Grund dazu. Wenn Programme die Registry im Abschnitt HKEY_CURRENT_USER ändern, werden die gleichen Änderungen automatisch unter HKEY_USERS\'Aktiver Benutzer' vorgenommen. Wenn die Ashampoo UnInstaller Suite versucht, beide Veränderungen wiederherzustellen - was geschieht, wenn Sie beide Abschnitte überwachen - können unerwartete Effekte aufgrund der gegenseitigen Interaktion zwischen beiden Abschnitten auftreten.

HKEY_Classes_Root

Das Gleiche gilt für den Abschnitt HKEY_Classes_Root - dieser Hauptschlüssel muss und sollte nicht separat überwacht werden, da es sich um eine Untergruppe von HKEY_Local_Machine handelt.

HKEY_LOCAL_MACHINE\System\ControlSet00x

Die Standard-Einstellungen schließen automatisch die Zweige HKEY_LOCAL_MACHINE\System\ControlSet00x in der Registry aus. Diese Zweige sind Kopien von ...\CurrentControlSet, die manchmal erzeugt und umbenannt werden, wenn Windows neubootet. (Bei Windows NT handelt es sich um die "Letzte als funktionierend bekannte Konfiguration").

Die Überwachung dieser Zweige bringt wirklich keinen Nutzen und das Auswählen dieser Zweige wird nicht empfohlen. Wenn Sie es trotzdem tun oder diese Zweige mit der Ashampoo UnInstaller Suite oder einem Registry-Editor bearbeiten oder löschen wird ihr System mit Sicherheit abstürzen.

Ashampoo UnInstaller Suite meldet normalerweise keine Veränderungen in diesem Zweigen. Dadurch ist es dem Programm möglich, ohne Systemabstürze während Installationsroutinen ohne Probleme zu behandeln, da diese Einträge in der Regel von Windows erst nach dem Absturz geschrieben werden. Wenn Sie diese Schlüssel überwachen müssen, ist es besser, stattdessen HKEY_LOCAL_MACHINE\ System\CurrentControlSet auszuwählen (Das ist auch in der Standard-Auswahl eingeschlossen).

Dateien und Ordner, die vermieden werden sollten:

· Dateien:

Es gibt eine Reihe von Dateien, die Sie nie überwachen sollten, da deren Wiederherstellung entweder sinnlos oder gefährlich ist. Das schließt die Dateien der Windows Registry, die Swap-Datei und andere Systemdateien ein. Zum Beispiel wäre die Überwachung von Dateien der Windows Registry sinnlos, da alle einzelne Komponenten ja bereits in Registry-Auswahl enthalten sind. Das Wiederherstellen der gesamten Registry-Dateien als ein Block würde Ihr System schwer beeinträchtigen (Siehe Das Feature Backup benutzen für weitere Hinweise zu diesem Thema). Das Überwachen der Swapdatei (Auslagerungsdatei) ist sinnlos, da sie keine brauchbaren Daten enthält und bei jeder Arbeitssitzung von Windows wieder neu erzeugt wird.

Alle relevanten Dateien für jede Windows-Version werden automatisch in den Abschnitt Diese Dateien nicht prüfen: des Unterregisters Optionen in Auswahl: Registry & Laufwerke aufgenommen. Bitte löschen Sie keine dieser Standardausschlüsse, bevor Sie nicht absolut sicher sind, was Sie tun! Die Einstellungen sind unverzichtbar für das einwandfreie Arbeiten der Ashampoo UnInstaller Suite und Sie können unvorhersehbare oder ernsthafte Fehler erhalten, wenn Sie diese Einstellungen löschen.

· Ordner:

Wenn Sie einen Blick auf die Standardeinstellungen im Unterregister Laufwerke (Wählen Sie Zurücksetzen der Auswahl im Menü Datei, falls Sie irgendwelche Änderungen vorgenommen haben) werfen, werden Sie feststellen, dass einige Ordner abgewählt sind. Als einfache Grundregel gilt: Sie sollten keine der Ordner auswählen, die in der Standardeinstellung abgewählt wurden, wenn Sie nicht absolut sicher sind, was Sie tun! Das ist besonders wichtig in allen Windows-Verzeichnissen auf Ihrem System.

Einige der abgewählten Ordner sind harmlos, wie die Ordner für Cookies und temporäre Internetdateien oder die Ordner für den Papierkorb. Andere Ordner können schwerwiegende Zerstörungen nach sich ziehen, wenn sie gelöscht werden. Zum Beispiel enthält der Ordner C:\WINNT\SYSTEM32\CONFIG unter Windows NT4, 2000 und XP spezielle Registry-Dateien. Das Löschen dieses Ordners kann zu den schwerwiegenden Konsequenzen führen, wie sie im Abschnitt Das Feature Backup benutzen beschrieben sind.


Das Register Auswahl: Registry & Laufwerke
Die Unterregister der Auswahl-Register ermöglichen Ihnen die genaue Definition dessen, was durch die Ashampoo UnInstaller Suite auf Ihrem System überwacht und wiederhergestellt werden soll.
Die Durchführung detaillierter Änderungen an dieser Stelle setzen gute Kenntnisse über Windows und der Windows Registry voraus! Wenn Sie unsicher sind, sollten Sie keine Änderungen vornehmen. Und selbst wenn Sie wissen, was Sie tun, lesen Sie bitte den gesamten Abschnitt Auswahl sehr sorgfältig, bevor Sie beginnen!

Ausnahme:
Sie können ganz sicher ganze Laufwerke abwählen, die Sie nicht überwachen wollen - mit Ausnahme des Laufwerke, auf dem Windows installiert ist. Sie sollten eine solche Abwahl jedoch nur treffen, wenn Sie absolut sicher sind, dass auf diesem Laufwerk keine wichtigen Bestandteile oder gar eine Anwendung selbst installiert werden. Zum Beispiel ist es in der Regel sicher und ratsam die Laufwerke abzuwählen, auf die Sie nur persönliche Daten (Texte, Videos, Grafiken etc.) speichern. Das Absuchen des Systems durch die Ashampoo UnInstaller Suite wird erheblich beschleunigt und Ihre Daten sind gegen versehentliches Löschen geschützt.

Tipp und Warnung:

Bevor Sie zum ersten Mal im Inhalt der Auswahl-Register "stöbern", wählen Sie die Funktion Zurücksetzen der Auswahl im Menü Datei, um die Auswahl auf die Standardeinstellungen des Programms zurückzusetzen. Dadurch wird alles relevante eingeschlossen und wiederum alles ausgeschlossen, was beim Überwachen nutzlos oder gefährlich ist. Die Standardeinstellungen sind ein guter Ausgangspunkt. Das Betrachten dieser Auswahl hilft Ihnen, die Arbeitsweise der Ashampoo UnInstaller Suite zu verstehen.

Widmen Sie besondere Aufmerksamkeit den Einträgen, die in den Standardeinstellungen nicht ausgewählt sind! Bitte wählen Sie diese Einträge nicht aus, bevor Sie wirklich verstanden haben, was Sie damit bewirken - Sie können ansonsten unvorhersehbare und möglicherweise negative Ergebnisse erhalten! Siehe den Abschnitt Was Sie nicht auswählen sollten für nähere Hinweise zu diesem Aspekt.

Das Register Registry:

· Die Ansicht links zeigt die Registry, das Fenster rechts zeigt die Werte des ausgewählten Schlüssels an.

· Sie können die Äste in der Ansicht durch einen Doppelklick oder durch das Klicken auf das [image] Symbol öffnen. Halten Sie die Ctrl gedrückt und klicken Sie auf [image], um den gesamten Ast und die darunter liegende Verästelung zu öffnen.

· Wählen Sie Äste durch Klicken in die Checkbox aus. Dadurch werden immer alle weiteren Unterverzeichnisse aus- oder abgewählt.

· Die Checkboxen von Ästen, die sowohl ausgewählte als auch nicht gewählte Elemente beinhalten, werden schattiert angezeigt.

Seien Sie besonders vorsichtig, wenn Sie wieder ganze Äste auswählen, die Sie bereits ausgewählt hatten. Es können Einträge ausgewählt werden, die normalerweise in den Standardeinstellungen ausgeschlossen sind.

· Mit einem Rechtsklick greifen Sie auf den integrierten Registry-Editor zu. Ein Doppelklick auf Werte öffnet den Registry-Editor ebenfalls.

Das Register Laufwerke:

· Die Ansicht links zeigt die Laufwerke, das Fenster rechts listet die Dateien im ausgewählten Ordern auf.

· Sie können die Äste in der Ansicht durch einen Doppelklick oder durch das Klicken auf das [image] Symbol öffnen. Halten Sie die Ctrl gedrückt und klicken Sie auf [image], um den gesamten Ast und die darunter liegende Verästelung zu öffnen.

· Wählen Sie Äste durch Klicken in die Checkbox aus. Dadurch werden immer alle weiteren Unterverzeichnisse aus- oder abgewählt.

· Die Checkboxen von Ästen, die sowohl ausgewählte als auch nicht gewählte Elemente beinhalten, werden schattiert angezeigt.

Seien Sie besonders vorsichtig, wenn Sie wieder ganze Äste auswählen, die Sie bereits ausgewählt hatten. Es können Einträge ausgewählt werden, die normalerweise in den Standardeinstellungen ausgeschlossen sind. Im Easy-Modus führt das Auswählen ganzer Laufwerke automatisch dazu, dass alle Einträge ausgeschlossen werden, die in den normalen Standardeinstellungen auch ausgeschlossen sind.

· Nach einem Doppelklick auf die Dateien im rechten Fenster öffnet sich ein PopUp Menü, im dem Sie die Dateien der Liste der Ausschlüsse im Register Ausgeschlossene Dateien hinzufügen können.

· Aus verständlichen Gründen macht es wenig Sinn, Elemente auf verbundenen Laufwerken oder Laufwerken mit Wechselmedien, wie z.B. CD-ROMs oder Floppy-Laufwerke, auszuwählen!

Das Register Systemdateien:

Die Ashampoo UnInstaller Suite kann zwei verschiedene Dateitypen bei Systemdateien überwachen, Textdateien und INI Dateien. Sie können zusätzliche Systemdateien hinzufügen, die Sie vom Programm überwachen lassen wollen. Für weitere Hinweise siehe Benutzerdefinierte Systemdateien.

· Die Ansicht links zeigt Ihnen die Systemdateien, das Fenster rechts den Inhalt der ausgewählten Systemdateien an.

· Wählen Sie die zu überwachenden Dateien durch Klicken in die jeweilige Checkbox aus.

· Textdateien können nur aus- oder abgewählt werden. Sie können keine einzelnen Zeilen in den Textdateien auswählen.

· Sie können einzelne Abschnitte in INI Dateien auswählen oder ausschließen.

· Zusätzlich zur Überwachung einzelner Abschnitt von INI Dateien ist die Ashampoo UnInstaller Suite in der Lage, Änderungen in den gewählten Abschnitten zu protokollieren und wiederherzustellen. Dies geschieht in der gleichen Weise wie beim Protokollieren und Wiederherstellen der Änderungen in der Registry.

· Änderungen in Textdateien wie AUTOEXEC.BAT und CONFIG.SYS werden protokolliert, können aber durch das Programm nicht wiederhergestellt werden, es sei denn, Sie nutzen das Feature Backup erstellen.

Ausgeschlossene Dateien:

Dieses Register verfügt über zwei Abschnitte: Dem Fenster Ausgeschlossene Dateien auf der linken Seite und der Erläuterung der Icons, die in den Registern der Installationsprotokolle verwendet werden, auf der rechten Seite. Bitte entfernen Sie niemals standardmäßig ausgeschlossene Dateien! Das kann zu schwer wiegenden negativen Konsequenzen führen! (Siehe Was Sie nicht auswählen sollten für weitere Hinweise.) Wenn Sie glauben, dass Sie aus Versehen einen Datei-Ausschluss gelöscht haben, wählen Sie einfach die Option Zurücksetzen der Auswahl im Menü Datei, um die Standardeinstellungen wiederherzustellen.

· Um eine Datei hinzuzufügen, die vom Suchvorgang der Ashampoo UnInstaller Suite ausgeschlossen werden soll, klicken Sie einfach auf den Schalter Hinzufügen und wählen die Datei im folgenden Dialog aus. (Sie können der Liste auch Dateien hinzufügen, im dem Sie im Register Laufwerke mit der rechten Maustaste auf die Dateien klicken.)

· Sie können Datei-Ausschlüsse auch Löschen, in dem Sie den Eintrag auswählen und auf den Schalter Löschen klicken. Bitte nur für Ihre eigenen Einträge benutzen. Löschen Sie bitte keine vom Programm eingetragenen Einträge!


Das Register Installationsprotokolle
Die Unterregister unter dem Register Installationsprotokolle bieten Ihnen den direkten Zugriff auf alle Installationsprotokolle und ermöglichen Ihnen die Ansicht, deren Inhalte sowie deren Wiederherstellung. Siehe den Abschnitt Manuelle Wiederherstellung von Änderungen für weitere Hinweise zu diesem Thema.

Zur Anzeige der Register klicken Sie bitte auf das Register Installationsprotokoll im Fenster des Hauptprogramms:

Das Register Protokolldatei laden:

In diesem Register sind alle mit diesem Programm erzeugten und gespeicherten Installationsprotokolle gelistet - vorausgesetzt die Dateien sind im Standardverzeichnis gespeichert worden. (Wenn Sie die Dateien in einem anderen Verzeichnis gespeichert haben, müssen Sie die Funktion Lade Auswahl aus Datei im Menü Datei wählen.)

Um ein Protokoll zu laden, wählen Sie bitte die Datei aus und klicken dann auf Protokolldatei laden. Die Funktion Anwendung deinstallieren bietet den schnellen Zugriff auf den Deinstallations-Assistenten für die ausgewählte Protokolldatei.

Die Register Änderungen:

Diese drei Register listen alle Änderungen an Ihrem System auf, die im ausgewählten aktuellen Installationsprotokoll dokumentiert sind. Sie haben den Zugriff auf mächtige Funktionen, um diese Änderungen im einzelnen wiederherzustellen oder umzukehren. Siehe den Abschnitt Manuelle Wiederherstellung von Änderungen für detaillierte Hinweise.

Die Register sind leer, wenn kein Protokoll geladen wurden. Wenn Sie einen Vergleich durchführen, wird das daraus resultierende Protokoll automatisch geladen. Sie können alternativ auch von Hand ein Protokoll laden: Wählen Sie dazu Lade Auswahl aus Datei im Menü Datei oder das Register Protokolldateien.


Gemeinsam benutzte Dateien
Viele Windows-Programme benutzen gemeinsame Dateien. Es handelt sich um binäre Dateien mit der Dateierweiterung .dll (Dynamic Link Library). Sie werden zum Speichern von Programm-Codes von Funktionen verwendet, auf die von anderen Programmen zugegriffen werden kann.

Gemeinsam genutzte DLLs sind Programmbibliotheken mit Funktionen, die von mehr als einem Programm benutzt werden. Es gibt eine Vielzahl von Standard-Bibliotheken, die von vielen Windows-Programmen benutzt werden, einschließlich Programme von verschiedenen Herstellern. Einige sind aktuelle Windows-DLLs, die von Microsoft produziert wurden. Andere DLLs sind Funktionsbibliotheken, die von Herstellern von Programmiersprachen hergestellt wurden. Sie werden zur Entwicklung von Windows-Anwendungen verwendet.

Aber egal aus welcher Quelle die DLLs stammen - viele Programme installieren aktuelle Versionen auf die Festplatte. Windows versucht, den "Überblick" über die Programme, welche diese DLLs benutzen, mit einem Zähler zu bewahren. Aber leider funktioniert der Zählmechanismus nicht einwandfrei.

Ein Beispiel, wie gemeinsam benutzte Dateien von Windows behandelt werden:

Im folgenden ein Praxisbeispiel und dessen Bedeutung für das Installieren und Entfernen von Anwendungen:

· Anwendung A benutzt eine allgemeine Datei für eine Klangfunktion mit dem Namen DSound.dll, die von der Anwendung beim Installieren auf Ihre Festplatte in das Windows-Verzeichnis kopiert wird.

· So weit, so gut! Ein Programm und eine DLL. Wenn Sie das Programm und die Datei DSound.dll entfernen, werden keine Probleme auftauchen, da nur die Anwendung A diese DLL benutzt hat.

· Jetzt installieren Sie eine Anwendung B, die ebenfalls die Datei DSound.dll verwendet. Die Installationsroutine von Anwendung B sucht das Windows-Verzeichnis ab und entdeckt die bereits vorhandene Datei. Wird anhand eines Prüfvorgangs (Leider nicht immer der Fall) festgestellt, dass es sich bei der Datei um die aktuellste Version handelt, überspringt die Installationsroutine diese Datei, da sie ja bereits vorhanden ist.

· Das ist in Ordnung. Aber jetzt haben Sie zwei Anwendungen, die eine DLL benutzen. Was passiert, wenn Sie eine der Anwendungen deinstallieren? Die DLL ist als "Bestandteil" von beiden Programmen registriert. Richtigerweise müsste diese Datei gelöscht werden, wenn Sie eines der Programme entfernen. Leider würde dann das andere Programme nicht mehr funktionieren, da die benötigte DLL nicht mehr vorhanden ist.

· Windows bewältigt das Problem mit Hilfe eines Registry-Eintrags für jede DLL mit einem Zähler, der die Anzahl der Anwendungen, die auf diese DLL zugreifen, erfasst. Jedes mal, wenn eine neue Anwendung auf diese DLL zugreift, wird der Zähler um "1" erhöht. Wird eine der Anwendungen entfernt, sinkt der Zählerstand (hoffentlich) wieder um "1". Erreicht der Zähler den Stand "Null" benutzt keine einzige Anwendung diese DLL mehr und die Datei kann auf jeden Fall sicher gelöscht werden. In einer perfekten Welt könnte dieser Mechanismus perfekt funktionieren. Aber leider ist das nicht der Fall.

Wie die Ashampoo UnInstaller Suite gemeinsam benutzte Dateien behandelt:

Hinweis: Diese Erläuterungen gelten nur für das Arbeiten im Experten-Modus. Im Easy-Modus werden die Zähler ebenfalls verwaltet, aber gemeinsam benutzte DLLs werden nicht gelöscht, wenn Sie Programme entfernen. Damit soll sichergestellt werden, dass Sie nichts löschen, was noch benötigt werden kann.

Wenn Sie Ihre Windows-Registry mit den bei der Installation von Anwendungen erzeugten Protokollen wiederherstellen, wird der Zähler der gemeinsam benutzen DLL nicht einfach auf den vorherigen Wert gesetzt. Sie könnten ja in der Zwischenzeit weitere Anwendungen installiert haben, die ebenfalls diese DLL benutzen. Stattdessen wird der Zähler um den gleichen Wert erniedrigt, wie der Zähler durch die Installation einer Anwendung erhöht wurde. Wird dadurch der Zähler auf Null gesetzt, öffnet sich ein Dialog mit der Abfrage, ob Sie die Datei löschen wollen.

Sie können unter Einstellungen bestimmen, wie die Ashampoo UnInstaller Suite gemeinsam benutzte DLLs behandelt.

Wenn Sie versuchen, einen Datei zu löschen (Mit "Änderungen wiederherstellen", unter Verwendung einer .ECL Protokolldatei) deren Zähler von der gleichen .ECL Protokolldatei erhöht wurde, erscheint ebenfalls ein Dialog.

Sie erhalten keine Warnung, wenn der Zugriffszähler bereits erniedrigt wurde. Dann ist die Datei automatisch übersprungen worden (d.h. nicht gelöscht) und eine Meldung erscheint im Protokoll-Fenster, wenn der Vorgang beendet ist.

Zusammenfassung:

Das Arbeiten mit gemeinsam genutzten DLLs ist etwas kompliziert, aber die Ashampoo UnInstaller Suite nimmt Ihnen schon die meiste Arbeit ab. Die Standardeinstellungen sind sicher. Sie garantieren, dass vom System benötigte DLLs nicht gelöscht werden.

Warnung:

Bitte versuchen Sie niemals, die programmeigene Deinstallationsroutine (Siehe Was ist mit programmeigenen UnInstallern?) und die Ashampoo UnInstaller Suite zusammen zu benutzen! Sollten Sie es dennoch versuchen, wird der Zähler der gemeinsam genutzten DLLs durch beide Vorgänge erniedrigt. Das führt zu falschen Werten beim Zähler und kann zum Löschen einer DLL führen, die vom System aber noch gebraucht wird!

Zusätzlicher Hinweis:

Wie bereits erwähnt funktioniert der Zählmechanismus für DLLs in der Praxis nicht immer einwandfrei. Es existieren zwei grundsätzliche Probleme: Einige Installationsroutinen "kümmern" sich nicht um eine Erhöhung des Zählerstands, andere Installationsroutinen erhöhen den Zählerstand immer wieder und wieder, wenn Sie das Programm mehr als einmal installieren. Sie können sich vorstellen, dass daraus bedeutungslose Zählerstände resultieren können.

Sollten Zweifel bestehen, ist es immer sicherer, die DLL zu behalten statt sie zu löschen. Sie verursachen keine Störungen und Speicherplatz ist heutzutage wirklich keine Kostenfrage mehr!


Die Windows Registry
Die Registrierdatenbank (englisch: Registry) ist das Herzstück von Windows.
Es ist die Datenbank, in der alle Informationen gespeichert sind, die Ihr Windows zum korrekten Betrieb benötigt. Dies sind Informationen über installierte Hardware, Software, System-Komponenten, Treiber, Einstellungen, Benutzer-Profile und vieles mehr.

Anwendungsprogramme und die Registry:

Nahezu alle Windows-Anwendungen legen auch Ihre Einstellungen in der Registrierdatenbank ab. Ausnahme sind hier nur alte Windows 3.X Anwendungen die Sie aber ohnehin nicht mehr nutzen sollten.

Diese Programme (und einige andere) speichern ihre Einstellungen in zwei Systemdateien mit den Namen win.ini und system.ini, die aus Gründen der Kompatibilität auch von späteren Windows-Versionen unterstützt werden. (Diese Dateien finden Sie im Unterregister Änderungen in den Systemdateien im Register Installationsprotokolle, wenn sich das Programm im Experten-Modus befindet.)

Datenmüll in der Registry nach dem Entfernen von Programmen

Zusätzlich zu ihren automatischen Installations-Routinen speichern die meisten Anwendungen Informationen in der Registry, die es Ihnen ermöglichen, das Programm später von Ihrem Rechner zu entfernen. Entweder über die Systemsteuerung und der Funktion Software Installieren/Deinstallieren oder mit einem Uninstaller, der mit dem Programm gleich mitgeliefert wurde.

Leider hinterlassen beide Methoden eine unglaubliche Anzahl an veralteten Einträgen und Referenzen in der Windows Registry. Genauso schlecht ist die Methode, das Programm einfach, ohne den Uninstaller zu verwenden, zu löschen oder die dazugehörigen Dateien und Ordner zu verschieben. Sie erreichen das Gegenteil: Es bleiben noch mehr verwaiste Einträge in der Registry zurück.

Konsequenzen einer wachsenden Registry:

Ihre Registry wächst kontinuierlich mit der Zahl der redundanten und verwaisten Einträge und Ihr Betriebssystem wird langsamer und langsamer, da sich Windows durch eine immer größere Datenbank durcharbeiten muss - was erhöhte Rechnerleistung und einen größeren Zeitbedarf bedeutet. Da auch einfache Aktionen wie Tastendrücke und Klicken mit der Maus eine erstaunliche Anzahl von Zugriffe auf die Registry erzeugen können, kann dies eine nicht zu vernachlässigende Rechnerlast mit sich bringen.

Darüber hinaus wird die Registry immer in den Arbeitsspeicher Ihres Computers geladen. Eine aufgeblähte Registry frisst mehr und mehr an Speicherplatz, der für andere Anwendungen sinnvoller zu nutzen ist.


Versionsinformationen
Ashampoo UnInstaller Suite kann die Versionsinformationen von Dateien zusammen mit dem Namen, der Größe und dem Datum speichern. Dadurch kann geprüft werden, welche Version einer DLL, EXE oder anderen Datei mit einer Anwendung installiert werden. Die Informationen über die Version sind in der Regel genauer und nützlicher als die Dateigröße und das Datum.

Der Nachteil der Funktion besteht darin, dass das Speichern der Versionsinformationen den Vorgang beim Speichern der Konfiguration verlangsamt. Die Funktion ist daher zunächst standardmäßig deaktiviert. Sie können die Funktion in den Einstellungen aktivieren und ebenso bestimmen, von welchen Dateien die Versionsinformationen gespeichert werden sollen.

Die Versions-Informationen werden in der Spalte Version im Fenster des Unterregisters Veränderte Dateistruktur des Registers Betrachten des Installationsprotokoll angezeigt.(Nur im Experten-Modus verfügbar.) Wenn keine Versionsinformation für die Datei gespeichert wurde, erscheint der Eintrag Ver. 0.0.0.0 in der entsprechenden Spalte.

Tipp:

Solange sich Dateien auf ihrer Festplatte befinden, können Sie sich die Versions-Informationen auch durch einen Rechtsklick auf den Dateinamen im Windows Explorer anzeigen lassen, in dem Sie aus dem PopUp-Menü die Option Eigenschaften auswählen.


Was ist mit programmeigenen UnInstallern?
Die meisten modernen Anwendungen verfügen über eine Deinstallationsroutine, die gewöhnlich über die Windows-Funktion Programme hinzufügen/entfernen unter dem Eintrag Software in der Systemsteuerung aufgerufen kann.
Oder das Programm verfügt über eine Option zur Deinstallation in der eigenen Programmgruppe im Startmenü.

Sie mögen nun denken, dass wenn alle Stricke reißen, diese Routinen die besten Ergebnisse bei der Installation erzielen werden. Die Programmier der Anwendungen sollten besser als jeder andere wissen, wo alle Komponenten ihrer Anwendungen gespeichert sind.

Leider stimmt das nicht!

In 90% aller Fälle ist das Script zur Deinstallation, welches von den Routinen benutzt wird, automatisch während des Installationsvorgangs durch Installationsprogramm generiert. Das Problem bei diesem Denkansatz besteht darin, dass viele Einstellungen nicht durch die Installationsroutine, wohl aber von der Anwendung selbst erzeugt werden. Keine dieser Änderungen kann von der Deinstallationsroutine registriert werden und diese Tatsache führt dazu, dass viel unnötiger Müll auf Ihrem Rechner verbleibt, wenn Sie diese Routinen zum Entfernen der Anwendung verwenden.

Die Ashampoo UnInstaller Suite registriert alle Änderungen, einschließlich derer, die von der Anwendung selbst verursacht werden. Das Programm verfügt damit über eine weitaus bessere Leistung beim Entfernen als automatisierte Deinstaller.

Deshalb empfehlen wir Ihnen, dass Sie jede neue Anwendung mindesten einmal starten sollten, bevor Sie ein Installationsprotokoll mit der Ashampoo UnInstaller Suite erzeugen! Siehe Warum Anwendungen vor dem Protokollieren starten? für weitere Hinweise.

Lesen Sie bitte auch die Hinweise im Abschnitt Andere UnInstaller testen zum Testen der Leistungsfähigkeit der Ashampoo UnInstaller Suite im Vergleich mit den Installationsroutinen anderer Anwendungen.


Warum Anwendungen vor dem Protokoll starten?
Hinweise für Benutzer des Easy-Modus

Die zahlreichen detaillierten Erläuterungen in diesem Abschnitt richten sich an Benutzer, die manuell im Experten-Modus arbeiten. Wenn Sie nur im Easy-Modus arbeiten, müssen Sie nur folgendes beachten: Es ist wichtig, dass Sie ihre neu installierten Anwendungen einmal starten, bevor Sie ein Installationsprotokoll mit der Ashampoo UnInstaller Suite erzeugen. Alles Weitere wird automatisch vom Programm erledigt.

Warum müssen neue Anwendungen vor dem Erzeugen des Installationsprotokolls gestartet werden?

Durch die ganze Ashampoo UnInstaller Suite hindurch, machen wir Sie darauf aufmerksam, dass Sie eine Anwendung mindestens einmal starten müssen bevor Sie ein Installationsprotokoll erzeugen. Der Grund dafür liegt in der Tatsache begründet, dass viele Programme ihre Konfiguration nicht während der Installation durchführen - viele wichtige Einstellungen und Optionen, besonders die in der Windows Registry gespeicherten, werden oft erst geschrieben, wenn das Programm läuft.

Erst wenn das Programm einmal gestartet wurde, kann die Ashampoo UnInstaller Suite diese Änderungen protokollieren und ist damit in der Lage, das Programm restlos zu entfernen, wenn Sie es wollen. Nach dem Sie das Programm einmal gestartet haben und alle notwendigen Arbeiten an der Konfiguration durchgeführt haben, kehren Sie zur Ashampoo UnInstaller Suite zurück und wählen Vergleiche (Protokoll erstellen), um das Protokoll zu erstellen.

Tipp für den erfahrenen Benutzer

Viele Benutzer bearbeiten die Einstellungen im Windows-Startmenü, die von den Anwendungen erzeugt wurden und verschieben deren Einträge in Unterverzeichnisse, um das Startmenü aufzuräumen. Wenn Sie solche Änderungen vornehmen wollen, vergessen Sie bitte nicht, es vor dem Erzeugen ihres Protokolls zu tun. Da die Ashampoo UnInstaller Suite im Experten-Modus nicht mit dem Installationsprozess verbunden ist, können Änderungen, die Sie selbst vorgenommen haben, in der gleichen Weise wie Änderungen durch ein Installationsprogramm entfernt werden.

Vergessen Sie bitte nicht ein Protokoll zu erzeugen!

Das Spielen mit allen Funktionen eines neuen Programms ist sehr oft faszinierend. Wie auch immer, bitte vergessen Sie nicht, zur Ashampoo UnInstaller Suite zurückzukehren und Vergleiche (Protokoll erstellen) zu wählen, um ein Protokoll nach dem Verlassen des neuen Programmes zu erzeugen. Wenn Sie kein Protokoll erstellen, bevor Sie irgendwelche Änderungen an Ihrem System vornehmen, werden Sie nicht in der Lage sein, das Programm später sauber zu entfernen. Oder Sie entfernen Ihre ganze geleistete Arbeit, die vor dem Protokoll entstand!

Bitte keine neuen Dateien vor dem Protokollieren erzeugen!

Es ist besonders wichtig, dass Sie keine wichtigen neuen Dateien erzeugen oder wichtige Änderungen an Ihrer Systemkonfiguration vornehmen, die Sie bewahren möchten, bevor Sie den Vergleich durchführen. Sollte das trotzdem geschehen, werden diese Dateien mit in das Protokoll aufgenommen und Sie könnten aus Versehen diese Dateien löschen oder Ihre Änderungen zurücknehmen, wenn Sie die Anwendung später deinstallieren.


Menüs und Werkzeuge
Dieser Abschnitt enthält eine kurze Einführung zu den Funktionen in den Menüs der Ashampoo UnInstaller Suite und den Werkzeugen und Icons in der Werkzeugleiste.


Das Menü Datei

Die rot markierten Optionen sind nur im Experten-Modus verfügbar.

Wechsle Modus
Wechselt zwischen Easy-Modus und Experten-Modus.

Lade Auswahl aus Datei
Lädt ein Set an Auswahl-Einstellungen, die Sie vorher in einer Datei gespeichert haben.

Speichere Auswahl in Datei
Speichert alle aktuellen Einstellungen in den Registern unter Auswahl: Registry & Laufwerke. Sie werden zur Eingabe eines Namens für die Datei aufgefordert.

Zurücksetzen der Auswahl
Alle Einstellungen in den Registern unter Auswahl: Registry & Laufwerke werden auf die sicheren Standardvorgaben des Programms zurückgesetzt.

Wiederherstellen der gespeicherten Auswahl
Ersetzt die aktuelle Konfiguration durch eine Backup-Kopie. Bitte benutzen, wenn Sie versehentlich Ihre Konfiguration durch Wählen von Speichere aktuelle Konfiguration statt Vergleiche (Protokoll erstellen) überschrieben haben. Klicken Sie hier für weitere Einzelheiten.

Lade Protokolldatei(Installationsprotokoll)
Lädt das mit der Ashampoo UnInstaller Suite erzeugte Installationsprotokoll. Im Experten-Modus kann der Inhalt der Datei in den Registern unter Installationsprotokolle eingesehen werden.

Einstellungen
Öffnet einen Dialog mit Optionen zur Konfiguration der wesentlichen Einstellungen, die die Arbeitsweise der Ashampoo UnInstaller Suite bestimmen.

Beenden
Beendet die Ashampoo UnInstaller Suite.


Das Menü UnInstaller
Die rot markierten Optionen sind nur im Experten-Modus verfügbar.

Suite Bildschirm
Wechselt zum Hauptbildschirm mit den Icons zur Auswahl der Programm-Module.

Schritt-für-Schritt Assistent
Startet einen speziellen interaktiven Assistenten, der Sie durch die wichtigsten Programmfunktionen führt.

Neue Anwendung installieren
Startet den interaktiven Assistenten, der Sie durch den Vorgang bei der Installation einer neuen Anwendung mit der Ashampoo UnInstaller Suite und beim Speichern eines Installationsprotokolls führt. Es werden unterschiedliche Assistenten gestartet, abhängig davon ob Sie sich gerade im Easy-Modus oder Experten-Modus befinden.

Anwendung deinstallieren
Startet den interaktiven Assistenten, der Sie durch den Vorgang beim Entfernen einer Anwendung führt, die Sie mit der Ashampoo UnInstaller Suite installiert haben. Es werden unterschiedliche Assistenten gestartet, abhängig davon ob Sie sich gerade im Easy-Modus oder Experten-Modus befinden.

Anwendung ohne Protokoll deinstallieren
Startet den interaktiven Assistenten, der Sie durch den Vorgang bei der Deinstallation einer Anwendung führt, für die kein mit der Ashampoo UnInstaller Suite erzeugtes Installationsprotokoll vorliegt. Unterschiedliche Funktionen im Easy-Modus und Experten-Modus.

Alles wiederherstellen
Stellt alles aus der aktuellen Protokolldatei wieder her (bzw. entfernt alles). Ausgegraut, wenn kein Protokoll geladen ist (Wählen Sie Lade Auswahl aus Datei im Menü Datei oder in der Werkzeugleiste, um eine Protokolldatei zu laden).

Speichere aktuelle Konfiguration
Sucht Ihr System ab und speichert eine Aufzeichnung der aktuellen Konfiguration in die vorgegebene "Bevor"-Konfigurationsdatei. Benutzen Sie bitte Speichere Konfiguration unter ..., um die Datei mit einem anderen Namen zu speichern.

Vergleiche (Protokoll erstellen)
Sucht Ihr System ab und speichert eine Aufzeichnung der aktuellen Konfiguration in die vorgegebene "Danach"- Konfigurationsdatei. Es findet ein Vergleich mit der "Bevor"-Konfigurationsdatei statt. Die gefundenen Unterschiede werden in das Installationsprotokoll geschrieben. Bitte benutzen Sie die Funktion Vergleiche zwei Konfigurationen, um Konfigurationsdateien zu vergleichen, die Sie selbst benannt haben.

Inkrementelles Vergleichen
Erlaubt Ihnen verschiedene Arbeitsabläufe bei der Vergleichsoperation. Siehe Inkrementelles Installieren & Vergleichen für weitere Hinweise.

Speichere aktuelle Konfiguration unter ...
Sucht Ihr System ab und speichert eine Aufzeichnung der aktuellen Konfiguration in eine Datei ab, die Sie selbst anstelle der standardmäßigen Konfigurationsdateien benennen.

Vergleiche zwei Konfigurationen
Erlaubt Ihnen das Vergleichen von jeweils zwei Konfigurationsdateien. Das Ergebnis wird in eine Protokolldatei geschrieben.


Das Menü Werkzeuge
Die rot markierten Optionen sind nur im Experten-Modus verfügbar.

Doppelte Dateien suchen und löschen
Startet das Modul zum Auffinden und Löschen von doppelten Dateien auf Ihrem Rechner.

Temporäre Dateien suchen und löschen
Startet das Modul zum Auffinden und Löschen von temporären oder anderen Dateien auf Ihrem Rechner. Sie können Ihre eigene Suchfunktionen generieren.

Schriften verwalten und löschen
Startet das Modul zum Betrachten der auf Ihrem System installierten Schriften. Enthält Funktionen zum Entfernen nicht mehr benötigter Schriften.

Internetbereich aufräumen
Startet das Modul zum Auffinden und Löschen der temporären Internetdateien und weiterer Objekte, die beim Surfen im Internet erzeugt werden.

Leere Ordner suchen und löschen
Startet das Modul zum Auffinden und Löschen von leeren Ordnern auf Ihrem Rechner.

Backup erstellen
Startet die Funktion Backup erstellen, mit der Sie wichtige Dateien sichern können. Sie können die Ashampoo UnInstaller Suite so konfigurieren, dass wichtige Dateien, die durch die Installation einer Anwendung überschrieben wurden, aus diesen Backups heraus wiederhergestellt werden.

Installationsdateien erzeugen
Ermöglicht Ihnen das Erzeugen einer Reihe von REG und INF Dateien, um Installationen von Anwendungen auf mehreren Computern zu vervielfältigen (klonen).

Ansicht aktualisieren
Zeichnet den Bildschirm der Ashampoo UnInstaller Suite neu und aktualisiert den Inhalt der Fenster.


Das Menü Internet
Dieses Menü enthält Optionen zum Zugang zur Ashampoo Internet-Seite, zur Registrierung und zum Kauf des Programmes, wenn Sie eine Shareware-Version benutzen. (Einzelne Punkte innerhalb dieses Menüs variieren geringfügig, abhängig davon welche Version Sie verwenden).

Diese Software jetzt kaufen
Wird nur in der Shareware-Version angezeigt. Verbindet Sie mit der Ashampoo-Webseite, auf der Sie das Programm erwerben können.

Dieses Programm einem Freund empfehlen
Ermöglicht es Ihnen, das Programm automatisch per eMail einem Freund oder natürlich einer Freundin zu empfehlen.

Heutige Angebote ansehen
Verbindet Sie mit der Ashampoo-Webseite und zeigt Ihnen spezielle Angebote und Hinweise auf Produkte und Dienstleistungen, die für Sie von Interesse sein können.

Ashampoo Free Newsletter
Verbindet Sie mit der Ashampoo-Webseite, auf der Sie sich für unseren kostenlosen eMail Newsletter, der Ihnen wöchentlich Informationen zu Ashampoo-Produkten, Updates und Sonderangeboten bietet, eintragen können.

Zur Ashampoo Internet-Seite
Verbindet Sie mit der Ashampoo-Webseite.

Zur Ashampoo Produkt-Seite
Verbindet Sie mit der aktuellen Produktübersicht von Ashampoo im Internet.

Ashampoo Support
Verbindet Sie mit der Support-Seite von Ashampoo im Internet.

Online Update
Verbindet Sie mit der Ashampoo-Webseite, auf der Sie neue Patches und Online-Updates erhalten können.

Programm registrieren
Ermöglicht Ihnen die kostenfreie Online-Registrierung des Programms. Dieser Menüpunkt wird erst nach der Eingabe des Vollversionsschlüssels angezeigt.

Kostenlosen Freischaltcode holen
Wird nur in der unregistrierten Shareware-Version angezeigt. Startet die kostenlose Online-Registrierung, mit der Sie das Programm freischalten können. Sie können danach das Programm in seiner vollen Funktionalität, aber mit zeitlicher Beschränkung nutzen. Sie erhalten den kostenfreien Freischaltcode per eMail.

Freischaltcode eingeben
Wird nur in der Shareware-Version angezeigt. Wählen Sie diese Option zur Eingabe des Freischaltcodes oder des Registrierungsschlüssels, den Sie auf Anforderung per eMail erhalten.


Das Menü Hilfe
Ashampoo UnInstaller Suite Hilfe
Öffnet diese Hilfedatei.

Info
Zeigt Ihnen Informationen zum Programm an.


Die Werkzeugleiste
Wie bei den Menüs hängt auch das Aussehen der Werkzeugleiste davon ab, ob Sie im Easy-Modus oder Experten-Modus arbeiten.

Die Werkzeugleiste im Easy-Modus:

Die Werkzeugleiste im Experten-Modus:

Werkzeuge:

Easy-Modus: Durch Klicken wechseln Sie zum Experten-Modus. | Experten-Modus: Durch Klicken wechseln Sie zum Easy-Modus.
Suite Bildschirm: Aktiviert den Hauptbildschirm. | Schritt-für-Schritt Assistent: Interaktiver Assistent, der Sie durch die wichtigsten Programmfunktionen führt.
Lade Auswahl aus Datei: Lädt Auswahl-Einstellungen zur Überwachung aus einer Datei. | Speichere Auswahl in Datei: Speichert Ihre aktuellen Einstellungen zur Überwachung in eine Datei.
Neue Anwendung installieren: Startet den interaktiven Assistenten zum Installieren und Protokollieren einer neuen Anwendung. | Speichere aktuelle Konfiguration: Sucht Ihren Computer ab und speichert die Aufzeichnung Ihrer aktuellen Konfiguration in einen standardmäßigen "Bevor"-Schnappschuss.
Vergleiche (Protokoll erstellen): Sucht Ihren Computer ab, speichert eine Aufzeichnung der aktuellen Konfiguration in einen standardmäßigen "Danach"-Schnappschuss, vergleicht diesen mit dem "Bevor"-Schnappschuss und schreibt die Ergebnisse in eine Protokolldatei. | Inkrementelles Vergleichen: Erlaubt Ihnen die Durchführung von Vergleichsoperationen. Zum Beispiel der Installation einer Reihe von Anwendungen mit separaten Installationsprotokollen.
Anwendung deinstallieren: Startet den inter-aktiven Assistenten zur Deinstallation einer Anwendung, die mit der Ashampoo UnInstaller Suite protokolliert wurde. | Lade Protokolldatei (Installationsprotokoll): Lädt eine Protokolldatei, die mit der Ashampoo UnInstaller Suite erzeugt wurde, so dass Sie sich deren Inhalt anschauen können und die aufgezeichneten Änderungen wiederherstellen können.
Alles wiederherstellen: Stellt alle Änderungen in der aktuellen Protokolldatei wieder her. Ausgegraut wenn kein Protokoll geladen ist. | Doppelte Dateien suchen und löschen: Startet das Modul zum Aufspüren und Löschen überflüssiger doppelter Dateien auf Ihre Festplatten.
Temporäre Dateien suchen und löschen: Startet das Modul zum Aufspüren und Löschen überflüssiger temporärer und sonstiger Dateien auf Ihren Festplatten. Sie können eigene Suchkriterien erstellen. | Leere Ordner suchen und löschen: Startet das Modul zum Auffinden und Löschen leerer Ordner auf Ihren Festplatten.
Schriften verwalten und löschen: Startet das Modul zum Betrachten der auf Ihrem System installierten Schriften. Enthält Funktionen zum Löschen nicht mehr benötigter Schriften. | Backup erstellen: Startet die Funktion Backup erstellen, mit der Sie wichtige Dateien sichern können. Sie können die Ashampoo UnInstaller Suite so konfigurieren, dass wichtige Dateien, die von Installationsprogrammen überschrieben wurden, mit diesen Sicherungskopien wiederhergestellt werden können.
Internetbereich säubern: Startet das Modul zum Aufspüren und Löschen von temporären Internetdateien und anderen Einträgen, die während des Surfens im Internet erzeugt werden. | Ansicht aktualisieren: Aktualisiert den Bildschirm der Ashampoo UnInstaller Suite und aktualisiert den Inhalt der Fenster.
Einstellungen: Öffnet den Bildschirm mit den Einstellungen. Sie können die wesentlichen Einstellungen, die die Arbeitsweise der Ashampoo UnInstaller Suite bestimmen, hier einstellen. | Hilfe: Öffnet diese Hilfe-Datei. Die kontextsensitive Hilfe können Sie immer durch Drücken der Taste F1 aufrufen.
Beenden: Beendet das Programm. |


Ashampoo Support
Kostenfreier Support für alle Ashampoo Produkte [image] Auch für Trial-Versionen!

Wir von Ashampoo sind der festen Überzeugung, dass ein exzellenter Support wesentlicher Bestandteil eines Produktes ist. Wir sichern den kostenfreien Online-Support für alle unsere Produkte - einschließlich Freeware-, Shareware- und Trial-Versionen.
Sollten Sie irgendwelche Probleme mit oder Fragen zu Ashampoo UnInstaller Suite haben, kontaktieren Sie bitte unser Support-Team unter den unten angeführten Adressen. Sie können unseren Support auch direkt durch Auswahl der entsprechenden Optionen im Menü Internet kontaktieren.

Wie auch immer, bevor Sie diesen Weg gehen, sollten Sie das Hilfe-Systems zu Rate ziehen und diese Hilfe aufmerksam lesen. In vielen Fällen werden Sie die Antworten auf Ihre Fragen bereits finden.

Hinweis: Die Links für die Kontaktaufnahme mit Ashampoo finden Sie auch im Menü Internet.

Ashampoo Kontaktadressen:

Webseite: http://www.ashampoo.de

Supportseite: http://www.ashampoo.de/support

E-Mail Support: E-Mail

Fehlerbericht: E-Mail

Anregungen: E-Mail

Anschrift: ashampoo GmbH & Co. KG
Felix-Wankel-Str. 16
26125 Oldenburg
Germany


Ashampoo Bannerwerbung
Informationen zur Ashampoo Bannerwerbung:

In diesem Abschnitt finden Sie detaillierte Informationen zur Ashampoo Bannerwerbung.

Die Werbebanner werden unten im Programmfenster angezeigt. In der Vollversion werden Sie hier nichts sehen, schließlich haben Sie dafür bezahlt, keine Werbung sehen zu müssen.
In anderen Versionen wird hier Werbung eingeblendet, während die Software läuft.

Warum wird Bannerwerbung eingesetzt?

Wir haben uns entschlossen, in unseren Shareware-Versionen Bannerwerbung einzusetzen, um Ihnen die volle, aber zeitlich eingeschränkte Funktionalität der Produkte anbieten zu können. Und das kostenlos.
Um Ihnen diese Leistung anbieten zu können, sind wir auf die Unterstützung von Werbepartnern angewiesen.
Mit einem Klick auf einen Werbebanner gelangen Sie zum entsprechenden Angebot unserer Werbepartner.
Im Gegensatz zu anderer werbefinanzierter Software passiert bei der Banner-Technologie von Ashampoo folgendes:

· Mit der Installation der Software wird ein "Paket" mit Werbebanner geladen.
· Das Programm geht im Hintergrund nicht online!
· Informationen über Sie oder Ihren Computer werden auf keinen Fall von Ashampoo gesammelt.
· Es wird nur unsere Webseite kontaktiert, um die von Ihnen ausgewählten Banner zu holen.
· Der Aufbau einer Internet-Verbindung findet nur statt, wenn Sie es wollen.
· Sie suchen die Banner aus, die Sie sehen wollen.

Die als "Adware" bzw. Spyware" in Verruf gekommene Banner-Technologie anderer Software-Anbieter wird NICHT eingesetzt. Sie haben jederzeit die volle Kontrolle. Es geschieht nichts ohne Ihre Bestätigung.

Sollten Sie auf Dauer die Bannerwerbung nicht weiter sehen wollen, so müssen Sie die Software käuflich erwerben. Dazu müssen Sie lediglich über einen Internet-Zugang verfügen und die Schaltfläche "Diese Software kaufen" im Menü Internet anklicken.

Wir sind der festen Überzeugung, hiermit allen unseren Kunden eine faire Lösung anbieten zu können.

Ihr Ashampoo Team


automatic backup

 Wichtiger Hinweis:

Bitte vergessen Sie nicht, dass ein automatisches Backup jedes mal ein neues Backup von allen Dateien und Ordnern, die Sie in Ihrer Liste für Backup bestimmt haben, erzeugt, wenn Sie die Option Speichere aktuelle Konfiguration wählen.

Diese Funktion ist zwar integriert, es sprechen jedoch zwei Gründe dagegen, sie beim normalen Gebrauch des Programms zu benutzen:

1) Die aktuellen Versionen der Dateien (zum Beispiel in Ihrem Windows-Systemverzeichnis) können Versionen sein, die von anderen Anwendungen hinein kopiert wurden. Sie möchten ja aber die Originalversionen Ihrer wichtiger Systemdateien behalten.

2) Jedes mal wenn Sie Ihre aktuelle Konfiguration speichern würden, nähme das Erzeugen von Backups aus großen Verzeichnissen sehr viel Zeit in Anspruch.

Empfohlene Strategie:

1) Wählen Sie Backup erstellen (Werkzeugleiste oder im Menü Werkzeuge) und erzeugen ein großes Backup aller wichtigen Systemdateien und der Dateien, die Sie schützen wollen. Aktualisieren Sie dieses Backup, wenn Sie die Dateien aktualisieren - zum Beispiel wenn Sie die Funktion Windows Update von Microsoft benutzen.

2) Bei der Option Backup unter Einstellungen wählen Sie bitte folgende Optionen ab: Dateien sichern im nachfolgenden Verzeichnis: und Gesicherte Dateien beim Wiederherstellen verwenden. Sie verhindern dadurch, dass Ihr Backup überschrieben wird, wenn Sie Ihre aktuelle Konfiguration speichern. Es wird damit sichergestellt, dass alle wichtigen Dateien, die von der protokollierten Anwendung überschrieben wurden, bei der Deinstallation oder Wiederherstellung durch die bekannten "guten" Dateien aus dem Backup ersetzt werden.


.topic 10000

Ashampoo UnInstaller Suite
Für Windows® 95, 98, Me, NT4, 2000 und XP

Copyright © 1999-2003, ashampoo GmbH & Co. KG
Felix-Wankel-Str. 16, 26125 Oldenburg, Germany

Chef-Programmierer: Bernd Klaiber
Hilfe und Dokumentation: Tim Green & Johann Lüppen

Wichtig:
Dieses Programm unterliegt den Bestimmungen der
Lizenzvereinbarung, denen Sie bei der Installation zugestimmt haben.

.topic 20000
Sie wollen gleich starten?

Wenn Sie gleich mit dem Programm arbeiten möchten, lesen Sie die Hinweis im Kapitel Wie die UnInstaller Suite arbeitet und wechseln dann zum Kapitel Das Programm im Easy-Modus benutzen.

Wichtiger Hinweis für Benutzer von Ashampoo UnInstaller 2000

Die Art und Weise, wie die Auswahl gespeichert, geladen und benutzt wird, hat sich in der Ashampoo UnInstaller Suite ein wenig geändert, um das Programm einfacher und intuitiver in der Handhabung gestalten zu können. Sollten Sie bereits mit Ashampoo UnInstaller 2000 gearbeitet haben, lesen Sie bitte die Kapitel Auswahl und Auswahl speichern im Abschnitt Referenzen sorgfältig, bevor Sie das Programm im Experten-Modus benutzen wollen.

Hilfe anfordern

Die Ashampoo UnInstaller Suite verfügt über ein vollständiges kontextsensitives Hilfesystem. Drücken Sie einfach, egal wo Sie sich im Programm befinden, die Taste F1, um das entsprechende Kapitel oder den entsprechende Abschnitt in der Online-Hilfe zu sehen. Wenn Sie wirklich nicht mehr weiter wissen, kontaktieren Sie bitte den Ashampoo Support. Lesen Sie aber bitte zunächst diese Online-Hilfe sorgfältig durch. Sie werden sicherlich für die meisten Fragen die Antworten bereits in dieser Dokumentation finden.

Über die Ashampoo UnInstaller Suite

Windows-Anwendungen sind grundsätzlich schwer von einem Rechner zu entfernen. Sie installieren eigene Bestandteile überall auf Ihrem System und erschweren ein effektives und vollständiges Entfernen. Die Ashampoo UnInstaller Suite ändert das!

Anstelle ein neues Programm direkt zu installieren, starten Sie das Installationsprogramm mit der Ashampoo UnInstaller Suite, die ein Installationsprotokoll mit allen Änderungen, die während der Installation vorgenommen wurden, erzeugt.

Wenn Sie sich dafür entscheiden, das Programm zu entfernen, laden Sie einfach das Protokoll mit der Ashampoo UnInstaller Suite, welches dann alle protokollierten Änderungen rückgängig macht. Hinzugefügte Dateien und Registry-Einträge werden gelöscht und veränderte Einstellungen in den ursprünglichen Zustand zurückgesetzt. Siehe das Kapitel Wie der UnInstaller arbeitet für weitere Einzelheiten.

Easy-Modus und Experten-Modus

Ashampoo UnInstaller Suite ist der richtige UnInstaller sowohl für unerfahrene Benutzer von Windows als auch für Experten. Im erstaunlich einfachen neuen Easy-Modus werden alle schwierigen und kritischen Entscheidungen vom Programm getroffen. Das Überwachen von Programminstallationen und das anschließende Entfernen könnte nicht einfacher sein.

Im Experten-Modus verfügen Sie über alle Features, die bereits den Vorgänger Ashampoo UnInstaller 2000 zu einem der beliebtesten Anwendungen für Experten werden ließ. In diesem Modus können Sie mit dem Programm alle Veränderungen an Ihrem System zwischen zwei Zeitpunkten überwachen und rückgängig machen - das gilt nicht nur für Programminstallationen.

.topic 20010
Wozu braucht man eigentlich einen UnInstaller?

Wie der Name bereits suggeriert, besteht die primäre Funktion der Ashampoo UnInstaller Suite im Entfernen oder der Deinstallation von Anwendungen aus dem Windows-Betriebssystem. Die Frage ist, ob das unbedingt nötig ist. Warum braucht man dazu ein spezielles Programm? Warum kann man nicht eine Anwendungen genauso wie eine Datei einfach mit Löschen entfernen?

Die vollständige Antwort auf diese Fragen würde ein Buch füllen. In wenigen Worten formuliert: Moderne Windows-Anwendungen sind komplizierte "Biester". Sie beinhalten eine große Anzahl von Dateien, die sehr oft an den unterschiedlichsten Orten im System abgespeichert sind - nicht nur im Programmverzeichnis der Anwendungen selbst. Zusätzlich besitzen viele Anwendungen eine ebenso große Anzahl von Einstellungen, die in die zentrale Datenbank von Windows, der Windows Registry geschrieben werden.

Es ist schlimm:
Viele der Programmdateien, die von Anwendungen benutzt werden, werden mit anderen Anwendungen "geteilt". Diese Dateien beinhalten sehr oft universelle Funktionen, die von vielen Windows-Programmen für allgemeine Aufgaben benutzt werden. Obwohl diese Dateien als zu einer Anwendung gehörig gelistet werden, kann das Löschen einer solchen Datei beim Entfernen einer Anwendung das Funktionieren einer anderen Anwendung beeinträchtigen.

Die Einträge in der Windows Registry sind ähnlich problematisch. Neben anderen Dingen, verändern sich die Einträge sehr häufig, weil Programme Werte und Einstellungen während des Arbeitens schreiben und löschen. Und die Einstellungen werden an alle möglichen Orte geschrieben, nicht nur im programmeigenen Abschnitt der Registry.

Man könnte fast schon sagen, dass eine Windows-Anwendung nach der Installation ein Bestandteil von Windows wird. Stellen Sie sich vor, Sie kippen ein halbes Glas Coca Cola in ein halbes Glas mit Orangensaft und versuchen anschließend beide Getränke wieder voneinander zu trennen. Es ist vielleicht nicht ganz so schlimm, aber als Vergleich sehr hilfreich.

Warum die mitgelieferten programmeigenen UnInstaller in der Regel nicht so gut sind

Heutzutage verfügen fast alle Programme über die Möglichkeit, sich selbst zu deinstallieren - zu guter Letzt im Abschnitt Programme hinzufügen / entfernen in der Windows-Systemsteuerung. Das Problem besteht in der minimalen Funktionalität dieser "UnInstaller". Viele von ihnen hinterlassen eine beträchtliche Anzahl von "verwaisten" Registry-Einträgen, Einstellungen und im System verstreuten Dateien zurück - quasi wie Touristen ihren Müll nach einem Picknick im Grünen hinterlassen. (Wenn es Sie interessiert, testen Sie doch die Leistungsfähigkeit anderer UnInstaller mit der Ashampoo UnInstaller Suite im Experten-Modus.)

Warum ist das so? Im Grunde möchte doch kein Programmierer, dass Sie sein Programm entfernen. Das Schreiben eines guten UnInstallers bedeutet viel Arbeit, ohne jedoch die Funktionalität eines Programmes zu erweitern. Viele Programmierer scheuen diese lästige Mehrarbeit. Sie wählen den sicheren Weg und hinterlassen scheinbar alles intakt.
Für weitere Informationen siehe den Abschnitt Was ist mit programmeigenen UnInstallern?

Wie erledigt die Ashampoo UnInstaller Suite ihre Aufgabe?

Die Ashampoo UnInstaller Suite arbeitet quasi mit zwei "Schnappschüssen" von Ihrem System - der erste Schnappschuss entsteht bevor Sie ein Programm installieren, der zweite direkt im Anschluss. Diese beiden Schnappschüsse beschreiben den gegenwärtigen Status ihres Systems, einschließlich aller Registry-Einträge, den Orten, Daten, Größen und Versionen aller Dateien und den Inhalt der Konfigurationsdateien. Die korrekte Erfassung dieser Daten ist sehr komplex, diese Aufgabe wird aber von der Ashampoo UnInstaller Suite mit Bravour erledigt.

Nach dem Erzeugen des zweiten Schnappschusses vergleicht das Programm dieses Abbild mit dem ersten Schnappschuss und schreibt alle Unterschiede in eine besondere Datei, das "Installationsprotokoll".

Wenn Sie über die  Ashampoo UnInstaller Suite eine Anwendung entfernen, wird diese Protokolldatei geladen und anhand der darin gespeicherten Information der Zustand Ihres System vor der Programminstallation wiederhergestellt. Neue Dateien, Verzeichnisse und Registry-Einträge sind gelöscht. Veränderte Registry-Einträge werden ebenfalls wieder auf die Werte zurückgesetzt, die sie vor der Installation des Programmes hatten. Wenn Sie das Feature Backup erstellen benutzen (Nur im Experten-Modus verfügbar!), können Sie sogar Originaldateien wiederherstellen, die bei der Installation der Anwendung überschrieben wurden.

.topic 20020
Windows-Anwendungen einfach und vollständig zu deinstallieren ist nicht das Einzige, was Sie mit der Ashampoo UnInstaller Suite machen können. Dieses mächtige Programm enthält eine ganze Reihe starker integrierter Module mit vielen Funktionen, die es zu einem unverzichtbaren Werkzeug für jeden Windows-Benutzer machen:

Kreative Anwendungen zur Überwachung und zum Vergleich:

Da die  Ashampoo UnInstaller Suite alle Veränderungen in ihrem System zwischen zwei definierten Zeitpunkten vergleichen und wieder zurücksetzen kann, können Sie weitaus aus mehr mit diesen Überwachungs- und Vergleichsfunktionen anfangen, als nur Anwendungen deinstallieren! Zum Beispiel können Sie mit den Funktionen herausfinden, wo Programme ihre Einstellungen speichern - Sie brauchen dazu nur die Änderungen der Dateien und in der Registry vor und nach dem Ablauf des Programmes vergleichen. Oder Sie benutzen die Ashampoo UnInstaller Suite als ein Sicherheitssystem, wenn Sie mit Konfigurations- und Registry-Einstellungen experimentieren. Sie speichern einfach Ihre Konfiguration bevor Sie Änderungen vornehmen, erzeugen eine Protokolldatei nach den vorgenommenen Änderungen und können alle Veränderungen wieder zurücksetzen, falls die neuen Einstellungen nicht funktionieren sollten. Die Möglichkeiten sind endlos! (Diese Funktionalität ist nur im Experten-Modus verfügbar!)

Doppelte Dateien suchen und löschen:

Mit diesem Modul können Sie doppelte Dateien, die wertvollen Speicherplatz vergeuden, identifizieren, finden und löschen. Sie werden erstaunt sein, wie viele Kopien von identischen Dateien sich im Laufe der Zeit in Ihrem System angesammelt haben!

Temporäre Dateien suchen und löschen:

Das Gleiche gilt für temporäre Dateien. Viele Programme erzeugen temporäre Dateien während der Arbeitssitzung, "vergessen" aber, diese anschließend zu löschen. Installationsprogramme erzeugen sehr oft ein ganzes Paket temporärer Dateien während der Installationsroutine und sehr oft bleiben auch diese Dateien einfach übrig und werden nicht wieder entfernt. Im Laufe der Zeit füllt sich Ihre Festplatte mit immer mehr Datenmüll.

Leere Ordner suchen und löschen:

Sehr oft werden Ordner angelegt und nie wieder benutzt - manchmal werden sie von Programmen angelegt, manchmal auch vom Benutzer selbst. Warum auch immer es sie gibt, es gibt keinen Grund, diese Ordner beizubehalten. Mit diesem Modul finden Sie ganz schnell leere Ordner und befreien sich von ihnen.

Schriften verwalten und löschen:

Wie viele Schriften (Schriftarten) brauchen Sie wirklich? Alle auf ihrem System installierten Schriften werden bei jedem Start von Windows geladen. Sie verbrauchen nicht nur Speicherplatz, sondern auch wertvolle Systemressourcen. Dieses nützliche Modul listet alle Schriftarten in einem integrierten Betrachter auf und Sie können so ganz einfach die Schriften löschen, welche Sie nicht mehr benutzen wollen.

Internetbereich säubern:

Wissen Sie, dass Jedermann mit Zugriff auf Ihren Rechner ganz einfach Ihren Spuren der letzten Internet-Sesssions folgen kann? Selbst noch nach mehr als drei Wochen, je nach dem, wie Ihr Rechner konfiguriert ist! Unbefugte sehen alle Seiten, die Sie betrachtet haben und die Namen und Adressen der von Ihnen besuchten Webseiten. Wenn Sie Ihre Privatsphäre schützen wollen, benutzen Sie bitte dieses Modul regelmäßig. Sie können sich alle Cookies, die von besuchten Seiten auf Ihrem Rechner hinterlegt werden, anschauen und löschen.

.topic 20030

Einschränkung:

UIWatcher wird nur dann automatisch aktiv, wenn die standardmäßigen Namen INSTALL.EXE oder SETUP.EXE der Installationsdateien vorhanden sind. Sollte das Installationsprogramm über einen anderen Namen verfügen, sollten Sie die Installation von Hand starten. Klicken Sie bitte mit Rechts auf das UIWatcher Icon in der Taskbar und wählen dann die Option Anwendung installieren.

Wie auch immer, viele Installationsprogramme mit anderem Namen erzeugen und starten ein Programm mit dem Namen INSTALL.EXE oder SETUP.EXE, die dann den UIWatcher auslösen. Wenn Sie sich entscheiden, eine Installation manuell mit der Option Neue Anwendung installieren zu überwachen, sollten Sie zunächst den UIWatcher zwischenzeitlich deaktivieren. Klicken Sie dazu mit der rechten Maustaste auf das UIWatcher Icon in der Taskbar und deaktivieren die Option Installationsüberwachung aktiv.

.topic 20040
Bevor Sie das Programm zu ersten Mal benutzen, wählen Sie bitte Einstellungen im Menü Datei oder in der Werkzeugleiste und prüfen, ob alle Einstellungen wie von Ihnen benötigt gesetzt sind. Die Einstellungen kontrollieren die Arbeitsweise der Ashampoo UnInstaller Suite und ermöglichen Ihnen, das Programm nach Ihren persönlichen Erfordernissen und Wünschen zu konfigurieren. Die Optionen werden unterschiedlich angezeigt, abhängig davon ob Sie das Programm im Easy-Modus oder Experten-Modus benutzen.

Der Easy-Modus für unerfahrene Benutzer von Windows:

Wenn Sie über wenig Erfahrung mit Windows verfügen, prüfen Sie, ob der Easy-Modus aktiviert ist. (Wählen Sie Wechsle Modus und anschließend Wechsle zum Easy-Modus im Menü Datei). Folgen Sie bitte den Anweisungen im Abschnitt Die Konfiguration im Easy-Modus.

Der Experten-Modus für erfahrene Benutzer von Windows:

Sollten Sie bereits ein erfahrener Benutzer von Windows sein und den Einsatz der Ashampoo UnInstaller Suite im Experten-Modus planen, wechseln Sie bitte in den Experten-Modus mit der entsprechenden Option im Menü Datei. Lesen Sie bitte den Abschnitt Die Konfiguration im Easy-Modus für die wesentlichen Einstellungen des Programms und den Abschnitt Die Konfiguration im Experten-Modus für zusätzliche Optionen und Einstellungen, die im Easy-Modus nicht zur Verfügung stehen.

.topic 20050
Bitte prüfen Sie zunächst, ob der Easy-Modus aktiv ist. (Wählen Sie Wechsle Modus und  anschließend Wechsle zum Easy-Modus im Menü Datei).

Wählen Sie dann Einstellungen im Menü Datei oder das Icon Einstellungen in der Werkzeugleiste. Die Einstellungen im Easy-Modus sind in vier Registern organisiert:

#Das Register Allgemein

Pfad zur Autoexec.bat und Config.sys:

Diese sind die Adressen der zwei wesentlichen Startdateien, die überwiegend von Windows 95, 98 und Me Systemen verwendet werden. Bitte tragen Sie hier nichts ein, solange Sie ihr System nicht anders konfiguriert haben und andere, vom Standard abweichende (normalerweise C:\ ) Speicheradressen, angegeben haben. Wenn Sie unsicher sind, tragen Sie bitte nichts ein oder befragen Sie die Person, die auch den Rechner eingerichtet hat.

Vorgabe für Standard-Registry-Einträge:

Dies ist der Text, der bei der Anzeige von Standardschlüsseln in der Windows Registry verwendet wird. Der Standardwert ist (Standard). Bitte ändern Sie nichts daran, wenn kein Grund dafür vorliegt - es ist auch nur für den Experten-Modus von Bedeutung.

leerer Registry-Eintrag:

Dies ist der Text, der bei noch leeren Registry-Einträgen angezeigt wird. Bitte ändern Sie nichts daran, wenn kein Grund dafür vorliegt - es ist auch nur für den Experten-Modus von Bedeutung.

Zeige Registry-Fehlermeldungen:

Manchmal ist es nicht möglich, Teile der Registry korrekt zu lesen, vor allem auf Systemen mit Windows 2000 oder XP. Die Abwahl dieser Option unterdrückt diese Fehlermeldungen. Wenn Sie generell im Easy-Modus arbeiten, sollten Sie diese Optionen abgewählt lassen.

Aktiviere Installationsüberwachung in der Taskbar:

Wenn ausgewählt, startet der UIWatcher jedes mal automatisch, wenn Windows gestartet wird. Sie sollten die Einstellung so belassen. Der UIWatcher wird dann automatisch aktiv, wenn Sie ein neues Programm installieren und Sie daran erinnern, die Installation zu überwachen und zu protokollieren. Sie können die Anwendungen später restlos und sauber entfernen. Der UIWatcher verbraucht kaum Speicherplatz und beeinflusst auch keine anderen Programme auf Ihrem System.

Hinweis: UIWatcher wird nur dann aktiviert bei Installationsprogrammen mit den Namen setup.exe oder install.exe. Wie auch immer, Sie können Programme von Hand  aus dem UIWatcher installieren. Klicken Sie dazu mit Rechts auf das Icon des UIWatcher in der Taskbar und wählen dann Neue Anwendung installieren.

Modus:

Bestimmt, ob die  Ashampoo UnInstaller Suite im Easy-Modus oder Experten-Modus starten soll. Sie können zwischen beiden Modi auch mit dem Icon Wechsle Modus und der Option Wechsle Modus im Menü Datei wechseln.

Das Register Ansicht

Anzeigen der Hilfe-Hinweise:

Aktiviert oder deaktiviert die Hilfe-Hinweise, die automatisch angezeigt werden, wenn Sie die Maus über Bedienungselemente in den Programmfenstern positionieren.

Menüs im XP-Style:

Aktiviert oder deaktiviert Menüs im Windows® XP-Style. Bitte deaktivieren Sie diese Option unter Windows® Me, wenn Sie Probleme mit der grafischen Anzeige von Icons und Menü-Elementen feststellen sollten.

#Das Register Löschen

Mit diesen Optionen bestimmen Sie, wie die Ashampoo UnInstaller Suite gelöschte Dateien behandeln soll, wenn Sie eine Anwendungen deinstallieren.

Optionen beim Löschen:

Sie können auswählen, ob die gelöschten Dateien in den Papierkorb verschoben werden (Standard) oder in einem speziellen Verzeichnis gespeichert werden sollen. Wenn Sie die Option Dateien sichern im nachfolgenden Verzeichnis: wählen, werden die gelöschten Dateien automatisch von der  Ashampoo UnInstaller Suite an die gewählte Adresse verschoben. Wenn Sie grundsätzlich im Easy-Modus arbeiten, wählen Sie bitte die Option verschieben der Dateien in Papierkorb beim Löschen aus. Siehe den Abschnitt Die Konfiguration im Experten-Modus für Details zur Verwendung der Backup-Funktion.

Warnung:
Wenn Sie beide Optionen verschieben der Dateien in Papierkorb beim Löschen und Dateien sichern im nachfolgenden Verzeichnis: abwählen wird die Ashampoo UnInstaller Suite die Dateien einfach löschen - ohne ein Backup im Papierkorb oder einem Backup-Verzeichnis zu erstellen!

gemeinsam benutzte Dateien:

Dieser Abschnitt ist im Easy-Modus abgeschaltet. Siehe Die Konfiguration im Experten-Modus für weitere Hinweise.

Das Register Sprache

Bestimmt die Sprache der Programmoberfläche. Wenn Sie Systemvorgabe wählen, versucht die Ashampoo UnInstaller Suite in die Sprache zu wechseln, in der das Windows-System konfiguriert ist. Das kann misslingen, wenn die Einstellungen Ihres Keyboards (Tastatur) und andere sogenannte lokale Einstellungen nicht mit denen Ihrer Windows-Version übereinstimmen. Sie müssen das Programm mit einer ausgewählten Sprache neu starten, damit die Änderungen wirksam werden.

Hinweis:
     Die Fenstergrößen, die Position der Werkzeugleiste etc. werden automatisch beim Verlassen der Ashampoo UnInstaller Suite gespeichert und erneut geladen, wenn Sie das Programm wieder starten.

.topic 20060
Dieser Abschnitt deckt die Einstellungen ab, die im Easy-Modus entweder nicht verfügbar oder nicht relevant sind. Bitte lesen Sie die Informationen sorgfältig, wenn Sie beabsichtigen, im Experten-Modus zu arbeiten!

Das Register Allgemein:

Pfad zur Autoexec.bat und Config.sys:

Ashampoo UnInstaller Suite benötigt die gültigen Pfade zu den Versionen dieser Dateien, die beim Starten Ihrer Windows-Konfiguration verwendet werden. Wenn Sie Ihr System so eingestellt haben, dass andere Versionen der autoexec.bat und config.sys an anderen Speicheradressen verwendet werden, tragen Sie bitte den entsprechenden Pfad ein. Sonst kann Ashampoo UnInstaller Suite die Änderungen an diesen Dateien nicht korrekt überwachen.

Hinweis: Wenn Sie ein Dual-Boot-System mit einer Windows 9x Version auf ihrer sichtbaren primären Partition (z.B. C:\ ) benutzen und ein NT-basiertes System wie NT4, 2000 oder XP auf einer anderen Partition (z.B. D:\ oder höher), wird das NT-basierte Betriebssystem die Dateien Autoexec.bat und Config.sys auf C:\ beim Starten abarbeiten!

Texte für "Default-Registry-Einträge" und "Leerer Registry-Eintrag":
Diese Texte werden automatisch für Standardschlüssel und leere Werte in der Windows Registry angezeigt. Die Standardwerte sind (Standard) und (leer).

Das Register Löschen:

Lösch-Einstellungen:

Wenn Sie die Option Dateien sichern im nachfolgenden Verzeichnis: auswählen, erzeugt Ashampoo UnInstaller Suite Kopien aller gelöschten Dateien mit ihrem Quellverzeichnis in dem angegebenen Ordner. Dadurch können Sie die Dateien schnell wieder finden und wiederherstellen, wenn sie versehentlich gelöscht wurden. Diese Einstellung ist unbedingt notwendig zur Deinstallation von Anwendungen mit Installationsprotokollen, die von der Ashampoo UnInstaller Suite erzeugt wurden. Darüber hinaus ist diese Einstellung für alle Vergleichs- und Wiederherstellungsfunktionen, die von Hand im Experten-Modus durchgeführt werden, unbedingt erforderlich.

Zum Beispiel können Sie um 9 Uhr 30 im Experten-Modus die Option Speichere aktuelle Konfiguration durchführen, anschließend eine Vielzahl von Aktionen tätigen und um 10 Uhr 30 die Option Vergleiche (Protokoll erstellen) nutzen. Dieses Protokoll enthält alles, was Sie während der 1 1/2 Stunden an Ihrem Rechner zwischen Speichern und Vergleichen getan haben - einschließlich neuer, von Ihnen erzeugter Dokumente etc. Wenn Sie dann das Protokoll von 10 Uhr 30 laden und die Option Alles Wiederherstellen wählen, können Sie leicht Einträge löschen, die Sie behalten möchten. In einem solchen Fall ist es hilfreich, über ein Backup zu verfügen.

Warnung:
Wenn Sie beide Optionen Verschieben der Dateien in Papierkorb beim Löschen und Dateien sichern im nachfolgenden Verzeichnis: abwählen wird die Ashampoo UnInstaller Suite die Dateien einfach löschen - ohne ein Backup im Papierkorb oder einem Backup-Verzeichnis zu erstellen!

Gemeinsam benutzte Dateien:#

Diese Option bestimmt die Arbeitsweise des Programms bei gemeinsam genutzten Dateien. Im Easy-Modus ist aus Sicherheitsgründen diese Option deaktiviert. Im Experten-Modus verfügen Sie über drei Optionen:

Jeweils nachfragen: Wenn Sie diese Option auswählen, werden Sie vom Programm immer gefragt, bevor Sie eine gemeinsam genutzte Datei löschen, selbst wenn der Zähler Null ist. (Siehe gemeinsam benutzte Dateien für weitere Erläuterungen).

Automatisch löschen wenn Zähler Null wird: In diesem Modus wird das Programm automatisch gemeinsam benutzte Dateien ohne Abfrage löschen, wenn der "Zähler" Null erreicht hat. Bitte nur auswählen, wenn Sie dem Zähler von Windows völlig vertrauen oder gelöschte Dateien wenn nötig mit Backups wieder herstellen wollen.

Alle Dateien beibehalten: Diese Option belässt gemeinsam benutzte Dateien immer auf Ihrer Festplatte, selbst wenn der Zähler auf Null gesetzt wurde. Das ist die sicherste Option. Da Speicherplatz kein Kostenfaktor mehr darstellt ist es die  wahrscheinlich beste Möglichkeit. Gemeinsam benutzte Dateien verbrauchen relativ gesehen nicht all zu viel Festplattenplatz. Es ist daher einfacher, sie an ihrem Platz zu belassen, als sie zu löschen.

#Das Register Backup

Dieses Register wird nur im Experten-Modus angezeigt. Es ermöglicht die Konfiguration für die Funktion Backup erstellen, die ebenfalls nur im Experten-Modus verfügbar ist.

Verzeichnisse autom. sichern im nachfolgenden Verzeichnis:

Ist diese Option ausgewählt, werden die in Backup erstellen ausgewählten Dateien jedes mal automatisch gesichert, wenn Sie Speichere aktuelle Konfiguration oder Speichere Konfiguration unter wählen. Sie können einen Ordner angeben, der für diese Backups verwendet werden soll. Wenn Sie Windows® NT, 2000 oder XP verwenden, ist es ratsam, einen komprimierten Order dafür zu verwenden.

Gesicherte Dateien beim Wiederherstellen verwenden:

Ist diese Option ausgewählt, versucht die Ashampoo UnInstaller Suite eine Wiederherstellung mit diesen Dateien, wenn Sie eine Anwendung deinstallieren oder andere Veränderungen an ihrem System mit einem Protokoll wiederherstellen wollen. (Siehe Backup erstellen und die entsprechenden Abschnitte im Kapitel Das Programm im Experten-Modus benutzen für weitere Hinweise zu diesem Thema.)

#Das Register Versionsinformation

Dieses Register wird nur im Experten-Modus angezeigt. Sie können mit dieser Option bestimmen, ob Versionsinformationen für Dateien auf ihrem System mit der Funktion Speichere Konfiguration gespeichert werden sollen. Sie können auch die Dateitypen bestimmen, für die Sie die Funktion nutzen wollen.

Im Allgemeinen macht es nur Sinn, Versionsinformationen für wichtige Systemdateien zu speichern, die von anderen Programmen überschrieben werden könnten.

Besonderer Tipp:
Aktivieren Sie die Option Speichere Versionsinformation und prüfen die Register Installationsprotokolle nach dem Installieren einer Anwendung. Sie können dann sofort sehen, ob wichtige Dateien mit älteren Versionen überschrieben wurden. Wenn Sie diese Funktion in Verbindung mit dem Feature Backup erstellen nutzen, können Sie umgehend Ihre Originaldateien wiederherstellen.

.topic 20070

Betriebssysteme:

Windows® 95, 98, Me, NT4, 2000 oder XP.

Wichtiger Hinweis für Benutzer von Windows® NT4, 2000 & XP:

Ashampoo UnInstaller Suite unterstützt Windows® NT4 (ServicePack 3 oder höher erforderlich), 2000 und XP. Sie können das Programm zur Überwachung von Installationen sowohl als Administrator aber auch als normaler Benutzer ohne Administratorrechte benutzen. In der Regel sind jedoch Administratorrechte zur Programminstallation und für Änderungen am Betriebssystem erforderlich. Das Entfernen von Anwendungen und die Wiederherstellung berührt das Löschen oder die Veränderungen von Registry- und Dateieinträgen, die vom Betriebssystem geschützt sind.

Hardware:

Jeder Computer, der das verwendete Betriebssystem unterstützt. Eine Grafikkarte mit einer Auflösung von 800 x 600 Pixeln und mindestens 256 Farben (Das Programm wird bei weniger Farben nicht so schön aussehen.) sowie ausreichend Speicherplatz für das von Ihnen benutzte Betriebssystem.

Speicherplatz:

Ca. 10MB für die Programmdateien. Zusätzlicher Speicherplatz für die Backups Ihres Betriebssystems, wenn Sie die Funktion Backup erstellen benutzen (Wie viel Platz Sie benötigen hängt von den von Ihnen ausgewählten Ordnern und Dateien ab).

.topic 20080
Ashampoo UnInstaller Suite ist ein mächtiges Werkzeug und wie alle Werkzeuge kann es bei unkorrekter Anwendung zu Problemen führen. Bitte lesen Sie die Dokumentation sorgfältig und beachten Sie alle Warnungen und Hinweise.

Experten-Modus

Bitte seien Sie besonders sorgfältig, wenn Sie das Programm im Experten-Modus benutzen. Dieses Modul wurde für erfahrene Benutzer mit guten Kenntnissen über die Windows-Konfiguration und der Windows Registry entwickelt.
Bevor Sie irgendwelche Operationen im Experten-Modus durchführen, lesen Sie bitte den Abschnitt Das Programm im Experten-Modus benutzen sorgfältig durch.

Autostart-Programme

Sehr oft wird durch Installationsprogramme Windows automatisch heruntergefahren und neu gestartet, um die Installation einer Anwendung abzuschließen. Die manuellen und automatischen Optionen der Ashampoo UnInstaller Suite zur Installationsüberwachung können damit ohne Probleme umgehen - ein Neustart von Windows beeinträchtigt nicht die Überwachung der Installation. Weil das Programm alle Änderungen an Ihrem System, die während der Installation einer Anwendungen stattfinden, überwacht, sollten Sie sich einige Gedanken zu den Programmen machen, die Sie automatisch zusammen mit Windows starten.

Wenn eine Anwendung neue Daten erzeugt, wenn es mit Windows gestartet wird, besteht die Möglichkeit, dass die Ashampoo UnInstaller Suite diese Daten als Teil der Installation aufzeichnet. Diese Daten würden dann beim Entfernen der Anwendung gelöscht werden. Angenommen Sie hätten ein Programm, dass Ihre E-Mails sammelt oder Wetterberichte oder Börsendaten herunter lädt - es ist offensichtlich, dass Sie solche Daten nicht als Teil einer Anwendung protokollieren möchten, welches Sie später vielleicht einmal entfernen möchten.

   Die meisten Autostart-Programme verursachen keine Probleme. Um aber auf der sicheren Seite zu sein, sollten Sie Anwendungen, die automatisch E-Mails anfordern oder automatische neue Daten erzeugen, abschalten, während Sie neue Anwendungen installieren.

Wann Sie das Feature der automatischen Erkennung des UIWatcher nicht nutzen sollten

Die Fähigkeit des UIWatcher, automatisch Installationsprogramme zu erkennen wird für die meisten Installationen sehr gut arbeiten. Das Programm kann aber "verwirrt" sein, wenn Sie ein Installationsprogramm für ein Paket an Anwendungen starten.  Das Problem besteht darin, dass ein solcher Installer zwei, drei oder mehr Installationsprogramme starten. Darüber hinaus starten einige dieser Pakete dann Installationsprogramme mit einer ganzen Serie von unterschiedlichen Namen. Einige davon werden vom UIWatcher erkannt, andere wiederum nicht. Wenn Sie Pech haben, wird das erste Installationsprogramm vom UIWatcher nicht erkannt. Das Installationsprotokoll wird dann nicht die gesamte Anwendung enthalten, weil einige Einträge bereits installiert sind, bevor der UIWatcher aktiviert ist.

Um auf der sicheren Seite zu sein, benutzen Sie die im Abschnitt Installieren mit dem UIWatcher beschrieben Arbeitsweise für:

Anwendungen, die mehr als ein Software-Modul enthalten.

Installationsprogramme, die weder INSTALL.EXE oder SETUP.EXE heißen.

Multi-Boot-Systeme

Wenn Sie ein System mit verschiedenen Instanzen von Windows auf sichtbaren Partitionen benutzen, lesen und beachten Sie bitte die folgenden Sicherheitshinweise. (Diese Hinweise gelten nicht, wenn ein Boot Manager verwendet wird, der aktuell nicht benutzte Systempartitionen physikalisch verbirgt.)

Benutzen Sie den Easy-Modus nie auf Multi-Boot-Systemen mit mehr als einem installierten Windows-System auf der gleichen Partition. Ashampoo UnInstaller Suite wurde dafür nicht entwickelt und Sie können Ihr System schwer beeinträchtigen. (Die Installation von mehr als einem Windows-System auf einer Partition führt von sich aus schon zu vielen Problemen ...). Bei solchen Konfigurationen müssen Sie den Experten-Modus benutzen und alles abwählen, was in Verbindung mit den Windows-Instanzen steht und in den Auswahl-Registern aktuell nicht aufgeführt    sind.

Egal ob Sie den Easy-Modus oder Experten-Modus benutzen, bitte wählen Sie alle Laufwerke der Windows-Betriebssysteme ab, die gegenwärtig nicht arbeiten.

Wir empfehlen Ihnen dringend, mehrere Installationen der Ashampoo UnInstaller Suite in unterschiedlichen Ordner für jede Windows-Instanz durchzuführen. Der Inhalt der Konfigurations- und Installationsprotokolldateien, die unter einem System erstellt wurden, müssen ja nicht mit der aktuellen Struktur der Registry eines anderen Windows-Systems übereinstimmen. Wenn Sie die Ashampoo UnInstaller Suite aus dem gleichen Ordner heraus für mehr als ein System starten und benutzen, erhalten Sie völlig bedeutungslose und (möglicherweise gefährliche) Resultate, wenn Sie die Konfigurationen von zwei verschiedenen Systemen vergleichen wollen.

.topic 20090
Der Zugriff auf das Hilfe-System:

Die Ashampoo UnInstaller Suite verfügt über ein komplett kontextsensitives Hilfe-System. Um sich die Online-Hilfe anzeigen zu lassen, klicken Sie einfach in jedem Bildschirm auf die Schaltfläche Hilfe oder Sie wählen Hilfe im Menü Hilfe, um jederzeit den Zugriff auf die entsprechenden Hinweise und Erläuterungen zur gerade geplanten Aktion  zu haben. Sollten Ihnen die Hinweise nicht weiterhelfen, kontaktieren Sie bitte den Ashampoo Support. Lesen Sie aber bitte zunächst diese Hilfe - es wurden viele Anstrengungen unternommen, diese so umfassend wie möglich zu gestalten. Wir sind sicher, Sie werden auf die Mehrzahl Ihrer Fragen die Antworten bereits in dieser Online-Dokumentation finden!

Links in diesem Hilfe-System:

In dieser Online-Hilfe werden drei verschiedene Arten von Links benutzt, die durch unterschiedliche Farben gekennzeichnet sind:

So finden Sie die benötigten Informationen:

So fangen Sie an:

Dieses Hilfe-System wurde entwickelt, um Ihnen schnell und einfach die benötigten Informationen zu liefern. Wenn Sie das Programm zum ersten Mal benutzen, sollten Sie die Abschnitte im Kapitel Einführung studieren; sie vermitteln Ihnen das Basiswissen zur Arbeitsweise dieses Programms.

Der Inhalt:

Wenn Sie beim Aufruf der Online-Hilfe nicht automatisch das benötigte Kapitel oder den benötigten Abschnitt angezeigt bekommen, müssen Sie zunächst in den Inhalt schauen. Sollte der Inhalt noch nicht angezeigt werden, klicken Sie bitte auf das Register Inhalt im linken Fenster des Hilfe-Fensters. (Klicken Sie auf das Icon Einblenden in der Werkzeugleiste, falls die Register nicht sichtbar sein sollten.)

Das Hilfe-System verfolgt den Ansatz des "Learning by doing". Sie werden zu allen Aktionen, die Sie mit dem Programm durchführen können, die entsprechenden Abschnitte mit den Erläuterungen finden. Zusätzliche Informationen stehen Ihnen in den Abschnitten Referenzen sowie Menüs und Werkzeuge zur Verfügung.

Der Index:

Um sich den Index der Hilfe anzeigen zu lassen, klicken Sie einfach auf das Register Index (Klicken Sie auf das Icon Einblenden in der Werkzeugleiste, falls das Register nicht sichtbar sein sollte.). Sie können dann durch die Liste aller Einträge "scrollen" oder einen Suchbegriff im Feld oben eingeben. Wenn Sie ein passendes Stichwort gefunden haben, klicken Sie bitte doppelt auf den Eintrag, um sich den Abschnitt anzeigen zulassen, auf den das Stichwort verweist.

Suchen:

Falls Sie keinen passenden Begriff oder ein passendes Stichwort gefunden haben, können Sie selbstverständlich eine Volltextsuche durchführen. Klicken Sie einfach auf das Register Suchen im Hilfe-Fenster. (Klicken Sie auf das Icon Einblenden in der Werkzeugleiste, falls das Register nicht sichtbar sein sollte.) Bitte geben Sie dann Ihren Suchbegriff ein, nach dem gesucht werden soll. Anschließend klicken Sie auf die Schaltfläche Themen auflisten, um die Suche zu starten.

Tipp:

Sie können auch komplexe Suchvorgänge mit mehreren Suchbegriffen durchführen, indem Sie die Operatoren AND, OR, NEAR und NOT verwenden. Zum Beispiel: Bei Eingabe von "Installieren AND UIWatcher NOT XP" werden alle Abschnitte aufgelistet, welche die Begriffe "Installieren" und "UIWatcher" beinhalten; aber nicht den Begriff "XP". ("Installieren AND UIWATCHER AND XP" wird ein anderes Ergebnis liefern.)
Bei der Eingabe von "Installieren NEAR UIWatcher" finden Sie die Abschnitte, in denen der Begriff "Installieren" nahe beim Begriff "UIWatcher" auftaucht. Durch Klicken auf das Pfeil-Symbol direkt rechts neben dem Eingabefeld öffnet sich eine Popup-Auswahlliste, mit der Sie die Operatoren direkt eingeben können.

.topic 12700
Bei bestimmten Konstellationen von Windows®NT, dem Microsoft Internet Explorer und ActiveX-Controls kann es vereinzelt zu Problemen beim Benutzen dieser Online-Hilfe kommen.
Sollten Sie Fehlermeldungen erhalten, wenn Sie einige Seiten öffnen oder auf einige Links dieser Hilfe klicken, lesen Sie bitte den Artikel der Microsoft Knowledge Base zur Problemlösung.

  MS Knowledge Base Q235653

.topic 30000
Der Easy-Modus ist der Standardmodus der Ashampoo UnInstaller Suite. Alle weiterführenden Funktionen des Programms, die tiefer gehende Kenntnisse erfordern, sind verborgen. Das bedeutet keinesfalls, dass der Easy-Modus nicht leistungsfähig ist. Im Gegenteil: Auch als erfahrener Windows-Benutzer werden Sie feststellen, dass der Easy-Modus der einfachste Weg zur Überwachung von Anwendungen und zur späteren Deinstallation ist. Sie werden nur dann in Experten-Modus wechseln, um die weiteren tollen Features des Programms (wie im Abschnitt Das Programm im Experten-Modus benutzen) beschrieben, zu nutzen.

Erkennen und Wechsel des Modus:

Der Easy-Modus schützt Sie

Wenn Sie zum Easy-Modus wechseln, werden alle Einstellungen der  Ashampoo UnInstaller Suite auf die sicheren Standardeinstellungen zurückgesetzt. Es ist damit unmöglich, mit den im Experten-Modus gemachten Einstellungen Daten zu verlieren oder irgendeinen Schaden anzurichten, falls Sie vergessen haben sollten, diese Einstellungen vor dem Wechsel in den Easy-Modus zurückzusetzen.

Ebenso schützt Sie die Ashampoo UnInstaller Suite vor dem Verlust von Einstellungen im Experten-Modus. Wenn Sie in den Easy-Modus wechseln, werden Ihre Einstellungen automatisch in eine Sicherungsdatei gespeichert. Beim nächsten Wechsel zurück in den Experten-Modus erfolgt die automatische Abfrage, ob Sie Ihre Einstellungen wieder laden möchten, die Sie vor dem Wechsel in den Easy-Modus benutzt hatten.

.topic 30010
Dieser Abschnitt enthält Anweisungen zur Installation von Anwendungen im Easy-Modus.

Warum benötigen Sie den UnInstaller oder UIWatcher bei der Programminstallation?

Ashampoo UnInstaller Suite kann nur dann alle Spuren einer Anwendung von Ihrem System entfernen, wenn ein Installationsprotokoll mit allen Veränderungen, die durch die Installation eines Programms vorgenommen wurden, erstellt wurde. Dazu ist es erforderlich, den Status Ihrer Systemkonfiguration vor der Installation eines Programmes und direkt nach der Installation in einer Protokolldatei zu speichern. Aus dem Vergleich der beiden Berichte wird das Installationsprotokoll erzeugt.

Im Easy-Modus ist der gesamte Prozess automatisiert

Ist der Easy-Modus aktiviert, ist der gesamte Prozess der Installation und Deinstallation eines Programmes automatisiert, unabhängig davon, ob der Vorgang aus dem UIWatcher in der Taskbar oder aus dem Hauptprogramm-Bildschirm heraus gestartet wird.

Die Auswahlregister - was das Programm überwacht

Bevor Sie beginnen, starten Sie bitte die Ashampoo UnInstaller Suite und prüfen, ob sich das Programm im Easy-Modus befindet. Klicken Sie dann auf Auswahl: Registry & Laufwerke. Sie sehen dann eine Liste aller Laufwerke auf Ihrem Computer. Anhand dieser Liste wird bestimmt, an welchen Stellen das Programm nach Dateien und Einträgen, die während der Installation einer neuen Anwendung hinzugefügt werden, schauen soll.

.topic 30020
Sobald Sie ein Installationsprogramm mit den Namen INSTALL.EXE oder SETUP.EXE starten, schaltet sich der Ashampoo UnInstaller Watcher automatisch ein und fragt ab, ob Sie die Installation mit der Ashampoo UnInstaller Suite überwachen möchten. Bitte folgen Sie einfach den Hinweisen auf den Bildschirmen. (Das funktioniert natürlich nur, wenn Sie den UIWatcher in der Taskbar nicht deaktiviert haben!)

Die Vorgehensweise ist nahezu identisch wie beim weiter unten beschriebenen Ablauf bei der manuellen Installation von Anwendungen mit dem UIWatcher - der einzige Unterschied liegt in der automatischen Erkennung des Installationsprogramms und dem automatischen Start des UIWatcher.

Wann Sie das Feature der automatischen Erkennung des UIWatcher nicht nutzen sollten

Die Fähigkeit des UIWatcher, automatisch Installationsprogramme zu erkennen wird für die meisten Installationen sehr gut arbeiten. Das Programm kann aber "verwirrt" sein, wenn Sie ein Installationsprogramm für ein Paket an Anwendungen starten.  Das Problem besteht darin, dass ein solcher Installer zwei, drei oder mehr Installationsprogramme starten. Darüber hinaus starten einige dieser Pakete dann Installationsprogramme mit einer ganzen Serie von unterschiedlichen Namen. Einige davon werden vom UIWatcher erkannt, andere wiederum nicht. Wenn Sie Pech haben, wird das erste Installationsprogramm vom UIWatcher nicht erkannt. Das Installationsprotokoll wird dann nicht die gesamte Anwendung enthalten, weil einige Einträge bereits installiert sind, bevor der UIWatcher aktiviert ist.

Um auf der sicheren Seite zu sein, benutzen Sie die beschriebenen Arbeitsweise für:

Anwendungen, die mehr als ein Software-Modul enthalten.

Installationsprogramme, die weder INSTALL.EXE noch SETUP.EXE heißen.

Programme manuell mit dem UIWatcher installieren

Das Programm UIWatcher schaltet sich nur automatisch ein, wenn ein Installationsprogramm mit den Namen INSTALL.EXE oder SETUP.EXE gestartet wird. Das gilt in der Regel für die meisten Installationsprogramme. Selbst Instaallationsprogramme mit anderen Namen generieren gewöhnlich Dateien, die INSTALL.EXE oder SETUP.EXE heißen und die dann gestartet werden.

     Wenn der UIWatcher nicht aktiviert wird, wenn Sie ein Installationsprogramm mit einem anderen Namen starten, klicken Sie bitte im Installationsprogramm auf Abbrechen und starten dann den Vorgang manuell.

  Sie sollten den UIWatcher in der Taskbar deaktivieren, bevor Sie eine manuelle Installation durchführen. Sie verhindern damit, dass der UIWatcher automatisch aktiviert wird, wenn Sie ein Installationsprogramm starten, das Sie bereits manuell überwachen.  Klicken Sie einfach mit der rechten Maustaste auf das Icon des UIWatcher und wählen die Option Installationsüberwachung aktivieren ab.

Vorgehensweise:

Das in Schritt 4 erzeugte Protokoll enthält alle Änderungen, die bei der Installation der neuen Anwendung an Ihrem System vorgenommen wurden. Diese Informationen ermöglichen der Ashampoo UnInstaller Suite das Programm komplett von Ihrem Rechner zu entfernen, wenn Sie sich zum Deinstallieren entscheiden. Siehe Programme deinstallieren für weitere Hinweise.

Wichtiger Hinweis:

Bitte schließen Sie den Installationsvorgang so schnell wie möglich ab und führen auch keine Arbeiten an Ihrem Computer durch, bis Sie Installationsprotokoll gespeichert haben. Das Programm erlaubt Ihnen nur die Durchführung des automatischen Deinstallationsvorgangs mit Installationsprotokollen, die unmittelbar nach der Installation erzeugt wurden. Dieser Schutzmechanismus wurde entwickelt, damit sichergestellt wird, dass Sie keine wichtigen Daten in Ihr Installationsprotokoll einschließen, die nicht mit der neuen Anwendung in Beziehung stehen (Zum Beispiel Text- und andere Dateien, die Sie vor dem Generieren der Installationsprotokolle erzeugt haben).

.topic 30030
Im Easy-Modus ist das Installieren von Anwendungen mit dem Hauptprogramm UnInstaller ebenso einfach wie mit der automatischen Funktion des UIWatcher.

     Es ist sinnvoll, den UIWatcher in der Taskbar zu deaktivieren, bevor Sie eine manuelle Installation vornehmen. Dadurch wird verhindert, dass der UIWatcher automatisch aktiviert wird, wenn Sie ein Installationsprogramm starten, das Sie schon manuell überwachen. Klicken Sie einfach mit der rechten Maustaste auf das UIWatcher Icon in der Taskbar und wählen die Option Installationsüberwachung aktiv ab.

Vorgehensweise:

Das in Schritt 4 erzeugte Protokoll enthält alle Änderungen, die bei der Installation der neuen Anwendung an Ihrem System vorgenommen wurden. Diese Informationen ermöglichen der Ashampoo UnInstaller Suite das Programm komplett von Ihrem Rechner zu entfernen, wenn Sie sich zum Deinstallieren entscheiden. Siehe Programme deinstallieren für weitere Hinweise.

Wichtiger Hinweis:

Bitte schließen Sie den Installationsvorgang so schnell wie möglich ab und führen auch keine Arbeiten an Ihrem Computer durch, bis Sie Installationsprotokoll gespeichert haben. Das Programm erlaubt Ihnen nur die Durchführung des automatischen Deinstallationsvorgangs mit Installationsprotokollen, die unmittelbar nach der Installation erzeugt wurden. Dieser Schutzmechanismus wurde entwickelt, damit sichergestellt wird, dass Sie keine wichtigen Daten in Ihr Installationsprotokoll einschließen, die nicht mit der neuen Anwendung in Beziehung stehen (Zum Beispiel Text- und andere Dateien, die Sie vor dem Generieren der Installationsprotokolle erzeugt haben).

.topic 30040
Vorhandene Anwendungen zu deinstallieren ist im Easy-Modus sogar einfacher als die Installation. Sie wählen einfach das Protokoll aus, welches während der Installation der Anwendung mit der Ashampoo UnInstaller Suite erzeugt wurde - alles andere wird vom Programm geregelt. Sie können den Deinstallationsvorgang aus dem Menü des UIWatcher in der Taskbar oder aus dem Hauptprogramm-Bildschirm starten - der Vorgang ist absolut identisch.

Programme deinstallieren ohne Protokolldatei

Wenn Sie über kein Protokoll verfügen (z.B. wenn Sie das Programme ohne die Ashampoo UnInstaller Suite installiert haben), können Sie die automatische Deinstallationsroutine des Programmes nicht nutzen. Wenn Sie ein Programm dennoch entfernen müssen, wählen Sie bitte die Funktion Anwendung ohne Protokoll deinstallieren im Bildschirm der Suite oder im Menü UnInstaller und folgen dann den angezeigten Erläuterungen.

.topic 30050
Zum Verständnis:

Der automatische Deinstallationsprozess wird nur dann aktiviert, wenn Sie ein Protokoll direkt nach der Installation einer Anwendung erzeugt haben. Wenn Sie das Protokoll später erzeugen, werden die Auswahlbildschirme des Experten-Modus angezeigt und Sie werden gefragt, welche Einträge Sie per Hand wiederherstellen möchten. Das ist eine Sicherheitsfunktion - es wird angenommen, dass Sie bereits andere Aktivitäten auf Ihrem Rechner vorgenommen haben, bevor Sie das Protokoll geschrieben haben.

Vorgehensweise:

  Wenn Sie nicht über ein Protokoll verfügen:
Wenn Sie über kein Protokoll verfügen (z.B. wenn Sie das Programm ohne die Ashampoo UnInstaller Suite installiert haben), folgen Sie bitte den Anweisungen, wie im Abschnitt Anwendungen ohne Protokoll deinstallieren beschrieben

.topic 30060
Folgen Sie bitte Schritt für Schritt den Anweisungen, um eine Anwendung mit der Ashampoo UnInstaller Suite von Ihrem Rechner zu entfernen.

Hinweise:

Dieser Vorgang gilt nur für Programme, die Sie mit der Hilfe der Ashampoo UnInstaller Suite installiert haben. Siehe den Abschnitt  Anwendungen ohne Protokoll deinstallieren zur Vorgehensweise zum Entfernen von Anwendungen, die Sie vor dem Benutzen dieses Programmes installiert haben.

Der automatische Deinstallationsprozess wird nur dann aktiviert, wenn Sie ein Protokoll direkt nach der Installation einer Anwendung erzeugt haben. Wenn Sie das Protokoll später erzeugen, werden die Auswahlbildschirme des Experten-Modus angezeigt und Sie werden gefragt, welche Einträge Sie per Hand wiederherstellen möchten. Das ist eine Sicherheitsfunktion - es wird angenommen, dass Sie bereits andere Aktivitäten auf Ihrem Rechner vorgenommen haben, bevor Sie das Protokoll geschrieben haben.

Vorgehensweise:

Alternative Methode:

  Wenn Sie nicht über ein Protokoll verfügen:
Wenn Sie über kein Protokoll verfügen (z.B. wenn Sie das Programm ohne die Ashampoo UnInstaller Suite installiert haben), folgen Sie bitte den Anweisungen, wie im Abschnitt Anwendungen ohne Protokoll deinstallieren beschrieben.

.topic 30070
Wenn Sie über kein Protokoll verfügen (z.B. wenn Sie das Programm ohne die Ashampoo UnInstaller Suite installiert haben), müssen Sie entweder den programmeigenen Uninstaller benutzen oder in den Experten-Modus wechseln und die Komponenten der Anwendung manuell entfernen. Die Benutzung des programmeigenen Uninstaller ist immer sicherer als die manuelle Vorgehensweise, besonders wenn noch keine Erfahrungen vorhanden sind.

Vorgehensweise:

Wenn das Programm nicht im Bildschirm aufgeführt ist:

 1.	Es gibt öfters Anwendungen mit der Option der eigenen Deinstallation in der Programmgruppe im Windows-Startmenü. Bitte prüfen Sie diese Option. Sollten Sie eine Option finden, wie Programm XXX entfernen oder Programm löschen treffen Sie bitte die entsprechende Auswahl und folgen den Hinweisen.

 2.	Sollte das Programm nicht über einen Uninstaller verfügen, müssen Sie in den Experten-Modus wechseln und den manuellen Deinstallationsvorgang benutzen. Wenn Ihnen die Optionen zu komplex erscheinen, versuchen Sie bitte nichts auf eigene Faust. Holen Sie sich Rat von einem erfahrenen Windows-Benutzer. Lassen Sie im Zweifelsfall eine Anwendung mehr auf Ihrem System als eine unnötige Zerstörung Ihres Setup oder Ihrer Konfiguration zu riskieren!

.topic 40000
Wie der Name bereits verdeutlicht, ist der Experten-Modus für erfahrene Windows-Benutzer entwickelt worden. Bevor Sie ausgiebigen Gebrauch von der Funktionalität in diesem Modus machen, sollten Sie sich mit den wesentlichen Prinzipien der Windows-Konfiguration und der Windows Registry vertraut machen.

Die im Experten-Modus verfügbaren Funktionen sind sehr mächtig und falls Sie nicht sorgfältig arbeiten, können Registry-Einträge sowie weitere Dateien, die Sie besser behalten sollten, ganz leicht gelöscht werden.

Wie man im Experten-Modus erfolgreich arbeitet

Der sicherste Weg um die Möglichkeiten im Experten-Modus verstehen zu lernen ist den Erläuterungen zu den von Ihnen geplanten Aufgaben zu folgen. Jeder Abschnitt verfügt über Links zu den benötigten weiteren Informationen. "Learning by doing" ist in der Regel der einfachste Weg ein neues Progamm komplett zu begreifen.

Was passiert beim Wechsel in den Experten-Modus?

Wenn sich die Ashampoo UnInstaller Suite im Experten-Modus befindet, verfügen Sie über die volle Kontrolle über alle Ihre Arbeitsschritte. Alle vollautomatischen Mechanismen im Easy-Modus sind deaktiviert und bis dato verborgene Features stehen jetzt zur Verfügung. Sie können die Vorgänge mit Hilfe interaktiven Assistenten oder aber völlig für sich alleine erledigen.

Was passiert beim Wechsel zurück in den Easy-Modus?

Wenn Sie zum Easy-Modus wechseln, werden alle Einstellungen durch die  Ashampoo UnInstaller Suite automatisch auf die sicheren Standardwerte zurückgesetzt. Dadurch ist gewährleistet, dass Sie weder Daten verlieren noch irgendwelche Schäden durch Einstellungen im Experten-Modus verursachen können, wenn Sie ohne deren Zurücksetzen in den Easy-Modus wechseln.

Gleichzeitig werden alle Einstellungen im Experten-Modus automatisch in einem Backup gesichert. Sie werden beim erneuten Wechsel in den Experten-Modus gefragt, ob Sie die letzten benutzten Einstellungen wieder laden möchten, bevor Sie in den Easy-Modus wechseln.

Interaktive Assistenten

Im Experten-Modus starten die folgenden Optionen jeweils mit einem interaktiven Assistenten, der Sie durch die weiteren Schritte führt. Diese Assistenten unterscheiden sich von denen, die im Easy-Modus aktiv sind. Neben der aktuellen Benutzerführung erfahren Sie mehr darüber, wie Sie die mächtigen Programmfunktionen für sich selbst nutzen können.

Vorgehensweise:

Die Kapitel in diesem Abschnitt der Hilfe enthalten Hinweise zu den wesentlichen Aufgaben, die Sie mit der Ashampoo UnInstaller Suite bewältigen wollen. Sie sind an erfahrene Benutzer gerichtet und setzen voraus, dass Sie mit den grundlegenden Funktionen von Windows vertraut sind. Sie sollten ebenfalls über Grundkenntnisse in Bezug auf die Windows-Registry verfügen, bevor Sie die weiterreichenden Funktionen nutzen.

.topic 40010
Methode 1: Interaktiver Assistent

     Es ist sinnvoll, den UIWatcher in der Taskbar zu deaktivieren, bevor Sie eine manuelle Installation vornehmen. Dadurch wird verhindert, dass der UIWatcher automatisch aktiviert wird, wenn Sie ein Installationsprogramm starten, das Sie schon manuell überwachen. Klicken Sie einfach mit der rechten Maustaste auf das UIWatcher Icon in der Taskbar und wählen die Option Installationsüberwachung aktiv ab.

 1.	Stellen Sie sicher, dass das Programm im Experten-Modus ist. Klicken Sie dann doppelt auf Neue Anwendung installieren im Register Suite oder wählen Neue Anwendung installieren im Menü UnInstaller oder der Werkzeugleiste.

 2.	Arbeiten Sie sich durch die Register des Assistenten von links nach rechts und folgen den Anweisungen. An einigen Punkten werden Sie aufgefordert, zur Ashampoo UnInstaller Suite zu wechseln. Nach den geforderten Aktionen im Hauptprogramm können Sie zum Assistenten zurückkehren und Ihren Kurs fortsetzen.

Methode 2: Benutzen der Werkzeuge

Sie sollten diese Methode erst dann benutzen, wenn Sie mit dem Programm vertraut sind. Sie haben die volle Kontrolle und können alle verfügbaren Optionen nutzen.

 1.	Stellen Sie sicher, dass das Programm im Experten-Modus ist. Klicken Sie dann auf das Register Auswahl: Registry & Laufwerke im Hauptbildschirm. Sie sehen anschließend weitere Unterregister, in denen Sie alle Einträge sehen und verändern können, die von der  Ashampoo UnInstaller Suite überwacht werden, wenn Sie ein Programm installieren oder sonstige Änderungen an Ihrem System vornehmen.

  Sie können jederzeit mit der Option Zurücksetzen der Auswahl im Menü Datei den ursprünglichen Zustand wiederherstellen.

 2.	Gehen Sie durch alle Einträge in den Unterregistern und wählen die Einträge aus, die überwacht werden sollen bzw. wählen die Einträge ab, die von der Überwachung ausgeschlossen werden sollen. Sie können spezielle Dateien auch unter dem Register Ausgeschlossene Dateien ausschließend. Bitte keine Einträge auswählen oder abwählen, wenn Sie nicht wirklich sicher sind, was Sie tun!  Wählen Sie insbesondere keine Einträge aus, die in den Vorgaben des Programms abgewählt sind. Bitte benutzen Sie bitte die sichere Standardauswahl.

 3.	Wählen Sie Speichere aktuelle Konfiguration im Menü UnInstaller oder in der Werkzeugleiste.

      Wenn Sie die Auswahl verändern, bevor Sie die aktuelle Konfiguration speichern, stellen Sie beim Verlassen des Programms sicher, dass Ihre neue Einstellungen als Standard  gespeichert werden (Sie werden dazu aufgefordert!). Geschieht das nicht, werden unterschiedliche Auswahl-Einstellungen für den Vergleich benutzt und die daraus resultierende Protokolldatei wird nicht korrekt sein. Als Alternative können Sie Ihre Auswahl in eine Datei speichern (Speichere eine Auswahl-Datei im Menü Datei) und laden diese Auswahl wieder (Lade eine Auswahl-Datei im Menü Datei), bevor Sie den Vergleich durchführen.

 4.	Installieren Sie die neue Anwendung. Es besteht keine Notwendigkeit, die Ashampoo UnInstaller Suite während dessen gestartet zu haben. Sie können das Programm beenden und sogar den Rechner neu starten, wenn Sie es möchten.

 5.	Nach der Installation starten Sie das Programm bitte einmal und beenden es dann. Das ist wichtig, weil viele Anwendungen die Installation erst dann abschließen, wenn sie einmal gestartet wurden. Sie können die Anwendung jetzt konfigurieren, aber das ist nicht so wichtig. Sie brauchen letztendlich das Programm nur einmal starten und wieder beenden.

 6.	Starten Sie die Ashampoo UnInstaller Suite wenn das Programm nicht bereits gestartet sein sollte. Wählen Sie Vergleiche/Protokoll erstellen im Menü UnInstaller oder benutzen Sie einen einfachen Dateinamen für Ihr Protokoll, damit Sie das Protokoll schnell und einfach identifizieren können. Es ist sinnvoll, den Namen der gerade installierten Anwendung zu benutzen.

Das ist alles. Sie können jetzt das soeben erzeugte Protokoll zum Entfernen der Anwendung benutzen. Wann immer Sie es möchten. Wenn Sie interessiert sind, können Sie einen Blick in das Register Installationsprotokolle werfen. Hier sind alle Komponenten aufgeführt, die von der Anwendung dem System hinzugefügt wurden. (Die Protokolldatei wird automatisch nach dem Erzeugen geladen).

Methode 3: Benutzen der UIWatcher Menü-Optionen

Die wesentlichen Funktionen, die für die Methode 1 und 2 benutzt werden, können auch aus dem PopUp-Menü des UIWatcher heraus gewählt werden. Sie können die meisten dieser Operationen durchführen, ohne das Hauptprogramm zu starten. (Diese Optionen werden im Menü des UIWatcher nur dann angezeigt, wenn sich die Ashampoo UnInstaller Suite im Experten-Modus befindet.)

Besonderer Tipp:

Nutzen Sie für zusätzliche Sicherheit und Informationen die Funktion Backup erstellen in Verbindung mit dem Feature  Speichere Versionsinformationen. Wenn Sie nach der Installation einer Anwendung die Register Installationsprotokolle überprüfen, können Sie sofort sehen, ob wichtige Dateien mit älteren Versionen überschrieben wurden. Sie können sie dann mit den Originaldateien aus Ihrem Backup wiederherstellen. Vergessen Sie nicht die Option Gesicherte Dateien beim Wiederherstellen verwenden in den Einstellungen zu aktivieren!

.topic 40015
Es kommt ja vor: Sie sind mitten bei der Installation einer Anwendung und entweder haben Sie gerade Ihre Meinung geändert oder es passiert etwas, was die Fortführung der Installation unmöglich macht. Das Passwort oder der Code für die Installation wird nicht akzeptiert. Es "friert" etwas auf Ihrem Bildschirm ein, das Programm stürzt ab, das Installationsprogramm "hängt sich auf" oder Windows ist der Meinung, dass es an der Zeit ist, Sie mit dem berühmten "blauen Bildschirm" unterhalten zu müssen. Was auch immer - Sie können oder wollen nicht mehr fortfahren.

Installationsprogramme sind nicht zum Verlassen entwickelt worden

Installationsprogramme wollen nur eines: Sie möchten das Programm des Herstellers auf Ihre Festplatte bringen. Die Programme sind wahrlich nicht an einem Stopp interessiert. Sie wollen fortfahren, bis das Programm installiert ist. Bis auf wenige Ausnahmen brechen Installationsprogramm nicht "in Schönheit" ab. Die meisten Installationsprogramme werden zwar abbrechen, sind aber "beleidigt" und verabschieden ohne sich selbst wegzuräumen. Es gibt nur wenige Installationsprogramme mit einer Abbrechfunktion, die auch wirklich alle temporären Dateien oder Einträge in der Registry löscht, die vor dem Befehl zum Abbruch geschrieben wurden. Das Ergebnis ist eine weitere Ladung von Müll, der Ihre Festplatten und Windows Registry verstopft.

Jetzt können Sie den Rest abgebrochener Installationen "entsorgen"

Für die Ashampoo UnInstaller Suite besteht kein Unterschied zwischen einer abgebrochenen und kompletten Installation. Beide Formen führen zu Veränderungen auf Ihrer Festplatte und der Registry. Es spielt keine Rolle, ob Sie den blauen Bildschirm erhalten - der vorherige Status wurde bereits in einer Konfigurationsdatei aufgezeichnet, so dass Sie nach dem erfolgreichen Neustart von Windows mit den Kommandos Vergleiche (Protokoll erstellen) und Alles wiederherstellen den ganzen hinterlassenen "Müll" der abgebrochenen Installation entfernen können. Und zwar wie folgt:

Vorgehensweise:

Wir gehen davon, dass Sie ihre aktuelle System-Konfiguration gespeichert haben (siehe Anwendungen installieren) und dass Sie das Installationsprogramm für eine Anwendung, welches Sie auf Ihrem Rechner installieren möchten, gestartet haben. Jetzt beenden Sie das Installationsprogramm oder das Programm oder Windows stürzen ab oder "hängen sich auf". Jetzt unternehmen Sie folgende Schritte:

 1.	Sollte etwas abgestürzt sein, starten Sie zunächst Windows wieder. Verlassen Sie die Ashampoo UnInstaller Suite wenn möglich vor dem Neustart. Sollte das nicht gelingen, ist es nicht weiter tragisch. Die aktuelle Konfiguration wurde ja bereits protokolliert, Sie verlieren also keine Daten.

 2.	Wenn der UIWatcher "anspringt" und Ihnen mitteilt, dass die Installation abgeschlossen ist (was sehr unwahrscheinlich ist, aber passieren kann), geben Sie bitte einen Namen für das Installationsprotokoll in das Feld ein und klicken auf Installationsprotokoll speichern.

 3.	Wenn nichts passiert, starten Sie einfach die Ashampoo UnInstaller Suite und wählen Vergleiche (Protokoll erstellen) im Menü UnInstaller  oder der Werkzeugleiste. Alternativ können Sie mit einem Rechtsklick auf das Icon in der Taskbar das Menü des UIWatcher öffnen und wählen dort Vergleiche (Protokoll erstellen) - dann brauchen Sie die Ashampoo UnInstaller Suite nicht starten.

 4.	Geben Sie einen Namen für die Protokolldatei ein und klicken Sie auf Speichern. Wenn das Protokoll erzeugt wurde, werden alle registrierten Änderungen automatisch in den Registern Installationsprotokolle der Ashampoo UnInstaller Suite angezeigt. (Wenn Sie aus dem Menü des UIWatcher heraus arbeiten, müssen Sie das Hauptprogramm starten und das Protokoll manuell laden, um die Änderungen zu sehen.)

 5.	Um alle Änderungen rückgängig zu machen wählen Sie einfach Alles wiederherstellen im Menü UnInstaller oder der Werkzeugleiste. Um einzelne Änderungen wiederherzustellen folgen Sie bitte den Anweisungen wie im Abschnitt  Manuelle Wiederherstellung von Änderungen beschrieben. Wenn Sie aus dem Menü des UIWatcher heraus arbeiten, wählen Sie bitte Anwendung deinstallieren und wählen die Protokolldatei aus, die Sie in Schritt 2 oder 3 erzeugt haben.

Das ist alles. Ihr System wurde auf den Status wiederhergestellt, den es hatte, bevor Sie das abgebrochene Installationsprogramm gestartet hatten. Sie können die Protokolldatei jetzt löschen. Es besteht keine Veranlassung diese Datei zu behalten.

.topic 40020
Methode 1: Interaktiver Assistent

1.	Stellen Sie sicher, dass das Programm im Experten-Modus ist. Klicken Sie dann doppelt auf Anwendung deinstallieren im Register Suite oder wählen Anwendung ohne Protokoll deinstallieren im Menü UnInstaller oder der Werkzeugleiste.

 2.	Arbeiten Sie sich durch die Register des Assistenten von links nach rechts und folgen den Anweisungen. An einigen Punkten werden Sie aufgefordert, zur Ashampoo UnInstaller Suite zu wechseln. Nach den geforderten Aktionen im Hauptprogramm können Sie zum Assistenten zurückkehren und Ihren Kurs fortsetzen.

  Diese Methode steht Ihnen auch im PopUp-Menü des UIWatcher in der Taskbar zur Verfügung.

Methode 2: Schnelles Deinstallieren aus dem Register Installationsprotokolle

 1.	Stellen Sie sicher, dass das Programm im Experten-Modus ist. Wählen Sie dann das Register Installationsprotokolle und das Unterregister Protokolldateien aus. Alle verfügbaren Protokolle werden im Hauptfenster dieses Register aufgelistet.

 2.	Klicken Sie auf das Protokoll der Anwendungen, die Sie entfernen möchten, um es zu markieren. Klicken Sie dann auf den Schalter Anwendung deinstallieren.

 3.	Im angezeigten Dialog wählen Sie alle Einträge ab, die Sie nicht entfernen möchten (Registry, Dateien, Systemdateien).

 4.	Klicken Sie auf OK. Das Programm zeigt Ihnen jede Liste mit Einträgen zum Löschen oder Wiederherstellen. Sie können die Aktion bestätigen oder abbrechen. Sie können keine einzelnen Einträge mit dieser Methode bearbeiten. Sie können den Vorgang abbrechen, wenn Sie Ihre Meinung über das Entfernen der Anwendung geändert haben sollten.

Methode 3: Verwenden der Werkzeuge im Experten-Modus

Sie sollten diese Methode erst dann benutzen, wenn Sie mit dem Programm vertraut sind. Sie haben die volle Kontrolle und können alle verfügbaren Optionen nutzen.

 1.	Stellen Sie sicher, dass das Programm im Experten-Modus ist. Wählen Sie dann Lade Protokolldatei (Installationsprotokoll) im Menü Datei oder der Werkzeugleiste und wählen das Protokoll des Programmes, welches Sie entfernen möchten.

 2.	Um alle im Protokoll gelisteten Einträge automatisch zu entfernen, wählen Sie einfach Alles wiederherstellen im Menü UnInstaller oder der Werkzeugleiste. Bestätigungsfenster öffnen sich, damit Sie die Einträge betrachten können und wenn nötig den Vorgang auch abbrechen können.

 4. Wählen Sie Änderungen wiederherstellen im PopUp-Menü, um den aktuellen Eintrag wiederherzustellen. Es öffnet sich ein Dialog, der Ihnen alle durchzuführenden Operationen zur Wiederherstellung anzeigt. Zusätzliche Optionen ermöglichen Ihnen die Feinabstimmung des Vorgangs.

WICHTIG:

Wenn Sie einen Zweig in einem Baum auswählen, werden sowohl der aktuelle Eintrag als auch die Sub-Einträge zusammen wiederhergestellt. Zum Beispiel werden durch die Auswahl des Icons   Arbeitsplatz im Register Änderungen in Registry alle Änderungen in der Registry wiederhergestellt. Die Auswahl des Icons  im Register Veränderte Dateistruktur wird alle Änderungen an Dateien zusammen zurücksetzen.

  Siehe das Unterregister Ausgeschlossene Dateien im Register Auswahl: Registry & Laufwerke für weitere Hinweise zur Benutzung von Icons im Register Installationsprotokolle.

Besonderer Tipp:

Nutzen Sie für zusätzliche Sicherheit und Informationen die Funktion Backup erstellen in Verbindung mit dem Feature  Speichere Versionsinformationen. Wenn Sie nach der Installation einer Anwendung die Register Installationsprotokolle überprüfen, können Sie sofort sehen, ob wichtige Dateien mit älteren Versionen überschrieben wurden. Sie können sie dann mit den Originaldateien aus Ihrem Backup wiederherstellen. Vergessen Sie nicht die Option Gesicherte Dateien beim Wiederherstellung verwenden in den Einstellungen zu aktivieren!

.topic 40030

Alternativ dazu können Sie aber auch beide Methoden verwenden: Zunächst arbeiten Sie mit dem programmeigenen UnInstaller und anschließend mit dem interaktiven Assistenten, um ggf. übrig gebliebene Einträge zu finden und zu löschen.

Den programmeigenen UnInstaller benutzen

 1. Klicken Sie auf Anwendung ohne Protokoll deinstallieren im Programm-Bildschirm (oder wählen Sie Anwendung ohne Protokoll deinstallieren im Menü UnInstaller).

 2.	Wenn die Anwendung im Fenster gelistet ist, klicken Sie bitte zur Auswahl auf den Namen in der Liste. Klicken Sie dann auf den Schalter Ausgewählte Anwendung deinstallieren und folgen den angezeigten Hinweisen.

Den interaktiven Assistenten benutzen:

 1. Klicken Sie doppelt auf das Icon Anwendung ohne Protokoll deinstallieren im Programm-Bildschirm (oder wählen Sie Anwendung ohne Protokoll deinstallieren im Menü UnInstaller).

 2.	Wählen Sie das Register Manuell und arbeiten sich anschließend von rechts nach links durch alle Register des Assistenten. In jedem Bildschirm erhalten Sie die entsprechenden Hinweise und Erläuterungen zur Vorgehensweise.

.topic 40035
Einführung und Warnung

Die Funktionen zum Entfernen von Anwendungen sind ausgezeichnet, wenn Sie einfach mit der Ashampoo UnInstaller Suite protokollierte Anwendungen entfernen. Wenn Sie das Programm aber zu anderen Zwecken benutzen, möchten Sie verständlicherweise auch die Änderungen im Register Installationsprotokolle sehen und einzelne Änderungen wiederherstellen.

Schwierig daran ist die Entscheidung, welche Änderungen wiederhergestellt werden sollen und welche man besser belässt. Das gilt im Besonderen für Änderungen in der Windows Registry. Bitte denken Sie daran, dass die Wiederherstellungsfunktionen der  Ashampoo UnInstaller Suite direkt auf die Registry zugreifen und diese verändern. Seien Sie also bitte vorsichtig, wenn Sie Änderungen in der Registry wiederherstellen möchten.

Sie sind mit den Installationsprotokollen, die direkt nach der Installation von Anwendungen generiert wurden, auf der sicheren Seite. Diese Protokolle enthalten nur die Änderungen, die durch die Installation der Anwendung bewirkt wurden. Für alle anderen Aktionen gilt: Lassen Sie diese Funktion auf sich beruhen, wenn Sie keine Ahnung von den Einträgen haben, die Sie wiederherstellen.

Sie sollten über wirklich gute Kenntnisse der  Windows-Konfiguration und der Windows Registry verfügen, bevor Sie ernsthaften Gebrauch dieser Möglichkeiten der Ashampoo UnInstaller Suite machen.

Vorgehensweise:

Wenn Sie einen Vergleich durchführen oder eine Protokolldatei laden (Lade Auswahl aus Datei im Menü Datei oder der Werkzeugleiste) werden die Änderungen immer in den Registern unterhalb von Installationsprotokolle angezeigt. Sollten Sie noch keine Protokolldatei geladen haben, tun Sie es jetzt. Dann können Sie auf eines der Register mit den Veränderungen im Register Installationsprotokolle klicken, um sich die in der Protokolldateien dokumentierten Änderungen anzeigen zu lassen.

Es werden nur die Verzweigungen, für die Änderungen dokumentiert sind, in der Baumansicht angezeigt. Zum Beispiel sehen Sie im Register Änderungen in der Registry nur die Abschnitte der Registry, die in der Auswahl, mit denen die Protokolldatei gespeichert wurde, eingeschlossen waren. Sie können also nur die Abschnitte und Verzweigungen aufklappen, die auch wirklich Änderungen enthalten. Im Register Veränderte Dateistruktur werden alle Laufwerke angezeigt, die bei Auswahl mit einbezogen waren, aber Sie können nur die Zweige für die Laufwerke aufklappen, für die Änderungen dokumentiert sind. Ähnliches gilt für das Register Änderungen an den Systemdateien. Sie können nur die Baumansicht für Systemdateien öffnen, die verändert wurden.

Änderungen wiederherstellen:

WICHTIG:

Wenn Sie einen Zweig in einem Baum auswählen, werden sowohl der aktuelle Eintrag als auch die Sub-Einträge zusammen wiederhergestellt. Zum Beispiel werden durch die Auswahl des Icons Arbeitsplatz im Register Änderungen in der Registry alle Änderungen in der Registry wiederhergestellt. Die Auswahl des Icons Laufwerke im Register Veränderungen an der Dateistruktur wird alle Änderungen an Dateien zusammen zurücksetzen.

Besonderer Tipp:

Nutzen Sie für zusätzliche Sicherheit und Informationen die Funktion Backup erstellen in Verbindung mit dem Feature  Speichere Versionsinformationen. Wenn Sie nach der Installation einer Anwendung die Register Installationsprotokolle überprüfen, können Sie sofort sehen, ob wichtige Dateien mit älteren Versionen überschrieben wurden. Sie können sie dann mit den Originaldateien aus Ihrem Backup wiederherstellen. Vergessen Sie nicht die Option Gesicherte Dateien beim Wiederherstellen verwenden in den Einstellungen zu aktivieren!

Einträge, die nicht wiederhergestellt werden können:

Einige Einträge können nicht wiederhergestellt werden, es sei denn, Sie haben zuvor Backups von ihnen erstellt. Nachfolgend ein Beispiel:

Es besteht keine Möglichkeit schon im voraus zu erkennen, ob sich ein Programm so verhalten wird. Der einzige Schutz liegt in der Verwendung des Features Backup erstellen, um alle wichtigen Dateien in Ihren System-und Windows-Verzeichnissen zu schützen. Aber manchmal wird ein "schelmisches" Programm einen anderen Ort finden, um Dateien zu überschreiben, die besser in Ruhe gelassen werden sollten. Sie können das Feature Benutzerdefinierte Systemdateien benutzen, um Ihre .INI Dateien gegen Änderungen zu schützen. Ashampoo UnInstaller Suite wird dann in der Lage sein, Änderungen an Ihren .INI Dateien genauso wiederherzustellen wie die Änderungen in der Registry.

Programme, die neue Dateien mit alten Versionen überschreiben:

Eine erstaunliche Anzahl von Windows-Installationsprogrammen scheren sich wenig darum, ob durch die Installation schon vorhandene Dateien durch ältere Versionen überschrieben werden. Kann zu unerklärlichen Problemen führen, die nur schwer zu lokalisieren sind. Sie können solche Probleme verhindern, in dem Sie die Option Speichere Versionsinformation nutzen und direkt nach der Installation einer Anwendung prüfen, ob Dateien überschrieben wurden.

Im Beispiel oben hat das Programm eine Version der Datei MSVBVM50.DLL aus dem Jahr 1998 mit einer kleineren Version aus dem Jahr 1997 überschrieben. Auch in diesem Fall besteht der einzige Schutz in der Verwendung der Backup-Funktion, um alle wichtigen Systemdateien in Kombination mit der Funktion Speichere Versionsinformation zu schützen. Bei einigen neuen Windows-Versionen können Sie das system-eigene Feature zum Schutz von Systemdateien benutzen. Nähere Hinweise entnehmen Sie bitte der Online-Hilfe Ihres Windows-Systems.

.topic 40040
Die Funktion Inkrementelles Vergleichen (Menü UnInstaller und Werkzeugleiste) ermöglicht Ihnen die Installation einer ganzen Reihe von Anwendungen und das Erzeugen einzelner Protokolle, ohne jedes mal die Konfiguration speichern zu müssen. Diese Option ist bei der Installation von Programmpaketen oder Suiten, die aus separaten Programmmodulen mit eigenen Installationsprogrammen bestehen, von Vorteil.

Diese Funktion steht nur im Experten-Modus zur Verfügung.

     Alle Operationen zum inkrementellen Vergleichen, die Sie durchführen, müssen direkt nacheinander in einer Sitzung durchgeführt werden. Bitte versuchen Sie nicht, einen inkrementellen Vergleich durchzuführen, nach dem Sie an Ihrem Computer gearbeitet haben oder neue Dateien erzeugt haben - alle Arbeiten und Dateien werden mit in das Installationsprotokoll aufgenommen!

    Wenn Sie verschiedene Teile einer Programmgruppe zu unterschiedlichen Zeiten installieren, müssen Sie die Funktionen Speichere aktuelle Konfiguration und Vergleiche (Protokoll erstellen) für jede einzelne Anwendung benutzen.

     Es ist sinnvoll, den UIWatcher in der Taskbar zu deaktivieren, bevor Sie eine manuelle Installation vornehmen. Dadurch wird verhindert, dass der UIWatcher automatisch aktiviert wird, wenn Sie ein Installationsprogramm starten, das Sie schon manuell überwachen. Klicken Sie einfach mit der rechten Maustaste auf das UIWatcher Icon in der Taskbar und wählen die Option Installationsüberwachung aktiv ab.

Vorgehensweise:

 1.	Prüfen Sie Ihre Einstellungen im Register Auswahl (Klicken Sie hier für weitere Informationen), als wenn Sie eine normale Anwendung installieren würden.

 2.	Wählen Sie Speichere aktuelle Konfiguration, um die aktuelle Konfiguration Ihres Rechners zu speichern (Siehe die Kapitel zum Installieren von Anwendungen für weitere Hinweise).

 3.	Installieren Sie die erste Anwendung. Bitte vergessen Sie nicht, die Anwendung nach der Installation  einmal zu starten und wieder zu beenden.

 4.	Falls die Ashampoo UnInstaller Suite nicht gestartet sein sollte, starten Sie das Programm bitte. Stellen Sie sicher, dass Sie die gleichen Einstellungen in den Auswahl-Registern wie unter Schritt 2 benutzt eingestellt haben.

 5.	Wählen Sie Inkrementelles Vergleichen. Dadurch wird die neue Systemkonfiguration mit der in Schritt 2 erzeugten Version verglichen. Es wird ein Protokoll gespeichert (Sie müssen wie gewohnt einen Namen angeben). Anschließend wird die neue Konfiguration als aktuelle Konfiguration definiert. Sie können dadurch zum nächsten Arbeitsschritt weitergehen, ohne die aktuelle Konfiguration speichern zu müssen.

 6.	Wiederholen Sie bitte die Schritte 3 - 5, bis Sie alle Anwendungen des Paketes oder der Gruppe installiert haben.

Wie funktioniert das?

Inkrementelles Vergleichen ist relativ einfach. Die aktuelle Konfigurationsdatei, die in Schritt 2 erzeugt wurde, heißt OldCfg.ECD. Wenn Sie einen inkrementellen Vergleich nach der Installation einer Anwendung durchführen, wird eine neue Konfigurationsdatei mit dem Namen NewCfg.ECD geschrieben. Es wird ein Vergleich zwischen der zweiten Datei und der ersten Datei durchgeführt und die Unterschiede zwischen beiden Dateien werden protokolliert. Anschließend wird die Datei OldCfg.ECD gelöscht und NewCfg.ECD in OldCfg.ECD umbenannt.

Besonderer Tipp:

Nutzen Sie für zusätzliche Sicherheit und Informationen die Funktion Backup erstellen in Verbindung mit dem Feature  Speichere Versionsinformationen. Wenn Sie nach der Installation einer Anwendung die Register Installationsprotokolle überprüfen, können Sie sofort sehen, ob wichtige Dateien mit älteren Versionen überschrieben wurden. Sie können sie dann mit den Originaldateien aus Ihrem Backup wiederherstellen. Vergessen Sie nicht die Option Gesicherte Dateien beim Wiederherstellen verwenden in den Einstellungen zu aktivieren!

.topic 40050
Konfigurationsdateien sind die Dateien, in denen die Ashampoo UnInstaller Suite die Schnappschüsse Ihrer gesamten Systemkonfiguration speichern - einschließlich der Kopien aller Einträge und Werte in der Windows Registry und Berichte über alle Dateien auf Ihrem System.

Normalerweise werden Konfigurationsdateien automatisch erzeugt. Wenn Sie Speichere aktuelle Konfiguration wählen, speichert die Ashampoo UnInstaller Suite einen Schnappschuss ihres aktuellen Systems in einer Konfigurationsdatei mit dem Namen OldCFG.ECD. Wenn Sie Vergleiche (Protokoll erstellen)  auswählen, wird vom Programm ein weiterer Schnappschuss Ihres Systems als Konfigurationsdatei mit dem Namen NewCFG.ECD erzeugt und gespeichert. Anschließend werden beide Dateien verglichen und die Unterschiede in einem Installationsprotokoll gespeichert.

Manuelles Erzeugen und Vergleichen von Konfigurationen

Wenn Sie es möchten können Sie Konfigurationsdateien manuell erzeugen und vergleichen. Sie können Namen Ihrer Wahl vergeben. Diese Option richtet sich an erfahrene Benutzer. Sie haben die volle Kontrolle über den gesamten Vergleichsvorgang.

Vorgehensweise:

 1.	Bitte prüfen Sie Ihre Einstellungen in den Auswahl-Registern und wählen dann Speichere Konfiguration unter ... im Menü UnInstaller. Sie werden zur Eingabe eines Namens aufgefordert und das Programm wird Ihr System absuchen und einen Schnappschuss der Konfiguration in einer Datei speichern.

 2.	Installieren Sie eine Anwendung oder führen Sie irgendwelche Änderungen an Ihrem System durch.

 3.	Wählen Sie erneut Speichere Konfiguration unter ..., um den Schnappschuss des neuen Systemstatus zu speichern.

 4.	Bitte prüfen Sie Ihre Einstellungen in den Auswahl-Registern und wählen dann Vergleiche zwei Konfigurationen im Menü UnInstaller. Es öffnet sich ein Dialog, in dem Sie die beiden Konfigurationsdateien auswählen und den Namen für die Protokolldatei eingeben können, in der Sie die gefundenen Unterschiede zwischen beiden Konfigurationen speichern können.

 5.	Wenn Sie dann auf OK klicken, werden beide Konfigurationen verglichen und die Unterschiede in das Protokoll geschrieben und in die Register unter Installationsprotokolle geladen. Sie können die einzelnen Register auswählen, um sich die gefundenen Unterschiede anzuschauen und wenn gewünscht wieder herstellen.

Hinweis:
Wie immer wird die Ashampoo UnInstaller Suite nur die in den Auswahl-Registern ausgewählten Einträge speichern und vergleichen. Im Allgemeinen sollten Sie in den Schritten 1 und 4 immer die gleichen Einstellungen getroffen haben. Es sei denn, dass gute Gründe dafür sprechen. Sie erhalten sonst bedeutungslose Resultate.

.topic 40060
Auswahldateien speichern alle in den Auswahl-Registern benutzten Einstellungen. Sie geben der Ashampoo UnInstaller Suite vor, nach welchen Einträgen das System abgesucht werden soll, was in den Konfigurationsdateien gespeichert und verglichen werden soll. Klicken Sie hier für weitere Informationen.

Die standardmäßige Auswahldatei

Wenn Sie irgendwelche Änderungen an Ihren Auswahl-Einstellungen vorgenommen haben, erscheint beim Verlassen ein Dialog mit der Abfrage, ob Sie die Änderungen als neuen Standard speichern wollen. Wenn Sie Ja wählen, wird Ihre aktuelle Auswahl in einer Datei mit dem Namen Last.ECS gespeichert, die automatisch beim Starten der Ashampoo UnInstaller Suite geladen wird. Dies gilt auch, wenn Sie Zurücksetzen der Auswahl im Menü Datei wählen. Dadurch wird die Auswahl verändert. Wenn Sie das Programm verlassen und die Änderungen als neuen Standard speichern, wird die Datei Last.ECS diese als neue Standardeinstellungen enthalten. (Sie können die Standardeinstellungen auch durch das Löschen der Datei Last.ECS zurücksetzen, aber dadurch werden enthaltenen Einstellungen gelöscht.)

Wann sollten Sie Ihre eigenen Auswahldateien erzeugen?

Das Speichern Ihrer Auswahl als Standard ist sinnvoll, wenn Sie diese Einstellungen beibehalten wollen. Wenn Sie zum Beispiel Ihr Laufwerk D:\ nur zur Datensicherung benutzen und keine Anwendungen installieren, können Sie das Laufwerk im Unterregister Laufwerk der Auswahl-Register abwählen. Dadurch werden die Funktionen Speichere aktuelle Konfiguration und Vergleiche (Protokoll erstellen) beschleunigt, da die  Ashampoo UnInstaller Suite ein Laufwerk weniger absuchen muss.

Die Situation ist bei speziellen Einstellung natürlich anders. Zum Beispiel wenn Sie alle Laufwerke Ihres Systems abwählen, weil Sie nur die Veränderungen in der Windows Registry, wie im Abschnitt Die Registry ausspionieren beschrieben überwachen wollen. Wenn Sie diese Einstellung nun als Standard speichern (Was sehr leicht geschehen kann), wird die   Ashampoo UnInstaller Suite viele wichtige Komponenten der Anwendungen "vermissen".
Wenn alle Laufwerke abgewählt werden, erscheint ein Warnhinweis, bevor Sie die aktuelle Konfiguration speichern. Andere subtile Änderungen an der Auswahl, die zu Problemen führen können, verursachen jedoch keine Warnmeldungen. Aus diesem Grund ist es ratsam, spezielle Einstellungen gesondert zu speichern und bei Bedarf zu laden, statt sie als Standardeinstellung zu sichern.

Wie werden Auswahldateien gespeichert und geladen?

Speichern:
Nehmen Sie alle gewünschten Änderungen in den Auswahl-Registern vor und wählen dann Speichere Auswahl in Datei im Menü Datei. Die Dateierweiterung .ECS wird automatisch von Ashampoo UnInstaller Suite angefügt.

Laden:
Wählen Sie einfach die Funktion Lade Auswahl aus Datei im Menü Datei und suchen anschließend die Datei mit Ihren Einstellungen aus dem geöffneten Dialog aus. Alle Auswahleinstellungen werden automatisch in die Auswahl-Register geladen, wenn Sie auf Öffnen klicken. Alle aktuellen Einstellungen werden überschrieben.

Siehe auch:

Die gute Auswahl von Einstellungen sind der Schlüsseln, um die besten Ergebnisse mit der Ashampoo UnInstaller Suite im Experten-Modus zu erzielen. Für weitere Informationen lesen Sie bitte die Kapitel Auswahl, Eine Auswahl speichern, Eine Auswahl als Standard speichern, Was Sie nicht auswählen sollten und Dateitypen.

.topic 40080
Ashampoo UnInstaller Suite überwacht und speichert normalerweise die Veränderungen bei Dateien zwischen zwei Zeitstempeln - gewöhnlich vor und nach der Installation einer Anwendung. Dateien, die gelöscht oder überschrieben wurden, werden in die Protokolldatei aufgenommen. Sie können aber normalerweise nicht wiederhergestellt werden, da die Originaldaten zerstört wurden.

Eine vollautomatische Wiederherstellungsfunktion für gelöschte oder überschriebene Dateien ist unmöglich, da vorher nicht bekannt ist, welche Dateien von einer Anwendung gelöscht oder überschrieben werden. Die einzige Chance bestünde in einem kompletten Backup Ihrer Festplatte nach jeder Installation einer Anwendung. Aber das ist wirklich keine praktikable Option.

Ganz so schlimm wie es klingt ist es aber nicht. Die große Mehrheit an Anwendungen speichert Dateien nur im eigenen Programmverzeichnis und den Windows- und Systemverzeichnissen. An dieser Stelle müssen Sie ansetzen: Der Inhalt der Windows- und Systemverzeichnisse ist so wichtig für Ihr System, dass eine Sicherung mehr als sinnvoll ist. Falls eine Anwendung Dateien in diesen Verzeichnissen überschreibt, können Sie die Daten mit Hilfe des Backups wiederherstellen.

Es gibt aber einige wichtige Dateien in Ihrem System, die auf jeden Fall standardmäßig durch ein Backup gesichert werden sollten. Als Schutzmaßnahme für den Fall, dass eine Anwendung diese Dateien löscht oder überschreibt. Zum Beispiel alle wichtigen Dateien in den Verzeichnissen ..\Windows\System32 und ..\Windows\System.

Über das Backup erstellen

Die Funktion Backup erstellen ist nur im Experten-Modus verfügbar. Sie können die Funktion in der Werkzeugleiste oder im Menü Werkzeuge aufrufen. Sie können eine Reihe von Ordnern und Filterkriterien bestimmen, um spezifische Dateien für das Backup aus zu wählen. Die Dateien können entweder manuell oder automatisch wiederhergestellt werden, wann immer Sie die aktuelle Konfiguration speichern. Sie können das Programm auch so einstellen, dass gelöschte oder überschriebene Dateien durch das Backup wiederhergestellt werden, wenn Sie die Wiederherstellungsfunktion benutzen.

Die Einstellungen für das Backup befinden sich in der Gruppe der Programm-Einstellungen. Sie können diese Einstellungen direkt aus dem Dialog Backup durch Klicken auf den Schalter Optionen erreichen. Bitte lesen Sie den Abschnitt Konfiguration und Setup für nähere Erläuterungen, bevor Sie das Feature Backup erstellen benutzen.

Warnung:
Die intensive Durchführung von automatischen Backups von großen Systemordnern verlangsamt das Speichern Ihrer aktuellen Konfiguration erheblich.

Besonderer Tipp:

Nutzen Sie für zusätzliche Sicherheit und Informationen die Funktion Backup erstellen in Verbindung mit dem Feature  Speichere Versionsinformationen. Wenn Sie nach der Installation einer Anwendung die Register Installationsprotokolle überprüfen, können Sie sofort sehen, ob wichtige Dateien mit älteren Versionen überschrieben wurden. Sie können sie dann mit den Originaldateien aus Ihrem Backup wiederherstellen. Vergessen Sie nicht die Option Gesicherte Dateien beim Wiederherstellen verwenden in den Einstellungen zu aktivieren!

Vorgehensweise:
Wählen Sie Backup erstellen im Menü Werkzeuge oder klicken Sie auf das Icon Backup erstellen in der Werkzeugleiste. Es öffnet sich folgender Dialog:

Klicken Sie bitte auf den Schalter Optionen und prüfen Ihre Einstellungen für das Backup.

Die Verzeichnisse für das Backup sind im Hauptfensters aufgelistet. Um einen neuen Eintrag zu erstellen, klicken Sie bitte auf Neuer Eintrag, geben Sie dann im folgenden Dialog die Suchkriterien an. Zusätzlich zur Bestimmung der Verzeichnisse können auch Filter mit einer Suchmaske angelegt werden. Sie können zum Beispiel *.dll für DLL-Dateien angeben. Dadurch werden nur die Dateien aus den ausgewählten Verzeichnissen, die Ihrem Suchtext entsprechen, eingeschlossen.

Wählen Sie dann Dateien sichern, um das Backup zu starten. Alle Dateien, die Ihren Kriterien entsprechen, werden in das angegebene Backup-Verzeichnis kopiert. Sollten Dateien durch eine Installation gelöscht oder überschrieben worden sein, sind Sie in der Lage, sie mittels der Kopien aus dem Backup-Verzeichnis wieder herzustellen. Sie können das Programm dahin gehend konfigurieren, dass gelöschte oder überschriebene Dateien automatisch mit diesen Backups wieder hergestellt werden. Siehe Konfiguration und Setup für weitere Hinweise.

   Dateien, die aktuell von Windows benutzt werden, werden nicht gesichert. Wenn Sie solche Dateien einschließen erhalten Sie eine Fehlermeldung des Betriebssystem. Klicken Sie auf OK und das Backup wird normal fortfahren. Es besteht keine Möglichkeit, dieses Problem zu umgehen und Sie brauchen auch keine Lösung dafür finden. Installationsprogramme können diese Dateien nicht überschreiben.

Welche Dateien gesichert werden sollten:

Es ist nicht notwendig und sinnvoll, alle Dateien auf Ihrem System-Laufwerk zu sichern. Sie möchten ja Ihre wichtigen Systemdateien vor dem Überschreiben durch Installationsprogramme schützen. Diese Dateien sind immer im Windows-Verzeichnis und den System-Verzeichnissen gespeichert. Da die Ashampoo UnInstaller Suite automatisch Registry-Einträge überspringt (siehe unten) können Sie Ihr gesamtes Windows-Verzeichnis ohne Risiken sichern - vorausgesetzt Sie verfügen über genügend Speicherplatz.
Ihr System-Verzeichnis ist immer ein Unterverzeichnis Ihres Windows-Verzeichnis, somit decken Sie mit einem Backup des Windows-Verzeichnis alle Anforderungen ab.

Die Vorschläge im folgenden betreffen die  Installation und Deinstallation von Anwendungen. Wenn Sie Ashampoo UnInstaller Suite zur Überwachung anderer Veränderungen an Ihrem System benutzen, sind die Anforderungen an das Backup natürlich komplett anders. Was Sie auch vorhaben: Es ist Ihnen überlassen!

      Klicken Sie hier  für weitere Informationen über eine effektive Backup-Strategie.

Windows 95, 98 und Me

 C:\Windows und das Systemverzeichnis ist C:\Windows\System. Sie werden öfters auch ein Verzeichnis C:\Windows\System32 Verzeichnis auf Windows 9x Versionen finden, das offizielle Systemverzeichnis wird aber ..\System genannt. Wenn Sie alle wichtigen Systemdateien schützen wollen, erstellen Sie einfach einen Eintrag für das Backup (Sie müssen etwas anderes als C:\WINDOWS eintragen, wenn Sie Ihr Windows in ein anderes Verzeichnis installiert haben):

Sie können als Alternative mit den drei folgenden Einträgen Platz sparen:

Dadurch wird das meiste abgedeckt. Wenn Sie absolut sicher gehen wollen, können Sie Unterverzeichnisse einbeziehen? auf Ja setzen.  Da die meisten Unterverzeichnisse von Programmen von anderen Herstellern erzeugt werden, besteht im Grunde keine Gefahr, dass hier Dateien überschrieben werden.

Windows NT4, 2000 und XP

Bei diesen Windows-Versionen ist das Windows-Verzeichnis in der Regel C:\WINNT und das Systemverzeichnis ist  C:\WINNT\SYSTEM32. Sie werden öfters auch ein Verzeichnis C:\WINNT\SYSTEM finden, das offizielle Systemverzeichnis ist ..\SYSTEM32. Der umfassende Backup-Eintrag für diese Systeme lautet:

Sie können als Alternative mit den drei folgenden Einträgen Platz sparen:

Auch hier gilt: Sie decken damit wird das meiste ab. Wenn Sie absolut sicher gehen wollen, können Sie Unterverzeichnisse einbeziehen? auf Ja setzen.  Da die meisten Unterverzeichnisse von Programmen von anderen Herstellern erzeugt werden, besteht im Grunde keine Gefahr, dass hier Dateien überschrieben werden.

#Registry-Dateien werden nicht durch das Backup wiederhergestellt:

Wenn Sie versuchen, Dateien der Windows Registry oder Verzeichnisse, die Registry-Dateien enthalten, in die Liste der Backups aufzunehmen, werden Sie von der Ashampoo UnInstaller Suite benachrichtigt, dass diese Dateien nicht in das Backup aufgenommen werden. Es handelt sich um eine Schutzmaßnahme, um die mögliche Zerstörung ihrer Systemkonfiguration zu verhindern.

Auf den ersten Blick erscheint es sinnvoll, die gesamte Registry in das Backup zu integrieren und wiederherzustellen. In Wirklichkeit handelt es sich aber um ein denkbar schlechte Idee.

Zunächst einmal müssen Sie die Registry-Dateien nicht durch Backups wiederherstellen. Die Ashampoo UnInstaller Suite überwacht und stellt alle individuellen Veränderungen der Registry durch Programm-Installationen oder sonstigen System-Modifikationen wieder her. Außerdem würden Sie beim Wiederherstellen der Registry mittels Backups automatisch alle anderen Veränderungen der Registry überschreiben.

Ein Beispiel, warum Sie die gesamte Registry nicht wiederherstellen sollten:

Stellen Sie sich folgenden Vorgang vor: Sie erstellen ein Backup der Registry-Dateien und installieren die Anwendung A, überwachen die Installation und erstellen mit der Ashampoo UnInstaller Suite ein Installationsprotokoll. Etwas später installieren Sie eine Anwendung B. Nach der Installation der Anwendung B entschließen Sie sich, die Anwendung A zu entfernen. Sie laden das entsprechende Installationsprotokoll und schreiben alle Veränderungen, die mit der Installation von Anwendung A verbunden sind, zurück.

Wenn Sie ein Backup der Registry-Dateien erstellt haben, stellen Sie die Dateien aus dem Backup wieder her, bevor Sie die Anwendung A installiert haben. Das Problem besteht darin, dass alle Einträge der Registry für die Anwendung B nach der Installation der Anwendung A geschrieben wurden. Durch das Backup werden alle Einträge der Anwendung B überschrieben - einschließlich aller anderen in der Zwischenzeit veränderten Registry-Einträge. Im schlimmsten Fall werden Sie die Anwendung B nicht mehr benutzen können. Sie werden darüber hinaus feststellen müssen, dass viele wichtige Informationen zur Konfiguration und Systemdaten fehlen.

Welche Dateien sind denn nun Registry-Dateien?

In Windows® 95, 98 und Me ist die Registry in zwei verborgenen Dateien in Ihrem Windows-Verzeichnis gespeichert. Es sind die Dateien USER.DAT und SYSTEM.DAT. In Windows® NT4, 2000 und XP ist die Registry an verschiedenen Orten in den Verzeichnissen \winnt\system32\config und \Dokumente und Einstellungen\{Benutzername} gespeichert.

Unter Windows® 95, 98 und Me können Sie Ihr ...\Windows Verzeichnis in Ihr Backup aufnehmen, wenn Sie darin enthaltene andere Dateien sichern wollen, da die Ashampoo UnInstaller Suite automatisch die Registry-Dateien ausschließt. Bei den Betriebssystemen  Windows® NT4, 2000 und XP sollten Sie das Verzeichnis ...\winnt\system32\config nicht aufnehmen, da es nur Registry-Dateien enthält (Es wird keine Zerstörung nach sich ziehen, es macht nur absolut keinen Sinn!). Sie können die Verzeichnisse \Dokumente und Einstellungen\{Benutzername} aufnehmen, wenn Sie andere Dateien in diesen Verzeichnissen wiederherstellen möchten. Registry-Dateien werden automatisch übersprungen.

.topic 40090
Da die Ashampoo UnInstaller Suite in der Lage ist, alle Veränderungen an Ihrem System zwischen zwei Zeitpunkten zu überwachen und anzuzeigen, können Sie das Programm als ein wirklich mächtiges und flexibles Werkzeug zur Systemüberwachung und zur Fehlersuche (Debugging)  benutzen. Erfahrene Benutzer werden feststellen, dass es sich um eines der nützlichsten Features der Ashampoo UnInstaller Suite handelt. Viele Benutzer verwenden das Programm mehr zum Ausspionieren der Registry und des Restes Ihres System denn als Programm zur Deinstallation von Programmen!

Finden Sie heraus, wo Einstellungen gespeichert werden

Angenommen Sie möchten herausfinden, wo und wie Windows selbst oder eine Anwendung die Einstellungen zur Aktivierung oder Deaktivierung von speziellen Features speichert. Alles was Sie tun müssen, ist Ihre aktuelle Konfiguration mit der Ashampoo UnInstaller Suite abzuspeichern, die Einstellungen zu ändern und dann Vergleiche (Protokoll erstellen) durchführen. Wenn Sie dann einen Blick in die Register unter Installationsprotokolle werfen, sehen Sie auf Anhieb alles, was mit den Einträgen verbunden ist, einschließlich Registry-Schlüssel, Registry-Werte, Dateien und Einträgen zu Systemdateien.

Erstellen Sie Ihre eigenen Windows Tuning-Funktionen mit Ashampoo PowerUp XP

Wir benutzten den gleichen Denkansatz beim Ausspionieren der Registry für viele Funktionen, die in unserem Windows-Konfigurations- und Tuning-Programm Ashampoo PowerUp XP integriert sind. Und da Ashampoo PowerUp XP über einen Funktions-Editor verfügt, können Sie das Programm mit der Ashampoo UnInstaller Suite zusammen einsetzen, um Ihre eigenen Windows-Funktionen zu erstellen, die Sie mit nur wenigen Klicks aktivieren oder deaktivieren können.

Besuchen Sie die  Ashampoo PowerUp XP Produktseite im Internet!

Benutzen Sie die Ashampoo UnInstaller Suite als mächtiges Werkzeug zur Fehlersuche

Stellen Sie sich vor, Sie möchten ein Programm "debuggen" (kontrollieren), dass nicht einwandfrei läuft. Mit der gleichen Prozedur wie oben bereits beschrieben können Sie prüfen, ob das Programm auch die richtigen Registry-Schlüssel in die Registry schreibt. Das Protokoll wird alle zusätzlichen Schlüssel offenbaren, bei denen Sie keine Änderungen wahrgenommen haben.

Weitere Einsatzmöglichkeiten

Die Möglichkeiten sind nahezu unbegrenzt - Sie können mit der Ashampoo UnInstaller Suite alle Änderungen an Ihrem System überwachen! Sie können das Programm vor und nach dem Surfen im Internet benutzen, um festzustellen, was Ihr Internet Browser und die Webseiten auf Ihrem Rechner abspeichern. Sie können das Programm vor und nach dem Benutzen von Programm verwenden, um zu sehen, wo und wie Konfigurationseinstellungen gespeichert werden. Sie werden sicherlich noch eigene Ideen entwickeln.

Vorgehensweise

Der erste Schritt liegt in der Entscheidung was Sie überwachen möchten - nur die Registry oder die Registry und die Systemdateien. Wenn Sie herausfinden möchten, wo Programmeinstellungen gespeichert werden, sollten Sie alles überwachen. Sie wissen nie, ob die Programme einen Registry-Eintrag oder eine Datei benutzen. Sie könnten auch die Überwachung aller Laufwerke ins Auge fassen, da versteckte Einstellungen oft an "unmöglichen" Stellen gespeichert werden. Wenn Sie die Windows Registry ausspionieren, ist es sicher, nur die Registry zu überwachen, da fast alle Aktivitäten von Windows selbst hier gespeichert sind.

Erstellen Sie Auswahldateien für besondere Zwecke
Wenn Sie nur die Registry überwachen wollen oder andere spezielle Auswahl-Einstellungen benutzen wollen, die nicht zur Überwachung von Installationen passen, sollten Sie spezielle Auswahldateien erzeugen, die Sie nur zu diesem Zweck nutzen. Wenn Sie spezielle Auswahl-Einstellungen als neuen Standard gespeichert haben, kann das leicht in Vergessenheit geraten und Sie würden diese Einstellung bei der Installation einer Anwendung benutzen.

 1.	Starten Sie die Ashampoo UnInstaller Suite. Prüfen Sie Ihre Auswahl in den Auswahl-Registern und ändern Sie notfalls die Einstellungen. Wenn Sie spezielle Auswahldateien für die besondere Aufgabe erzeugt haben, laden Sie diese mit der Option Lade Auswahl aus Datei im Menü Datei.

 2.	Wenn Sie versuchen, eine bestimmte Einstellung zu lokalisieren, sollten Sie alles so einstellen, um die Einstellung an diesem Punkt zu ändern. Starten Sie zum Beispiel die Systemsteuerung, um Windows-Einstellungen zu ändern oder führen alle notwendigen Vorbereitungen mit einem anderen Programm (welches Sie überwachen wollen) durch. Die nächste Operation sollte dann die sein, die Sie ausspionieren wollen. Sie verhindern dadurch, dass das Protokoll zu viele überflüssige Einträge enthält.

 3.	Wählen Sie Speichere aktuelle Konfiguration im Menü UnInstaller oder der Werkzeugleiste.

      Sie können auch die Option Speichere Konfiguration unter ... benutzen. Sie können selbst den Namen für Ihre  Konfigurationsdatei vergeben. Wenn Sie diese Option nutzen, müssen Sie diese Datei wieder in Schritt 5 anstelle der Funktion Vergleiche (Protokoll erstellen) benutzen.

 4.	Nehmen Sie die Änderungen vor, die Sie überwachen möchten. Um das Erzeugen von "überflüssigen Änderungen" zu vermeiden, sollten Sie während dessen die Ashampoo UnInstaller Suite laufen lassen. Bitte vermeiden Sie sonstige Aktivitäten an Ihrem Computer.

 5.	Wählen Sie Vergleiche (Protokoll erstellen) im Menü UnInstaller oder in der Werkzeugleiste.

      Wenn Sie die Option Speichere Konfiguration unter ... wie in Schritt 3 verwendet haben, benutzen Sie bitte Vergleiche (Protokoll erstellen) hier nicht! Statt dessen benutzen Sie zunächst wieder Speichere Konfiguration unter ..., anschließend Vergleiche zwei Konfigurationen (Beide Optionen sind im Menü UnInstaller verfügbar).

 6.	Zusätzlich zur Aufzeichnung in den Protokollen werden die gefundenen Änderungen automatisch in die Unterregister Änderungen des Registers Installationsprotokolle geladen. Sie können damit die Änderungen direkt sehen.

Export der gefundenen Änderungen in eine Textdatei

Nach dem Sie die Änderungen entdeckt haben, möchten Sie diese Änderungen in eine Textdateien als Referenz speichern. Klicken Sie einfach mit der rechten Maustaste in das Register Installationsprotokolle und wählen Daten exportieren aus dem PopUp Menü. Dadurch erzeugen Sie eine kommentierte ASCII-Datei mit allen Informationen, die Sie zum Identifizieren der gefundenen  Einstellungen benötigen.

      Die Export-Funktion exportiert immer den aktuellen Eintrag und dessen Untereinträge. Wenn Sie zum Beispiel das Icon Arbeitsplatz im Unterregister Änderungen in der Registry auswählen, werden alle in der gesamten Registry gefundenen Änderungen in eine Textdatei exportiert. Das gilt auch für die Unterregister.

Benutzen Sie den inkrementellen Vergleich für "Spionage-Sequenzen"

Wenn Sie eine Reihenfolge von Änderungen herausfinden möchten, benutzen Sie bitte Inkrementelles Vergleichen in Schritt 5 statt Vergleichen. Sie können dann die nächste Änderung direkt anschließend durchführen, ohne die Funktion Speichere aktuelle Konfiguration wieder ausführen zu müssen. Siehe Inkrementelles Installieren & Vergleichen für weitere Hinweise.

Wenn Sie die Änderungen in Textdateien exportieren möchten, vergessen Sie bitte nicht, die Export-Funktion nach jedem inkrementellen Vergleich aufzurufen.

.topic 40095
Wenn Sie Windows intensiv nutzen, können Sie auf Shareware-Programme treffen, die über keinen UnInstaller verfügen. Die Anweisungen zur Installation sind in der Regel wie folgt: "Bitte legen Sie ein Verzeichnis an, kopieren Sie alle Dateien in diesem Ordner und klicken anschließend doppelt auf die Datei program.exe, um das Programm zu starten."

Sie mögen nun denken, dass die Überwachung einer solchen Installation eines solchen Programms unnötig ist. Ebenso könnte man meinen, man braucht nur den Ordner und dessen Inhalt zu löschen, um das Programm vollständig vom System zu entfernen. Es ist eine verständliche Annahme, aber leider falsch.

Es gibt zwei wesentliche Probleme mit solchen Programmen:

 1.	Selbst wenn das Programm nicht über einen Installer verfügt, "installiert" es sich selbst beim ersten Programmstart gewöhnlich durch das Schreiben einer Vielzahl von Einträgen in die Windows Registry. Wenn Sie später das Programmverzeichnis und dessen Inhalt löschen, bleiben die Einträge in der Registry "verwaist" zurück. Das ist zwar kein großes Problem, Sie sollten diese verwaisten Einträgen jedoch entfernen. Sie halten Ihr System schlank und vermeiden das "Aufblasen" Ihrer Registry.

 2.	Sehr oft verwenden diese Programm gemeinsam benutzte Dateien, die auf Ihrem System installiert sind. Das ist das eigentliche Problem. Wenn ein solches Programm zum ersten Mal läuft, sucht es die benötigte DLL und registriert sich selbst als Benutzer, was Zugriffszähler erhöht (Siehe Gemeinsam benutzte Dateien für weitere Hinweise zu diesem Thema). Wenn Sie einfach das Programmverzeichnis und die darin enthalten Dateien löschen, bleibt der Zähler auf einem falschen Wert stehen. Diesen Umstand möchten Sie ja vermeiden.  Das Problem ist nicht unbedingt gravierend. Der Zählerstand wird immer eher zu hoch als zu niedrig sein. Im schlimmsten Fall wird die fragliche DLL nie von Ihrem System entfernt, weil der Zählerstand nie auf Null sinken wird.

Wenn Sie solche Probleme vermeiden möchten, benutzen Sie die Ashampoo UnInstaller Suite um die "Installation" von Programmen ohne Installer zu überwachen.

Vorgehensweise:

 1.	Starten Sie die Ashampoo UnInstaller Suite und prüfen die Einstellungen in den Auswahl-Registern. Wählen Sie Zurücksetzen der Auswahl im Menü Datei, wenn Sie die Standardauswahl für die Installation von Anwendungen nutzen möchten.

 2.	Wählen Sie Speichere aktuelle Konfiguration im Menü UnInstaller oder in der Werkzeugleiste.

    Wenn Sie möchten, können Sie die Ashampoo UnInstaller Suite jetzt verlassen.

 3.	Erstellen Sie jetzt ein neues Programmverzeichnis für die Anwendung und kopieren alle Dateien des Programms in dieses Verzeichnis. Starten Sie dann das neue Programm mindestens einmal, führen alle notwendigen Einstellungen in dem Programm durch und verlassen es wieder.

    Sie Windows erneut starten oder sogar Ihren Rechner aus- und wieder einschalten. Das wird den Vorgang nicht beeinträchtigen. Sie sollten aber nichts anderes machen. Bitte starten Sie keine anderen Programme oder erstellen irgendwelche Dateien. Sie würden sonst in das Installationsprotokoll aufgenommen werden!

 4.	Sollte die Ashampoo UnInstaller Suite nicht laufen, starten Sie das Programm wieder. Vergewissern Sie sich, dass Sie die gleichen Einstellungen in den Auswahl-Registern verwenden, die Sie auch zum Speichern der aktuellen Konfiguration wie in Schritt 2 benutzt haben.

    Wählen Sie anschließend Vergleiche (Protokoll erstellen) im Menü UnInstaller oder der Werkzeugleiste und geben den Namen für das Installationsprotokoll ein. Sobald der Vergleich abgeschlossen ist, können Sie die neuen Inhalte in den Registern Installationsprotokolle untersuchen, um alle durch das Programm erzeugten Änderungen zu betrachten. Es ist manchmal erstaunlich, wie viele Einträge von einem Programm erzeugt werden, was "nur in ein Verzeichnis kopiert und gestartet" wurde!

Hinweis:
Wenn Sie das Programmverzeichnis und die Dateien nicht in das Installationsprotokoll aufnehmen möchten, müssen Sie lediglich Schritt 2 nach dem Erstellen des Verzeichnisses und dem Kopieren der Dateien in das Verzeichnis durchführen. Alternativ können Sie auch alle Festplatten im Unterregister Laufwerke im Auswahl-Register abwählen. Dann werden die Verzeichnisse und Dateien ignoriert.

.topic 40100
Mit Hilfe dieser Anweisungen können Sie unseren eigenen Anspruch an die Ashampoo UnInstaller Suite, eine weitaus bessere Leistung bei der Deinstallation von Anwendungen als die mitgelieferten UnInstaller zu erzielen, testen.

Bevor Sie beginnen:

Die Ashampoo UnInstaller Suite muss sich im Experten-Modus befinden, um diesen Test durchzuführen.

Diese Anweisungen setzen voraus, dass Sie bereits über einige Erfahrungen mit der Ashampoo UnInstaller Suite verfügen. Sollten Ihnen die folgenden Hinweise zu schwierig erscheinen, lesen Sie bitte zunächst die Erläuterungen in den Abschnitten  Anwendungen installieren und Anwendungen deinstallieren.

     Es ist sinnvoll, den UIWatcher in der Taskbar zu deaktivieren, bevor Sie eine manuelle Installation vornehmen. Dadurch wird verhindert, dass der UIWatcher automatisch aktiviert wird, wenn Sie ein Installationsprogramm starten, das Sie schon manuell überwachen. Klicken Sie einfach mit der rechten Maustaste auf das UIWatcher Icon in der Taskbar und wählen die Option Installationsüberwachung aktiv ab.

Vorgehensweise:

 1.	Starten Sie die Ashampoo UnInstaller Suite und wählen die zu überwachenden Einträge in den Auswahl-Registern. Wenn Sie wollen können Sie die Option Zurücksetzen der Auswahl im Menü Datei wählen, um die Auswahl auf den Standard zurückzusetzen.  Bitte vergessen Sie nicht, das Register Laufwerke zu prüfen. Alle lokalen Laufwerke sind standardmäßig ausgewählt. Sie können diese Einstellung ändern. Wenn es das erste Mal ist, dass Sie die Ashampoo UnInstaller Suite benutzen, ist es ratsam, die standardmäßige Auswahl für die Registry nicht zu ändern. Siehe den Abschnitt Eine Auswahl speichern für weitere Hinweise.

 2.	Wählen Sie anschließend Speichere aktuelle Konfiguration (Menü UnInstaller oder Werkzeugleiste). Es wird dadurch ein Schnappschuss Ihres gesamten Systems erzeugt, einschließlich aller Dateien, Verzeichnisstrukturen, der Registry und der Systemdateien.

 3.	Beenden Sie die Ashampoo UnInstaller Suite und installieren eine große Anwendung auf Ihrem Rechner (Im Idealfall ein umfangreiches Office-Paket oder eine Bildbearbeitungs-Software). Die Ashampoo UnInstaller Suite muss dazu nicht gestartet sein, um den Vorgang der Installation zu überwachen; es werden keine Veränderungen geprüft bis die Installation vollständig abgeschlossen ist.

      Wichtig: Es muss sich um die erste Installation der ausgewählten Anwendung auf Ihrem Rechner handeln! Bitte versuchen Sie nicht, die Anwendung über eine bestehende Installation zu installieren. Sollten Sie es dennoch vornehmen, wird das Programm nicht in der Lage sein, viele Einträge zu "sehen", da sie ja bereits auf Ihrem Rechner vorhanden sind. Im Endeffekt würde nichts Neues hinzugefügt sein!

 4.	Starten und beenden Sie die Anwendung bitte mindestens einmal (Alle Anwendungen, wenn es sich um eine Suite handelt). Siehe den Abschnitt Warum Anwendungen vor dem Protokollieren starten? zu den notwendigen Gründen.

 5.	Starten Sie die Ashampoo UnInstaller Suite bitte wieder und führen die Funktion Vergleiche (Protokoll erstellen) (Werkzeugleiste oder Menü   UnInstaller), um die neue Systemkonfiguration mit der in Schritt 2 gespeicherten Version zu vergleichen und das Installationsprotokoll zu speichern. Bitte benutzen Sie den Namen der Anwendung für das Protokoll. Sie können es dann später leichter identifizieren.

    Der Inhalt des Protokolls wird automatisch in den Registern Installationsprotokolle angezeigt. Sie können sich alle Veränderungen an Ihrem System, die durch die Installation der Anwendung vorgenommen wurden, anschauen. Klicken Sie einfach auf die Einträge in den Registern.

 6.	Jetzt kommt der lustige Teil der Arbeit: Entfernen Sie die gerade installierte Anwendung mit Hilfe der mitgelieferten Deinstallations-Routine (In der Systemsteuerung im Abschnitt Programme hinzufügen/entfernen oder in der Programmgruppe der Anwendung im Windows-Startmenü) oder anderer Windows-Deinstaller.

 7.	Starten Sie die Ashampoo UnInstaller Suite und wählen erneut Vergleiche (Protokoll erstellen) - ohne jedoch die Funktion Speichere aktuelle Konfiguration auszuführen, um ein anderes Protokoll mit einem anderen Namen zu erzeugen. Es werden alle durch die Anwendung installierten Komponenten angezeigt, die vom eigenen UnInstaller nicht entfernt wurden. Bleiben nur wenige Komponenten zurück, handelt es sich um eine gute Routine. In der Regel finden Sie jedoch eine erstaunliche Anzahl an Dateien und Registry-Einträgen. Sie können die Ashampoo UnInstaller Suite jetzt dazu benutzen, um diese Komponenten ebenfalls zu entfernen (Siehe die Erläuterungen im Abschnitt Anwendungen deinstallieren).

.topic 40110
Die Ashampoo UnInstaller Suite ist in der Lage, jegliche Änderungen an der System-Konfiguration zu protokollieren und wieder zurückzusetzen. Dabei spielt es keine Rolle, ob die Änderungen automatisch durch ein Installationsprogramm oder von Ihnen von Hand durchgeführt wurden. Sie können das Programm dazu benutzen, sich selbst vor den negativen Konsequenzen beim Experimentieren mit der System-Konfiguration zu schützen. Sie speichern einfach Ihre aktuelle Konfiguration, nehmen Änderungen, führen einen Vergleich durch und zeichnen die Änderungen in einem Protokoll mit. Wenn Ihnen die eigenen Änderungen nicht gefallen, können Sie das Protokoll laden und die Änderungen zurücksetzen. Ihr System wird auf den Status zurückgesetzt, den es beim Speichern der Konfiguration im ersten Schritt hatte.

Arbeiten Sie bitte sorgfältig!

Obwohl in die Ashampoo UnInstaller Suite einige Sicherheitsfunktionen eingebaut sind, bestehen doch einige Einschränkungen hinsichtlich seiner Fähigkeiten. Das Programm kann Sie zum Beispiel nicht davor schützen, dass durch die Bearbeitung der Registry ein Neustart von Windows unmöglich geworden ist. Sie können dann das Programm nicht mehr starten, um die Änderungen rückgängig zu machen!

Selbst wenn Sie durch die Ashampoo UnInstaller Suite geschützt sind, sollten Sie die notwendigen Schritte unternehmen, um sich selbst vor einer solchen Katastrophe zu schützen. Bitte erstellen Sie Sicherungen Ihrer Registrydateien und halten Sie Ihre Notfall- und Reparaturdisketten auf den aktuellen Stand. Für weitere Hinweise suchen Sie in Ihrer Windows-Hilfe nach Begriffen wie: Notfalldiskette, Reparaturdiskette, Backup, Dateisicherung etc.

Der beste Schutz ist immer ein komplettes Image-Backup Ihres gesamten Systems. Sie können dazu professionelle Backup-Software wie DriveImage von PowerQuest oder Norton Ghost von Symantec benutzen. Diese Programme sind in der Lage, ein komplettes, funktionierendes Backup Ihres Standardsystems zu erstellen, was Sie in wenigen Minuten wiederherstellen können. Der einzige Nachteil besteht darin, dass Sie Ihr gesamtes System-Laufwerk überschreiben.

Vorgehensweise:

Der erste Schritt liegt in der Entscheidung darin, was Sie überwachen möchten - nur die Registry oder die Registry, Dateien und Systemdateien. Ihre Auswahl hier hängt von Ihren geplanten Aktionen ab.

   Wenn Sie planen, Änderungen vorzunehmen, die Dateien löschen oder überschreiben, sollten Sie die Verwendung des Features Backup erstellen in Erwägung ziehen, damit Sie wichtige gelöschte oder überschriebene Dateien wiederherstellen können.

Erstellen Sie Auswahldateien für besondere Zwecke
Wenn Sie nur die Registry überwachen wollen oder andere spezielle Auswahl-Einstellungen benutzen wollen, die nicht zur Überwachung von Installationen passen, sollten Sie spezielle Auswahldateien erzeugen, die Sie nur zu diesem Zweck nutzen. Wenn Sie spezielle Auswahl-Einstellungen als neuen Standard gespeichert haben, kann das leicht in Vergessenheit geraten und Sie würden diese Einstellung versehentlich bei der Installation einer Anwendung benutzen.

 1.	Starten Sie die Ashampoo UnInstaller Suite. Prüfen Sie Ihre Auswahl in den Auswahl-Registern und ändern Sie notfalls die Einstellungen. Wenn Sie spezielle Auswahldateien für die besondere Aufgabe erzeugt haben, laden Sie diese mit der Option Lade Auswahl aus Datei im Menü Datei.

 2.	Wählen Sie Speichere aktuelle Konfiguration im Menü UnInstaller oder der Werkzeugleiste.

      Sie können auch die Option Speichere Konfiguration unter ... benutzen. Sie können selbst den Namen für Ihre  Konfigurationsdatei vergeben. Wenn Sie diese Option nutzen, müssen Sie diese Datei wieder in Schritt 5 anstelle der Funktion Vergleiche (Protokoll erstellen) benutzen.

 3. Nehmen Sie die Änderungen vor, die Sie überwachen wollen. Sie können die Ashampoo UnInstaller Suite während dessen verlassen. Es besteht keine Notwendigkeit darin, dass das Programm läuft.

 4.	Wählen Sie Vergleiche (Protokoll erstellen) im Menü UnInstaller oder in der Werkzeugleiste.

       Wenn Sie die Option Speichere Konfiguration unter ... wie in Schritt 2 verwendet haben, benutzen Sie bitte Vergleiche (Protokoll erstellen) hier nicht! Statt dessen benutzen Sie zunächst wieder Speichere Konfiguration unter ..., anschließend Vergleiche zwei Konfigurationen (Beide Optionen sind im Menü UnInstaller verfügbar).

 5.	Zusätzlich zur Aufzeichnung in den Protokollen werden die gefundenen Änderungen automatisch in die Unterregister Änderungen des Registers Installationsprotokolle geladen. Sie können damit sehen, wie Ihre Aktionen an der Konfiguration implementiert wurden.

Sie können Ihr Windows neu starten und Ihre neue Konfiguration testen. Wenn alles in Ordnung ist, belassen Sie es dabei. Wenn Sie nicht zufrieden mit dem Ergebnis sind, wählen Sie die Option Lade Auswahl aus Datei im Menü Datei oder in der Werkzeugleiste und machen alle oder einige Änderungen wieder rückgängig.

Export der Ergebnisse in eine Textdatei

Sie können die Aufzeichnungen Ihrer Änderungen an der Konfiguration in eine Textdateien als Referenz speichern. Klicken Sie einfach mit der rechten Maustaste in das Register Installationsprotokolle und wählen Daten exportieren aus dem PopUp Menü. Dadurch erzeugen Sie eine kommentierte ASCII-Datei mit allen Informationen, die Sie zum Identifizieren der gefundenen Einstellungen benötigen.

      Die Export-Funktion exportiert immer den aktuellen Eintrag und dessen Untereinträge. Wenn Sie zum Beispiel das Icon Arbeitsplatz im Unterregister Änderungen in der Registry auswählen, werden alle in der gesamten Registry gefundenen Änderungen in eine Textdatei exportiert. Das gilt auch für die Unterregister.

Benutzen Sie den inkrementellen Vergleich für "Spionage-Sequenzen"

Wenn Sie eine Reihenfolge von Änderungen herausfinden möchten, benutzen Sie bitte Inkrementelles Vergleichen in Schritt 4 statt Vergleichen. Sie können dann die nächste Änderung direkt anschließend durchführen, ohne die Funktion Speichere aktuelle Konfiguration wieder ausführen zu müssen. Siehe Inkrementelles Installieren & Vergleichen für weitere Hinweise.

Wenn Sie die Änderungen in Textdateien exportieren möchten, vergessen Sie bitte nicht, die Export-Funktion nach jedem inkrementellen Vergleich aufzurufen.

.topic 40120
Die Funktion Installationsdateien erzeugen im Menü Werkzeuge ist tolles Feature, mit dem Sie Installation von Anwendungen auf mehreren Rechnern oder Festplatten "klonen" können, ohne sich jedes mal durch die gesamte Setup-Routine der Anwendung durcharbeiten zu müssen. Das Programm benutzt das Installationsprotokoll der Anwendung, die mit der Funktionen Vergleichen  erzeugt wurde, um ein Set von .REG, .INF und .VBS Dateien zu generieren, die Sie als Basis zur "geklonte" Installationen benutzen können.

Nur für erfahrene Benutzer!

Diese Funktion richtet sich an erfahrene Benutzer und Systemadministrator mit fundierten Kenntnissen über das Format, die Syntax und den Gebrauch von .REG, .INF und .VBS Dateien. Sie sollten nicht versuchen, diese Dateien direkt zum Klonen von Installationen zu verwenden. Obwohl die Ashampoo UnInstaller Suite das meiste der Arbeit erledigt, sollten die erzeugten Dateien als Rohmaterial angesehen werden, das Sie entsprechend bearbeiten müssen, um die "Klon"-Dateien zu erstellen.

Es ist eigentlich überflüssig zu erwähnen, aber Sie können diese Methode nur zum Klonen von Installationen auf Rechnern mit identischen Verzeichnis- und Registry-Strukturen, einschließlich aller betroffenen Abschnitte, verwenden!

Vorgehensweise:

 1.	Installieren Sie die Anwendung, die Sie klonen möchten, auf Ihren Hauptrechner und protokollieren Sie die Installation  mit der Ashampoo UnInstaller Suite.

 2.	Stellen Sie sicher, dass das in Schritt 1 erzeugte Installationsprotokoll geladen ist (Laden Sie es wenn nötig mit der Option Lade Auswahl aus Datei im Menü Datei).

 3.	Wählen Sie Installationsdateien erzeugen im Menü Werkzeuge.

 4.	Wählen Sie die Einträge zum Export in der Dialogbox und geben den Pfad und den Dateinamen im darauf folgenden Dialog ein.

      Bitte geben Sie keine Dateierweiterung ein! Der gleiche Dateiname wird für alle drei erzeugten Dateitypen benutzt.

.topic 40130
Das Unterregister Registry im Register Auswahl: Registry & Laufwerke enthält einen Funktions-Editor, mit dem Sie bestehende Registry-Einträge und neue Werte und Schlüssel hinzufügen können. Sie haben über das Fenster Werte in den Registern Installationsprotokolle auch Zugriff auf den Registry-Editor.

Um den Editor aufzurufen, klicken Sie einfach mit Rechts auf einen Wert oder Schlüssel in eines der Fenster im Register Registry unter Auswahl: Registry & Laufwerke:

Das Bearbeiten der Registry sollten nur erfahrene Benutzer durchführen!

Bitte seien Sie extrem vorsichtig, wenn Sie die Windows Registry bearbeiten. Führen Sie Änderungen nur durch, wenn Sie sich absolut sicher über Ihre Aktionen sind. Bitte sichern Sie Ihre Registry mit Hilfe eines Backups, bevor Sie Änderungen vornehmen. Unbedachte Änderungen der Registry können Fehlfunktionen von Windows provozieren und in seltenen Fällen das ganze System gefährden!

Bitte führen Sie immer ein Backup Ihrer Systemdateien durch und halten Sie Ihre Notfall- und Reparaturdisketten auf dem aktuellsten Stand. Für detaillierte Anweisungen suchen Sie bitte Ihre Windows-Hilfe nach folgenden Begriffen ab: Notfalldisketten, Registrierung, Backup (-Programm) etc.

Werte editieren:

Werte hinzufügen:

Hinzufügen und Löschen von Schlüsseln:

Löschen von Schlüsseln:

Klicken Sie mit der rechten Maustaste auf den Schlüssel, den Sie löschen möchten, im linken Fenster (Verzeichnis) des Registers Registry und wählen Schlüssel löschen aus dem PopUp Menü.

Bitte seien Sie vorsichtig! Der Schlüssel wird für immer aus der Registry gelöscht!

.topic 40140
Die Ashampoo UnInstaller Suite erlaubt Ihnen das Hinzufügen von benutzerdefinierten Dateien zur Standardliste im Register Systemdateien, die normalerweise folgende Dateien enthält: WIN.INI, SYSTEM.INI, CONFIG.SYS und AUTOEXEC.BAT. Sie können dadurch Änderungen an diesen Dateien überwachen und sie mit der Wiederherstellungsfunktion des Programmes wieder rückgängig machen.

Hinweis:
Die Einträge für diese Dateien sind im Register Systemdateien für alle Windows-Systeme einbezogen, obwohl einige oder keine von ihnen noch wirklich von neueren Windows-Versionen gebraucht werden. Der Grund liegt darin, dass sie immer noch manchmal von Anwendungen benutzt werden und einige Kommandos und Einstellungen, die von Anwendungen dort eingetragen werden, von Windows abgearbeitet werden. Obwohl beispielsweise Windows® NT4, 2000 und XP nicht mehr länger auf DOS basieren, werden die DOS-Konfigurationsdateien CONFIG.SYS und AUTOEXEC.BAT weiterhin von diesen Betriebssystemen abgearbeitet, wenn sie vorhanden sind und relevante Einstellungen enthalten.

Unterstützte Typen benutzerdefinierter Systemdateien

Sie können zwei verschiedene Typen von benutzerdefinierten Systemdateien hinzufügen: Gewöhnliche Textdateien wie AUTOEXEC.BAT und INI-Dateien, die dem standardmäßigen INI-Format entsprechen. Die Ashampoo UnInstaller Suite wird die Änderungen in beiden Dateitypen überwachen, kann aber nur die Änderungen in den INI-Dateien umkehren. Wenn Sie Änderungen an Textdateien umkehren möchten, sollten Sie die Funktion Backup erstellen benutzen und die Option Gesicherte Dateien beim Wiederherstellen werden in den Einstellungen verwenden.

Dieses Feature ermöglicht Ihnen die Überwachung und Wiederherstellung von vielen INI-Dateien anderer Anwendungen, die normalerweise im Windows- und Systemverzeichnis oder den programmeigenen Verzeichnissen gespeichert werden.

Wie Sie benutzerdefinierte Systemdateien hinzufügen können:

Die Ashampoo UnInstaller Suite wird nur Änderungen in INI-Dateien, die der standardmäßigen Syntax (siehe unten) entsprechen, überwachen und wiederherstellen. Die Kopfzeilen der Abschnitte müssen in eckige Klammern eingefasst sein und die Angaben zu den Einträgen müssen exakt eingegeben werden. Zur Erläuterung schauen Sie sich bitte die auf Ihrem Computer gespeicherten INI-Dateien an.

[Abschnitt 1]
Eintrag1=Wert1
Eintrag2=Wert2
...
[Abschnitt 2]
Eintrag2=Wert2
Eintrag2=Wert22
...

Die Ashampoo UnInstaller Suite wird Dateien, die diesem Format entsprechen, in der gleichen Weise behandeln wie WIN.INI und SYSTEM.INI und erlaubt es Ihnen, einzelne Einträge zur Überwachung aus- oder abzuwählen. Sie können geänderte oder gelöschte Einträge aus Protokollen wiederherstellen, genauso wie Sie Einträge in der Registry wiederherstellen können.

.topic 40150
Sie können die Ashampoo UnInstaller Suite im Batchmodus über die Kommandozeile oder durch Batchdateien ausführen:

Kommandozeilen-Parameter für den Batchmodus:

UNINSTALLER.EXE /STORECONFIG [Dateiname]

Speichert die aktuelle Konfiguration des Rechners in die angegebene Datei [Dateiname] -- bitte die eckigen Klammern nicht einfügen! Dieser Aufruf entspricht den folgenden manuellen Schritten:

 1.	Starten der Ashampoo UnInstaller Suite.

 2.	Durchführung von Speichere aktuelle Konfiguration

 3.	Beenden der Ashampoo UnInstaller Suite.

     Der Parameter [Dateinamen] ist optional. Wenn Sie keinen Namen eingeben, wird der standardmäßige "Bevor"-Schnappschuss OldCfg.ECD (durch Speichere aktuelle Konfiguration erstellt) per Voreinstellung verwendet.

UNINSTALLER.EXE /COMPARE [Name der Protokolldatei] [Alte ECD Datei] [Neue ECD Datei]

Generiert ein Installationsprotokoll mit dem angegebenen Namen [Name der Protokolldatei].  Dieser Aufruf entspricht den folgenden manuellen Schritten:

 1.	Starten der Ashampoo UnInstaller Suite.

 2.	Durchführung von Vergleiche (Protokoll erstellen)

 3.	Beenden der Ashampoo UnInstaller Suite.

     Der Parameter [Name der Protokolldatei] ist notwendig. Es ist der Name für das zu erstellende Installationsprotokoll.

     Die Parameter [Alte ECD Datei] und [Neue ECD Datei] sind optional. Wenn Sie diese Dateien angeben, müssen die Konfigurationsdateien, auf die sie sich beziehen, vorhanden sein. Das Programm nimmt an, dass die aktuelle Konfiguration für die Vergleichsoperation bereits gespeichert wurde und vergleicht einfach die beiden angegebenen Dateien. Das entspricht der Durchführung von Vergleiche zwei Konfigurationen im Menü UnInstaller.

    Wenn Sie keine Dateinamen angeben, wechselt die Ashampoo UnInstaller Suite in den Modus Vergleiche (Protokoll erstellen) und benutzt automatisch die standardmäßigen Dateivorgaben (OldCfg.ecd und NewCfg.ecd). Das Programm speichert die aktuelle Konfiguration in die Datei NewCfg.ecd und vergleicht sie mit der Datei OldCfg.ecd. Das Ergebnis wird in die Datei mit dem Namen [Dateiname]geschrieben. Das entspricht der Durchführung von Vergleiche (Protokoll erstellen) im Menü UnInstaller.

UNINSTALLER.EXE /UNINSTALL [Dateiname]

Stellt alle Änderungen, die in die Protokolldatei mit dem Namen [Dateiname]geschrieben wurden ohne Warnung oder Abfrage wieder her bzw. entfernt die Anwendung, deren Installation in [Dateiname] protokolliert wurde. Der Parameter  [Dateiname] ist erforderlich.
Mit Vorsicht benutzen! Diese Funktion entspricht der Auswahl von Alles wiederherstellen.

UNINSTALLER.EXE /CREATEINSTALL [Dateiname]

Erzeugt Installationsdateien für die Protokolldatei wie in [Dateiname] angegeben. Die erzeugten Dateien werden automatisch entsprechend der Syntax Dateiname+_xxx.xx benannt und in das Standardverzeichnis gespeichert, welches von der Funktion Installationsdateien erzeugen benutzt wird.

UNINSTALLER.EXE /EXPORTTEXT [Dateiname]

Exportiert die in die Protokolldatei [Dateiname]geschriebenen protokollierten Änderungen in Textdateien. Diese erzeugten Textdateien werden automatisch entsprechend der Syntax Dateiname+_xxx.TXT benannt. Siehe  Daten der Installationsprotokolle exportieren für weitere Erläuterungen zu dieser Funktion.

.topic 40160
Sie können alle in den Installationsprotokollen gespeicherten Überwachungsdaten in Textdateien zum Nachschlagen, Archivieren und Drucken exportieren. Klicken Sie einfach auf einen Eintrag in einem der Register unter Installationsprotokolle und wählen Daten exportieren aus dem PopUp Menü, um die Daten dieses Eintrags in eine kommentierte Textdatei zu schreiben. Sie können diese Textdatei mit Notepad oder einem anderen Text-Editor bearbeiten und ausdrucken.

Hinweise:

Die Funktion exportiert immer die Daten des ausgewählten Eintrags und alle darunter liegenden Einträge (wenn vorhanden) - zum Beispiel der aktuelle Ast der Registry und alle weiteren Verzweigungen.
Das Auswählen der Icons   ,   und   wählt alle Daten in den entsprechenden Abschnitten.

Sie können bestimmte Sets sichern, in dem Sie einzelne Zweige des Baumes auswählen.

Eine kurze Erläuterung zu den Einträgen mit Legende wird als Kopfzeile an den Anfang jeder Exportdatei eingefügt.

.topic 50000
Dieser Abschnitt beschreibt die Funktionen der fünf zusätzlichen Module, die in die Ashampoo UnInstaller Suite integriert worden sind:

Doppelte Dateien suchen und löschen

 Mit diesem Modul können Sie doppelte Dateien, die wertvollen Speicherplatz vergeuden, identifizieren, finden und löschen.

Temporäre Dateien suchen und löschen

Ermöglicht Ihnen das Aufspüren und Löschen temporärer und anderer unnötiger Dateien, um Ihr System schlank zu halten und Speicherplatz zurück zu gewinnen.

Leere Ordner suchen und löschen

Ermöglicht Ihnen, leere Ordner aufzuspüren und zu löschen, die nur Speicherplatz auf Ihrem System verschwenden.

Schriften verwalten und löschen

Anzeige aller auf Ihrem System installierten Schriften mit der Möglichkeit, nicht mehr benötigte Schriften zu löschen.

Internetbereich säubern

Ermöglicht Ihnen den Schutz Ihrer Privatsphäre und das Wiedergewinnen von Speicherplatz durch das Löschen von temporären Dateien und anderen Objekte, die während Ihrer Internet-Sessions erzeugt wurden.

.topic 50010
Die Ashampoo UnInstaller Suite ist auch in der Lage, doppelte Dateien auf Ihrem System zu entdecken und zu löschen. Der eingesetzte Suchalgorythmus ist sehr schnell. Ashampoo UnInstaller Suite kann in wenigen Sekunden bis zu 50.000 Dateien in 3.000 Ordnern auf 5 Laufwerken abarbeiten.

Vorgehensweise:

 3.	Wählen Sie bitte die Suchkriterien (2) aus:

a) Name, Größe, Inhalt (Extrem genau, aber etwas langsamer) oder
b) Name, Größe, Datum (Weniger genau, aber sehr schnell)

    Methode a) identifiziert Dateien, die nach Namen, Größe und Inhalt identisch sind. Diese Methode ist extrem genau, dauert aber etwas länger, da das Programm alle Dateien von Anfang bis Ende absuchen und deren Inhalt vergleichen muss.

    Methode b) identifiziert Dateien, die nach Namen, Größe und Datum identisch sind. Diese Methode ist sehr schnell und in den meisten Fällen völlig ausreichend.

 4.	Wählen Sie Suche beginnen. Die Ashampoo UnInstaller Suite sucht und sortiert zunächst alle Dateinamen an den ausgewählten Orten. Anschließend werden Dateien mit gleichem Namen gesucht und dann die einzelnen Dateien verglichen.

 5.	Die Resultate werden in den beiden rechten Fenstern aufgelistet. Durch Klicken auf einen Dateinamen im oberen Fenster erhalten Sie die Pfade zu den Dubletten mit den Namen im unteren rechten Fenster angezeigt.

 6.	Mit einem Rechtsklick auf die Datei öffnet sich ein kleines Menü zum Löschen. Sie können mehrere Dateien auswählen und löschen.

Tipps:

Sie können die Liste sortieren, in dem auf die Spaltenköpfe im oberen rechten Fenster doppelklicken (Gleiche Funktionalität wie im Windows Explorer). Sie können damit schneller erkennen, wo der meiste Platz verschwendet wird.

Sie können mit einem Doppelklick auf die Einträge im unteren Ergebnisfenster die Dateien, um deren Inhalte zu prüfen.

Sie können auch die normalen Tastenkombinationen von Windows im unteren Fenster benutzen: Alt+A (Alles auswählen), Ctrl + Klicken (Auswahl mehrerer ungeordneter Dateien), Shift + Klicken (Auswahl eines Blocks von Dateien) und Del (Löschen).

.topic 50020
Diese Funktion ermöglicht Ihnen das Auffinden und Löschen temporärer Dateien, die Speicherplatz auf Ihrem System verschwenden.

Die Suchleistung ist sehr genau, da Sie selbst Ihre eigenen Suchkriterien festlegen können, mit denen Sie der Ashampoo UnInstaller Suite vorgeben, wonach und was gesucht werden soll. Diese Kriterien werden als Vorgabe gespeichert und jedes mal automatisch angezeigt, wenn Sie diese Funktion aufrufen.

Vorgehensweise:

Klicken Sie auf Suche beginnen (2), um die Suche durchzuführen. Wenn die Suche abgeschlossen ist, zeigt Ihnen das Modul alle Dateien, die den Suchkriterien entsprechen, im unteren Teil (3) an. Ein Rechtsklick auf die einzelnen Einträge im unteren Fenster öffnet ein kleines Menü zu Löschen.

Tipps:

Sie können die Liste sortieren, in dem auf die Spaltenköpfe im oberen rechten Fenster doppelklicken (Gleiche Funktionalität wie im Windows Explorer). Sie können damit schneller erkennen, wo der meiste Platz verschwendet wird.

Sie können mit einem Doppelklick auf die Einträge im unteren Ergebnisfenster die Dateien, um deren Inhalte zu prüfen.

Sie können auch die normalen Tastenkombinationen von Windows im unteren Fenster benutzen: Alt+A (Alles auswählen), Ctrl + Klicken (Auswahl mehrerer ungeordneter Dateien), Shift + Klicken (Auswahl eines Blocks von Dateien) und Del (Löschen).

.topic 50030
Mit Hilfe dieser Funktion können Sie leere Ordner, die keine Daten enthalten, aufspüren und löschen. Es ist in der Regel sicher, leere Ordner zu löschen. Sie sollten aber dennoch vorsichtig mit Odnern, die zu noch installierten Anwendungen gehören, umgehen. Es gibt Programme, die Ordner für eine spätere Verwendung erzeugen. Sie können Fehlermeldungen erhalten, wenn Sie solche Ordner löschen sollten. Aber selbst in solchen Fällen, sind ernsthafte Probleme nicht zu erwarten. Sie werden in der Regel eine Meldung wie die folgende erhalten: "Verzeichnis C:\Programme\Anwendung\Backup" nicht gefunden!" Sie müssen dann nur den Ordner von Hand anlegen.

Wählen Sie bitte Leere Ordner suchen und löschen im Bildschirm der Suite, der Werkzeugleiste oder im Menü Werkzeuge.

Vorgehensweise:

Auswählen:

Sie können die Einträge, die Sie löschen möchten, mit den standardmäßigen Windows-Tastenkombinationen auswählen: Linksklick, Hochstelltaste (Shift) + Linksklick, Hochstelltaste (Shift) + Linksklick und Ziehen (Beginnen Sie das Ziehen rechts in der ersten Spalte).

Löschen:
Um einzelne Ordner zu löschen, klicken Sie einfach mit rechts auf den Eintrag und wählen dann Löschen aus dem PopUp-Menü. Sie können alle aufgelisteten Ordner mit der Funktion Alle markieren auswählen. Um mehrere Ordner zu löschen, treffen Sie bitte Ihre Auswahl in der Liste, klicken Sie mit der rechten Maustaste auf einen der Einträge und wählen dann Löschen.

.topic 50040
Mit dieser Funktion können Sie sich alle auf Ihrem System installierten Schriften anzeigen lassen. Sie können die Schriften, die Sie nicht benötigen, löschen.

Sie können diese Funktion aufrufen, in dem Sie Schriften verwalten und löschen im Bildschirm der Suite, der Werkzeugleiste oder dem Menü Werkzeuge auswählen.

Vorgehensweise:

.topic 50050
Diese mächtige Funktion ermöglicht Ihnen das Entfernen aller Dateien und Einträge, die von Ihrem Browser erzeugt wurden, als Sie online waren. Wenn Sie diese Funktion regelmäßig benutzen, werden Sie überrascht sein, wie viel Müll sich ablagert.

Klicken Sie bitte doppelt auf das Icon Internetbereich säubern im Bildschirm der Suite (Ebenso erreichbar über die Werkzeugleiste und das Menü Werkzeuge):

Generelle Vorgehensweise in allen Registern:

Einträge zum Löschen auswählen:

Es gibt ein separates Register (2) für jede der vier Kategorien von temporären Internet-Einträgen: Temporäre Dateien, Cookies, Besuchte Seiten, URLs.

Auswählen:

Sie können die Dateien, die Sie löschen möchten, mit den standardmäßigen Windows-Tastenkombinationen auswählen: Linksklick, Hochstelltaste (Shift) + Linksklick, Hochstelltaste (Shift) + Linksklick und Ziehen (Beginnen Sie das Ziehen rechts in der ersten Spalte).  Im Register Temporäre Dateien können Sie die drei praktischen Auswahlschalter über der Listenbox (siehe unten) benutzen. Klicken Sie auf den Schalter Alle markieren (5), um alle Einträge in der Liste auszuwählen.

Abwählen:
Um alle ausgewählten Einträge wieder abzuwählen, klicken Sie einfach irgendwo in das weiße Feld rechts neben der Liste (6).

Sortieren:

Klicken Sie bitte doppelt auf den Kopf der Spalte, um die Einträge in den Spalten numerisch oder alphabetisch zu sortieren. Durch ein erneutes Klicken auf den Kopf der Spalte ändern Sie die Sortierreihenfolge von absteigend auf aufsteigend und umgekehrt.

#Das Register Temporäre Dateien

Wann immer Sie eine Webseite besuchen, speichert Ihr Browser alle besuchten Seiten in einem temporären Speicherbereich mit dem Namen Cache. (Sie können die Einstellungen für diesen Cache in Ihrem Browser vornehmen). Das kann den Zugriff beim erneuten Besuch der Seite enorm beschleunigen, wenn Sie die Seite besuchen, bevor die Dateien im Cache gelöscht wurden. Es werden dann die Daten von Ihrer Festplatte statt aus dem Internet geladen. Auf der anderen Seite nehmen diese Dateien sehr viel Speicherplatz in Ihrem System in Anspruch.
Die Liste im Hauptteil der Dialogbox zeigen Ihnen alle Dateien, die im Browser-Cache gespeichert wurden.

Spezielle Auswahlschalter:

Im Register Temporäre Dateien befinden sich drei besondere Schalter, mit denen Sie Ihre Auswahl in den Listen "tunen" können. Sie tragen dazu entweder den Kontrollwert rechts neben den Schalter ein oder benutzen die Hoch/Runter-Pfeile. Alternativ klicken Sie doppelt in das Zahlenfeld und geben einen neuen Wert ein.

Unterschiede bei Netscape:

Temporäre Internetdateien: Aufgrund der Art und Weise, wie die temporären Dateien bei Netscape organisiert sind, können alle temporären Dateien nur zusammen gelöscht werden.

History löschen: Der zweite Schalter im Register Temporäre Dateien unter Netscape löscht die History. Das ist die Liste aller Adressen von allen Dateien, die Sie kürzlich besucht haben.

#Das Register Cookies

Viele Webseiten speichern Informationen auf Ihrem Rechner in kleinen Dateien, den sogenannten "Cookies" ab und laden diese Daten wieder, wenn Sie die Seiten erneut besuchen. Vorausgesetzt Sie haben das Setzen von Cookies in den Sicherheitseinstellungen Ihres Webbrowsers nicht unterbunden. Es ist kaum noch möglich, bestimmte Webseiten zu laden, wenn Sie das Setzen von Cookies abgestellt haben. Das gilt insbesondere für kommerzielle Seiten und Online-Shops.

Cookies werden sehr oft benutzt, um das Erscheinungsbild und Verhalten der Internetseiten den Vorlieben und Profilen der Benutzer anzupassen. Die Cookies selbst beinhalten nur wenige Daten, es ist ein spezieller Code, der den Benutzer beim erneuten Besuch der Internetseite identifiziert. Die aktuellen Daten sind auf dem Server des Anbieters gespeichert. Das Cookie auf Ihrem Rechner wird quasi als Zugangscode benutzt, um Ihren Rechner mit den Daten zu verbinden. Das ist die unangenehme Seite an den Cookies - Sie haben keine Chance heraus zu finden, welche Daten gespeichert worden sind.

Viele Benutzer sind von der Vorstellung verschreckt, dass Sie keinen Zugriff auf solche Daten haben, die irgendwo auf einem Server gespeichert und mit einem Cookie auf dem eigenen Rechner verbunden sind. Darüber hinaus können Cookies dazu benutzt werden, Ihren "Internetspuren" zu folgen und ein Benutzerprofil zu erzeugen.
Aus diesen Gründen ist es sinnvoll, Cookies zu löschen. Ein wenig Sorgfalt sollte man dennoch walten lassen. Einige Internetseiten können unerwartet reagieren oder erfordern eine erneute Indifikation, wenn das Cookie gelöscht wurde. Sie sollten die Cookies, von den Internetseiten, denen Sie vertrauen, daher nicht löschen.

#Das Register Besuchte Seiten

Ihr Internetbrowser speichert automatisch die Adressen der von Ihnen besuchten Internetseiten. Wenn Sie möchten, dass diese Informationen nicht auf Ihrem System gespeichert werden, können Sie die Einträge hier löschen. Diese Option ist nur für den Internet Explorer von Microsoft verfügbar.

Der Schalter Besuchte Seiten:
Microsoft Internet Explorer speichert Ihre Seitenzugriffe an verschiedenen Orten. Die Liste Besuchte Seiten ist eine verborgene Liste, die im Hintergrund verwaltet wird. Die Liste xxx entspricht der Liste, die Sie sehen können, wenn Sie auf das Icon Verlauf in der Werkzeugleiste des Internet Explorers klicken. Der Inhalt der Liste Verlauf kann nur zusammen gelöscht werden. Klicken Sie einfach auf den Schalter Verlauf löschen.

Unterschiede bei Netscape:

Bei Netscape werden die besuchten Seiten und die History zusammen gelöscht, wenn Sie auf den Schalter History löschen klicken.

#Das Register Eingegebene URLs

Alle Adressen von Webseiten (URLs), die Sie manuell in das Adressfeld eingeben, werden von Ihrem Browser in einer Liste gespeichert. Diese Liste kann von jedermann mit Zugriff auf Ihren Computer eingesehen werden. Wenn Sie das verhindern möchten, löschen Sie die Einträge in diesem Register.

Unterschiede bei Netscape:

Bei Netscape werden die manuell eigegebenen Adressen von Webseiten (URLs) ebenfalls gelöscht, wenn Sie auf den Schalter History löschen klicken.

.topic 60000
Dieser Abschnitt enthält weitere Informationen zur Funktionsweise der Ashampoo UnInstaller Suite und zur besseren Handhabung des Programmes. Bitte lesen Sie diese Kapitel sorgfältig durch, wenn Sie das Programm ernsthaft im Experten-Modus benutzen wollen.

.topic 60090
Wenn Sie mit der Ashampoo UnInstaller Suite im Experten-Modus arbeiten ist es sehr hilfreich zu verstehen, welche Dateien vom Programm erzeugt werden und welchem Zweck diese Dateien dienen. Das Programm generiert und benutzt die drei folgenden Typen von Dateien im eigenen Programmverzeichnis:
#
Auswahldateien (.ECS)

Diese Dateien speichern die Einstellungen in den Auswahl-Registern. Es gibt zu mindestens eine .ECS Datei mit dem Namen Last.ECS, in der die Auswahl gespeichert ist, die automatisch bei jedem Start der Ashampoo UnInstaller Suite geladen wird. Wenn Sie das Programm verlassen, werden Sie aufgefordert, irgendwelche in den Auswahl-Registern vorgenommenen Änderungen als neue Vorgabe zu speichern, die beim nächsten Start des Programms benutzt werden. Wenn Sie auf Ja bei der Abfrage klicken, speichert das Programm die aktuelle Auswahl in die Datei Last.ECS und überschreibt die bestehende Version.

Sie können Auswahl-Konfigurationen auch in Ihre eigenen .ECS Dateien speichern. Benutzen Sie dazu das Kommando Speichere Auswahl in Datei im Menü Datei. Das empfiehlt sich besonders für Einstellungen, die Sie nur zu bestimmten Zwecken nutzen wollen - wie zum Beispiel dem Ausspionieren der Registry. Die Standardvorgaben bei den Auswahl-Einstellungen, die Sie zu jeder Zeit mit dem Kommando Zurücksetzen des Auswahl im Menü Datei zurücksetzen können, sind sicherlich die beste Wahl für die Installation und Deinstallation von Anwendungen. Alle anderen Einstellungen sollten in separate .ECS Dateien gespeichert werden und nur wenn benötigt auch geladen werden. Dazu benutzen Sie das Kommando Lade Auswahl aus Datei im Menü Datei.

Backups:
Wenn Sie eine von der Vorgabe abweichende Auswahl benutzen, empfiehlt sich das Erstellen von Backups Ihrer .ECS Dateien.
#
Konfigurationsdateien (.ECD)

Das sind die Dateien, die zum Speichern der "Schnappschüsse" Ihres gesamten Systems benutzt werden. Aus diesem Grund sind diese Dateien auch verhältnismäßig groß. Sie enthalten Kopien von allen Einträgen in der Windows Registry und Listen aller auf Ihren Festplatten gespeicherten Dateien und deren Daten wie z.B. Datum, Versionsnummer etc.

Wenn Sie Speichere aktuelle Konfiguration auswählen, untersucht die Ashampoo UnInstaller Suite Ihr gesamtes System und speichert alle gefundenen Informationen in eine Konfigurationsdatei mit dem Namen OldCFG.ECD. Wenn diese Datei bereits existiert, wird sie zunächst in OldCFG.BAK umbenannt, damit Sie mit dem Kommando Wiederherstellen der gespeicherten Konfiguration im Menü Datei wiederhergestellt werden kann.

Wenn Sie Vergleiche (Protokoll erstellen) auswählen, untersucht die Ashampoo UnInstaller Suite Ihr System erneut und schreibt eine zweite Konfigurationsdatei mit dem Namen NewCFG.ECD, vergleicht diese Datei mit der Datei OldCFG.ECD und zeichnet die Unterschiede in ein Installationsprotokoll (siehe unten).
Sie können Ihre aktuelle Konfiguration auch in eine Datei mit einem Namen Ihrer Wahl speichern. Wählen Sie dazu Speichere Konfiguration unter ... im Menü UnInstaller. Siehe Arbeiten mit Konfigurationsdateien für weitere Hinweise.
#
Installationsprotokolle - (Dateierweiterung  .ECL)

Diese Dateien werden zur Aufzeichnung der gefundenen Unterschiede beim Vergleich zweier Konfigurationen benutzt. Sie haben in der Regel die Namen, die der Benutzer (also Sie selbst ) eingegeben haben oder den protokollierten Namen der Anwendung, der bei der Installation mit dem UIWatcher vorgeschlagen wurde.

Backups:
Es ist sinnvoll, ein Backup aller .ECL Installationsprotokolle an einem sicheren Ort zu hinterlegen. Sie können die Ashampoo UnInstaller Suite immer wieder installieren, aber wenn Sie Ihre Protokolldateien verlieren, werden Sie nicht mehr in der Lage sein, protokollierte Anwendungen zu deinstallieren.

.topic 60060
Im Experten-Modus der Ashampoo UnInstaller Suite können Sie exklusiv alle Teile Ihrer System-Konfiguration bestimmen, die Sie auf Veränderungen hin überwachen wollen. Diese Möglichkeiten machen das Programm sehr mächtig. Es bedeutet aber auch, dass Sie wissen müssen, was Sie tun! Wenn Sie zum Beispiel keine Einträge in den Registern unter Auswahl: Registry & Laufwerke auswählen, wird die Ashampoo UnInstaller Suite keine Änderungen aufzeichnen, wenn Sie eine Protokolldatei erstellen.

Auf der anderen Seite werden Sie durch die Auswahl aller Einträge in den Auswahl-Registern Konflikte und unerwartete Probleme herauf beschwören können. Sie sollten daher zu Beginn mit der Standard-Auswahl des Programms arbeiten. Sie können diese Standardeinstellungen mit der Option Zurücksetzen der Auswahl im Menü Datei zurücksetzen.

Sie sollten die Standardeinstellungen erst dann verändern, wenn Sie einige Erfahrungen mit dem Programm und dem Entfernen von Anwendungen gewonnen haben. Am Ende ist es immer besser, einige überflüssige Daten auf dem Rechner zu haben, als ein komplett "sauberes" System, dass nicht einwandfrei funktioniert oder gar nicht mehr startet.

Wenn Sie die Ashampoo UnInstaller Suite ernsthaft im Experten-Modus benutzen wollen, empfehlen wir Ihnen die Anschaffung und das Studium eines guten Nachschlagewerkes über die Windows-Systemkonfiguration und die Windows Registry.

Tipp für die Registry-Auswahl

Versuchen Sie die Taste Ctrl zu drücken, wenn Sie den Baum "aufklappen" oder "schließen". Dadurch wird der gesamte Verzeichnisbaum unterhalb des aktuellen Auswahlpunkts aufgeklappt oder geschlossen. Durch Klicken auf das Verzeichnis des Eintrags öffnet sich das nächste Unterverzeichnis usw. Das ist hilfreich bei den Registern unter Installationsprotokolle, es kann aber sehr viel Zeit bei den Auswahl-Registern in Anspruch nehmen, insbesondere wenn Sie die ganze Registry "aufklappen".

Standard-Auswahl

Beim ersten Start der Ashampoo UnInstaller Suite zeigt das Programm ein Set an Standardeinstellung mit den Ein- und Ausschlüssen an, die für die meisten Zwecke am effektivsten sind. Wenn Sie andere Registry-Einträge oder andere Einträge überwachen oder ausschließen möchten, müssen Sie diese Einträge in den Auswahl-Registern von Hand aus- oder abwählen.

Sie können die Auswahl immer auf die Standardwerte mit dem Kommando Zurücksetzen der Auswahl im Menü Datei zurücksetzen. Wenn Sie unterschiedliche Auswahl-Konfigurationen für unterschiedliche Aufgaben erstellen wollen, benutzen Sie bitte die Kommandos Speichere Auswahl in Datei und Lade Auswahl aus Datei im Menü Datei.

.topic 600100
Wenn Sie mit der  Ashampoo UnInstaller Suite im Experten-Modus arbeiten, ist sehr wichtig, die Art und Weise wie das Programm die von Ihnen in den Auswahl-Registern vorgenommenen Änderungen verarbeitet und speichert, zu kennen. Die Auswahl ist kritisch, da sie folgende wichtigen Aspekte beim Programmablauf bestimmen: Was ist eingeschlossen, wenn die aktuelle Konfiguration gespeichert wird? Was wird verglichen, wenn Sie Protokolldateien erstellen? Was wird gelöscht oder wiederhergestellt, wenn Sie Installationsprotokolle zur Deinstallation von Anwendungen und Wiederherstellung Ihres Systems benutzen?

Wichtiger Hinweis für Benutzer von Ashampoo UnInstaller 2000

Wenn Sie mit dem Programm Ashampoo UnInstaller 2000 vertraut sind, lesen Sie bitte diesen Abschnitt sorgfältig durch. Die Art, wie die Auswahl beim Laden von Installationsprotokollen behandelt wird (siehe letzten Punkt am Ende dieses Abschnitts) hat sich bei der Ashampoo UnInstaller Suite geändert, um das Programm intuitiver in der Bedienung zu machen.

Standardauswahl

Die Standardauswahl des Programms beinhalten alle sicheren Einträge in der Windows Registry und auf allen lokalen Festplatten auf Ihrem System sowie eine Reihe von Ausschlüssen im Register Ausgeschlossene Dateien. Sie können diese Auswahl mit der Option Zurücksetzen der Auswahl im Menü Datei zu jeder Zeit zurücksetzen. Bitte ändern Sie diese Auswahl nur dann, wenn Sie genau wissen, was und weshalb Sie es tun. Klicken Sie bitte hier für einige weitere Hintergrundinformationen zur Auswahl und Verwendung von Einstellungen in den Auswahl-Registern.

Eine Auswahl als Standard speichern

Wann immer Sie Änderungen an den Einstellungen in den Auswahl-Registern vornehmen, einschließlich der Einstellungen zu den ausgeschlossenen Dateien im Register Ausgeschlossene Dateien, erfolgt die Abfrage beim Verlassen des Programms, ob die neuen Einstellungen als neuer Standard gespeichert werden sollen. Die Vorgaben werden in der Datei Last.ECS gespeichert.  Es ist wichtig, diese Abfrage zu bestätigen, wenn Sie gerade das Kommando Speichere aktuelle Konfiguration durchgeführt haben. Sie müssen die gleichen Auswahleinstellungen benutzen, wenn Sie das Kommando Vergleiche (Protokoll erstellen) durchführen - der Vergleich wäre sonst nicht korrekt.

Wenn Sie Ihre Standardauswahl nicht überschreiben möchten, wählen Sie bitte Speichere Auswahl in Datei im Menü Datei (siehe folgenden Hinweis unten) und laden dann die Auswahl mit dem Kommando Lade Auswahl aus Datei im Menü Datei, bevor Sie den Vergleich ausführen.

Wie man eine Auswahl in eine Datei für eine spätere Wiederverwendung speichert

Sie möchten vielleicht unterschiedliche Sets an Auswahleinstellungen für verschiedene Aufgaben benutzen, zum Beispiel um die die Registry mit besonderen Ansätzen auszuspionieren. Wenn Sie diese besonderen Auswahleinstellungen nicht als Vorgabe speichern möchten, können Sie diese Einstellungen in separate Dateien abspeichern. Benutzen Sie dazu das Kommando Speichere Auswahl in Datei im Menü Datei oder der Werkzeugleiste.

Was passiert beim Ändern der Auswahl

Wenn Sie manuell Änderungen der Einstellungen in den Auswahl-Registern vornehmen, werden diese neuen Einstellungen sofort benutzt, wenn Sie Speichere aktuelle Konfiguration auswählen. Beim Verlassen der Ashampoo UnInstaller Suite erfolgt die Aufforderung zum Speichern der neuen Einstellungen aus neue Standardauswahl. Sollten Sie die Abfrage bestätigen, werden die neuen Einstellungen automatisch beim nächsten Programmstart geladen. Es ist wichtig, diese Abfrage zu bestätigen, wenn Sie gerade das Kommando Speichere aktuelle Konfiguration durchgeführt haben. Sie müssen die gleiche Auswahleinstellungen benutzen, wenn Sie das Kommando Vergleiche (Protokoll erstellen) durchführen - der Vergleich wäre sonst nicht korrekt.

Was passiert wenn Sie das Installationsprotokoll vergleichen / speichern wollen?

Wenn Sie ein Installationsprotokoll mit der Funktion Vergleiche (Protokoll erstellen) oder Inkrementelles Vergleichen oder einer anderen Funktion, die automatisch ein Protokoll nach der Installation einer Anwendung generiert, erzeugen, werden die Auswahleinstellungen automatisch mit dem Protokoll gespeichert und geladen, wenn Sie das Protokoll laden. Sie können dadurch prüfen, welche Einträge zum Erzeugen des Protokolls abgesucht wurden und welche nicht.

Neu: Was passiert beim Laden eines Installationsprotokolls

Wenn Sie das Protokoll erneut laden, werden die Einstellungen in den Auswahl-Registern automatisch geändert, um die Einstellungen des Protokolls widerzuspiegeln. Dieser Vorgang entspricht der Arbeitsweise von Ashampoo UnInstaller 2000. Wie aber die durch das Protokoll geladenen Einstellungen behandelt werden, hat sich in zwei wichtigen Bereichen geändert:

 1)	Das Laden des Protokolls ändert die Einstellungen in den Auswahl-Registern nur temporär. Wenn Sie das Protokoll laden, dass die Einstellungen in den Auswahl-Registern ändert, erfolgt keine Abfrage zum Speichern dieser Einstellungen als neue Vorgabe, wenn Sie das Programm verlassen. Das Programm nimmt an, dass die Auswahleinstellungen des Protokolls nur zu diesem Protokoll gehören und das Sie Ihre Einstellungen behalten möchten, die Sie vor dem Laden des Protokolls hatten. Diese Einstellungen werden automatisch aus der Datei LAST.ECS geladen. Diese Datei enthält die Standardeinstellungen, die bei jedem Programmstart geladen werden.

    Sollten Sie die Einstellungen des Protokolls als neue Vorgabe benutzen, müssen Sie die Funktion Speichere Auswahl in Datei im Menü Datei auswählen und die Datei LAST.ECS überschreiben. Diese Datei enthält die Standardeinstellungen, die bei jedem Start der Ashampoo UnInstaller Suite automatischen geladen werden.

 2)	Wenn Sie Speichere aktuelle Konfiguration nach dem Laden eines Protokolls auswählen, wird das Programm die Auswahleinstellungen des Protokolls nicht zum Speichern der aktuellen Konfiguration verwenden. Auch hier gilt: Das Programm nimmt jetzt an, dass die Auswahleinstellungen des Protokolls nur zu diesem Protokoll gehören und wird automatisch die Standardauswahl benutzen, die vor dem Laden des Protokolls aktiv waren.

.topic 60070

Sie sollten die Abfrage nur dann bestätigen, wenn Sie diese Einstellungen jedes mal verwenden wollen, wenn Sie mit dem Programm arbeiten. Wenn Sie spezielle Einstellungen vorgenommen haben, die Sie nur gelegentlich nutzen wollen, sollten Sie in der Abfrage auf Abbrechen klicken und die Option Speichere Auswahl in Datei im Menü Datei nutzen. Sie können damit Ihre Einstellungen in eine separate Datei speichern, die Sie bei Bedarf laden können.

Wenn Sie gerade Speichere aktuelle Konfiguration ausgeführt haben

Wenn Sie diese Abfrage gerade nach dem Speichern Ihrer aktuellen Konfiguration erhalten, bedeutet es, dass die gerade von Ihnen erzeugte Konfigurationsdatei mit veränderten Auswahl-Einstellungen generiert wurde, die noch nicht gespeichert sind. Sie müssen diese Einstellungen vor dem Verlassen des Programms speichern, damit Sie die gleichen Einstellungen benutzen können, wenn Sie Vergleiche (Protokoll erstellen) ausführen. Sie erhalten sonst bedeutungslose Ergebnisse.  Klicken Sie hier für weitere Hinweise.

Option 1: Speichern der neuen Auswahl als Vorgabe
Wenn Sie die neue Auswahl immer vom aktuellen Zeitpunkt an benutzen wollen, klicken Sie in der Abfrage einfach auf Ja. Dadurch wird Ihre geänderte Auswahl als neue Vorgabe gespeichert, die dann bei jedem Start der Ashampoo UnInstaller Suite geladen wird.

Option 2: Speichern der neuen Auswahl in eine Datei
Wenn Sie spezielle Einstellungen vorgenommen haben, die Sie nur gelegentlich nutzen wollen, sollten Sie bei der Abfrage auf Abbrechen klicken. Wählen Sie dann Speichere Auswahl in Datei im Menü Datei und speichern Ihre Einstellungen in eine separate Datei. Wenn Sie dann die Ashampoo UnInstaller Suite nach der Durchführung von Speichere aktuelle Konfiguration verlassen, vergessen Sie bitte nicht, diese Datei mit Lade Auswahl aus Datei erneut zu laden, bevor Sie Vergleiche (Protokoll erstellen) ausführen. Sie werden ansonsten nicht die gleiche Auswahl für die Vergleichsoperation benutzen! Klicken Sie hier für weitere Hinweise.

Für weitere Informationen lesen Sie bitte auch die Hinweise in folgenden Abschnitten: Auswahl, Eine Auswahl speichern, Was Sie nicht auswählen sollten, Arbeiten mit Auswahldateien und Dateitypen.

.topic 60080
Registry-Schlüssel, die vermieden werden sollten:

 HKEY_CURRENT_USER

Es ist keine besonders gute Idee, HKEY_CURRENT_USER zur gleichen Zeit wie HKEY_USERS zu überwachen. Es sei denn, Sie haben einen besonderen Grund dazu. Wenn Programme die Registry im Abschnitt HKEY_CURRENT_USER ändern, werden die gleichen Änderungen automatisch unter HKEY_USERS\'Aktiver Benutzer' vorgenommen. Wenn die Ashampoo UnInstaller Suite versucht, beide Veränderungen wiederherzustellen - was geschieht, wenn Sie beide Abschnitte überwachen - können unerwartete Effekte aufgrund der gegenseitigen Interaktion zwischen beiden Abschnitten auftreten.

HKEY_Classes_Root

Das Gleiche gilt für den Abschnitt HKEY_Classes_Root - dieser Hauptschlüssel muss und sollte nicht separat überwacht werden, da es sich um eine Untergruppe von HKEY_Local_Machine handelt.

HKEY_LOCAL_MACHINE\System\ControlSet00x

Die Standard-Einstellungen schließen automatisch die Zweige HKEY_LOCAL_MACHINE\System\ControlSet00x in der Registry aus. Diese Zweige sind Kopien von ...\CurrentControlSet, die manchmal erzeugt und umbenannt werden, wenn Windows neubootet. (Bei Windows NT handelt es sich um die "Letzte als funktionierend bekannte Konfiguration").

Die Überwachung dieser Zweige bringt wirklich keinen Nutzen und das Auswählen dieser Zweige wird nicht empfohlen. Wenn Sie es trotzdem tun oder diese Zweige mit der Ashampoo UnInstaller Suite oder einem Registry-Editor bearbeiten oder löschen wird ihr System mit Sicherheit abstürzen.

Ashampoo UnInstaller Suite meldet normalerweise keine Veränderungen in diesem Zweigen. Dadurch ist es dem Programm möglich, ohne  Systemabstürze während Installationsroutinen ohne Probleme zu behandeln, da diese Einträge in der Regel von Windows erst nach dem Absturz geschrieben werden. Wenn Sie diese Schlüssel überwachen müssen, ist es besser, stattdessen HKEY_LOCAL_MACHINE\ System\CurrentControlSet auszuwählen (Das ist auch in der Standard-Auswahl eingeschlossen).

Dateien und Ordner, die vermieden werden sollten:

Dateien:

Es gibt eine Reihe von Dateien, die Sie nie überwachen sollten, da deren Wiederherstellung entweder sinnlos oder gefährlich ist. Das schließt die Dateien der Windows Registry, die Swap-Datei und andere Systemdateien ein. Zum Beispiel wäre die Überwachung von Dateien der Windows Registry sinnlos, da alle einzelne Komponenten ja bereits in Registry-Auswahl enthalten sind. Das Wiederherstellen der gesamten Registry-Dateien als ein Block würde Ihr System schwer beeinträchtigen  (Siehe Das Feature Backup benutzen für weitere Hinweise zu diesem Thema). Das Überwachen der Swapdatei (Auslagerungsdatei) ist sinnlos, da sie keine brauchbaren Daten enthält und bei jeder Arbeitssitzung von Windows wieder neu erzeugt wird.

Alle relevanten Dateien für jede Windows-Version werden automatisch in den Abschnitt Diese Dateien nicht prüfen:  des Unterregisters Optionen in Auswahl: Registry & Laufwerke aufgenommen.  Bitte löschen Sie keine dieser Standardausschlüsse, bevor Sie nicht absolut sicher sind, was Sie tun! Die Einstellungen sind unverzichtbar für das einwandfreie Arbeiten der Ashampoo UnInstaller Suite und Sie können unvorhersehbare oder ernsthafte Fehler erhalten, wenn Sie diese Einstellungen löschen.

Ordner:

Wenn Sie einen Blick auf die Standardeinstellungen im Unterregister Laufwerke (Wählen Sie Zurücksetzen der Auswahl im Menü Datei, falls Sie irgendwelche Änderungen vorgenommen haben) werfen, werden Sie feststellen, dass einige Ordner abgewählt sind. Als einfache Grundregel gilt: Sie sollten keine der Ordner auswählen, die in der Standardeinstellung abgewählt wurden, wenn Sie nicht absolut sicher sind, was Sie tun! Das ist besonders wichtig in allen Windows-Verzeichnissen auf Ihrem System.

Einige der abgewählten Ordner sind harmlos, wie die Ordner für Cookies und temporäre Internetdateien oder die Ordner für den Papierkorb. Andere Ordner können schwerwiegende Zerstörungen nach sich ziehen, wenn sie gelöscht werden. Zum Beispiel enthält der Ordner C:\WINNT\SYSTEM32\CONFIG unter Windows NT4, 2000 und XP spezielle Registry-Dateien. Das Löschen dieses Ordners kann zu den schwerwiegenden Konsequenzen führen, wie sie im Abschnitt Das Feature Backup benutzen beschrieben sind.

.topic 600120
Die Unterregister der Auswahl-Register ermöglichen Ihnen die genaue Definition dessen, was durch die Ashampoo UnInstaller Suite auf Ihrem System überwacht und wiederhergestellt werden soll.
Die Durchführung detaillierter Änderungen an dieser Stelle setzen gute Kenntnisse über Windows und der Windows Registry voraus!  Wenn Sie unsicher sind, sollten Sie keine Änderungen vornehmen. Und selbst wenn Sie wissen, was Sie tun, lesen Sie bitte den gesamten Abschnitt Auswahl sehr sorgfältig, bevor Sie beginnen!

Ausnahme:
Sie können ganz sicher ganze Laufwerke abwählen, die Sie nicht überwachen wollen - mit Ausnahme des Laufwerke, auf dem Windows installiert ist. Sie sollten eine solche Abwahl jedoch nur treffen, wenn Sie absolut sicher sind, dass auf diesem Laufwerk keine wichtigen Bestandteile oder gar eine Anwendung selbst installiert werden. Zum Beispiel ist es in der Regel sicher und ratsam die Laufwerke abzuwählen, auf die Sie nur persönliche Daten (Texte, Videos, Grafiken etc.) speichern. Das Absuchen des Systems durch die Ashampoo UnInstaller Suite wird erheblich beschleunigt und Ihre Daten sind gegen versehentliches Löschen geschützt.

#Tipp und Warnung:

Bevor Sie zum ersten Mal im Inhalt der Auswahl-Register "stöbern", wählen Sie die Funktion Zurücksetzen der Auswahl im Menü Datei, um die Auswahl auf die Standardeinstellungen des Programms zurückzusetzen. Dadurch wird alles relevante eingeschlossen und wiederum alles ausgeschlossen, was beim Überwachen nutzlos oder gefährlich ist. Die Standardeinstellungen sind ein guter Ausgangspunkt. Das Betrachten dieser Auswahl hilft Ihnen, die Arbeitsweise der Ashampoo UnInstaller Suite zu verstehen.

Widmen Sie besondere Aufmerksamkeit den Einträgen, die in den Standardeinstellungen nicht ausgewählt sind! Bitte wählen Sie diese Einträge nicht aus, bevor Sie wirklich verstanden haben, was Sie damit bewirken - Sie können ansonsten unvorhersehbare und möglicherweise negative Ergebnisse erhalten! Siehe den Abschnitt Was Sie nicht auswählen sollten für nähere Hinweise zu diesem Aspekt.

Das Register Registry:

Die Checkboxen von Ästen, die sowohl ausgewählte als auch nicht gewählte Elemente beinhalten, werden schattiert angezeigt.

      Seien Sie besonders vorsichtig, wenn Sie wieder ganze Äste auswählen, die Sie bereits ausgewählt hatten. Es können Einträge ausgewählt werden, die normalerweise in den Standardeinstellungen ausgeschlossen sind.

Mit einem Rechtsklick greifen Sie auf den integrierten Registry-Editor zu. Ein Doppelklick auf Werte öffnet den Registry-Editor ebenfalls.

#Das Register Laufwerke:

Die Checkboxen von Ästen, die sowohl ausgewählte als auch nicht gewählte Elemente beinhalten, werden schattiert angezeigt.

     Seien Sie besonders vorsichtig, wenn Sie wieder ganze Äste auswählen, die Sie bereits ausgewählt hatten. Es können Einträge ausgewählt werden, die normalerweise in den Standardeinstellungen ausgeschlossen sind. Im Easy-Modus führt das Auswählen ganzer Laufwerke automatisch dazu, dass alle Einträge ausgeschlossen werden, die in den normalen Standardeinstellungen auch ausgeschlossen sind.

Nach einem Doppelklick auf die Dateien im rechten Fenster öffnet sich ein PopUp Menü, im dem Sie die Dateien der Liste der Ausschlüsse im Register Ausgeschlossene Dateien hinzufügen können.

Aus verständlichen Gründen macht es wenig Sinn, Elemente auf verbundenen Laufwerken oder Laufwerken mit Wechselmedien,  wie z.B. CD-ROMs oder Floppy-Laufwerke, auszuwählen!

Das Register Systemdateien:

Die Ashampoo UnInstaller Suite kann zwei verschiedene Dateitypen bei Systemdateien überwachen, Textdateien und INI Dateien. Sie können zusätzliche Systemdateien hinzufügen, die Sie vom Programm überwachen lassen wollen. Für weitere Hinweise siehe Benutzerdefinierte Systemdateien.

Sie können einzelne Abschnitte in INI Dateien auswählen oder ausschließen.

Zusätzlich zur Überwachung einzelner Abschnitt von INI Dateien ist die Ashampoo UnInstaller Suite in der Lage, Änderungen in den gewählten Abschnitten zu protokollieren und wiederherzustellen. Dies geschieht in der gleichen Weise wie beim Protokollieren und Wiederherstellen der Änderungen in der Registry.

Änderungen in Textdateien wie AUTOEXEC.BAT und CONFIG.SYS werden protokolliert, können aber durch das Programm nicht wiederhergestellt werden, es sei denn, Sie nutzen das Feature Backup erstellen.

#Ausgeschlossene Dateien:

Dieses Register verfügt über zwei Abschnitte: Dem Fenster Ausgeschlossene Dateien auf der linken Seite und der Erläuterung der Icons, die in den Registern der Installationsprotokolle verwendet werden, auf der rechten Seite. Bitte entfernen Sie niemals standardmäßig ausgeschlossene Dateien! Das kann zu schwer wiegenden negativen Konsequenzen führen! (Siehe Was Sie nicht auswählen sollten für weitere Hinweise.) Wenn Sie glauben, dass Sie aus Versehen einen Datei-Ausschluss gelöscht haben, wählen Sie einfach die Option Zurücksetzen der Auswahl im Menü Datei, um die Standardeinstellungen wiederherzustellen.

.topic 600110
Die Unterregister unter dem Register Installationsprotokolle bieten Ihnen den direkten Zugriff auf alle Installationsprotokolle und ermöglichen Ihnen die Ansicht, deren Inhalte sowie deren Wiederherstellung. Siehe den Abschnitt Manuelle Wiederherstellung von Änderungen für weitere Hinweise zu diesem Thema.

Zur Anzeige der Register klicken Sie bitte auf das Register Installationsprotokoll im Fenster des Hauptprogramms:

Das Register Protokolldatei laden:

Die Register Änderungen:

.topic 60040
Viele Windows-Programme benutzen gemeinsame Dateien. Es handelt sich um binäre Dateien mit der Dateierweiterung .dll (Dynamic Link Library). Sie werden zum Speichern von Programm-Codes von Funktionen verwendet, auf die von anderen Programmen zugegriffen werden kann.

Gemeinsam genutzte DLLs sind Programmbibliotheken mit Funktionen, die von mehr als einem Programm benutzt werden. Es gibt eine Vielzahl von Standard-Bibliotheken, die von vielen Windows-Programmen benutzt werden, einschließlich Programme von verschiedenen Herstellern. Einige sind aktuelle Windows-DLLs, die von Microsoft produziert wurden. Andere DLLs sind Funktionsbibliotheken, die von Herstellern von Programmiersprachen hergestellt wurden. Sie werden zur Entwicklung von Windows-Anwendungen verwendet.

Aber egal aus welcher Quelle die DLLs stammen - viele Programme installieren aktuelle Versionen auf die Festplatte. Windows versucht, den "Überblick" über die Programme, welche diese DLLs benutzen, mit einem Zähler zu bewahren. Aber leider funktioniert der Zählmechanismus nicht einwandfrei.

Ein Beispiel, wie gemeinsam benutzte Dateien von Windows behandelt werden:

Im folgenden ein Praxisbeispiel und dessen Bedeutung für das Installieren und Entfernen von Anwendungen:

Anwendung A benutzt eine allgemeine Datei für eine Klangfunktion mit dem Namen DSound.dll, die von der Anwendung beim Installieren auf Ihre Festplatte in das Windows-Verzeichnis kopiert wird.

So weit, so gut! Ein Programm und eine DLL. Wenn Sie das Programm und die Datei DSound.dll entfernen, werden keine Probleme auftauchen, da nur die Anwendung A diese DLL benutzt hat.

Jetzt installieren Sie eine Anwendung B, die ebenfalls die Datei DSound.dll verwendet.  Die Installationsroutine von Anwendung B sucht das Windows-Verzeichnis ab und entdeckt die bereits vorhandene Datei. Wird anhand eines Prüfvorgangs  (Leider nicht immer der Fall) festgestellt, dass es sich bei der Datei um die aktuellste Version handelt, überspringt die Installationsroutine diese Datei, da sie ja bereits vorhanden ist.

Das ist in Ordnung. Aber jetzt haben Sie zwei Anwendungen, die eine DLL benutzen. Was passiert, wenn Sie eine der Anwendungen deinstallieren? Die DLL ist als "Bestandteil" von beiden Programmen registriert. Richtigerweise müsste diese Datei gelöscht werden, wenn Sie eines der Programme entfernen. Leider würde dann das andere Programme nicht mehr funktionieren, da die benötigte DLL nicht mehr vorhanden ist.

Windows bewältigt das Problem mit Hilfe eines Registry-Eintrags für jede DLL mit einem Zähler, der die Anzahl der Anwendungen, die auf diese DLL zugreifen, erfasst. Jedes mal, wenn eine neue Anwendung auf diese DLL zugreift, wird der Zähler um "1" erhöht. Wird eine der Anwendungen entfernt, sinkt der Zählerstand (hoffentlich) wieder um "1". Erreicht der Zähler den Stand "Null" benutzt keine einzige Anwendung diese DLL mehr und die Datei kann auf jeden Fall sicher gelöscht werden. In einer perfekten Welt könnte dieser Mechanismus perfekt funktionieren. Aber leider ist das nicht der Fall.

Wie die Ashampoo UnInstaller Suite gemeinsam benutzte Dateien behandelt:

Hinweis:	Diese Erläuterungen gelten nur für das Arbeiten im Experten-Modus. Im Easy-Modus werden die Zähler ebenfalls verwaltet, aber gemeinsam benutzte DLLs werden nicht gelöscht, wenn Sie Programme entfernen. Damit soll sichergestellt werden, dass Sie nichts löschen, was noch benötigt werden kann.

Wenn Sie Ihre Windows-Registry mit den bei der Installation von Anwendungen erzeugten Protokollen wiederherstellen, wird der Zähler der gemeinsam benutzen DLL nicht einfach auf den vorherigen Wert gesetzt. Sie könnten ja in der Zwischenzeit weitere Anwendungen installiert haben, die ebenfalls diese DLL benutzen. Stattdessen wird der Zähler um den gleichen Wert erniedrigt, wie der Zähler durch die Installation einer Anwendung erhöht wurde. Wird dadurch der Zähler auf Null gesetzt, öffnet sich ein Dialog mit der Abfrage, ob Sie die Datei löschen wollen.

Sie können unter Einstellungen bestimmen, wie die Ashampoo UnInstaller Suite gemeinsam benutzte DLLs behandelt.

Wenn Sie versuchen, einen Datei zu löschen (Mit "Änderungen wiederherstellen", unter Verwendung einer .ECL Protokolldatei) deren Zähler von der gleichen .ECL Protokolldatei erhöht wurde, erscheint ebenfalls ein Dialog.

Sie erhalten keine Warnung, wenn der Zugriffszähler bereits erniedrigt wurde. Dann ist die Datei automatisch übersprungen worden (d.h. nicht gelöscht) und eine Meldung erscheint im Protokoll-Fenster, wenn der Vorgang beendet ist.

Zusammenfassung:

Das Arbeiten mit gemeinsam genutzten DLLs ist etwas kompliziert, aber die Ashampoo UnInstaller Suite nimmt Ihnen schon die meiste Arbeit ab. Die Standardeinstellungen sind sicher. Sie garantieren, dass vom System benötigte DLLs nicht gelöscht werden.

Warnung:

Bitte versuchen Sie niemals, die programmeigene Deinstallationsroutine (Siehe Was ist mit programmeigenen UnInstallern?) und die Ashampoo UnInstaller Suite zusammen zu benutzen! Sollten Sie es dennoch versuchen, wird der Zähler der gemeinsam genutzten DLLs durch beide Vorgänge erniedrigt. Das führt zu falschen Werten beim Zähler und kann zum Löschen einer DLL führen, die vom System aber noch gebraucht wird!

Zusätzlicher Hinweis:

Wie bereits erwähnt funktioniert der Zählmechanismus für DLLs in der Praxis nicht immer einwandfrei. Es existieren zwei grundsätzliche Probleme: Einige Installationsroutinen "kümmern" sich nicht um eine Erhöhung des Zählerstands, andere Installationsroutinen erhöhen den Zählerstand immer wieder und wieder, wenn Sie das Programm mehr als einmal installieren. Sie können sich vorstellen, dass daraus bedeutungslose Zählerstände resultieren können.

Sollten Zweifel bestehen, ist es immer sicherer, die DLL zu behalten statt sie zu löschen. Sie verursachen keine Störungen und Speicherplatz ist heutzutage wirklich keine Kostenfrage mehr!

.topic 60010
Die Registrierdatenbank (englisch: Registry) ist das Herzstück von Windows.
Es ist die Datenbank, in der alle Informationen gespeichert sind, die Ihr Windows zum korrekten Betrieb benötigt. Dies sind Informationen über installierte Hardware, Software,  System-Komponenten, Treiber, Einstellungen, Benutzer-Profile und vieles mehr.

Anwendungsprogramme und die Registry:

Nahezu alle Windows-Anwendungen legen auch Ihre Einstellungen in der Registrierdatenbank ab. Ausnahme sind hier nur alte Windows 3.X  Anwendungen die Sie aber ohnehin nicht mehr nutzen sollten.

Diese Programme (und einige andere) speichern ihre Einstellungen in zwei Systemdateien mit den Namen win.ini und system.ini, die aus Gründen der Kompatibilität auch von späteren Windows-Versionen unterstützt werden. (Diese Dateien finden Sie im Unterregister Änderungen in den Systemdateien im Register Installationsprotokolle, wenn sich das Programm im Experten-Modus befindet.)

Datenmüll in der Registry nach dem Entfernen von Programmen

Zusätzlich zu ihren automatischen Installations-Routinen speichern die meisten Anwendungen Informationen in der Registry, die es Ihnen ermöglichen, das Programm später von Ihrem Rechner zu entfernen. Entweder über die Systemsteuerung und der Funktion Software Installieren/Deinstallieren oder mit einem Uninstaller, der mit dem Programm gleich mitgeliefert wurde.

Leider hinterlassen beide Methoden eine unglaubliche Anzahl an veralteten Einträgen und Referenzen in der Windows Registry. Genauso schlecht ist die Methode, das Programm einfach, ohne den Uninstaller zu verwenden, zu löschen oder die dazugehörigen Dateien und Ordner zu verschieben. Sie erreichen das Gegenteil: Es bleiben noch mehr verwaiste Einträge in der Registry zurück.

Konsequenzen einer wachsenden Registry:

Ihre Registry wächst kontinuierlich mit der Zahl der redundanten und verwaisten Einträge und Ihr Betriebssystem wird langsamer und langsamer, da sich Windows durch eine immer größere Datenbank durcharbeiten muss - was erhöhte Rechnerleistung und einen größeren Zeitbedarf bedeutet. Da auch einfache Aktionen wie Tastendrücke und Klicken mit der Maus eine erstaunliche Anzahl von Zugriffe auf die Registry erzeugen können, kann dies eine nicht zu vernachlässigende Rechnerlast mit sich bringen.

Darüber hinaus wird die Registry immer in den Arbeitsspeicher Ihres Computers geladen. Eine aufgeblähte Registry frisst mehr und mehr an Speicherplatz, der für andere Anwendungen sinnvoller zu nutzen ist.

.topic 60050
Ashampoo UnInstaller Suite kann die Versionsinformationen von Dateien zusammen mit dem Namen, der Größe und dem Datum speichern. Dadurch kann geprüft werden, welche Version einer DLL, EXE oder anderen Datei mit einer Anwendung installiert werden. Die Informationen über die Version sind in der Regel genauer und nützlicher als die Dateigröße und das Datum.

Der Nachteil der Funktion besteht darin, dass das Speichern der Versionsinformationen den Vorgang beim Speichern der Konfiguration verlangsamt. Die Funktion ist daher zunächst standardmäßig deaktiviert. Sie können die Funktion in den Einstellungen aktivieren und ebenso bestimmen, von welchen Dateien die Versionsinformationen gespeichert werden sollen.

Die Versions-Informationen werden in der Spalte Version im Fenster des Unterregisters Veränderte Dateistruktur des Registers Betrachten des Installationsprotokoll angezeigt.(Nur im Experten-Modus verfügbar.) Wenn keine Versionsinformation für die Datei gespeichert wurde, erscheint der Eintrag Ver. 0.0.0.0 in der entsprechenden Spalte.

Tipp:

Solange sich Dateien auf ihrer Festplatte befinden, können Sie sich die Versions-Informationen auch durch einen Rechtsklick auf den Dateinamen im Windows Explorer anzeigen lassen, in dem Sie aus dem PopUp-Menü die Option Eigenschaften auswählen.

.topic 60020
Die meisten modernen Anwendungen verfügen über eine Deinstallationsroutine, die gewöhnlich über die Windows-Funktion Programme hinzufügen/entfernen unter dem Eintrag Software in der Systemsteuerung aufgerufen kann.
Oder das Programm verfügt über eine Option zur Deinstallation in der eigenen Programmgruppe im Startmenü.

Sie mögen nun denken, dass wenn alle Stricke reißen, diese Routinen die besten Ergebnisse bei der Installation erzielen werden. Die Programmier der Anwendungen sollten besser als jeder andere wissen, wo alle Komponenten ihrer Anwendungen gespeichert sind.

Leider stimmt das nicht!

In 90% aller Fälle ist das Script zur Deinstallation, welches von den Routinen benutzt wird, automatisch während des Installationsvorgangs durch Installationsprogramm generiert. Das Problem bei diesem Denkansatz besteht darin, dass viele Einstellungen nicht durch die Installationsroutine, wohl aber von der Anwendung selbst erzeugt werden. Keine dieser Änderungen kann von der Deinstallationsroutine registriert werden und diese Tatsache führt dazu, dass viel unnötiger Müll auf Ihrem Rechner verbleibt, wenn Sie diese Routinen zum Entfernen der Anwendung verwenden.

Die Ashampoo UnInstaller Suite registriert alle Änderungen, einschließlich derer, die von der Anwendung selbst verursacht werden. Das Programm verfügt damit über eine weitaus bessere Leistung beim Entfernen als automatisierte Deinstaller.

Deshalb empfehlen wir Ihnen, dass Sie jede neue Anwendung mindesten einmal starten sollten, bevor Sie ein Installationsprotokoll mit der Ashampoo UnInstaller Suite erzeugen! Siehe Warum Anwendungen vor dem Protokollieren starten? für weitere Hinweise.

Lesen Sie bitte auch die Hinweise im Abschnitt Andere UnInstaller testen zum Testen der Leistungsfähigkeit der Ashampoo UnInstaller Suite im Vergleich mit den Installationsroutinen anderer Anwendungen.

.topic 60030
Hinweise für Benutzer des Easy-Modus

Die zahlreichen detaillierten Erläuterungen in diesem Abschnitt richten sich an Benutzer, die manuell im Experten-Modus arbeiten. Wenn Sie nur im Easy-Modus arbeiten, müssen Sie nur folgendes beachten: Es ist wichtig, dass Sie ihre neu installierten Anwendungen einmal starten, bevor Sie ein Installationsprotokoll mit der Ashampoo UnInstaller Suite erzeugen. Alles Weitere wird automatisch vom Programm erledigt.

Warum müssen neue Anwendungen vor dem Erzeugen des Installationsprotokolls gestartet werden?

Durch die ganze Ashampoo UnInstaller Suite hindurch, machen wir Sie darauf aufmerksam, dass Sie eine Anwendung mindestens einmal starten müssen bevor Sie ein Installationsprotokoll erzeugen. Der Grund dafür liegt in der Tatsache begründet, dass viele Programme ihre Konfiguration nicht während der Installation durchführen - viele wichtige Einstellungen und Optionen, besonders die in der Windows Registry gespeicherten, werden oft erst geschrieben, wenn das Programm läuft.

Erst wenn das Programm einmal gestartet wurde, kann die  Ashampoo UnInstaller Suite diese Änderungen protokollieren und ist damit in der Lage, das Programm restlos zu entfernen, wenn Sie es wollen. Nach dem Sie das Programm einmal gestartet haben und alle notwendigen Arbeiten an der Konfiguration durchgeführt haben, kehren Sie zur Ashampoo UnInstaller Suite zurück und wählen Vergleiche (Protokoll erstellen), um das Protokoll zu erstellen.

Tipp für den erfahrenen Benutzer

Viele Benutzer bearbeiten die Einstellungen im Windows-Startmenü, die von den Anwendungen erzeugt wurden und verschieben deren Einträge in Unterverzeichnisse, um das Startmenü aufzuräumen. Wenn Sie solche Änderungen vornehmen wollen, vergessen Sie bitte nicht, es vor dem Erzeugen ihres Protokolls zu tun. Da die Ashampoo UnInstaller Suite im Experten-Modus nicht mit dem Installationsprozess verbunden ist, können Änderungen, die Sie selbst vorgenommen haben, in der gleichen Weise wie Änderungen durch ein Installationsprogramm entfernt werden.

Vergessen Sie bitte nicht ein Protokoll zu erzeugen!

Das Spielen mit allen Funktionen eines neuen Programms ist sehr oft faszinierend. Wie auch immer, bitte vergessen Sie nicht, zur Ashampoo UnInstaller Suite zurückzukehren und Vergleiche (Protokoll erstellen) zu wählen, um ein Protokoll nach dem Verlassen des neuen Programmes zu erzeugen. Wenn Sie kein Protokoll erstellen, bevor Sie irgendwelche Änderungen an Ihrem System vornehmen, werden Sie nicht in der Lage sein, das Programm später sauber zu entfernen. Oder Sie entfernen Ihre ganze geleistete Arbeit, die vor dem Protokoll entstand!

Bitte keine neuen Dateien vor dem Protokollieren erzeugen!

Es ist besonders wichtig, dass Sie keine wichtigen neuen Dateien erzeugen oder wichtige Änderungen an Ihrer Systemkonfiguration vornehmen, die Sie bewahren möchten, bevor Sie den Vergleich durchführen. Sollte das trotzdem geschehen, werden diese Dateien mit in das Protokoll aufgenommen und Sie könnten aus Versehen diese Dateien löschen oder Ihre Änderungen zurücknehmen, wenn Sie die Anwendung später deinstallieren.

.topic 70000
Dieser Abschnitt enthält eine kurze Einführung zu den Funktionen in den Menüs der Ashampoo UnInstaller Suite und den Werkzeugen und Icons in der Werkzeugleiste.

.topic 70010

Die rot markierten Optionen sind nur im Experten-Modus verfügbar.

        Wechsle Modus
Wechselt zwischen Easy-Modus und Experten-Modus.

        Lade Auswahl aus Datei
Lädt ein Set an Auswahl-Einstellungen, die Sie vorher in einer Datei gespeichert haben.

        Speichere Auswahl in Datei
Speichert alle aktuellen Einstellungen in den Registern unter Auswahl: Registry & Laufwerke. Sie werden zur Eingabe eines Namens für die Datei aufgefordert.

        Zurücksetzen der Auswahl
    Alle Einstellungen in den Registern unter Auswahl: Registry & Laufwerke werden auf die sicheren Standardvorgaben des Programms zurückgesetzt.

        Wiederherstellen der gespeicherten Auswahl
    Ersetzt die aktuelle Konfiguration durch eine Backup-Kopie. Bitte benutzen, wenn Sie versehentlich Ihre Konfiguration durch Wählen von Speichere aktuelle Konfiguration statt Vergleiche (Protokoll erstellen) überschrieben haben.  Klicken Sie hier  für weitere Einzelheiten.

        Lade Protokolldatei(Installationsprotokoll)
    Lädt das mit der Ashampoo UnInstaller Suite erzeugte Installationsprotokoll. Im Experten-Modus kann der Inhalt der Datei in den Registern unter Installationsprotokolle eingesehen werden.

        Einstellungen
    Öffnet einen Dialog mit Optionen zur Konfiguration der wesentlichen Einstellungen, die die Arbeitsweise der Ashampoo UnInstaller Suite bestimmen.

        Beenden
    Beendet die Ashampoo UnInstaller Suite.

.topic 70050
Die rot markierten Optionen sind nur im Experten-Modus verfügbar.

     Suite Bildschirm
    Wechselt zum Hauptbildschirm mit den Icons zur Auswahl der Programm-Module.

        Schritt-für-Schritt Assistent
Startet einen speziellen interaktiven Assistenten, der Sie durch die wichtigsten Programmfunktionen führt.

        Neue Anwendung installieren
    Startet den interaktiven Assistenten, der Sie durch den Vorgang bei der Installation einer neuen Anwendung mit der Ashampoo UnInstaller Suite und beim Speichern eines Installationsprotokolls führt. Es werden unterschiedliche Assistenten gestartet, abhängig davon ob Sie sich gerade im Easy-Modus oder Experten-Modus befinden.

         Anwendung deinstallieren
    Startet den interaktiven Assistenten, der Sie durch den Vorgang beim Entfernen einer Anwendung führt, die Sie mit der Ashampoo UnInstaller Suite installiert haben. Es werden unterschiedliche Assistenten gestartet, abhängig davon ob Sie sich gerade im Easy-Modus oder Experten-Modus befinden.

        Anwendung ohne Protokoll deinstallieren
    Startet den interaktiven Assistenten, der Sie durch den Vorgang bei der Deinstallation einer Anwendung führt, für die kein mit der Ashampoo UnInstaller Suite erzeugtes Installationsprotokoll vorliegt. Unterschiedliche Funktionen im Easy-Modus und Experten-Modus.

        Alles wiederherstellen
    Stellt alles aus der aktuellen Protokolldatei wieder her (bzw. entfernt alles). Ausgegraut, wenn kein Protokoll geladen ist (Wählen Sie Lade Auswahl aus Datei im Menü Datei oder in der Werkzeugleiste, um eine Protokolldatei zu laden).

        Speichere aktuelle Konfiguration
    Sucht Ihr System ab und speichert eine Aufzeichnung der aktuellen Konfiguration in die vorgegebene "Bevor"-Konfigurationsdatei. Benutzen Sie bitte Speichere Konfiguration unter ..., um die Datei mit einem anderen Namen zu speichern.

        Vergleiche (Protokoll erstellen)
    Sucht Ihr System ab und speichert eine Aufzeichnung der aktuellen Konfiguration in die vorgegebene "Danach"- Konfigurationsdatei. Es findet ein Vergleich mit der "Bevor"-Konfigurationsdatei statt. Die gefundenen Unterschiede werden in das Installationsprotokoll geschrieben. Bitte benutzen Sie die Funktion Vergleiche zwei Konfigurationen, um Konfigurationsdateien zu vergleichen, die Sie selbst benannt haben.

        Inkrementelles Vergleichen
    Erlaubt Ihnen verschiedene Arbeitsabläufe bei der Vergleichsoperation. Siehe Inkrementelles Installieren & Vergleichen für weitere Hinweise.

        Speichere aktuelle Konfiguration unter ...
    Sucht Ihr System ab und speichert eine Aufzeichnung der aktuellen Konfiguration in eine Datei ab, die Sie selbst anstelle der standardmäßigen Konfigurationsdateien benennen.

        Vergleiche zwei Konfigurationen
    Erlaubt Ihnen das Vergleichen von jeweils zwei Konfigurationsdateien. Das Ergebnis wird in eine Protokolldatei geschrieben.

.topic 70060
Die rot markierten Optionen sind nur im Experten-Modus verfügbar.

        Doppelte Dateien suchen und löschen
Startet das Modul zum Auffinden und Löschen von doppelten Dateien auf Ihrem Rechner.

        Temporäre Dateien suchen und löschen
Startet das Modul zum Auffinden und Löschen von temporären oder anderen Dateien auf Ihrem Rechner. Sie können Ihre eigene Suchfunktionen generieren.

        Schriften verwalten und löschen
    Startet das Modul zum Betrachten der auf Ihrem System installierten Schriften. Enthält Funktionen zum Entfernen nicht mehr benötigter Schriften.

        Internetbereich aufräumen
    Startet das Modul zum Auffinden und Löschen der temporären Internetdateien und weiterer Objekte, die beim Surfen im Internet erzeugt werden.

        Leere Ordner suchen und löschen
    Startet das Modul zum Auffinden und Löschen von leeren Ordnern auf Ihrem Rechner.

        Backup erstellen
    Startet die Funktion Backup erstellen, mit der Sie wichtige Dateien sichern können. Sie können die Ashampoo UnInstaller Suite so konfigurieren, dass wichtige Dateien, die durch die Installation einer Anwendung überschrieben wurden, aus diesen Backups heraus wiederhergestellt werden.

        Installationsdateien erzeugen
    Ermöglicht Ihnen das Erzeugen einer Reihe von REG und INF Dateien, um Installationen von Anwendungen auf mehreren Computern zu vervielfältigen (klonen).

        Ansicht aktualisieren
    Zeichnet den Bildschirm der Ashampoo UnInstaller Suite neu und aktualisiert den Inhalt der Fenster.

.topic 70020
Dieses Menü enthält Optionen zum Zugang zur Ashampoo Internet-Seite, zur Registrierung und zum Kauf des Programmes, wenn Sie eine Shareware-Version benutzen. (Einzelne Punkte innerhalb dieses Menüs variieren geringfügig, abhängig davon welche Version Sie verwenden).

        Diese Software jetzt kaufen
Wird nur in der Shareware-Version angezeigt. Verbindet Sie mit der Ashampoo-Webseite, auf der Sie das Programm erwerben können.

        Dieses Programm einem Freund empfehlen
Ermöglicht es Ihnen, das Programm automatisch per eMail einem Freund oder natürlich einer Freundin zu empfehlen.

        Heutige Angebote ansehen
Verbindet Sie mit der Ashampoo-Webseite und zeigt Ihnen spezielle Angebote und Hinweise auf Produkte und Dienstleistungen, die für Sie von Interesse sein können.

        Ashampoo Free Newsletter
Verbindet Sie mit der Ashampoo-Webseite, auf der Sie sich für unseren kostenlosen eMail Newsletter, der Ihnen wöchentlich Informationen zu Ashampoo-Produkten, Updates und Sonderangeboten bietet, eintragen können.

        Zur Ashampoo Internet-Seite
Verbindet Sie mit der Ashampoo-Webseite.

        Zur Ashampoo Produkt-Seite
Verbindet Sie mit der aktuellen Produktübersicht von Ashampoo im Internet.

        Ashampoo Support
Verbindet Sie mit der Support-Seite von Ashampoo im Internet.

        Online Update
Verbindet Sie mit der Ashampoo-Webseite, auf der Sie neue Patches und Online-Updates erhalten können.

        Programm registrieren
Ermöglicht Ihnen die kostenfreie Online-Registrierung des Programms. Dieser Menüpunkt wird erst nach der Eingabe des Vollversionsschlüssels angezeigt.

        Kostenlosen Freischaltcode holen
Wird nur in der unregistrierten Shareware-Version angezeigt. Startet die kostenlose Online-Registrierung, mit der Sie das Programm freischalten können. Sie können danach das Programm in seiner vollen Funktionalität, aber mit zeitlicher Beschränkung nutzen. Sie erhalten den kostenfreien Freischaltcode per eMail.

        Freischaltcode eingeben
Wird nur in der Shareware-Version angezeigt. Wählen Sie diese Option zur Eingabe des Freischaltcodes oder des Registrierungsschlüssels, den Sie auf Anforderung per eMail erhalten.

.topic 70030
         Ashampoo UnInstaller Suite Hilfe
    Öffnet diese Hilfedatei.

        Info
    Zeigt Ihnen Informationen zum Programm an.

.topic 70040
Wie bei den Menüs hängt auch das Aussehen der Werkzeugleiste davon ab, ob Sie im Easy-Modus oder Experten-Modus arbeiten.

Die Werkzeugleiste im Easy-Modus:

Die Werkzeugleiste im Experten-Modus:

Werkzeuge:

.topic 80000
Kostenfreier Support für alle Ashampoo Produkte   Auch für Trial-Versionen!

Wir von Ashampoo sind der festen Überzeugung, dass ein exzellenter Support wesentlicher Bestandteil eines Produktes ist. Wir sichern den kostenfreien Online-Support für alle unsere Produkte - einschließlich Freeware-, Shareware- und Trial-Versionen.
Sollten Sie irgendwelche Probleme mit oder Fragen zu Ashampoo UnInstaller Suite haben, kontaktieren Sie bitte unser Support-Team unter den unten angeführten Adressen. Sie können unseren Support auch direkt durch Auswahl der entsprechenden Optionen im Menü Internet kontaktieren.

Wie auch immer, bevor Sie diesen Weg gehen, sollten Sie das Hilfe-Systems zu Rate ziehen und diese Hilfe aufmerksam lesen. In vielen Fällen werden Sie die Antworten auf Ihre Fragen bereits finden.

Hinweis: Die Links für die Kontaktaufnahme mit Ashampoo finden Sie auch im Menü Internet.

Ashampoo Kontaktadressen:

Webseite:	http://www.ashampoo.de

Supportseite:	http://www.ashampoo.de/support

E-Mail Support:	E-Mail

Fehlerbericht:	E-Mail

Anregungen:	E-Mail

Anschrift:	ashampoo GmbH & Co. KG
    Felix-Wankel-Str. 16
    26125 Oldenburg
    Germany

.topic 80010
Informationen zur Ashampoo Bannerwerbung:

In diesem Abschnitt finden Sie detaillierte Informationen zur Ashampoo Bannerwerbung.

Die Werbebanner werden unten im Programmfenster angezeigt. In der Vollversion werden Sie hier nichts sehen, schließlich haben Sie dafür bezahlt, keine Werbung sehen zu müssen.
In anderen Versionen wird hier Werbung eingeblendet, während die Software läuft.

Warum wird Bannerwerbung eingesetzt?

Wir haben uns entschlossen, in unseren Shareware-Versionen Bannerwerbung einzusetzen, um Ihnen die volle, aber zeitlich eingeschränkte Funktionalität  der Produkte anbieten zu können. Und das kostenlos.
Um Ihnen diese Leistung anbieten zu können, sind wir auf die Unterstützung von Werbepartnern angewiesen.
Mit einem Klick auf einen Werbebanner gelangen Sie zum entsprechenden Angebot unserer Werbepartner.
Im Gegensatz zu anderer werbefinanzierter Software passiert bei der Banner-Technologie von Ashampoo folgendes:

Mit der Installation der Software wird ein "Paket" mit Werbebanner geladen.
Das Programm geht im Hintergrund nicht online!
Informationen über Sie oder Ihren Computer werden auf keinen Fall von Ashampoo gesammelt.
Es wird nur unsere Webseite kontaktiert, um die von Ihnen ausgewählten Banner zu holen.
Der Aufbau einer Internet-Verbindung findet nur statt, wenn Sie es wollen.
Sie suchen die Banner aus, die Sie sehen wollen.

Die als "Adware" bzw. Spyware" in Verruf gekommene Banner-Technologie anderer Software-Anbieter wird NICHT eingesetzt. Sie haben jederzeit die volle Kontrolle. Es geschieht nichts ohne Ihre Bestätigung.

Sollten Sie auf Dauer die Bannerwerbung nicht weiter sehen wollen, so müssen Sie die Software käuflich erwerben. Dazu müssen Sie lediglich über einen Internet-Zugang verfügen und die Schaltfläche "Diese Software kaufen" im Menü Internet anklicken.

Wir sind der festen Überzeugung, hiermit allen unseren Kunden eine faire Lösung anbieten zu können.

Ihr Ashampoo Team


easy mode

 Der aktuelle Modus ist im Programmtitel immer sichtbar.
Um in den Easy-Modus zu wechseln klicken Sie auf
Wechsle Modus im Menü Datei, wählen Sie dann bitte
Wechsle zum Easy-Modus. Sie können dazu auch das
Icon in der Werkzeugleiste benutzen.


expert mode

 Der aktuelle Modus ist im Programmtitel immer sichtbar.
Um in den Experten-Modus zu wechseln klicken Sie auf
Wechsle Modus im Menü Datei, wählen Sie dann bitte
Wechsle zum Experten-Modus. Sie können dazu auch das
entsprechende Icon in der Werkzeugleiste benutzen.


recoverconfig

 Wiederherstellen der gespeicherten Konfiguration

Dieses Kommando im Menü Datei ermöglicht Ihnen die Wiederherstellung, wenn Sie versehentlich Speichere aktuelle Konfiguration anstelle von Vergleiche (Protokoll erstellen) gewählt haben sollten. Durch diese Auswahl wird die Backup-Kopie Ihrer aktuellen Konfiguration wiederhergestellt.

Der Ablauf:

1. Nach dem Speichern Ihrer aktuellen Konfiguration installieren Sie ein Programm oder nehmen Änderungen an Ihrem System vor. Anschließend möchten Sie ein Protokoll erstellen, aber statt die Funktion Vergleiche (Protokoll erstellen) aufzurufen wählen Sie aus Versehen Speichere aktuelle Konfiguration. Damit wird Ihre aktuelle Konfiguration überschrieben und alle Änderungen gehen verloren - Sie können kein Protokoll mehr erstellen!

2. Aber keine Panik! Wählen Sie einfach Wiederherstellen der gespeicherten Konfiguration im Menü Datei und bestätigen die Abfrage mit Ja. Dadurch wird Ihre ursprüngliche aktuelle Konfiguration aus der Backup-Kopie heraus wiederhergestellt. Alles wird bis zu dem Zeitpunkt zurückgesetzt, bevor Sie versehentlich Speichere aktuelle Konfiguration in Schritt 1 gewählt hatten.

3. Wählen Sie dann einfach Vergleiche (Protokoll erstellen). Diese Funktion wird normal ablaufen, so als wenn Ihnen der Fehler nicht unterlaufen wäre.

Wie es funktioniert:

Wenn Sie die Optionen Speichere aktuelle Konfiguration wählen, wird eine Aufzeichnung ihrer aktuellen System-Konfiguration als Datei OldCFG.ECD gespeichert. Gleichzeitig wird die vorhandene Version von OldCFG.ECD in OldCFG.BAK umbenannt.

Wenn Sie die Option Vergleiche (Protokoll erstellen) wählen (Nach der Installation einer Anwendung oder Durchführung von Änderungen an Ihrem System) wird eine neue Aufzeichnung der Konfiguration in der Datei NewCFG.ECD gespeichert. Das Programm vergleicht beide Konfigurationsdateien und schreibt die gefundenen Veränderungen in ein Installationsprotokoll.

Sollten Sie versehentlich Speichere aktuelle Konfiguration statt Vergleiche (Protokoll erstellen) wählen, überschreiben Sie damit automatisch die Datei OldCFG.ECD mit Ihrer neuen Konfiguration. Dadurch ist ein Vergleich unmöglich geworden. Wie auch immer, die letzte von Ihnen erzeugte Version heißt jetzt OldCFG.BAK. Es ist die Version, die durch die Funktion Wiederherstellen der gespeicherten Konfiguration wiederhergestellt wird.


restore all

 Wenn Sie im Experten-Modus arbeiten, sollten Sie immer die kritischen
Zweige im Register Installationsprotokolle auswählen und die vom Programm
geplanten Änderungen betrachten, bevor Sie die Änderungen
durchführen. Bitte benutzen Sie Alles Wiederherstellen mit Protokolldateien
nur, wenn diese unmittelbar nach der Installation einer Anwendung
generiert wurden.
Da das Programm alle Änderungen an Ihrem System protokolliert,
enthalten die Protokolldateien, die lange nach dem Speichern der
aktuellen Konfiguration generiert wurden, sicherlich Einträge, die
Sie nicht löschen möchten.


restoreoptions

 Optionen im Bestätigungsdialog:

· Lösche neue (hinzugefügte) Werte/Schlüssel

Löscht alle neuen Einträge, wie im Installationsprotokoll beschrieben - zum Beispiel alle Einträge, die durch das Installieren einer Anwendung hinzugefügt werden. Ist diese Option ausgewählt, werden neue Einträge beim Wiederherstellen gelöscht. Die Schlüssel und Werte in der Registry werden auf Dauer gelöscht, Dateien werden entweder in den Papierkorb oder in das Verzeichnis verschoben, dass unter Einstellungen als Backup-Verzeichnis festgelegt wurde.

Kann normalerweise ausgewählt sein.

· Stelle gelöschte Werte/Schlüssel wieder her

Stellt alle gelöschten Registry-Werte und Schlüssel aus dem Protokoll wieder her.

Kann normalerweise ausgewählt sein.

· Stelle geänderte Werte/Schlüssel wieder her

Stellt alle geänderten Registry-Werte und Schlüssel aus dem Protokoll wieder her.

Kann normalerweise ausgewählt sein.

· Schon restaurierte Werte erneut wiederherstellen

Einträge im Register Änderungen in Registry, die bereits wiederhergestellt wurden sind zur Identifikation ausgegraut. Im Normalfall wird das Programm nicht versuchen, diese Einträge wiederherzustellen, da davon ausgegangen wird, dass sie bereits zurückgesetzt worden sind. Wenn notwendig (Zum Beispiel wenn Sie die Veränderungen in der Zwischenzeit bereits von Hand zurückgesetzt haben) können diese Einträge einbezogen werden, so dass sie wiederhergestellt werden.

WICHTIG: Die Auswahl dieser Option verhindert NICHT den Vorgang der Wiederherstellung - es werden nur die ausgegrauten Einträge mit einbezogen. Diese Option bewirkt, dass diese Objekte "nochmal" restauriert werden, falls sie in der Zwischenzeit wieder gesetzt worden sind.


samplepopup

 Dies ist ein Beispiel für ein PopUp-
Informations-Fenster.


selections

 Auswahl, Konfigurationen und Protokolle

Wenn Sie im Experten-Modus arbeiten, müssen Sie immer folgendes beachten: Die Beziehungen zwischen den Einstellungen in den Auswahl-Registern und wie das Programm Konfigurationen speichert sowie vergleicht, um daraus Installationsprotokolle zu generieren.

Im Allgemeinen ist es sehr wichtig, die gleichen Auswahl-Einstellungen für die Funktionen Speichere aktuelle Konfiguration und Vergleiche (Protokoll erstellen) zu benutzen. Sie erhalten sonst bedeutungslose Resultate.

Wozu dienen die Auswahl-Einstellungen?

Die Einstellungen im Register Auswahl: Registry & Laufwerke (Registry, Laufwerke, Systemdateien, Ausgeschlossene Dateien) bestimmen, welche Teile Ihres Systems und welche eigenen Berichte von der Ashampoo UnInstaller Suite bei der Durchführung der verschiedenen Aufgaben abgesucht werden. Das gilt sowohl für das Speichern von Konfigurationen mit der Funktion Speichere aktuelle Konfiguration als auch für das Vergleichen von Konfigurationen mit der Funktion Vergleiche (Protokoll erstellen).

Die Auswahl bei Speichere aktuelle Konfiguration:

Die Funktion Speichere aktuelle Konfiguration speichert einen "Bevor"-Schnappschuss Ihres gesamten Systems. Später, wenn Sie die Funktion Vergleiche (Protokoll erstellen) wählen, generiert das Programm einen "Danach"-Schnappschuss Ihres Systems und vergleicht ihn mit dem "Bevor"-Schnappschuss, um die Änderungen zu prüfen.

Wenn Sie Ihre aktuelle Konfiguration speichern, sollten Ihre Einstellungen in den Auswahl-Registern aus diesem Grund alles enthalten, was Sie auf Veränderungen hin überwachen wollen. Wenn Sie unsicher sind, wählen Sie einfach Zurücksetzen der Auswahl im Menü Datei, um die Standardeinstellungen zu benutzen. Dadurch werden alle lokalen Festplatten, alle relevanten Registry-Schlüssel und alle Systemdateien überwacht. Gleichzeitig werden automatisch eine Reihe von Dateien, Ordnern und Registry-Schlüsseln, die potentiell Probleme verursachen könnten, ausgeschlossen. Alle Einbeziehungen und Ausschlüsse können in den Auswahl-Registern eingesehen werden.

Die Auswahl bei Vergleiche (Protokoll erstellen):

Sie sollten normalerweise die gleichen Auswahl-Einstellungen für die Funktion Vergleiche (Protokoll erstellen) verwenden, die Sie auch bei der Funktion Speichere aktuelle Konfiguration benutzt haben. Sie könnten ansonsten bedeutungslose Resultate erzielen.

Wenn Sie zum Beispiel das komplette Laufwerk D:\ im Register Laufwerke beim Speichern der aktuellen Konfiguration abwählen, werden keine Informationen über das Laufwerk D:\ in der Konfigurationsdatei gespeichert. Selbst wenn Sie später das Laufwerk D:\ im Register Laufwerke auswählen, bevor Sie die Funktion Vergleiche (Protokoll erstellen) wählen, wird das Programm keine Änderungen auf diesem Laufwerk finden können, da die "Bevor"-Konfigurationsdatei keine Informationen darüber enthält.

Gleiches gilt für die andere Reihenfolge: Wenn Sie D:\ vor der Durchführung von Speichere aktuelle Konfiguration auswählen und vor der Durchführung der Funktion Vergleiche (Protokoll erstellen) abwählen, werden Sie ebenfalls keine Änderungen auf dem Laufwerk D:\ sehen. Sie haben dem Programm ja mitgeteilt, dass es Veränderungen auf diesem Laufwerk nicht vergleichen soll.

Wie man gute Ergebnisse erzielt:

· Prüfen Sie Ihre Auswahl-Einstellungen bevor Sie die Funktion Speichere aktuelle Konfiguration benutzen!

Wenn Sie Ihre Auswahl-Einstellungen jemals geändert haben sollten, ist es sinnvoll, diese vor dem Arbeiten mit dem Programm zu prüfen. Wenn Sie unsicher sind, wählen Sie einfach Zurücksetzen der Auswahl im Menü Datei, um die Standardeinstellungen zu benutzen. Verlassen Sie dann die Ashampoo UnInstaller Suite und klicken Sie bei der Eingabeaufforderung auf Ja, um die aktuellen Auswahl-Einstellungen als neue Standardeinstellungen zu speichern. Wenn Sie das Programm erneut starten, werden diese Einstellungen automatisch benutzt.

· Speichern Sie Ihre Auswahl-Einstellungen nach Veränderungen!

Wenn Sie die Ashampoo UnInstaller Suite verlassen, nach dem Sie die Auswahl-Einstellungen verändert haben, werden Sie aufgefordert, Ihre neuen veränderten Einstellungen als Standardeinstellungen zu speichern. Das ist nur dann sinnvoll, wenn Sie Ihre Einstellungen für alle weiteren Arbeitssitzungen mit dem Programm benutzen wollen. Wenn Sie besondere Einstellungen vorgenommen haben, die Sie nur manchmal benutzen wollen, klicken Sie bitte auf Abbrechen. Wählen Sie Speichere Auswahl in Datei im Menü Datei und speichern Ihre besonderen Einstellungen in eine Datei, die Sie später erneut laden können.

Dieser Punkt ist nicht so bedeutend, wenn Sie die Ashampoo UnInstaller Suite nicht zwischen Speichere aktuelle Konfiguration und Vergleiche (Protokoll erstellen) verlassen. Alle veränderten Einstellungen werden automatisch für den Vergleichsvorgang herangezogen, da sie noch in den Auswahl-Registern gesetzt sind. Sie brauchen Ihre Einstellungen nur noch speichern, wenn Sie diese später für andere Sitzungen nutzen wollen.

· Laden Sie Ihre Auswahl-Einstellungen vor dem Aufrufen von Vergleiche (Protokoll erstellen)!

Wenn Sie besondere Einstellungen beim Speichern der aktuellen Konfiguration benutzt haben, dürfen Sie nicht vergessen, diese Einstellungen zu laden, bevor Sie die Operation Vergleiche (Protokoll erstellen) durchführen. Wenn Sie Ihre neuen Einstellungen als Standard gespeichert haben (siehe vorherigen Tipp), werden diese beim erneuten Start der Ashampoo UnInstaller Suite automatisch geladen. Wenn Sie Ihre Einstellungen in eine Datei gespeichert haben, sollten Sie diese Datei mit der Funktion Lade Auswahl aus Datei im Menü Datei erneut laden, bevor Sie den Vergleich durchführen. Sie könnten ansonsten bedeutungslose Ergebnisse erhalten.

Natürlich müssen Sie Ihre Einstellungen nicht erneut laden, wenn Sie die Ashampoo UnInstaller Suite zwischen Speichere aktuelle Konfiguration und Vergleiche (Protokoll erstellen) nicht verlassen. Ihre aus der Datei geladenen Einstellungen sind immer noch in den Auswahl-Registern gesetzt und werden automatisch benutzt, wenn Sie den Vergleich durchführen.


Shared DLLs

 Gemeinsam genutzte DLLs sind Programmbibliotheken mit Funktionen,
die von mehr als einem Programm benutzt werden. Es gibt eine Vielzahl
von Standard-Bibliotheken, die von vielen Windows-Programmen benutzt
werden, einschließlich Programme von verschiedenen Herstellern.
Programme platzieren sehr oft frische "Kopien" dieser DLLs, die sie
benötigen auf die Festplatte, damit sie verfügbar sind.
Windows versucht, den "Überblick" über die Programme,
welche diese DLLs benutzen, mit einem Zähler zu bewahren.
Aber leider funktioniert der Zählmechanismus nicht einwandfrei.


swap file

 Die Swapdatei (Auslagerungsdatei) ist eine versteckte Datei,
die von Windows für das Ablegen der aufgrund eines zu geringen
Arbeitsspeichers ausgelagerten Programmteile verwendet wird.
Suchen Sie nach "Virtuellem Speicher" in Ihrer Windows-Hilfe
für weitere Informationen.


Systempath

 Es gibt grundsätzlich nur einen Systempfad und einen Windows-Pfad
auf jedem Windows-System. Beide Pfade werden durch
Systemvariablen bestimmt (Sie können sich diese Variablen mit
Hilfe des Kommandos SET in der Eingabeaufforderung anzeigen
lassen). Wenn ein Programm versucht, auf eine DLL zuzugreifen,
schaut es zunächst in das eigenen Programmverzeichnis und
anschließend in die Windows- und Systemverzeichnisse.


Wildcards

 PLATZHALTER:

*.bak würde alle Dateien mit der Erweiterung .bak finden.

b*.bak würde folgende Dateien finden: bob.bak, butter.bak und b.bak - die Datei cbfiles.bak dagegen nicht.

b??.bak würde die folgenden Dateien finden: bob.bak und bib.bak - die Datei bobby.bak aber nicht.